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Goals of this Tutorial 
•	 Understanding the basic working, configuration and usage of Scorpion Vision Software. 

•	 Developing your first ‘Washer Presence Verification System’ using Scorpion Vision Software and seeing it in action. 

Before Starting the Tutorial
•	 Scorpion Vision Software version 7.2 or higher needs to be installed on the test machine and a license should be activated.  

•	 An actual camera is not needed since you will be using the ‘simulator’ feature available in Scorpion Vision Software.  

•	 Users of Scorpion Version X or later should read the section Using Scorpion Vision X  

•	 We are working hard to update the software with new features and Metro Look - this will continue most of 2013. We have scheduled a complete 
remake of the Scorpion documentation and tutorials in the second half of 2013. 

•	 The data files available with this tutorial should be copied to the test machine: 
(1) ‘GettingStartedTutorial_Part1_PresenceVerification.zip’ which is a pre-configured profile
(2) ‘CameraSimulationImages’ folder which has a set of 10 JPEG images
(3) ‘CalibrationImages’ folder which has 1 BMP image
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Using Scorpion Vision Version X 
•	 Scorpion Vision X is a major upgrade to Scorpion Vision Software with a new exciting Metro Look  

•	 The Scorpion Vision Version X up to build 10.0.0.540 has only minor changes in the gui details from version 10.1.0.546 the gui have also changed a lot 
also in the details with toolbar  everywhere. If you do not like the toolbars they can be removed by the following procedure: 

•	 Start Scorpion from the shortcut
•	 The profile selection dialog is activated
•	 Activate the mouse menu - select Show Buttons - this global settings restores the old button look in the complete application 

•	  To restore Metro look - unselect the Show Button item in the Profile Selection Dialog

Hints
•	 The following hints are important - keep them until you need them. 

•	 The Scorpion Vision Installer makes it a lot easier to install and deploy a Scorpion Vi-
sion Software System

•	 The latest tutorials and demonstration profiles are available from the Scorpion In-
staller 

•	 The New Profile Wizard makes it a lot easier to create a profile.
•	 The States Tab is moved from Settings to Service
•	 Scorpion Tool Components - STC - makes it possible to create tools using Python 

scripting
•	 Data Input Pages are significantly enhanced in Scorpion Version X
•	 Scorpion Version 9 is still available from download use this version to run the tutorials 

if you want to be compatible with the tutorial content.
•	 The integrated Scorpion html-help file contains up to date information about every 

version 

•	 The TordiveBlog - http://www.tordivelblog.com contains up to date  information 
about Scorpion Vision

http://www.tordivelblog.com
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Washer Presence Verification System
In this tutorial, we will be creating ‘Washer Presence Verification System’ using powerful, flexible, and easy to use Scorpion Vision Software. The Washer 
Presence Verification System’ will have following features: 

•	 Periodically reviews the image captures from camera (or simulator image in case of this tutorial) 

•	 Analyzes the image to understand washer presence or absence in the captured image 

•	 Displays the presence verification result to the user and generate statistical data

Figure 1: Image with washer present Figure 2: Image with no washer present

Figure 3: ‘OK’ is the expected result after inspection by the system Figure 4: ‘No washer’ is the expected result after inspection by the system
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2.	 Scorpion Vision Software Configuration
Configurations available in Scorpion Vision Software, can be categorized as: 

1.	 Camera configuration – camera selection, trigger settings
2.	 Detection logic configuration – as per the project requirements
3.	 Output configuration – user interface, RS232, TCP/IP

All configuration data is saved as a ‘Profile’. A profile can be created, saved, copied, exported and restored across different computers

3.	 Pre-Configured Profile
•	 GettingStartedTutorial_Part1_PresenceVerification.zip  - available with this tutorial is a pre-configured profile for ‘Washer Presence Verification Sys-

tem’ 

•	 This can be used on any computer to see ‘Washer Presence verification’ in action, without needing any additional changes. 

•	 We will first try this pre-configured profile and see it in action. 

•	 Then later in this tutorial, we will create this same profile from scratch.
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4.	Trying out the Pre-Configured Profile
Launch Scorpion Vision software from ‘Start->All Programs->Tordivel Vi-
sion Solutions->Scorpion 7->Scorpion 7.2’ 

Right click on the application window and select ‘Restore’ sub-menu. This 
will pop up zip file selection dialog. 

Figure 5: Restore Profile

Navigate to the directory where GettingStartedTutorial_Part1_Pres-
enceVerification.zip is available, select it and click on ‘Open’ button. 
Scorpion will restore the profile and it will be added to the available list of 
profiles. 

Right click on the new profile ‘GettingStartedTutorial_Part1_PresenceVeri-
fication’ and click on ‘Open’ sub-menu to launch Scorpion vision software 
with this profile loaded. 

Figure 6: Open Profile

Scorpion has a toolbar available at the top for quick navigation to various 
commonly used features.
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Click on the ‘Start’ button on the toolbar to start the inspection. Scorpion 
starts capturing images (from simulator configured in this profile) after 
every 1000 milliseconds, processes them and generates the results. 

Figure 7: Start the inspection

There are several captured images which have washer present and few 
which do not have washer.

Scorpion analyses each captured frame and updates result as ‘OK’ or ‘No 
washer’, in the inspection result panel visible in left bottom corner. Color of 
the inspection result panel also changes to green for ‘OK’ and changes to 
yellow for ‘No washer’ results. 

Figure 8: Result ‘OK’

Figure 9: Result ‘No washer’
Click on the ‘Stop’ toolbar button (previously available ‘Start’ button is 
changed to ‘Stop’ now) to stop the inspection. 
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Click on the ‘History’ tab available on the right hand side. This shows the 
inspection history with image number, time stamp and inspection result. 

Click on ‘Statistics’ tab next to ‘History’ tab. This shows various statistics 
related to inspection results. 

Congratulations!  You have successfully used Scorpion Vision Software for 
‘Presence Verification’!

Figure 10: History tab Figure 11: Statistics tab
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5.	 Scorpion - User Interface
Scorpion User Interface is very simple and intuitive. 

There is a toolbar at the top which has buttons for all commonly used 
features. 

Figure 12: Toolbar

Below the tool bar is ‘Image’ panel which displays the captured images. 
Captured images are overlaid with user defined status indicators, detec-
tion indicators and information text. 

Figure 13: Image Panel
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Below ‘Image’ panel, is the ‘Inspection Result’ panel which shows the 
inspection result text

Figure 14: Inspection result panel

On right hand side, there are four main tabs – ‘Operation’, ‘Settings’, ‘Sys-
tem log’ and ‘About’

Figure 15: Main tabs
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6.	Scorpion – Operation modes
There are 3 modes of operation available in Scorpion.

Default is ‘Operator mode’. In this mode only start/stop inspection and 
viewing history, curves and statistics is supported. No settings / configura-
tion are allowed in this mode.

There is a password protected (password = 1234) ‘Settings mode’ for certi-
fied operators. In this mode limited settings can be changed.

There is a password protected (password = 911) ‘Service mode’. This mode 
has full access to all settings.

To switch to ‘Settings mode’ or ‘Service mode’, click on ‘Setup’ toolbar but-
ton. This pops up access control password dialog. Type the password and 
click on ‘OK’ button.

While in ‘Service mode’, additional tab ‘Service’ is added to the user 
interface. 

Figure 16: Enter Password

Figure 17: ‘Service’ tab

Now we are ready to create our own ‘Presence Verification’ profile from 
scratch. All configurations described in next sections can be done from 
‘Service mode’.
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7.	 Creating a New Profile
Close Scorpion instance which had the pre-configured ‘Presence Verifica-
tion’ profile loaded.

Launch Scorpion Vision software from ‘Start->All Programs->Tordivel Vi-
sion Solutions->Scorpion 7->Scorpion 7.2’

Right click on the main dialog and click on ‘New’ sub-menu. This will ask 
for name of the new profile. Type ‘My_PresenceVerification’ (or you may 
choose any name of your choice) and click on ‘OK’ button. This will add the 
new profile to the list.

Figure 18: New Profile

Right click on the newly created profile name in the list and click on ‘Open’. 
This will pop up the confirmation message-box ‘My_PresenceVerification 
is empty profile! Create?’. Click on the ‘Yes’ button to create the new pro-
file. This will also launch Scorpion with the new profile loaded.

Figure 19: New Profile Name

Click on the ‘Setup’ tool bar button. This will pop up the pass-code dialog. 
Type 911 and click on the ‘OK’ button. This will switch to ‘Service mode’. 
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8.	Camera Set Up
Click on ‘Service’ tab, which one of the 5 main tabs on right hand side 
configuration area.

Select the ‘Camera’ sub tab. There are 2 panels available under ‘Camera’ – 
‘Camera Settings’ and ‘Image Settings’. We will be using simulator for this 
tutorial and hence will only be using the ‘Image Settings’ panel. In ‘Image 
Settings’, enable ‘Simulate’ checkbox.

Figure 20: Enable camera simulation

Select the only entry names ‘Image’ in the list under ‘Image Settings’, and 
click on the ‘Edit’ button. This will pop up the ‘Image Configuration’ dialog.

Click on the ‘Select Folder’ button next to the ‘Simulation->Path’ text 
box. Navigate to the ‘CameraSimulationImages’ folder which is available 
with this tutorial and is copied on the test machine. Then click on the ‘Ok’ 
button. 

Figure 21: Select Images folder

Type ‘*.*’ in ‘Simulation->Filter’ textbox. Click on ‘Folder’ button in front of 
the text box, for confirmation. This will pop up ‘Result for filter ‘*.*’ dialog 
and will display names of the 10 JPEG images. Click on ‘Ok’ buttons to close 
all open dialogs. Figure 22: Apply image filter

In real-life installations, we 
need to set up camera from 
‘Camera Settings’ panel. How-
ever in this tutorial we are us-
ing ‘Camera simulator’ which 
iterates through the available 
images, as per selected folder 
and filter, and uses the im-
ages as ‘captured frames’.
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9.	Scheduler Set Up
Click on the ‘Scheduler’ sub tag from the ‘Service’ tab, which is one of the 5 
main tabs on the right hand side configuration area.

Click on the ‘New’ button. This will pop up the ‘Add Event’ dialog.

Figure 23: Add new event

Check ‘Event->Enabled’ 

Type ‘Event->Name’ as ‘Trigger’ (or any name of your choice). 
 
Type ‘Event->Command’ as ‘CameraTrigger’ (‘CameraTrigger’ is special com-
mand and this text can not be changed). 

Select ‘Schedule Information->Frequency’ as ‘Every Nth millisecond’. 
 
Type ‘Schedule Information->Period’ as 1000. 

Click on the ‘OK’ button to close the ‘Add Event’ dialog. This will also add a 
new entry in the ‘Settings’ list. 

We have now set up the scheduler so that the ‘CameraTrigger’ command 
will be called after every 1000 milliseconds. This command captures im-
ages from the camera (camera simulator in case of this tutorial) and also 
executes scripts associated with this command. In the next section, we 
will associate scripts with this ‘CameraTrigger’ command. 

Figure 24: New event added
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10.	 System Events and Commands Set Up
Click on the ‘Actions’ sub tag from the ‘Service’ tab, which is one of the 5 
main tabs on the right hand side configuration area.

Default system events and commands sequences associated with each of 
them are displayed.

Figure 25: Default system events

Click on the ‘New’ button under ‘System Events’. This will pop up the ‘Event 
Properties’ dialog. 

Click on the ‘…’ button in front of the ‘Name’ text box, and select ‘Camer-
aTrigger’ event from the available list and click on the ‘OK’ button.

Figure 26: Select ‘CameraTrigger’ event

Click on the ‘Ok’ button to close the ‘Event Properties’ dialog.
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Select the newly added ‘CameraTrigger’ Event under the ‘System events’ 
list and click on the ‘New’ button under ‘Command Sequence for Camera 
trigger’. This will pop up the ‘Command Properties’ dialog.

Figure 27: New command

Click on the ‘…’ button next to the ‘Command’ textbox. This will pop up the 
command selection dialog.

Figure 28: Command selection

Select ‘GrabExecute’ and click on the ‘OK’ button.
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Select ‘Guard’ as ‘Running’ (This indicates that the command will be 
executed only in ‘Running’ state, which means only when the inspection is 
started eg - by clicking on the ‘Start’ button. ).

Figure 29: Select Guard

Click on the ‘OK’ button in the ‘Command Properties’ dialog to close it. 

We have now associated the ‘GrabExeute’ command with the 
‘CameraTrigger’ event which means that whenever a camera is triggered 
GrabExecute will be called and inspection will happen as per further 
settings.

The Start/Stop inspection button on the toolbar will now start/stop dis-
playing captured images. Before this step, it was not possible since basic 
association was incomplete. 
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11.	Detection Logic Set Up – Setting Reference
Click on the ‘Toolbox’ sub tag from the ‘Service’ tab, which is one of the 5 
main tabs on the right hand side configuration area. 

Click on the ‘New’ button under ‘Tool Settings’. This will pop up the ‘New 
Tool‘ dialog. 

Type name as ‘Calibration’. 

In the ‘Tools’ sub-tab select ‘Reference’ and then select ‘Calibrator; in the 
right hand pane.

Figure 30: Select tool Calibrator

Click on the ‘OK’ button to close the ‘New Tool’ dialog. This will add an 
entry related to the new ‘Calibrator’ tool, under ‘Tool Settings’. 

Select the newly added ‘Calibrator’ tool and click on the ‘Edit’ button. This 
will pop up the ‘Change Calibration’ dialog.

Figure 31: Edit Calibrator tool
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In the ‘Setup’ tab, click on the ‘Calibration Image->Load’ button, which 
will pop up the image selection dialog. Navigate to the ‘CalibrationIm-
ages’ folder which is available with this tutorial and is copied on the test 
machine. Select the ‘0001.bmp’ image. This will show the thumbnail of 
the selected image on the right hand side of the dialog. Then click on the 
‘Open’ button to close the image selection dialog.

Figure 32: Select Calibration image

Now the ‘Change Calibration’ dialog shows the selected image in the bot-
tom portion. 

In the ‘Grid->Row spacing’ text-box, type ‘8’. In ‘Grid->Col spacing’ text-box, 
type ‘8’. In ‘Grid->Unit’ text-box, type ‘mm’. Then click on the ‘Compute’ but-
ton. This will do the calibration calculations and will show the ‘OK’ result 
under ‘Gauging’ and ‘OK’ result under ‘Robot vision’ and will update results 
under ‘Results of model-fit’.

Figure 33: Calibration settings

Click on the ‘OK’ button to close the ‘Change Calibration’ dialog. The Cali-
brator  tool is now set up and ready to use.

We have now set up the reference for the system. 

The reference provides pixel to actual distance mapping information to 
Scorpion. We have used an 8mm grid image as an example which means 
distance between grid centres is 8 mm vertically as well as horizontally. 
Hence we have entered 8mm for ‘Row spacing’ and 8mm for ‘Col spacing’ 
during set up.

Calibrator is also used for calculating wide-angle lens deformations inside 
Scorpion (this is out of scope of this tutorial though). 

For this tutorial of ‘Presence Verification’, Calibrator is not a must, since we 
are not using any measurement feature. But in general it’s a good practice 
to set up a reference system as the first step in detection logic set up.
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12.	 Detection Logic Set Up – Setting Blob4 Tool

Click on the ‘New’ button under ‘Tool Settings’. This will pop up the ‘New 
Tool ‘ dialog. 

Type name as ‘Locate’. 

In the ‘Tools’ sub-tab select ‘Advanced’ and then select ‘Blob4’ in the right 
hand pane. 

Figure 34: Select tool Blob4

Click on the ‘OK’ button to close the ‘New Tool’ dialog. This will add an 
entry related to the new ‘Locate’ tool, under ‘Tool Settings’. 

Select the newly added ‘Locate’ tool and click on the ‘Edit’ button. This will 
pop up the ‘Change Locate’ dialog.

In the ‘Setup’ tab, select ‘Reference’ as ‘Calibration’. Also select ‘Search 
Area->Use whole picture’. 

Figure 35: Blob4 tool setup
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In the ‘Threshold’ tab, ‘Specify’ threshold as ‘Minimum’ = 0 and ‘Maximum’ 
= 100

Figure 36: Blob4 tool threshold

In the ‘Visualization’ tab, select ‘Center’ and ‘ROI’ visualizations. De-select 
all other visualizations. 

Click on the ‘OK’ button to close the ‘Change Locate’ dialog. The Blob4 tool 
is now set up and ready to use. 

Figure 37: Blob4 tool visualization

We have set up foreground pixels range as 0 to 100. Which means, that 
pixels with intensity value 0 to 100 (which indicates black color on image) 
are ‘foreground pixels’ and remaining are ‘background’ pixels (which are 
pixels in the white color range). 

We have set up the ‘Search area’ for blob detection as a complete scene.

Blob4 tool is a powerful tool which also calculates several properties of 
every detected blob and also calculates ranges based on all blobs found in 
the image.

For this tutorial we will be using ‘blob count’ detected by Blob4 tool. If blob 
count is more than 0, washer exists in the image, and if blob count is 0, 
washer is not present in the image.

By doing these settings, we have now included processing for ‘Presence 
Verification’.

We have now set up a blob detector tool. Every image has ‘foreground’ 
pixels which are associated with objects under detection (eg – washer in 
this tutorial) and remaining ‘background’ pixels. Blob is a set of foreground 
pixels connected to each other. Every image can have zero or more blobs in 
it. The Blob4 tool finds all such blobs.
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13.	Detection Logic Set Up – Setting LogicTool
Click on the ‘New’ button under ‘Tool Settings’. This will pop up the ‘New 
Tool‘ dialog

Type name as ‘Present’. 

In the ‘Tools’ sub-tab select ‘Basic’ and then select ‘LogicTool’ in the right 
hand pane.

Figure 38: Select LogicTool

Click on the ‘OK’ button to close the ‘New Tool’ dialog. This will add an 
entry related to the new ‘Present’ tool, under ‘Tool Settings’

Select the newly added ‘Present’ tool and click on the ‘Edit’ button. This will 
pop up the ‘Change Present’ dialog.

In the ‘Setup’ tab, click on the ‘New’ button, this will pop up the ‘Logic 
Parameter’ dialog. 

In the ‘Logic Parameter’ dialog, select ‘Tool’ as ‘Locate’ and ‘Parameter’ as 
‘Count’. Under ‘Conditions’, enable ‘minimum’ and type ‘1’ in the text box 
next to it. Click on ‘OK’ button to close ‘Logic Parameter’ dialog.

Figure 39: New logic parameter setup
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In the ‘Change Present’ dialog, now there will be an entry for the logic 
parameter we have newly added.

Figure 40: New logic parameter added

Click on the ‘OK’ button to close the ‘Change Present’ dialog.

We have now set up logic tool. As the name suggests, a logic tool is used 
for combining results from various tools and calculating single yes or no 
result.

This is a powerful tool which can act as ‘formula evaluator’, where formula 
is defined as combination of different logic parameters based on available 
results and calculations from individual tools.
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14.	 Detection Results Handling
Click on the ‘Settings’ tab, which is one of the 5 main tabs on the right 
hand side configuration area and is just before the ‘Service’ tab. 

Figure 41: Settings tab

There is a default entry ‘Pass’ under ‘List of States’. Select the ‘Pass’ state 
and click on the ‘Delete’ button. This will ask for confirmation ‘Delete state 
Pass?’. Click on the Yes button to delete the default state.

Click on the ‘New’ button under ‘List of States’. This will pop up the ‘Create 
new state ?’ dialog box. Type the name ‘OK’ and click on the ‘OK’ button to 
add a new state to ‘List of States’.

Figure 42: Add new state ‘OK’

Select the newly added ‘OK’ state and click on ‘Edit’ button. This will pop up 
the ‘Settings for state OK’ dialog.
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Under the ‘General’ tab, click on the ‘State colors->Back’ button, which will 
pop up the color selection dialog. Select green color and click the ‘OK’ but-
ton to close the color selection dialog. Green color will also be displayed on 
the ‘Settings for state OK’ dialog.

Figure 43: ‘OK’ state settings

In the ‘Constraints’ tab, click on the ‘New’ button. This will pop up the 
‘Guard’ selection dialog which lists several available guards.

Select ‘Present’ and click on the ‘Ok’ button to close the ‘Guard’ dialog. This 
will add an entry to the list available under the ‘Constraints’ tab.

Figure 44: New Constraint settings

Click on the ‘OK’ button to close the ‘Settings for state OK’ dialog.
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Click on the ‘New’ button under ‘List of States’. This will pop up the ‘Create 
new state ?’ dialog box. Type the name ‘No washer’ and click on the ‘OK’ 
button to add a new state to ‘List of States’. 

Figure 45: Add New State ‘No washer’

Select the newly added ‘No washer’ state and click on the ‘Edit’ button. This 
will pop up the ‘Settings for state No washer’ dialog.

Under the ‘General’ tab, select ‘Classification’ as ‘Ignore’. 

Click on the ‘State colors->Back’ button, which will pop up the color selec-
tion dialog. Select the yellow color and click the ‘OK’ button to close the 
color selection dialog. The yellow color will also be displayed on the ‘Set-
tings for state No washer’ dialog.

Figure 46: ‘No washer’ State Settings

In the ‘Constraints’ tab, click on the ‘New’ button. This will pop up the 
‘Guard’ selection dialog which lists several available guards.
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Select ‘Present’ and click on the ‘Ok’ button to close the ‘Guard’ dialog. This 
will add an entry to the list available under the ‘Constraints’ tab.

Figure 47: ‘New Constraint Settings

Click on the new entry ‘Present’ in the list of ‘Constraints’ and click on 
‘Invert’ button. This will change the ‘Inverted’ column text from ‘No’ to ‘Yes’.

Figure 48: ‘Invert Constraint

Click on the ‘OK’ button to close the ‘Settings for state No washer’ dialog.

Please note that we are checking the same constraint ‘Present’ (which is a 
LogicTool) for both these states. For the ‘OK’ state it is used normally and 
for the ‘No washer’ state, it is inverted.

We have set the ‘Classification’ for ‘No washer’ state as ‘Ignore’. This 
classification is related to statistics (‘Operation’ mode ‘Statistics’ tab). 
We have set the ‘No washer’ state to be ignored during statistics genera-
tion. Every new state defined can be linked to any one of the 4 statistics 
classifications: 

1.	 Pass – This is the default and indicates a positive inspection result and 
part is accepted

2.	 Fail – This indicates a negative inspection result and part is rejected
3.	 Ignore – This indicates that the state should be ignored from statistics 

calculations
4.	 Error – This indicates error in processing

We have now set up the states for the detection system. States can be 
defined to handle results and associate them with display and reports.

We have defined the ‘OK’ state which indicates ‘Washer Present’, we 
have set up a green color for it for better visual understanding about the 
inspection result.

We have also defined the ‘No washer’ state which indicates ‘Washer 
Absent’, we have set up a yellow color for it so that the inspection result 
stands out from the ‘OK’ state.
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15.	Running the System
Set up is complete and we are now ready to run the system. 

Click on the ‘Start’ tool bar button. This will start capturing the images 
(from camera simulator as per our settings) and will also do the detection 
for ‘Washer presence verification.

The captured image is displayed below the toolbar buttons and it also has 
visualization updates done by Scorpion (center and RIO as set up during 
Blob4 tool set up). 

When a washer is present in the captured image, the ‘Result’ panel shows 
a green color with an ‘OK’ text. 

Figure 49: Result ‘OK’

When the washer is not present in the captured image, the ‘Result’ panel 
shows a yellow color with ‘No washer’ text.

Figure 50: Result ‘No washer’

Congratulations! 
You have successfully created your first ‘Presence Verification’ system 
using Scorpion Vision Software!
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16.	 Using Statistics
Click on  ‘Operation’ mode. Go to the ‘Statistics’ tab.

The first section gives ‘Classification’ statistics. It has 4 rows – Pass (ac-
cepted parts), Fail (rejected parts), Error (error in processing), and Total.

The second section gives ‘Yield’ statistics. It has 3 rows – Pass (% accepted 
parts), Fail (% rejected parts), Error (% error in processing).

The third section gives the ‘States’ statistics. It has one row for every de-
fined state, one row for ‘Undefined state’ when the inspection result does 
not fall under any of the defined states, and one row for ‘Total’.

Figure 51: Statistics Tab

Right click anywhere on the ‘Statistics’ tab. Click on ‘Reset Period’. This will 
copy the ‘Current Period’ statistics to the ‘Previous Period’ statistics and 
will reset the current period statistics to zero.

This is used for starting a new period for statistics calculations.

Figure 52: Reset Period
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Right click anywhere on the ‘Statistics’ tab. Click on ‘Reset Statistics’. This 
resets all statistics to zero, including Current period, Previous period and 
Total.

The statistics are remembered by Scorpion. They are saved when Scorpion 
is closed and re-loaded when Scorpion starts again next time.

Figure 53: Result Statistics

The statistics can easily be reset from the convenient ‘User Interface’, 
as described in this section. However, statistics can also be reset from 
Scorpion commands (this is out of scope of this tutorial though). 

Statistics;cmd=zero => resets the period statistics 
Statistics;cmd=reset => resets all statistics 
Statistics;cmd=save => saves the statistics to file
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17.	A Few Important Features
A ‘Help’ button is available on every set up dialog in Scorpion. When the 
user clicks on the ‘Help’ button on any dialog, Scorpion Help is launched 
and it displays help related to that dialog.

As we have observed, clicking on the ‘Start’ toolbar button starts inspec-
tion. When inspection is on, the same button changes to ‘Stop’. Clicking on 
the ‘Stop’ toolbar button, stops the inspection. This is called an automatic 
inspection. 

We can also do a manual inspection. Clicking on the ‘Snapshot’ toolbar 
button captures a new frame from camera (or simulator in case of this 
tutorial). Clicking on the ‘Inspect’ toolbar button inspects the recently 
captured image. 

We can change thr title of the inspection results panel (located under 
the image display area). Right click on the panel area and select ‘General-
>Caption’. This will pop up the ‘Configuration’ title. Type a new title and 
click on the ‘OK’ button to close the dialog. A new title will now be dis-
played for the inspection results panel. Figure 54: Inspection Result Panel Caption Edit

Figure 55: Type new Caption

http://scorpion.tordivel.no/help/


Scorpion Vision Software® Getting Started Tutorial Part 1  - Presence Verification
© 2000-2013 Tordivel AS 33

18.	 Defining Region of Interest (ROI)
During the Blob4 tool set-up under the ‘Setup’ tab, we have selected the 
option ‘Search area’ -> ’Use whole picture’. Instead of selecting this, we 
can very easily define a ‘Region of Interest (ROI)’. When ‘Use whole picture’ 
is not selected and an ROI is defined, blob detection happens only in the 
defined ROI, everything outside the ROI is ignored.

Scorpion provides a very simple way for defining ROI polygons. Hold the 
keyboard ‘Control’ (Ctrl) button and mouse left-button-click on the image 
panel. First click will add a point on image. From 2nd click, it will draw con-
necting line with previously added point.

Holding ‘Control’ (Ctrl) button and mouse right-button-click removes the 
last added point and line if associated with it. This ‘undo’ can be done 
repeatedly to undo all points added so for.

Figure 56: Define ROI using ‘Ctrl+Mouse LButton’
Polygons of any shape, including the ones with hole inside can be defined 
and Scorpion can use ithem as ROIs for detection.
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Go to ‘Service’ mode. On the ‘Toolbox’ tab, select the tool ‘Locate’ which is a 
Blob4 tool.

Use keyboard short-cut ‘Ctrl+Z’ (or right-click on ‘Locate’, click on ‘Tool’ 
menu and click on ‘Set ROI’ sub-menu).

This will add the selected polygon ROI to the ‘Locate’ tool. 

Figure 57: Add ROI to ‘Locate’ Tool

Figure 58: Edit ‘Locate’ Tool

Click on the ‘Edit’ button. This will pop up the ‘Change Locate’ dialog box.

The polygon ROI will be available under ‘Search Area’ -> ‘Polygons’.

Uncheck ‘Search Area’ -> ‘Use whole picture’.

Click on the ‘OK’ button to close the ‘Change Locate’ dialog box.
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Click on the ‘Start’ button to start the inspection.

The ROI will be displayed on the image, as inspection happens.

All washers  which are partially or fully in the ROI are detected. 

Washers completely outside the ROI are not detected, and state shows ‘No 
washer’.

In Scorpion, defining ROI and associating it with a tool in the Toolbox is 
very easy.

ROI is a useful feature, normally used for increasing the detection accuracy 
and also for lowering the processing time by only processing the required 
region and ignoring all other regions.Figure 59: Inspection with ROI, Result ‘OK’

Figure 60: Inspection with ROI, Result ‘No washer’



Scorpion Vision Software® Getting Started Tutorial Part 1 - Presence Verification
© 2000-2013 Tordivel AS 36

19.	 Tutorial Summary

•	 We have learnt about overall working of the powerful Scorpion Vision Software and also got familiar with its intuitive user interface.  

•	 We tried out the pre-compiled profile ‘Presence Verification’ for detecting presence of washers in the images captured by Scorpion. 

•	 Finally we created our own ‘Presence Verification’ profile and saw it in action. The profile set up included camera set up, scheduler set up, system 
events and command set up and detection logic / tools set up. 
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