AVT Universal API - Image Transform module: AVT Universal API Image Transform module

  • Main Page
  • Related Pages
  • Data Structures
  • Files

AVT Universal API Image Transform module

1.6.

The AVT Universal API Image Transform module is a programming interface for those who want to transform images to different formats in their own applications. The methods provided are mainly for transforming FireWire formats to displayable bitmap formats.
Since the module is designed as a C-DLL interface, it is usable by many languages.
It is delivered in two versions:
  • A secure version that checks parameters for valid values
  • A faster version that only checks pointer parameters

Main contents:

  • The Introduction page provides the basics for understanding and using the Universal API Image Transform module.

  • The Transformation overview page gives an overview of the source and target formats of this module
  • The Color conversion page describes methods to convert color images
  • The Image transformation page describes the methods to manipulate images
Generated on 27 Nov 2008 using doxygen 1.5.6 by Allied Vision Technologies


AVT Universal API - Image Transform module: Introduction

  • Files

Introduction

General

Method names

All methods of this API have a prefix "UIT_", and the rest of the method names should be mostly self-explanatory. Definitions usually have a "UNI" as part of the name.

Method parameters

For better interoperability between languages, we have chosen our own definitions of the parameter types, and in this module, we restrict to the following types
  • INT32_TYPE or UINT32_TYPE (32 bit values) and pointers to these
  • pointer to UINT8_TYPE (unsigned 8 bit value) for data arrays
  • pointer to void for arrays to structs (e.g. for RGB)
  • COLOR_CORRECTION_HANDLE which is mainly a pointer to void
  • FLOAT_TYPE or pointer to this
See also:
uni_types.h

Method return codes

Return codes are always of type UNI_RETURN_TYPE (long), so that there is always the possibility to return error codes, which may then be evaluated. If everything was OK, a method returns S_OK, otherwise a specific error code.
The most common API error is:
UNI_RESULT_PARAMETER_INVALID_(X)
The xth parameter is not valid
See also:
uni_defines.h

Deployment

From version 1.1 of the UniTransform.dll on, you don't have to deploy more files with your application than the DLL itself. (Before, you needed to deploy the files MSVCRT_80.DLL and MSVCRP_80.DLL as well)

Image transformation

For a description on image transformation methods see Image transformation

Image format conversion

For a description on image format conversion methods see Image format conversion


AVT Universal API - Image Transform module: Overview of Image Format Transformations

Overview of Image Format Transformations

The following table gives an overview of the functions provided by the UniTransform.dll to perform corresponding format transformations of (memory) images stored on a PC

Target
Format

Source
Format

Mono8 (Y8)

Mono16 (Y16)

R8G8B8 (3 planes)

R8G8B8Y8 (4 planes)

BGR8 (RGB24 for Windows)

BGR16 (16Bit per color)

BGRA32 (BGRA32 windows)

YUV422 (UYVY windows)

Mono 8 (Y8)

X

X

X

Mono 16 (Y16)

X

X

X

YUV 422 (16Bit)

X

X

X

X

YUV 411 (12Bit)

X

X

X

X

RGB 8 (RGB24)

X

X

X

X

RAW 8

X 2 ,3

X 1 ,2 ,3

X 1 ,3

X

RAW 12

X

X

X 2

X 2

X

RAW 16

X 2

X

X 2

X

Table 1: Image Format Transformations provided by the UniTransform.dll

1 optionally with additional Debayering functionality

2 optionally with additional ColorConversion functionality

3 also available for interlaced cameras


AVT Universal API - Image Transform module: Image Format Conversion

Image Format Conversion

This section describes a collection of methods for handling images that may originate from AVT cameras.

It is made for those who use image formats that differ from the transfer formats the cameras provide directly.
It may also be used to transform raw images originating from color cameras to Windows bitmaps, which may be processed more easily.
The following transport formats are used (see the IIDC specification):

  • Mono 8
  • Mono 12
  • Mono 16
  • YUV 422
  • YUV 411
  • RGB 8
  • RAW 8
  • RAW 12
  • RAW 16
The following target formats are available:
  • 8 bit/pixel bitmap
  • 24 bit/pixel bitmap
  • 32 bit/pixel bitmap BGRA where the A(alpha channel)-component is unchanged
  • YUV422 (UYVY)
  • three color plane bitmaps (R,G,B)
  • four color plane bitmaps (R,G,B and Y)
  • special one-plane bitmap formatted like the transfer data
  • 16 bit/pixel bitmaps through debayering (from 16 bit data received with UIT_Raw16ToY16_CC and UIT_Raw16ToY16)
  • 16 bit/pixel RGB bitmaps through debayering (from 16 bit data received with UIT_Raw16ToBGR16_CC and UIT_Raw16ToBGR16)

Debayering, demosaicing, de-interlacing

The debayering methods may be called using the parameters:
  • A pointer to the destination image memory area
  • A pointer to the source image memory area
  • The width of the images
  • The height of the images
  • The number of pixels in the image
  • A parameter indicating the start pixel of the Bayer pattern used in the image. Possible values for the RGGB sensors:
    • 0 meaning the R pixel
    • 1 meaning the GB pixel
    • 2 meaning the GR pixel
    • 3 meaning the B pixel
  • Some 16-bit-to-16-bit methods also have a parameter to provide the number of bits the image should be shifted to the least significant position. (Normally, 16 bit images are MSB-aligned, so the lower four bits of real 12 bit images are 0.)
  • Some methods also allow a handle to a color correction object. If provided (means: !=NULL and created by methods like UIT_CreateColorCorrectionMatrix_Int8) the color correction pointed to by the given handle is applied to every pixel.
  • The UIT_XXXImageTransform functions use :E_UNI_SIMPLE_IMAGE_FORMAT to specify the output image format
See also:
Debayering methods


AVT Universal API - Image Transform module: Bayer patterns

Bayer patterns

There are various Bayer patterns in use by sensor manufacturers for allowing color images with only one sensor.

RGGB sensors

The most common one has rows of alternating red and green pixels, followed by rows of alternating green and blue pixels.
This leads to a lower resolution for red and blue, plus the colors are measured at different spots, so a debayering algorithm has to cope with color displacement as well as with the different resolution for the colors.
The start pixel of the Bayer pattern varies between sensor manufacturers.
  • The Sony sensors in the Guppy GF-033C, GF-046C and the GF-080C and in the Marlin, Stingray, Oscar and Dolphin color cameras all use the red pixel as start, resulting in a pattern of
    R | G
    G | B
  • The Ibis5 sensor inside the Marlin 131C uses the GB pixel as start, resulting in a pattern of pattern of
    G | B
    R | G
  • The Kodak sensors in most Pike cameras use the GR pixel as start, resulting in a pattern of
    G | R
    B | G
  • The Micron sensor in the Guppy GF-036C use the blue pixel as start, resulting in a pattern of
    B | G
    G | R

CYMG sensors

A different color pattern is used in some interlaced sensors by Sony, used inside the Guppy GF-025C,GF-029C,GF-038C and GF-044C. It uses colors complementary to the usual R, G and B colors, and the pattern changes every four lines.
C | Y
G | M
C | Y
M | G


AVT Universal API - Image Transform module: Debayering methods

Debayering methods

RGGB debayering

The following debayering methods for RGGB sensors are provided:
  • The straightforward Simple 2x2 debayering (code)
  • A Simple 2x2 debayering with only monochrome output (code)
  • A 3x3 debayering provided by the Oscar cameras(code)
  • The 2x2 debayering with light horizontal smoothing of the old Marlin cameras(code)
  • The LCAA: 2x2 debayering with strong horizontal U and V smoothing of the newer Marlin and the Stingray cameras(code)
  • The LCAA+V: 2x2 debayering with strong horizontal and light vertical U and V smoothing used in the Pike cameras(code)
The first method is the fastest color debayering, but with well-known drawbacks in color quality (which are not visible in a monochrome image, so this is also the preferred debayering for the monochrome output). The three by three debayering is used in the Oscar cameras. It uses linear and bilinear interpolation. Since the green channel is also interpolated, the resulting images is less sharp than with a 2x2 debayering.
The fourth method is used in the Marlin 2 cameras, the Stingray cameras and certain firmware versions of newer Dolphin cameras, and it uses four consecutive values for smoothing the U and the V values, thus smoothing abrupt horizontal color changes. The fifth method also uses four values horizontally plus the four values of the following row to smooth U and V values, smoothing colors in horizontal as well as in vertical direction.

Simple 2x2 debayering

This algorithm works as nearest neighbor for R and B and interpolates G diagonally, so you lose one row and one column of data

Simple 2x2 debayering with only monochrome output

Same as above, but the Y value for each debayered pixel is computed and replaces R,G and B.

3x3 debayering

For R and B, bilinear interpolation is applied if four color pixels are available, and linear interpolation is used if two pixels are available in the 3x3 window. For the green pixels, the interpolation done is according to the following matrix:
0 | 0 | 1
0 | 2 | 0
1 | 0 | 0
alternating with
1 | 0 | 0
0 | 2 | 0
0 | 0 | 1
and at the locations in-between:
0 | 1 | 0
1 | 0 | 1
0 | 1 | 0

2x2 debayering with light horizontal smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of neighboring pixels are averaged, and the image is converted back to RGB.
Example: U1new=(U1old+U2old)/2

LCAA: 2x2 debayering with strong horizontal U and V smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of four neighboring pixels are averaged, and the image is converted back to RGB.(LCAA meaning local color anti-aliasing)
Example: U2new=(U1old+ U2old+U3old+U4old)/4

LCAA+V: 2x2 debayering with strong horizontal and light vertical U and V smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of eight neighboring pixels on two rows are averaged, and the image is converted back to RGB. (LCAA+V meaning local color anti-aliasing plus vertical)
Example:
U1,2new= (U1,1old+U1,2old+U1,3 old+U1,4old
+U2,1old +U2,2old+U2,3old+U2,4old)/8

For the 2x2 simple algorithm, there are additional methods for color and b/w, for which you may create a color conversion object that is applied to your image data. For example, you might apply an additional color conversion matrix (UIT_Raw8ToY8_CC) after you created it with UIT_CreateColorCorrectionMatrix_Int8

CYMG debayering

At this time, there are only three debayering algorithms for the pure interlaced output (Format 7 mode 1 in the Guppy cameras) and one algorithm for the binned interlaced output (Format 7 mode 0 in the Guppy cameras). All of them result in an image in the Windows RGB format.
  • One 2x2 algorithm (UIT_IRaw8CYGMToBGR)
  • One algorithm working with a 3x3 matrix (UIT_IRaw8CYGMToBGR_3x3)
  • One 2x2 algorithm resulting in a monochrome image (UIT_IRaw8CYGMToMono)
  • One algorithm for converting a binned color image to an RGB image (UIT_IRaw8CYGMToBGR_Bin)


AVT Universal API - Image Transform module: Special image transformation

Special image transformation

There are some methods included in this library that are usable for converting images without changing image format.

  • UIT_InterlacedToProgressive just de-interlaces a raw or monochrome image resulting from an interlaced Guppy
  • UIT_GetResampledScanlineLength, UIT_ResampleScanlines and UIT_ResampleScanlinesEx may be used to convert an image to one with a different horizontal resolution. It should be used for monochrome images and also for raw images which have to be debayered afterwards.
  • UIT_RGB8ToBGR converts a Windows RGB image to a bitmap with R,G and B in the opposite order or vice versa
  • UIT_FlipVertical flips an image vertically
  • UIT_Flip flips an image in either direction


AVT Universal API - Image Transform module: Version information

Version information

  •  Changes from version 1.5.1 to 1.6:
    Additions/changes:
    • Added: E_UNI_SIMPLE_IMAGE_FORMAT enum for use with the UIT_XXXImageTransform functions
    • Added: UIT_RGB8ImageTransform
    • Added: UIT_YUV422ImageTransform
    • Added: UIT_YUV411ImageTransform
    • Added: UIT_Y8ImageTransform
    • Added: UIT_Y12ImageTransform
    • Added: UIT_Y16ImageTransform
    • Added: UIT_Raw8ImageTransform
    • Added: UIT_Raw12ImageTransform
    • Added: UIT_Raw16ImageTransform
    • Added: UIT_Raw8ImageTransform_3x3
    • Added: UIT_Raw8ImageTransform_IntYUV422
    • Added: UIT_Raw8ImageTransform_IntLCAA
    • Added: UIT_Raw8ImageTransform_IntLCAAV
    • Added: UIT_IRaw8CYGMImageTransform_Bin
    • Added: UIT_IRaw8CYGMImageTransform
    • Added: UIT_IRaw8CYGMImageTransform_3x3
  •  Changes from version 1.5 to 1.5.1:
    Additions/changes:
    • Added: UIT_Y8ToBGR
  •  Changes from version 1.4 to 1.5:
    Additions/changes:
    • UIT_GetSIS
      • added error handling for wrong colorcode
      • internal handling the return of GetBitsPerPixel
      • changed return from UNI_RESULT_INVALID_SETTINGS (not part of UniTransform) to UNI_RESULT_UNKNOWN_ERROR
    • UIT_GetBitsPerPixel color code out of bounds error return is now UNI_RESULT_PARAMETER_INVALID_1
    • UIT_GetErrorInfo missing error codes added
  •  Changes from version 1.3 to 1.4:
    Additions/changes:
    • Added UIT_RGB8ToY8 method for color-to-grayscale conversion
    • Corrected UIT_Raw12ToBGR16 and UIT_Raw12ToBGR16_CC method
    • Changed calling convention for x64 support
  •  Changes from version 1.2 to 1.3:
    Additions/changes:
    • Added UIT_GetSIS method to extract a Secure Image Stamp from a transfer image
    • Added methods to handle 12-bit images
      • UIT_Packed12BitTo8Bit
      • UIT_Packed12BitTo16Bit
      • UIT_Raw12ToBGR
      • UIT_Raw12ToBGR_CC
      • UIT_Raw12ToBGR16
      • UIT_Raw12ToBGR16_CC
    • Added method UIT_GetBitsPerPixel
    • Added method UIT_GetErrorInfo to be able to evaluate errors
    • Added methods UIT_GetTechnoInfo and UIT_Y16ToY8_MMX for accelerated conversions
    • Improved the documentation
    Solved bugs:
    • Removed a systematic error in the documentation concerning endianness of 16 bit images
  •  Changes from version 1.1 to 1.2:
    Additions/changes:
    • Renamed UIT_InterlacedToProgressive to UIT_InterlacedToProgressive (typo)
    • Improved the documentation
    Solved bugs:
    • Corrected bad return codes in UIT_ResampleScanlines
  •  Changes from version 1.0 to 1.1:
    Additions/changes:
    • The used CRT libraries are linked statically. Now, no additional libraries are needed at runtime
    • Added methods UIT_FlipVertical and UIT_Flip and enumeration E_UNI_FLIP_MODE
    • Color code enumeration ( E_UNI_COLOR_CODE) extended for future purposes
    • Bayer pattern enumeration ( E_UNI_BAYER_PATTERN): values for GRBG and GBRG switched to conform to IIDC (no code changes are necessary)
    • Bayer pattern enumeration ( E_UNI_BAYER_PATTERN): values for CYGM sensors added (not needed for debayering methods)
    Solved bugs:
    • Method UIT_YUV422ToRGBYPlanes was internally mapped to UIT_YUV411ToRGBYPlanes. Solved.
    • The internal computation for debayering CMYG images was corrected. Now, images resulting from the 3x3 algorithm have the same intensity as the images resulting from the 2x2 algorithm.
    • Re-used DEF file for undecorated method names
  •  1.0:
    Initial version


AVT Universal API - Image Transform module: S_12BIT_2PACKED Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_12BIT_2PACKED Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes.

Data Fields

UINT8_TYPE m_nVal8_1
High byte of the first Pixel.
UINT8_TYPE | m_nVal8_1Low: 4
Low nibble of the first pixel.
UINT8_TYPE | m_nVal8_2Low: 4
Low nibble of the second pixel.
UINT8_TYPE m_nVal8_2
High byte of the second pixel.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_BGR16 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGR16 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing 16-bit Windows-type RGB data.

Data Fields

UINT16_TYPE B
blue part
UINT16_TYPE G
green part
UINT16_TYPE R
red part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_BGR8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGR8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGB data.

Data Fields

UINT8_TYPE B
blue part
UINT8_TYPE G
green part
UINT8_TYPE R
red part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_BGRA8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGRA8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGBA data.

Data Fields

UINT8_TYPE B
blue part
UINT8_TYPE G
green part
UINT8_TYPE R
red part
UINT8_TYPE A
unused

The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_RGB8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_RGB8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGB data.

Data Fields

UINT8_TYPE R
red part
UINT8_TYPE G
green part
UINT8_TYPE B
blue part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_SIS_DATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SIS_DATA Struct Reference

#include <uni_defines.h>

Detailed Description

SIS data structure.

Data Fields

UINT32_TYPE m_CycleCounter
bus cycle count
UINT32_TYPE m_FrameCounter
frame count since last reset
UINT32_TYPE m_TriggerCounter
from camera received triggers
UINT16_TYPE m_AOILeft
left coordinate of the AOI begin
UINT16_TYPE m_AOITop
top coordinate of the AOI begin
UINT16_TYPE m_AOIWidth
width of the AOI
UINT16_TYPE m_AOIHeight
height of the AOI
UINT32_TYPE m_Shutter
camera shutter for the image
UINT16_TYPE m_Gain
camera gain for the image
UINT16_TYPE m_Reserved0
reserved for future use
UINT8_TYPE | m_OutputState [4]
state of the output pins
UINT8_TYPE | m_InputState [2]
state of the input pins
UINT8_TYPE | m_Reservec1 [2]
reserved for future use
UINT8_TYPE m_SequenceIndex
position in the sequence
UINT8_TYPE m_Reserved2a
reserved for future use
UINT8_TYPE m_ColorCoding
IIDC color coding for the transport format.
UINT8_TYPE m_Reserved2b
reserved for future use
UINT32_TYPE m_SerialNumber
camera serial number
UINT32_TYPE m_UserValue
user defined value
S_SIS_ENABLE m_SISEnable
state inq struct
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_SIS_ENABLE Union Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SIS_ENABLE Union Reference

#include <uni_defines.h>

Detailed Description

information about state of the fields of the S_SIS_DATA struct

Data Fields

struct
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS 		m_Enable
states of the sis data
UINT32_TYPE m_Data
Enable as UINT32.

Data Structures

struct S_SIS_ENABLE_FIELDS
states of the sis data More...
The documentation for this union was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS Struct Reference

#include <uni_defines.h>

Detailed Description

states of the sis data

Data Fields

UINT32_TYPE | m_CycleCounter: 1
inq cycle counter
UINT32_TYPE | m_FrameCounter: 1
inq frame count since last reset
UINT32_TYPE | m_TriggerCounter: 1
inq triggers received by the camera
UINT32_TYPE | m_AOILeft: 1
inq left coordinate of the cameras AOI
UINT32_TYPE | m_AOITop: 1
inq top coordinate of the cameras AOI
UINT32_TYPE | m_AOIWidth: 1
inq width of the AOI
UINT32_TYPE | m_AOIHeight: 1
inq height of the AOI
UINT32_TYPE | m_Shutter: 1
inq camera shutter for the image
UINT32_TYPE | m_Gain: 1
inq camera gain for the image
UINT32_TYPE | m_OutputState: 1
inq output pin states
UINT32_TYPE | m_InputState: 1
inq input pin states
UINT32_TYPE | m_SequenceIndex: 1
inq position in sequence
UINT32_TYPE | m_ColorCoding: 1
inq IIDC color coding
UINT32_TYPE | m_SerialNumber: 1
inq serial number of the camera
UINT32_TYPE | m_UserValue: 1
inq user defined value
UINT32_TYPE | m_Valid: 1
Data in Enable is valid.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_SUPPORT_STATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SUPPORT_STATE Struct Reference

#include <uni_defines.h>

Detailed Description

states of the multi media technology support for operating system and processor.

Data Fields

bool | Processor
technology supported by the processor
bool | OperatingSystem
technology supported by the OS
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_TECHNO_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_TECHNO_INFO Struct Reference

#include <uni_defines.h>

Detailed Description

states of the support for different multimedia technologies

Data Fields

S_SUPPORT_STATE IntelMMX
INTEL first gen MultiMedia eXtension.
S_SUPPORT_STATE IntelSSE
INTEL Streaming SIMD Extension.
S_SUPPORT_STATE IntelSSE2
INTEL Streaming SIMD Extension 2.
S_SUPPORT_STATE IntelSSE3
INTEL Streaming SIMD Extension 3.
S_SUPPORT_STATE IntelSSSE3
INTEL Supplemental Streaming SIMD Extension 3.
S_SUPPORT_STATE AMD3DNow
AMD 3DNow.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_YUV411 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV411 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:1:1 format (UYYVYY).

Data Fields

UINT8_TYPE U
the U part for all four pixels
UINT8_TYPE Y0
the intensity of the first pixel
UINT8_TYPE Y1
the intensity of the second pixel
UINT8_TYPE V
the V part for all four pixels
UINT8_TYPE Y2
the intensity of the third pixel
UINT8_TYPE Y3
the intensity of the fourth pixel
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_YUV422 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV422 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:2:2 format (UYVY).

Data Fields

UINT8_TYPE U
the U part for both pixels
UINT8_TYPE Y0
the intensity of the first pixel
UINT8_TYPE V
the V part for both pixels
UINT8_TYPE Y1
the intensity of the second pixel
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: S_YUV444 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV444 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:4:4 format (YUV).

Data Fields

UINT8_TYPE Y
Luma.
UINT8_TYPE U
U.
UINT8_TYPE V
V.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • g
  • i
  • m
  • o
  • p
  • r
  • u
  • v
  • y
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • A : S_BGRA8
  • AMD3DNow : S_TECHNO_INFO

- b -

  • B : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- g -

  • G : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- i -

  • IntelMMX : S_TECHNO_INFO
  • IntelSSE : S_TECHNO_INFO
  • IntelSSE2 : S_TECHNO_INFO
  • IntelSSE3 : S_TECHNO_INFO
  • IntelSSSE3 : S_TECHNO_INFO

- m -

  • m_AOIHeight : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOILeft : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_AOITop : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOIWidth : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_ColorCoding : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_CycleCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Data : S_SIS_ENABLE
  • m_Enable : S_SIS_ENABLE
  • m_FrameCounter : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Gain : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_InputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_nVal8_1 : S_12BIT_2PACKED
  • m_nVal8_1Low : S_12BIT_2PACKED
  • m_nVal8_2 : S_12BIT_2PACKED
  • m_nVal8_2Low : S_12BIT_2PACKED
  • m_OutputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Reservec1 : S_SIS_DATA
  • m_Reserved0 : S_SIS_DATA
  • m_Reserved2a : S_SIS_DATA
  • m_Reserved2b : S_SIS_DATA
  • m_SequenceIndex : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_SerialNumber : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Shutter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_SISEnable : S_SIS_DATA
  • m_TriggerCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_UserValue : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Valid : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS

- o -

  • OperatingSystem : S_SUPPORT_STATE

- p -

  • Processor : S_SUPPORT_STATE

- r -

  • R : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- u -

  • U : S_YUV444 , S_YUV411 , S_YUV422

- v -

  • V : S_YUV444 , S_YUV411 , S_YUV422

- y -

  • Y : S_YUV444
  • Y0 : S_YUV422 , S_YUV411
  • Y1 : S_YUV411 , S_YUV422
  • Y2 : S_YUV411
  • Y3 : S_YUV411


AVT Universal API - Image Transform module: uni_defines.h File Reference

uni_defines.h File Reference

Detailed Description

Definitions for the Universal API methods.

This file describes all necessary definitions for using the Universal API methods.

Version:
1.10
Date:
03-Mar-2008
Author:
Philipp Beyer, Holger Eddelbuettel, Matthias Heidenreich
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_types.h"

Data Structures

struct | S_12BIT_2PACKED
Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes. More...
struct | S_SUPPORT_STATE
states of the multi media technology support for operating system and processor. More...
struct | S_TECHNO_INFO
states of the support for different multimedia technologies More...
union | S_SIS_ENABLE
information about state of the fields of the S_SIS_DATA struct More...
struct | S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
states of the sis data More...
struct | S_SIS_DATA
SIS data structure. More...
struct | S_RGB8
Structure for accessing Windows RGB data. More...
struct | S_BGR8
Structure for accessing Windows RGB data. More...
struct | S_BGRA8
Structure for accessing Windows RGBA data. More...
struct | S_BGR16
Structure for accessing 16-bit Windows-type RGB data. More...
struct | S_YUV444
Structure for accessing data in the YUV 4:4:4 format (YUV). More...
struct | S_YUV422
Structure for accessing data in the YUV 4:2:2 format (UYVY). More...
struct | S_YUV411
Structure for accessing data in the YUV 4:1:1 format (UYYVYY). More...

Defines

#define | UNI_RESULT_API_ERROR 0x88000000
mask for API error
#define | UNI_RESULT_UNKNOWN_ERROR 0x88000001
unclassified error
#define | UNI_RESULT_PARAMETER_INVALID_1 0x88000002
parameter 1 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_2 0x88000003
parameter 2 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_3 0x88000004
parameter 3 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_4 0x88000005
parameter 4 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_5 0x88000006
parameter 5 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_6 0x88000007
parameter 6 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_7 0x88000008
parameter 7 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_8 0x88000009
parameter 8 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_9 0x8800000A
parameter 9 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_10 0x8800000B
parameter 10 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_11 0x8800000C
parameter 11 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_12 0x8800000D
parameter 12 is invalid
#define | UNI_RESULT_COMMAND_ABORTED 0x8800001E
the current command was aborted

Typedefs

typedef enum E_UNI_ROPMODE | E_UniRopMode
Enumeration for raster operation (used by re sampling methods).
typedef enum E_UNI_COLOR_CODE | E_UniColorCode
Enumeration for IIDC format 7 color codes / transfer formats.
typedef enum E_UNI_BAYER_PATTERN | E_UniBayerPattern
Enumeration for the Bayer pattern.
typedef enum E_UNI_FLIP_MODE | E_UniFlipMode
Enumeration for the direction for flipping images.
typedef struct S_SUPPORT_STATE | S_SupportState
states of the multi media technology support for operating system and processor.
typedef struct S_TECHNO_INFO | S_TechInfo
states of the support for different multimedia technologies
typedef enum E_UNI_SIS_TYPE | E_UniSISType
enum for the secure image signatures
typedef union S_SIS_ENABLE | S_SISEnable
information about state of the fields of the S_SIS_DATA struct
typedef struct S_SIS_DATA | S_SISData
SIS data structure.
typedef enum
E_UNI_SIMPLE_IMAGE_FORMAT 		E_UniSimpleImageFormat
Simple image type enum.

Enumerations

enum E_UNI_ROPMODE {
E_ROP_SRCCPY,
E_ROP_LININTERPOL
}
Enumeration for raster operation (used by re sampling methods). More...
enum E_UNI_COLOR_CODE { ,
E_CC_MONO8 = 0,
E_CC_YUV411,
E_CC_YUV422,
E_CC_YUV444,
E_CC_RGB8,
E_CC_MONO16,
E_CC_RGB16,
E_CC_SMONO16,
E_CC_SRGB16,
E_CC_RAW8,
E_CC_RAW16,
E_CC_MONOR = 128,
E_CC_MONOG,
E_CC_MONOB,
E_CC_MONO12 = 132,
E_CC_RGB12,
E_CC_SMONO12,
E_CC_SRGB12,
E_CC_RAW12
}
Enumeration for IIDC format 7 color codes / transfer formats. More...
enum E_UNI_BAYER_PATTERN {
E_BP_AUTO = -1,
E_BP_RGGB = 0,
E_BP_GBRG,
E_BP_GRBG,
E_BP_BGGR,
E_BP_CYGM = 128,
E_BP_GMCY,
E_BP_CYMG,
E_BP_MGCY
}
Enumeration for the Bayer pattern. More...
enum E_UNI_FLIP_MODE { ,
E_FLIP_MODE_HORIZONTAL = 1,
E_FLIP_MODE_LEFT_RIGHT = E_FLIP_MODE_HORIZONTAL,
E_FLIP_MODE_VERTICAL = 2,
E_FLIP_MODE_TOP_DOWN = E_FLIP_MODE_VERTICAL,
E_FLIP_MODE_BOTH = 3
}
Enumeration for the direction for flipping images. More...
enum E_UNI_SIS_TYPE {
E_SIS_NOT_PRESENT,
E_SIS_MARLIN,
E_SIS_PIKE
}
enum for the secure image signatures More...
enum E_UNI_SIMPLE_IMAGE_FORMAT {
E_SIF_MONO8_REC601,
E_SIF_BGR24,
E_SIF_BGRA32,
E_SIF_MONO8_REC709,
E_SIF_UYVY
}
Simple image type enum. More...


AVT Universal API - Image Transform module: uni_types.h File Reference

uni_types.h File Reference

Detailed Description

Definitions for the types used in the Universal API methods.

This file describes all necessary type definitions for using methods of AVT's Universal API. These type definitions are designed to be portable in the sense of Microsoft, means: also usable in VB and C#.

Version:
1.1
Date:
03-Mar-2008
Author:
Matthias Heidenreich, Holger Eddelbuettel
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

Typedefs

Basic types used to define the types really used
Don't use these typedefs directly!

typedef short | int16_t
16 bit signed integer on non-Microsoft systems
typedef int | int32_t
32 bit signed integer on non-Microsoft systems
typedef long long | int64_t
64 bit signed integer on non-Microsoft systems
typedef unsigned short | uint16_t
16 bit unsigned integer on non-Microsoft systems
typedef unsigned int | uint32_t
32 bit unsigned integer on non-Microsoft systems
typedef unsigned long long | uint64_t
64 bit unsigned integer on non-Microsoft systems
Portable types.
Use these types.

typedef signed char | INT8_TYPE
8 bit signed integer
typedef signed char | INT8_IN_TYPE
8 bit signed integer type for input
typedef INT8_IN_TYPE * | INT8_INOUT_TYPE
8 bit signed integer type for input and output
typedef INT8_IN_TYPE * | INT8_OUT_TYPE
8 bit signed integer type for output
typedef int16_t | INT16_TYPE
16 bit signed integer
typedef int16_t | INT16_IN_TYPE
16 bit signed integer type for input
typedef INT16_IN_TYPE * | INT16_INOUT_TYPE
16 bit signed integer type for input and output
typedef INT16_IN_TYPE * | INT16_OUT_TYPE
16 bit signed integer type for output
typedef int32_t | INT32_TYPE
32 bit signed integer
typedef int32_t | INT32_IN_TYPE
32 bit signed integer type for input
typedef INT32_IN_TYPE * | INT32_INOUT_TYPE
32 bit signed integer type for input and output
typedef INT32_IN_TYPE * | INT32_OUT_TYPE
32 bit signed integer type for output
typedef int64_t | INT64_TYPE
64 bit signed integer
typedef int64_t | INT64_IN_TYPE
64 bit signed integer type for input
typedef INT64_IN_TYPE * | INT64_INOUT_TYPE
64 bit signed integer type for input and output
typedef INT64_IN_TYPE * | INT64_OUT_TYPE
64 bit signed integer type for output
typedef unsigned char | UINT8_TYPE
8 bit unsigned integer
typedef unsigned char | UINT8_IN_TYPE
8 bit unsigned integer type for input
typedef UINT8_IN_TYPE * | UINT8_INOUT_TYPE
8 bit unsigned integer type for input and output
typedef UINT8_IN_TYPE * | UINT8_OUT_TYPE
8 bit unsigned integer type for output
typedef uint16_t | UINT16_TYPE
16 bit unsigned integer
typedef uint16_t | UINT16_IN_TYPE
16 bit unsigned integer type for input
typedef UINT16_IN_TYPE * | UINT16_INOUT_TYPE
16 bit unsigned integer type for input and output
typedef UINT16_IN_TYPE * | UINT16_OUT_TYPE
16 bit unsigned integer type for output
typedef uint32_t | UINT32_TYPE
32 bit unsigned integer
typedef uint32_t | UINT32_IN_TYPE
32 bit unsigned integer type for input
typedef UINT32_IN_TYPE * | UINT32_INOUT_TYPE
32 bit unsigned integer type for input and output
typedef UINT32_IN_TYPE * | UINT32_OUT_TYPE
32 bit unsigned integer type for output
typedef uint64_t | UINT64_TYPE
64 bit unsigned integer
typedef uint64_t | UINT64_IN_TYPE
64 bit unsigned integer type for input
typedef UINT64_IN_TYPE * | UINT64_INOUT_TYPE
64 bit unsigned integer type for input and output
typedef UINT64_IN_TYPE * | UINT64_OUT_TYPE
64 bit unsigned integer type for output
typedef float | FLOAT_TYPE
4 byte floating point
typedef float | FLOAT_IN_TYPE
4 byte floating point type for input
typedef FLOAT_IN_TYPE * | FLOAT_INOUT_TYPE
4 byte floating point type for input and output
typedef FLOAT_IN_TYPE * | FLOAT_OUT_TYPE
4 byte floating point type for output
typedef double | DOUBLE_TYPE
8 byte floating point
typedef double | DOUBLE_IN_TYPE
8 byte floating point type for input
typedef DOUBLE_IN_TYPE * | DOUBLE_INOUT_TYPE
8 byte floating point type for input and output
typedef DOUBLE_IN_TYPE * | DOUBLE_OUT_TYPE
8 byte floating point type for output
typedef UINT32_IN_TYPE | BOOL_IN_TYPE
BOOL type for input.
typedef BOOL_IN_TYPE * | BOOL_INOUT_TYPE
"bool" type for input and output
typedef BOOL_IN_TYPE * | BOOL_OUT_TYPE
"bool" type for output
typedef void | VOID_TYPE
void type
typedef VOID_TYPE * | VOID_POINTER
pointer to void tyype
typedef size_t | POINTER_SIZE
size of a pointer system dependent
Character types.
Types for character handling.

typedef unsigned short | wchar_t
if not defined wchar_t define it
typedef char | UNICODE_CHAR
char type dependent on the UNICODE define multi byte or single byte
typedef UNICODE_CHAR | CHAR_IN_TYPE
typedef UNICODE_CHAR | CHAR_TYPE
string type will change with UNICODE builds from char to wchar_t
typedef CHAR_TYPE * | CHAR_INOUT_TYPE
a valid pointer to a mutable char/wchar_t as, will take values into a function and return the result
typedef CHAR_TYPE * | CHAR_OUT_TYPE
a valid pointer to a char/wchar_t, will return results from a function
typedef wchar_t | WCHAR_TYPE
typedef wchar_t | WCHAR_IN_TYPE
string with wide char
typedef WCHAR_TYPE * | WCHAR_INOUT_TYPE
valid pointer to a mutable wchar_t, will take values into a function and return the ressult.
typedef WCHAR_TYPE * | WCHAR_OUT_TYPE
valid pointer to a wchar_t, will return results from a function
typedef char | ACHAR_TYPE
typedef char | ACHAR_IN_TYPE
string of 8bit ASCII chars
typedef ACHAR_TYPE * | ACHAR_INOUT_TYPE
8bit ASCII char string taking values int a function and returning a result
typedef ACHAR_TYPE * | ACHAR_OUT_TYPE
8bit ASCII string returning a result from a function
Special types.
Types for special purposes.

typedef long | HRESULT
Definition just in case HRESULT is not defined (and winnt.h should not be included).
typedef HRESULT | UNI_RETURN_TYPE
Return value for all the methods of the API.
typedef UINT32_IN_TYPE | ID_TYPE
Type for identifying a camera.
typedef void * | COLOR_CORRECTION_HANDLE
A handle for a color correction object to be used during debayering.


AVT Universal API - Image Transform module: UniTransform.h File Reference

UniTransform.h File Reference

Detailed Description

The available AVT Universal API Image Transformation methods.

All the AVT Universal API methods for image transformation publicly available are described in this part of the help. For a description see the section "Introduction " of this help.

Version:
1.6
Date:
27-Oct-2008
Author:
Holger Eddelbuettel, Matthias Heidenreich, Olaf Reuter
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_defines.h"

Functions

Miscellaneous methods
UNI_RETURN_TYPE | UIT_GetVersion (UINT32_OUT_TYPE pnValue)
Get Library Version.
UNI_RETURN_TYPE | UIT_GetTechnoInfo (S_TECHNO_INFO *pTechnoInfo)
Get information about processor supported features.
UNI_RETURN_TYPE | UIT_GetSIS (S_SIS_DATA *pSISData, const UINT8_TYPE *pImage, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE eColorCode, INT32_TYPE nSISPos, UINT32_TYPE eSISType)
extract the Secure Image Signature from a transport image.
UNI_RETURN_TYPE | UIT_GetBitsPerPixel (UINT32_IN_TYPE ColorCode, UINT32_OUT_TYPE BitsPerPixel)
get t he bits per pixel for the transport image with the given color coding.
UNI_RETURN_TYPE | UIT_GetErrorInfo (UNI_RETURN_TYPE nErrCode, char *pszInfoString, UINT32_IN_TYPE nMaxStrLen)
translates UNI_RETURN_TYPE into an human readable description.
Format conversions to BGR with simple 2x2 debayering w/o color conversion
Simple format conversions from IIDC transfer formats to the Windows RGB format.

UNI_RETURN_TYPE | UIT_YUV422ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert YUV 4:2:2 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_YUV411ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert YUV 4:1:1 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_RGB8ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert RGB8 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw16ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw16 (YH YL) to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Y8ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nPixelCount)
Convert MONO8 to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Y16ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_mono (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to the Windows RGB format with R=G=B.
Format conversions to BGR format with more sophisticated debayering w/o color conversion
Format conversions from raw color images resulting from a RGGB sensor to the Windows RGB format.

UNI_RETURN_TYPE | UIT_Raw8ToBGR_3x3 (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to the Windows RGB format using a 3x3 interpolation.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntYUV422 (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntLCAA (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via a stronglier interpolated YUV422 format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntLCAAV (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.
Format conversions to BGR format with color conversion
Format conversions to the Windows RGB with simple 2x2 debayering.

UNI_RETURN_TYPE | UIT_Raw8ToBGR_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Convert a RAW8 image to the Windows RGB format.
Format conversions
Format conversions to the Windows Mono8 format with and without color conversion.

UNI_RETURN_TYPE | UIT_RGB8ToY8 (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert RGB8 data to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Y16ToY8 (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to a monochrome 8BPP image.
Format conversions
Format conversions to the Windows Mono8 format with and without color conversion.

UNI_RETURN_TYPE | UIT_Y16ToY8_MMX (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Raw8ToY8 (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Raw8ToY8_CC (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Convert Raw8 to a monochrome 8BPP image with additional color conversion.
12 bit format conversions/depacking to 8 or 16 bit, with support of 2x2 debayering, color conversion
Format conversions between 12 bit formats with support of 2x2 debayering, color conversion

UNI_RETURN_TYPE | UIT_Packed12BitTo8Bit (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize)
Convert a packed 12 bit format to 8 bit data.
UNI_RETURN_TYPE | UIT_Packed12BitTo16Bit (UINT16_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize)
Convert a packed 12 bit format to 16 bit data.
UNI_RETURN_TYPE | UIT_Raw12ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern)
12Bit packed RAW mode to Windows BGR.
UNI_RETURN_TYPE | UIT_Raw12ToBGR_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern, COLOR_CORRECTION_HANDLE ColCor)
12Bit packed RAW mode to Windows BGR with color conversion.
UNI_RETURN_TYPE | UIT_Raw12ToBGR16 (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern)
Pike 12Bit Packed to windows 16 BGR.
UNI_RETURN_TYPE | UIT_Raw12ToBGR16_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Pike 12Bit Packed to windows 16 bit three channel BGR with color conversion.
16 bit format conversions with 2x2 debayering, some with color conversion
Format conversions between 16 bit formats with simple 2x2 debayering, but some with color conversion.

UNI_RETURN_TYPE | UIT_Raw16ToBGR16 (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits)
Convert Raw16 (YH YL) to a 16 bit RGB format (big endian).
UNI_RETURN_TYPE | UIT_Raw16ToBGR16_CC (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits, COLOR_CORRECTION_HANDLE hColCor)
Convert Raw16 (YH YL) to a 16 bit RGB format (big endian) added color correction.
UNI_RETURN_TYPE | UIT_Raw16ToY16 (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits)
Convert Raw16 (YH YL) to the MONO16 format (big endian).
UNI_RETURN_TYPE | UIT_Raw16ToY16_CC (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits, COLOR_CORRECTION_HANDLE hColCor)
Convert Raw16 (YH YL) to the MONO16 format (big endian) with added color conversion.
Methods for controling color conversion
Methods for use with format conversion methods ending with "_CC" (UIT_Raw8ToBGR_CC, UIT_Raw8ToY8_CC, UIT_Raw16ToBGR16_CC, UIT_Raw16ToY16_CC).

UNI_RETURN_TYPE | UIT_CreateColorCorrectionMatrix_Int8 (const FLOAT_TYPE *fArrayCorr, COLOR_CORRECTION_HANDLE *phCC)
Create a color conversion object and return the handle to it.
UNI_RETURN_TYPE | UIT_CreateColorCorrectionMatrix_Int16 (const FLOAT_TYPE *fArrayCorr, COLOR_CORRECTION_HANDLE *phCC)
Create a color conversion object and return the handle to it.
UNI_RETURN_TYPE | UIT_DestroyColorCorrection (COLOR_CORRECTION_HANDLE hCC)
Destroy the color correction object identified by the given handle.
Methods for interlaced cameras
Methods for use with interlaced cameras which also have a CYGM sensor.

UNI_RETURN_TYPE | UIT_InterlacedToProgressive (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an interlaced format to a progressive format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR_3x3 (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format with 3x3 matrix interpolation.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR_Bin (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM binning format into progressive RGB format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToMono (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM binning format into progressive RGB format with R=G=B.
Format conversions to image planes
Format conversions from IIDC transfer formats to image planes

UNI_RETURN_TYPE | UIT_YUV422ToRGBPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image in YUV422 format to R,G and B planes.
UNI_RETURN_TYPE | UIT_YUV411ToRGBPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image in YUV411 format to R,G and B planes.
UNI_RETURN_TYPE | UIT_YUV422ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from YUV422 format to R,G,B and additional Y planes.
UNI_RETURN_TYPE | UIT_YUV411ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from YUV411 format to R,G,B and additional Y planes.
UNI_RETURN_TYPE | UIT_RGB8ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from RGB format to R,G,B and additional Y planes.
Image transformation.
Methods for transforming images without image type change.

Logically, UIT_RGB8ToBGR and UIT_InterlacedToProgressive would also fall into this category, but since they are already listed in different categories, they do not appear here.

UNI_RETURN_TYPE | UIT_GetResampledScanlineLength (INT32_OUT_TYPE pDstXSize, INT32_TYPE nSrcXSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize)
Calculate the needed destination image width for images with non-square pixels.
UNI_RETURN_TYPE | UIT_ResampleScanlines (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, INT32_TYPE nDstXSize, INT32_TYPE nSrcXSize, INT32_TYPE nSrcYSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize, UINT32_TYPE nBytesPerPixel, UINT32_TYPE nRopMode)
Do resampling along lines.
UNI_RETURN_TYPE | UIT_ResampleScanlinesEx (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, INT32_TYPE nDstXSize, INT32_TYPE nDstPitch, INT32_TYPE nSrcXSize, INT32_TYPE nSrcPitch, INT32_TYPE nSrcYSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize, UINT32_TYPE nBytesPerPixel, UINT32_TYPE nRopMode)
Do resampling along lines.
UNI_RETURN_TYPE | UIT_FlipVertical (UINT8_INOUT_TYPE pImage, UINT32_TYPE nBytesPerLine, UINT32_TYPE nLines)
Flip image vertically.
UNI_RETURN_TYPE | UIT_Flip (UINT8_INOUT_TYPE pImage, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE eFlipMode, UINT32_TYPE eccColorCode)
Generic flip of image.
Format conversions to variable image formats
Format conversions from IIDC transfer formats to BGR24, BGRA32 or YUV422 UYVY

UNI_RETURN_TYPE | UIT_RGB8ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC RGB8 to variable image format.
UNI_RETURN_TYPE | UIT_YUV422ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC UYVY YUV422 to variable image format.
UNI_RETURN_TYPE | UIT_YUV411ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC YUV411 to variable image.
UNI_RETURN_TYPE | UIT_Y8ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
Convert Mono8 to variable image.
UNI_RETURN_TYPE | UIT_Y16ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC Mono16 to variable image.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image.
UNI_RETURN_TYPE | UIT_Raw16ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert IIDC RAW16 to variable image.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_3x3 (VOID_TYPE *pDst, const UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
RAW8 to variable image with 3x3 local filtering.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntYUV422 (VOID_TYPE *pDst, UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with U/V interpolation in the YUV color space.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntLCAA (VOID_TYPE *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with local color anti aliasing.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntLCAAV (VOID_TYPE *pDst, UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with local color anti aliasing vertical interpolation.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform_Bin (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 binning format to variable image.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform (VOID_TYPE *pDst, const UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 CYMG to variable image.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform_3x3 (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 CYMG to variable image with 3x3 local filtering.
UNI_RETURN_TYPE | UIT_Raw12ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE eImageFormat, UINT32_TYPE BayerPattern)
AVT RAW12 to variable image.
UNI_RETURN_TYPE | UIT_Y12ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nPixelCount, UINT32_TYPE eImageFormat)
Convert a packed 12 bit format to variable image.


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • ACHAR_IN_TYPE : uni_types.h
  • ACHAR_INOUT_TYPE : uni_types.h
  • ACHAR_OUT_TYPE : uni_types.h


AVT Universal API - Image Transform module: UIT_Flip

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Flip | ( | UINT8_INOUT_TYPE | pImage,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | eFlipMode,
 |  | UINT32_TYPE | eccColorCode
 | ) |  |

Generic flip of image.

Parameters:
[in,out] | pImage | Valid pointer to source/destination image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | eFlipMode | Use valid values from E_UNI_FLIP_MODE
[in] | eccColorCode | Use E_UNI_COLOR_CODE to allow for correct image flipping in horizontal and both modes
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_RGB8ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from RGB format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_IRaw8CYGMImageTransform_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform_3x3 | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 CYMG to variable image with 3x3 local filtering.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 CYMG image source
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Convert a RAW8 image to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | ColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int8. If NULL, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_Y8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

Convert Mono8 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | Mono8 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Note:
also supports E_SIF_UYVY_MONO output
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw12ToBGR16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR16 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

Pike 12Bit Packed to windows 16 BGR.

Parameters:
[out] | pDst | destination 16bit BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_GetVersion

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetVersion ( UINT32_OUT_TYPE pnValue )

Get Library Version.

Parameters:
[out] pnValue pointer, returns the library version (Major,Minor,SubMinor,Build)
Returns:
will always return S_OK


AVT Universal API - Image Transform module: UIT_GetTechnoInfo

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetTechnoInfo ( S_TECHNO_INFO * pTechnoInfo )

Get information about processor supported features.

Parameters:
[out] pTechnoInfo returns the supported SIMD technologies
Note:
This should be called before using any SIMD (MMX,SSE) optimmized functions


AVT Universal API - Image Transform module: UIT_Raw12ToBGR_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

12Bit packed RAW mode to Windows BGR with color conversion.

Parameters:
[out] | pDst | destination windows BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
[in] | ColCor | ColorCorrection used while debayering
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_IRaw8CYGMImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 CYMG to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 image source
[in] | XSize | width of the image
[in] | YSize | height off the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_YUV411ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert YUV 4:1:1 data to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (U Y Y V Y Y U Y Y V Y Y ...)
[in] | nPixelCount | The number of pixels to be converted n>1
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_IRaw8CYGMImageTransform_Bin

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform_Bin | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 binning format to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 image source
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_YUV422ToRGBPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToRGBPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image in YUV422 format to R,G and B planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_CreateColorCorrectionMatrix_Int8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_CreateColorCorrectionMatrix_Int8 | ( | const FLOAT_TYPE * | fArrayCorr,
 |  | COLOR_CORRECTION_HANDLE * | phCC
 | ) |  |

Create a color conversion object and return the handle to it.

This handle may then be used in some 8 bit debayering methods. This color conversion is then used as the last operation on the image data (in RGB space). Every RGB pixel is virtually multiplied with a RGB2RGB conversion matrix and a range check is performed. The actual multiplications are implemented as integer multiplications.

Parameters:
*fArrayCorr | A float vector with nine elements containing the color conversion matrix (3 by 3)
*phCC | The pointer to the conversion object handle
Returns:
Always S_OK


AVT Universal API - Image Transform module: UIT_Raw8ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory locations
See also:
Debayering methods


AVT Universal API - Image Transform module: UIT_YUV411ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from YUV411 format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw16ToY16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToY16_CC | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits,
 |  | COLOR_CORRECTION_HANDLE | hColCor
 | ) |  |

Convert Raw16 (YH YL) to the MONO16 format (big endian) with added color conversion.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
[in] | hColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int16. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory location


AVT Universal API - Image Transform module: UIT_Packed12BitTo16Bit

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Packed12BitTo16Bit | ( | UINT16_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize
 | ) |  |

Convert a packed 12 bit format to 16 bit data.

This method may be used to convert RAW12 to RAW16 or MONO12 to MONO16, for example

Parameters:
[out] | pDst | A pointer to the destination image (see E
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
Note:
the 12bit packed data will be output as continuous 16 bit data stream without most significat 4 bit padding [p1_8bit][p1_4bit|p2_4bit][p2_8bit]...[p(n)_8bit][p(n)_4bit|p(n+1)_4bit][p(n+1)_8bit]
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_YUV422ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from YUV422 format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Y8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y8ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert MONO8 to the Windows RGB format.

the Mono8 value is copied to each rgb pixel

Parameters:
[out] | pDst | A pointer to the destination image ( B G R B G R ...)
[in] | pSrc | A pointer to the source image
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_RGB8ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert RGB8 data to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y Y Y ...)
[in] | pSrc | A pointer to the source image (R G B R G B ...)
[in] | nPixelCount | The number of pixels (not: bytes) to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw8ToY8_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToY8_CC | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Convert Raw8 to a monochrome 8BPP image with additional color conversion.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | ColCor | A handle to the color conversion object, e.g. created by UIT_CreateColorCorrectionMatrix_Int8. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory locations


AVT Universal API - Image Transform module: UIT_CreateColorCorrectionMatrix_Int16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_CreateColorCorrectionMatrix_Int16 | ( | const FLOAT_TYPE * | fArrayCorr,
 |  | COLOR_CORRECTION_HANDLE * | phCC
 | ) |  |

Create a color conversion object and return the handle to it.

This handle may then be used in some 16 bit debayering methods. This color conversion is then used as the last operation on the image data (in RGB space). Every RGB pixel is virtually multiplied with a RGB2RGB conversion matrix and a range check is performed. The actual multiplications are implemented as integer multiplications.

Parameters:
fArrayCorr | A float vector with nine elements containing the color conversion matrix (3 by 3)
phCC | The pointer to the conversion object handle
Returns:
Always S_OK


AVT Universal API - Image Transform module: UIT_IRaw8CYGMToBGR_Bin

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR_Bin | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM binning format into progressive RGB format.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_RGB8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC RGB8 to variable image format.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC RGB8 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_GetErrorInfo

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetErrorInfo | ( | UNI_RETURN_TYPE | nErrCode,
 |  | char * | pszInfoString,
 |  | UINT32_IN_TYPE | nMaxStrLen
 | ) |  |

translates UNI_RETURN_TYPE into an human readable description.

Parameters:
[in] | nErrCode | return code to translate
[in,out] | pszInfoString | pointer to string for output
[in] | nMaxStrLen | length of the string


AVT Universal API - Image Transform module: UIT_Y16ToY8_MMX

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToY8_MMX | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 Y4 ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful
See also:
GetTechnoInfo


AVT Universal API - Image Transform module: UIT_Raw8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_mono

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_mono | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to the Windows RGB format with R=G=B.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_RGB8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert RGB8 data to the Windows RGB format.

In the IIDC RGB format, the R,G and B values appear in inverse order, so to be displayed in Windows systems, they have to be swapped.
Naturally, this method may also be used to convert Windows RGB images to RGB images with a different byte order.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (R G B R G B ...)
[in] | nPixelCount | The number of pixels (not: bytes) to be converted
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_YUV411ToRGBPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToRGBPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image in YUV411 format to R,G and B planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_GetSIS

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetSIS | ( | S_SIS_DATA * | pSISData,
 |  | const UINT8_TYPE * | pImage,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | eColorCode,
 |  | INT32_TYPE | nSISPos,
 |  | UINT32_TYPE | eSISType
 | ) |  |

extract the Secure Image Signature from a transport image.

Parameters:
[in,out] | pSISData | pointer to S_SIS_DATA struct to be filled
[in] | pImage | pointer to transport image with embedded SIS
[in] | nXSize | width of the image in pixel
[in] | nYSize | height of the image in pixel
[in] | eColorCode | IIDC color code for transport format, use E_UNI_COLOR_CODE
[in] | nSISPos | Line number where the SIS is embedded into the image
[in] | eSISType | Type of SIS, use E_UNI_SIS_TYPE


AVT Universal API - Image Transform module: UIT_Y16ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 Y4 ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_FlipVertical

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_FlipVertical | ( | UINT8_INOUT_TYPE | pImage,
 |  | UINT32_TYPE | nBytesPerLine,
 |  | UINT32_TYPE | nLines
 | ) |  |

Flip image vertically.

Creates a top-down version of the provided image (in place). This method is made for all kinds of images since the pixel format is not relevant if the correct number of overall bytes per line is submitted.

Parameters:
[in,out] | pImage | Valid pointer to source/destination image
[in] | nBytesPerLine | The number of bytes (not pixels!) per line
[in] | nLines | The number of lines
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw8ImageTransform_IntLCAA

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntLCAA | ( | VOID_TYPE * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with local color anti aliasing.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 source image, will be altered while processing
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_InterlacedToProgressive

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_InterlacedToProgressive | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an interlaced format to a progressive format.

This method may be used to convert raw or mono images consisting of two half-images to progressive-data images. Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-0xx NIR.

Parameters:
[out] | pDst | A pointer to the destination image
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_Raw12ToBGR16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR16_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Pike 12Bit Packed to windows 16 bit three channel BGR with color conversion.

Parameters:
[out] | pDst | destination 16bit BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
[in] | ColCor | ColorCorrection used while debayering
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw8ImageTransform_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_3x3 | ( | VOID_TYPE * | pDst,
 |  | const UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

RAW8 to variable image with 3x3 local filtering.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | RAW8 source image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_YUV422ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert YUV 4:2:2 data to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (U Y V Y U Y V Y ...)
[in] | nPixelCount | The number of pixels to be converted n>1
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_IRaw8CYGMToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_Raw8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | RAW8 source image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Note:
also supports E_SIF_UYVY output
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_ResampleScanlinesEx

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_ResampleScanlinesEx | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | INT32_TYPE | nDstXSize,
 |  | INT32_TYPE | nDstPitch,
 |  | INT32_TYPE | nSrcXSize,
 |  | INT32_TYPE | nSrcPitch,
 |  | INT32_TYPE | nSrcYSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize,
 |  | UINT32_TYPE | nBytesPerPixel,
 |  | UINT32_TYPE | nRopMode
 | ) |  |

Do resampling along lines.

This method is made for Mono8 images as well as for Raw8 images. Extended version.

Parameters:
[out] | pDst | valid pointer to destination image
[in] | pSrc | valid const pointer to source image
[in] | nDstXSize | destination image width
[in] | nDstPitch | distance between consecutive lines in the destination image
[in] | nSrcXSize | source image width
[in] | nSrcPitch | distance between consecutive line in the source image
[in] | nSrcYSize | source image height
[in] | nDstPixelSize | destination image pixel width
[in] | nSrcPixelSize | source image pixel width
[in] | nBytesPerPixel | The number of bytes per pixel (e.g. 1 for mono, 3 for RGB)
[in] | nRopMode | use E_UNI_ROPMODE
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_DestroyColorCorrection

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_DestroyColorCorrection ( COLOR_CORRECTION_HANDLE hCC )

Destroy the color correction object identified by the given handle.

After using this operation, the handle may not be used any more.

Parameters:
hCC The handle of the conversion object to be destroyed
Returns:
  • S_OK if successful,
  • UNI_RESULT_PARAMETER_INVALID_1 if the handle is NULL
  • UNI_RESULT_COMMAND_ABORTED if the object could not be destroyed


AVT Universal API - Image Transform module: UIT_IRaw8CYGMToMono

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToMono | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM binning format into progressive RGB format with R=G=B.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_Y16ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to the Windows RGB format.

The resulting mostly monochrome image format (the R,G and B values are more or less equal to one another) lets you extract at least a 10 bit monochrome image by applying the following formula: I = 4*G + 2*(R-G) + (B-G) = 2*R + G + B

Parameters:
[out] | pDst | A pointer to the destination image ( B G R B G R ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_IntLCAA

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntLCAA | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via a stronglier interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of four consecutive pixels is taken (indexes -1, 0 1 and 2)

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Image Transform module: UIT_Packed12BitTo8Bit

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Packed12BitTo8Bit | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize
 | ) |  |

Convert a packed 12 bit format to 8 bit data.

This method may be used to convert RAW12 to RAW8 or MONO12 to MONO8, for example

Parameters:
[out] | pDst | A pointer to the destination image
[in] | pSrc | A pointer to the binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)


AVT Universal API - Image Transform module: UIT_Y16ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC Mono16 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC Mono16 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw8ImageTransform_IntYUV422

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntYUV422 | ( | VOID_TYPE * | pDst,
 |  | UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with U/V interpolation in the YUV color space.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 image, will be altered in processing
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw16ToY16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToY16 | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits
 | ) |  |

Convert Raw16 (YH YL) to the MONO16 format (big endian).

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw16ToBGR16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR16 | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits
 | ) |  |

Convert Raw16 (YH YL) to a 16 bit RGB format (big endian).

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw16ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert IIDC RAW16 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC RAW16 image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw16ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw16 (YH YL) to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_Raw12ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

12Bit packed RAW mode to Windows BGR.

Parameters:
[out] | pDst | destination windows BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_YUV411ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC YUV411 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC YUV411 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Y12ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y12ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nPixelCount,
 |  | UINT32_TYPE | eImageFormat
 | ) |  |

Convert a packed 12 bit format to variable image.

Parameters:
[out] | pDst | a pointer to the destination image (according to eImageFormat)
[in] | pSrc | a pointer to the binned interlaced image
[in] | nPixelCount | number of pixels of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT


AVT Universal API - Image Transform module: UIT_GetBitsPerPixel

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetBitsPerPixel | ( | UINT32_IN_TYPE | ColorCode,
 |  | UINT32_OUT_TYPE | BitsPerPixel
 | ) |  |

get t he bits per pixel for the transport image with the given color coding.

Parameters:
[in] | ColorCode | The color coding E_UNI_COLOR_CODE (0..255)
[out] | BitsPerPixel | The number of bits (8,12,16,24 or 48)
Returns:
S_OK
if a known color coding was submitted


AVT Universal API - Image Transform module: UIT_Raw16ToBGR16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR16_CC | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits,
 |  | COLOR_CORRECTION_HANDLE | hColCor
 | ) |  |

Convert Raw16 (YH YL) to a 16 bit RGB format (big endian) added color correction.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
[in] | hColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int16. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_IRaw8CYGMToBGR_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR_3x3 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format with 3x3 matrix interpolation.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image ( [B,G,R] ...)
[in] | pSrc | A pointer to the raw source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Image Transform module: UIT_GetResampledScanlineLength

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetResampledScanlineLength | ( | INT32_OUT_TYPE | pDstXSize,
 |  | INT32_TYPE | nSrcXSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize
 | ) |  |

Calculate the needed destination image width for images with non-square pixels.

This method is made for Mono8 images as well as for Raw8 images.

Parameters:
[out] | pDstXSize | pointer, returns the needed destination image width
[in] | nSrcXSize | source image width
[in] | nDstPixelSize | destination image pixel size
[in] | nSrcPixelSize | source image pixel size
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_ResampleScanlines

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_ResampleScanlines | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | INT32_TYPE | nDstXSize,
 |  | INT32_TYPE | nSrcXSize,
 |  | INT32_TYPE | nSrcYSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize,
 |  | UINT32_TYPE | nBytesPerPixel,
 |  | UINT32_TYPE | nRopMode
 | ) |  |

Do resampling along lines.

Parameters:
[out] | pDst | valid pointer to destination image
[in] | pSrc | valid const pointer to source image
[in] | nDstXSize | destination image width
[in] | nSrcXSize | source image width
[in] | nSrcYSize | source image height
[in] | nDstPixelSize | destination image pixel width
[in] | nSrcPixelSize | source image pixel width
[in] | nBytesPerPixel | The number of bytes per pixel (e.g. 1 for mono, 3 for RGB)
[in] | nRopMode | use E_UNI_ROPMODE
Returns:
S_OK if the operation was successful


AVT Universal API - Image Transform module: UIT_YUV422ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC UYVY YUV422 to variable image format.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC UYVY YUV422 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw12ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

AVT RAW12 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | AVT RAW12 image source
[in] | nXSize | width of the image
[in] | nYSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | BayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_IntLCAAV

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntLCAAV | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of a four by two pixel window is taken (indexes -1, 0 1 and 2 of each row)

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_IntYUV422

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntYUV422 | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of consecutive pixels is taken

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Image Transform module: UIT_Raw8ToBGR_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_3x3 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to the Windows RGB format using a 3x3 interpolation.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Image Transform module: UIT_Raw8ImageTransform_IntLCAAV

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntLCAAV | ( | VOID_TYPE * | pDst,
 |  | UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with local color anti aliasing vertical interpolation.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 image, will be altered in processing
[in] | XSize | width of image
[in] | YSize | height of image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Image Transform module: Data Structures

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
S_12BIT_2PACKED | Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes
S_BGR16 | Structure for accessing 16-bit Windows-type RGB data
S_BGR8 | Structure for accessing Windows RGB data
S_BGRA8 | Structure for accessing Windows RGBA data
S_RGB8 | Structure for accessing Windows RGB data
S_SIS_DATA | SIS data structure
S_SIS_ENABLE | Information about state of the fields of the S_SIS_DATA struct
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS | States of the sis data
S_SUPPORT_STATE | States of the multi media technology support for operating system and processor
S_TECHNO_INFO | States of the support for different multimedia technologies
S_YUV411 | Structure for accessing data in the YUV 4:1:1 format (UYYVYY)
S_YUV422 | Structure for accessing data in the YUV 4:2:2 format (UYVY)
S_YUV444 | Structure for accessing data in the YUV 4:4:4 format (YUV)


AVT Universal API - Image Transform module: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structure Index

S

S
S_BGR8 S_SIS_DATA S_SUPPORT_STATE S_YUV422
S_12BIT_2PACKED S_BGRA8 S_SIS_ENABLE S_TECHNO_INFO S_YUV444
S_BGR16 S_RGB8 S_SIS_ENABLE::S_SIS_ENABLE_FIELDS S_YUV411

S


AVT Universal API - Image Transform module: File Index

  • File List
  • Globals

File List

Here is a list of all documented files with brief descriptions:
uni_defines.h | Definitions for the Universal API methods
uni_types.h | Definitions for the types used in the Universal API methods
UniTransform.h | The available AVT Universal API Image Transformation methods


AVT Universal API - Image Transform module: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • g
  • i
  • m
  • o
  • p
  • r
  • u
  • v
  • y

- a -

  • A : S_BGRA8
  • AMD3DNow : S_TECHNO_INFO

- b -

  • B : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- g -

  • G : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- i -

  • IntelMMX : S_TECHNO_INFO
  • IntelSSE : S_TECHNO_INFO
  • IntelSSE2 : S_TECHNO_INFO
  • IntelSSE3 : S_TECHNO_INFO
  • IntelSSSE3 : S_TECHNO_INFO

- m -

  • m_AOIHeight : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOILeft : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_AOITop : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOIWidth : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_ColorCoding : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_CycleCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Data : S_SIS_ENABLE
  • m_Enable : S_SIS_ENABLE
  • m_FrameCounter : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Gain : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_InputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_nVal8_1 : S_12BIT_2PACKED
  • m_nVal8_1Low : S_12BIT_2PACKED
  • m_nVal8_2 : S_12BIT_2PACKED
  • m_nVal8_2Low : S_12BIT_2PACKED
  • m_OutputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Reservec1 : S_SIS_DATA
  • m_Reserved0 : S_SIS_DATA
  • m_Reserved2a : S_SIS_DATA
  • m_Reserved2b : S_SIS_DATA
  • m_SequenceIndex : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_SerialNumber : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Shutter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_SISEnable : S_SIS_DATA
  • m_TriggerCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_UserValue : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Valid : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS

- o -

  • OperatingSystem : S_SUPPORT_STATE

- p -

  • Processor : S_SUPPORT_STATE

- r -

  • R : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- u -

  • U : S_YUV444 , S_YUV411 , S_YUV422

- v -

  • V : S_YUV444 , S_YUV411 , S_YUV422

- y -

  • Y : S_YUV444
  • Y0 : S_YUV422 , S_YUV411
  • Y1 : S_YUV411 , S_YUV422
  • Y2 : S_YUV411
  • Y3 : S_YUV411


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • BOOL_IN_TYPE : uni_types.h
  • BOOL_INOUT_TYPE : uni_types.h
  • BOOL_OUT_TYPE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CHAR_INOUT_TYPE : uni_types.h
  • CHAR_OUT_TYPE : uni_types.h
  • CHAR_TYPE : uni_types.h
  • COLOR_CORRECTION_HANDLE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • DOUBLE_IN_TYPE : uni_types.h
  • DOUBLE_INOUT_TYPE : uni_types.h
  • DOUBLE_OUT_TYPE : uni_types.h
  • DOUBLE_TYPE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • E_BP_AUTO : uni_defines.h
  • E_BP_BGGR : uni_defines.h
  • E_BP_CYGM : uni_defines.h
  • E_BP_CYMG : uni_defines.h
  • E_BP_GBRG : uni_defines.h
  • E_BP_GMCY : uni_defines.h
  • E_BP_GRBG : uni_defines.h
  • E_BP_MGCY : uni_defines.h
  • E_BP_RGGB : uni_defines.h
  • E_CC_MONO12 : uni_defines.h
  • E_CC_MONO16 : uni_defines.h
  • E_CC_MONO8 : uni_defines.h
  • E_CC_MONOB : uni_defines.h
  • E_CC_MONOG : uni_defines.h
  • E_CC_MONOR : uni_defines.h
  • E_CC_RAW12 : uni_defines.h
  • E_CC_RAW16 : uni_defines.h
  • E_CC_RAW8 : uni_defines.h
  • E_CC_RGB12 : uni_defines.h
  • E_CC_RGB16 : uni_defines.h
  • E_CC_RGB8 : uni_defines.h
  • E_CC_SMONO12 : uni_defines.h
  • E_CC_SMONO16 : uni_defines.h
  • E_CC_SRGB12 : uni_defines.h
  • E_CC_SRGB16 : uni_defines.h
  • E_CC_YUV411 : uni_defines.h
  • E_CC_YUV422 : uni_defines.h
  • E_CC_YUV444 : uni_defines.h
  • E_FLIP_MODE_BOTH : uni_defines.h
  • E_FLIP_MODE_HORIZONTAL : uni_defines.h
  • E_FLIP_MODE_LEFT_RIGHT : uni_defines.h
  • E_FLIP_MODE_TOP_DOWN : uni_defines.h
  • E_FLIP_MODE_VERTICAL : uni_defines.h
  • E_ROP_LININTERPOL : uni_defines.h
  • E_ROP_SRCCPY : uni_defines.h
  • E_SIF_BGR24 : uni_defines.h
  • E_SIF_BGRA32 : uni_defines.h
  • E_SIF_MONO8_REC601 : uni_defines.h
  • E_SIF_MONO8_REC709 : uni_defines.h
  • E_SIF_UYVY : uni_defines.h
  • E_SIS_MARLIN : uni_defines.h
  • E_SIS_NOT_PRESENT : uni_defines.h
  • E_SIS_PIKE : uni_defines.h
  • E_UNI_BAYER_PATTERN : uni_defines.h
  • E_UNI_COLOR_CODE : uni_defines.h
  • E_UNI_FLIP_MODE : uni_defines.h
  • E_UNI_ROPMODE : uni_defines.h
  • E_UNI_SIMPLE_IMAGE_FORMAT : uni_defines.h
  • E_UNI_SIS_TYPE : uni_defines.h
  • E_UniBayerPattern : uni_defines.h
  • E_UniColorCode : uni_defines.h
  • E_UniFlipMode : uni_defines.h
  • E_UniRopMode : uni_defines.h
  • E_UniSimpleImageFormat : uni_defines.h
  • E_UniSISType : uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FLOAT_IN_TYPE : uni_types.h
  • FLOAT_INOUT_TYPE : uni_types.h
  • FLOAT_OUT_TYPE : uni_types.h
  • FLOAT_TYPE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- h -

  • HRESULT : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • ID_TYPE : uni_types.h
  • INT16_IN_TYPE : uni_types.h
  • INT16_INOUT_TYPE : uni_types.h
  • INT16_OUT_TYPE : uni_types.h
  • int16_t : uni_types.h
  • INT16_TYPE : uni_types.h
  • INT32_IN_TYPE : uni_types.h
  • INT32_INOUT_TYPE : uni_types.h
  • INT32_OUT_TYPE : uni_types.h
  • int32_t : uni_types.h
  • INT32_TYPE : uni_types.h
  • INT64_IN_TYPE : uni_types.h
  • INT64_INOUT_TYPE : uni_types.h
  • INT64_OUT_TYPE : uni_types.h
  • int64_t : uni_types.h
  • INT64_TYPE : uni_types.h
  • INT8_IN_TYPE : uni_types.h
  • INT8_INOUT_TYPE : uni_types.h
  • INT8_OUT_TYPE : uni_types.h
  • INT8_TYPE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • POINTER_SIZE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • S_SISData : uni_defines.h
  • S_SISEnable : uni_defines.h
  • S_SupportState : uni_defines.h
  • S_TechInfo : uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • UINT16_IN_TYPE : uni_types.h
  • UINT16_INOUT_TYPE : uni_types.h
  • UINT16_OUT_TYPE : uni_types.h
  • uint16_t : uni_types.h
  • UINT16_TYPE : uni_types.h
  • UINT32_IN_TYPE : uni_types.h
  • UINT32_INOUT_TYPE : uni_types.h
  • UINT32_OUT_TYPE : uni_types.h
  • uint32_t : uni_types.h
  • UINT32_TYPE : uni_types.h
  • UINT64_IN_TYPE : uni_types.h
  • UINT64_INOUT_TYPE : uni_types.h
  • UINT64_OUT_TYPE : uni_types.h
  • uint64_t : uni_types.h
  • UINT64_TYPE : uni_types.h
  • UINT8_IN_TYPE : uni_types.h
  • UINT8_INOUT_TYPE : uni_types.h
  • UINT8_OUT_TYPE : uni_types.h
  • UINT8_TYPE : uni_types.h
  • UIT_CreateColorCorrectionMatrix_Int16() : UniTransform.h
  • UIT_CreateColorCorrectionMatrix_Int8() : UniTransform.h
  • UIT_DestroyColorCorrection() : UniTransform.h
  • UIT_Flip() : UniTransform.h
  • UIT_FlipVertical() : UniTransform.h
  • UIT_GetBitsPerPixel() : UniTransform.h
  • UIT_GetErrorInfo() : UniTransform.h
  • UIT_GetResampledScanlineLength() : UniTransform.h
  • UIT_GetSIS() : UniTransform.h
  • UIT_GetTechnoInfo() : UniTransform.h
  • UIT_GetVersion() : UniTransform.h
  • UIT_InterlacedToProgressive() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_3x3() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToBGR() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_3x3() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToMono() : UniTransform.h
  • UIT_Packed12BitTo16Bit() : UniTransform.h
  • UIT_Packed12BitTo8Bit() : UniTransform.h
  • UIT_Raw12ImageTransform() : UniTransform.h
  • UIT_Raw12ToBGR() : UniTransform.h
  • UIT_Raw12ToBGR16() : UniTransform.h
  • UIT_Raw12ToBGR16_CC() : UniTransform.h
  • UIT_Raw12ToBGR_CC() : UniTransform.h
  • UIT_Raw16ImageTransform() : UniTransform.h
  • UIT_Raw16ToBGR() : UniTransform.h
  • UIT_Raw16ToBGR16() : UniTransform.h
  • UIT_Raw16ToBGR16_CC() : UniTransform.h
  • UIT_Raw16ToY16() : UniTransform.h
  • UIT_Raw16ToY16_CC() : UniTransform.h
  • UIT_Raw8ImageTransform() : UniTransform.h
  • UIT_Raw8ImageTransform_3x3() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAA() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAAV() : UniTransform.h
  • UIT_Raw8ImageTransform_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR() : UniTransform.h
  • UIT_Raw8ToBGR_3x3() : UniTransform.h
  • UIT_Raw8ToBGR_CC() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAA() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAAV() : UniTransform.h
  • UIT_Raw8ToBGR_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR_mono() : UniTransform.h
  • UIT_Raw8ToY8() : UniTransform.h
  • UIT_Raw8ToY8_CC() : UniTransform.h
  • UIT_ResampleScanlines() : UniTransform.h
  • UIT_ResampleScanlinesEx() : UniTransform.h
  • UIT_RGB8ImageTransform() : UniTransform.h
  • UIT_RGB8ToBGR() : UniTransform.h
  • UIT_RGB8ToRGBYPlanes() : UniTransform.h
  • UIT_RGB8ToY8() : UniTransform.h
  • UIT_Y12ImageTransform() : UniTransform.h
  • UIT_Y16ImageTransform() : UniTransform.h
  • UIT_Y16ToBGR() : UniTransform.h
  • UIT_Y16ToY8() : UniTransform.h
  • UIT_Y16ToY8_MMX() : UniTransform.h
  • UIT_Y8ImageTransform() : UniTransform.h
  • UIT_Y8ToBGR() : UniTransform.h
  • UIT_YUV411ImageTransform() : UniTransform.h
  • UIT_YUV411ToBGR() : UniTransform.h
  • UIT_YUV411ToRGBPlanes() : UniTransform.h
  • UIT_YUV411ToRGBYPlanes() : UniTransform.h
  • UIT_YUV422ImageTransform() : UniTransform.h
  • UIT_YUV422ToBGR() : UniTransform.h
  • UIT_YUV422ToRGBPlanes() : UniTransform.h
  • UIT_YUV422ToRGBYPlanes() : UniTransform.h
  • UNI_RESULT_API_ERROR : uni_defines.h
  • UNI_RESULT_COMMAND_ABORTED : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_1 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_10 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_11 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_12 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_2 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_3 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_4 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_5 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_6 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_7 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_8 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_9 : uni_defines.h
  • UNI_RESULT_UNKNOWN_ERROR : uni_defines.h
  • UNI_RETURN_TYPE : uni_types.h
  • UNICODE_CHAR : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- v -

  • VOID_POINTER : uni_types.h
  • VOID_TYPE : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- w -

  • WCHAR_IN_TYPE : uni_types.h
  • WCHAR_INOUT_TYPE : uni_types.h
  • WCHAR_OUT_TYPE : uni_types.h
  • wchar_t : uni_types.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • UNI_RESULT_API_ERROR : uni_defines.h
  • UNI_RESULT_COMMAND_ABORTED : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_1 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_10 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_11 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_12 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_2 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_3 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_4 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_5 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_6 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_7 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_8 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_9 : uni_defines.h
  • UNI_RESULT_UNKNOWN_ERROR : uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • E_UNI_BAYER_PATTERN : uni_defines.h
  • E_UNI_COLOR_CODE : uni_defines.h
  • E_UNI_FLIP_MODE : uni_defines.h
  • E_UNI_ROPMODE : uni_defines.h
  • E_UNI_SIMPLE_IMAGE_FORMAT : uni_defines.h
  • E_UNI_SIS_TYPE : uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • e

- e -

  • E_BP_AUTO : uni_defines.h
  • E_BP_BGGR : uni_defines.h
  • E_BP_CYGM : uni_defines.h
  • E_BP_CYMG : uni_defines.h
  • E_BP_GBRG : uni_defines.h
  • E_BP_GMCY : uni_defines.h
  • E_BP_GRBG : uni_defines.h
  • E_BP_MGCY : uni_defines.h
  • E_BP_RGGB : uni_defines.h
  • E_CC_MONO12 : uni_defines.h
  • E_CC_MONO16 : uni_defines.h
  • E_CC_MONO8 : uni_defines.h
  • E_CC_MONOB : uni_defines.h
  • E_CC_MONOG : uni_defines.h
  • E_CC_MONOR : uni_defines.h
  • E_CC_RAW12 : uni_defines.h
  • E_CC_RAW16 : uni_defines.h
  • E_CC_RAW8 : uni_defines.h
  • E_CC_RGB12 : uni_defines.h
  • E_CC_RGB16 : uni_defines.h
  • E_CC_RGB8 : uni_defines.h
  • E_CC_SMONO12 : uni_defines.h
  • E_CC_SMONO16 : uni_defines.h
  • E_CC_SRGB12 : uni_defines.h
  • E_CC_SRGB16 : uni_defines.h
  • E_CC_YUV411 : uni_defines.h
  • E_CC_YUV422 : uni_defines.h
  • E_CC_YUV444 : uni_defines.h
  • E_FLIP_MODE_BOTH : uni_defines.h
  • E_FLIP_MODE_HORIZONTAL : uni_defines.h
  • E_FLIP_MODE_LEFT_RIGHT : uni_defines.h
  • E_FLIP_MODE_TOP_DOWN : uni_defines.h
  • E_FLIP_MODE_VERTICAL : uni_defines.h
  • E_ROP_LININTERPOL : uni_defines.h
  • E_ROP_SRCCPY : uni_defines.h
  • E_SIF_BGR24 : uni_defines.h
  • E_SIF_BGRA32 : uni_defines.h
  • E_SIF_MONO8_REC601 : uni_defines.h
  • E_SIF_MONO8_REC709 : uni_defines.h
  • E_SIF_UYVY : uni_defines.h
  • E_SIS_MARLIN : uni_defines.h
  • E_SIS_NOT_PRESENT : uni_defines.h
  • E_SIS_PIKE : uni_defines.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • u

- u -

  • UIT_CreateColorCorrectionMatrix_Int16() : UniTransform.h
  • UIT_CreateColorCorrectionMatrix_Int8() : UniTransform.h
  • UIT_DestroyColorCorrection() : UniTransform.h
  • UIT_Flip() : UniTransform.h
  • UIT_FlipVertical() : UniTransform.h
  • UIT_GetBitsPerPixel() : UniTransform.h
  • UIT_GetErrorInfo() : UniTransform.h
  • UIT_GetResampledScanlineLength() : UniTransform.h
  • UIT_GetSIS() : UniTransform.h
  • UIT_GetTechnoInfo() : UniTransform.h
  • UIT_GetVersion() : UniTransform.h
  • UIT_InterlacedToProgressive() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_3x3() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToBGR() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_3x3() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToMono() : UniTransform.h
  • UIT_Packed12BitTo16Bit() : UniTransform.h
  • UIT_Packed12BitTo8Bit() : UniTransform.h
  • UIT_Raw12ImageTransform() : UniTransform.h
  • UIT_Raw12ToBGR() : UniTransform.h
  • UIT_Raw12ToBGR16() : UniTransform.h
  • UIT_Raw12ToBGR16_CC() : UniTransform.h
  • UIT_Raw12ToBGR_CC() : UniTransform.h
  • UIT_Raw16ImageTransform() : UniTransform.h
  • UIT_Raw16ToBGR() : UniTransform.h
  • UIT_Raw16ToBGR16() : UniTransform.h
  • UIT_Raw16ToBGR16_CC() : UniTransform.h
  • UIT_Raw16ToY16() : UniTransform.h
  • UIT_Raw16ToY16_CC() : UniTransform.h
  • UIT_Raw8ImageTransform() : UniTransform.h
  • UIT_Raw8ImageTransform_3x3() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAA() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAAV() : UniTransform.h
  • UIT_Raw8ImageTransform_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR() : UniTransform.h
  • UIT_Raw8ToBGR_3x3() : UniTransform.h
  • UIT_Raw8ToBGR_CC() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAA() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAAV() : UniTransform.h
  • UIT_Raw8ToBGR_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR_mono() : UniTransform.h
  • UIT_Raw8ToY8() : UniTransform.h
  • UIT_Raw8ToY8_CC() : UniTransform.h
  • UIT_ResampleScanlines() : UniTransform.h
  • UIT_ResampleScanlinesEx() : UniTransform.h
  • UIT_RGB8ImageTransform() : UniTransform.h
  • UIT_RGB8ToBGR() : UniTransform.h
  • UIT_RGB8ToRGBYPlanes() : UniTransform.h
  • UIT_RGB8ToY8() : UniTransform.h
  • UIT_Y12ImageTransform() : UniTransform.h
  • UIT_Y16ImageTransform() : UniTransform.h
  • UIT_Y16ToBGR() : UniTransform.h
  • UIT_Y16ToY8() : UniTransform.h
  • UIT_Y16ToY8_MMX() : UniTransform.h
  • UIT_Y8ImageTransform() : UniTransform.h
  • UIT_Y8ToBGR() : UniTransform.h
  • UIT_YUV411ImageTransform() : UniTransform.h
  • UIT_YUV411ToBGR() : UniTransform.h
  • UIT_YUV411ToRGBPlanes() : UniTransform.h
  • UIT_YUV411ToRGBYPlanes() : UniTransform.h
  • UIT_YUV422ImageTransform() : UniTransform.h
  • UIT_YUV422ToBGR() : UniTransform.h
  • UIT_YUV422ToRGBPlanes() : UniTransform.h
  • UIT_YUV422ToRGBYPlanes() : UniTransform.h


AVT Universal API - Image Transform module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w

- a -

  • ACHAR_IN_TYPE : uni_types.h
  • ACHAR_INOUT_TYPE : uni_types.h
  • ACHAR_OUT_TYPE : uni_types.h

- b -

  • BOOL_IN_TYPE : uni_types.h
  • BOOL_INOUT_TYPE : uni_types.h
  • BOOL_OUT_TYPE : uni_types.h

- c -

  • CHAR_INOUT_TYPE : uni_types.h
  • CHAR_OUT_TYPE : uni_types.h
  • CHAR_TYPE : uni_types.h
  • COLOR_CORRECTION_HANDLE : uni_types.h

- d -

  • DOUBLE_IN_TYPE : uni_types.h
  • DOUBLE_INOUT_TYPE : uni_types.h
  • DOUBLE_OUT_TYPE : uni_types.h
  • DOUBLE_TYPE : uni_types.h

- e -

  • E_UniBayerPattern : uni_defines.h
  • E_UniColorCode : uni_defines.h
  • E_UniFlipMode : uni_defines.h
  • E_UniRopMode : uni_defines.h
  • E_UniSimpleImageFormat : uni_defines.h
  • E_UniSISType : uni_defines.h

- f -

  • FLOAT_IN_TYPE : uni_types.h
  • FLOAT_INOUT_TYPE : uni_types.h
  • FLOAT_OUT_TYPE : uni_types.h
  • FLOAT_TYPE : uni_types.h

- h -

  • HRESULT : uni_types.h

- i -

  • ID_TYPE : uni_types.h
  • INT16_IN_TYPE : uni_types.h
  • INT16_INOUT_TYPE : uni_types.h
  • INT16_OUT_TYPE : uni_types.h
  • int16_t : uni_types.h
  • INT16_TYPE : uni_types.h
  • INT32_IN_TYPE : uni_types.h
  • INT32_INOUT_TYPE : uni_types.h
  • INT32_OUT_TYPE : uni_types.h
  • int32_t : uni_types.h
  • INT32_TYPE : uni_types.h
  • INT64_IN_TYPE : uni_types.h
  • INT64_INOUT_TYPE : uni_types.h
  • INT64_OUT_TYPE : uni_types.h
  • int64_t : uni_types.h
  • INT64_TYPE : uni_types.h
  • INT8_IN_TYPE : uni_types.h
  • INT8_INOUT_TYPE : uni_types.h
  • INT8_OUT_TYPE : uni_types.h
  • INT8_TYPE : uni_types.h

- p -

  • POINTER_SIZE : uni_types.h

- s -

  • S_SISData : uni_defines.h
  • S_SISEnable : uni_defines.h
  • S_SupportState : uni_defines.h
  • S_TechInfo : uni_defines.h

- u -

  • UINT16_IN_TYPE : uni_types.h
  • UINT16_INOUT_TYPE : uni_types.h
  • UINT16_OUT_TYPE : uni_types.h
  • uint16_t : uni_types.h
  • UINT16_TYPE : uni_types.h
  • UINT32_IN_TYPE : uni_types.h
  • UINT32_INOUT_TYPE : uni_types.h
  • UINT32_OUT_TYPE : uni_types.h
  • uint32_t : uni_types.h
  • UINT32_TYPE : uni_types.h
  • UINT64_IN_TYPE : uni_types.h
  • UINT64_INOUT_TYPE : uni_types.h
  • UINT64_OUT_TYPE : uni_types.h
  • uint64_t : uni_types.h
  • UINT64_TYPE : uni_types.h
  • UINT8_IN_TYPE : uni_types.h
  • UINT8_INOUT_TYPE : uni_types.h
  • UINT8_OUT_TYPE : uni_types.h
  • UINT8_TYPE : uni_types.h
  • UNI_RETURN_TYPE : uni_types.h
  • UNICODE_CHAR : uni_types.h

- v -

  • VOID_POINTER : uni_types.h
  • VOID_TYPE : uni_types.h

- w -

  • WCHAR_IN_TYPE : uni_types.h
  • WCHAR_INOUT_TYPE : uni_types.h
  • WCHAR_OUT_TYPE : uni_types.h
  • wchar_t : uni_types.h


AVT Universal API - Image Transform module: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Introduction
  • Overview of Image Format Transformations
  • Image Format Conversion
  • Bayer patterns
  • Debayering methods
  • Special image transformation
  • Version information


AVT Universal API - Image Transform module: S_12BIT_2PACKED::m_nVal8_1

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_1

High byte of the first Pixel.


AVT Universal API - Image Transform module: S_12BIT_2PACKED::m_nVal8_2Low

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_2Low

Low nibble of the second pixel.


AVT Universal API - Image Transform module: S_12BIT_2PACKED::m_nVal8_2

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_2

High byte of the second pixel.


AVT Universal API - Image Transform module: S_12BIT_2PACKED::m_nVal8_1Low

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_1Low

Low nibble of the first pixel.


AVT Universal API - Image Transform module: S_BGR8::B

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::B

blue part


AVT Universal API - Image Transform module: S_BGR8::R

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::R

red part


AVT Universal API - Image Transform module: S_BGR8::G

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::G

green part


AVT Universal API - Image Transform module: S_BGR16::G

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::G

green part


AVT Universal API - Image Transform module: S_BGR16::R

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::R

red part


AVT Universal API - Image Transform module: S_BGR16::B

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::B

blue part


AVT Universal API - Image Transform module: S_BGRA8::G

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::G

green part


AVT Universal API - Image Transform module: S_BGRA8::B

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::B

blue part


AVT Universal API - Image Transform module: S_BGRA8::A

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::A

unused


AVT Universal API - Image Transform module: S_BGRA8::R

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::R

red part


AVT Universal API - Image Transform module: S_RGB8::B

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::B

blue part


AVT Universal API - Image Transform module: S_RGB8::R

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::R

red part


AVT Universal API - Image Transform module: S_RGB8::G

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::G

green part


AVT Universal API - Image Transform module: S_SIS_DATA::m_AOILeft

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOILeft

left coordinate of the AOI begin


AVT Universal API - Image Transform module: S_SIS_DATA::m_Reserved0

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_Reserved0

reserved for future use


AVT Universal API - Image Transform module: S_SIS_DATA::m_SerialNumber

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_SerialNumber

camera serial number


AVT Universal API - Image Transform module: S_SIS_DATA::m_AOIWidth

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOIWidth

width of the AOI


AVT Universal API - Image Transform module: S_SIS_DATA::m_InputState

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_InputState[2]

state of the input pins


AVT Universal API - Image Transform module: S_SIS_DATA::m_AOITop

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOITop

top coordinate of the AOI begin


AVT Universal API - Image Transform module: S_SIS_DATA::m_Gain

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_Gain

camera gain for the image


AVT Universal API - Image Transform module: S_SIS_DATA::m_SISEnable

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
S_SIS_ENABLE S_SIS_DATA::m_SISEnable

state inq struct


AVT Universal API - Image Transform module: S_SIS_DATA::m_AOIHeight

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOIHeight

height of the AOI


AVT Universal API - Image Transform module: S_SIS_DATA::m_OutputState

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_OutputState[4]

state of the output pins


AVT Universal API - Image Transform module: S_SIS_DATA::m_Reserved2b

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reserved2b

reserved for future use


AVT Universal API - Image Transform module: S_SIS_DATA::m_Reserved2a

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reserved2a

reserved for future use


AVT Universal API - Image Transform module: S_SIS_DATA::m_Reservec1

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reservec1[2]

reserved for future use


AVT Universal API - Image Transform module: S_SIS_DATA::m_TriggerCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_TriggerCounter

from camera received triggers


AVT Universal API - Image Transform module: S_SIS_DATA::m_SequenceIndex

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_SequenceIndex

position in the sequence


AVT Universal API - Image Transform module: S_SIS_DATA::m_ColorCoding

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_ColorCoding

IIDC color coding for the transport format.


AVT Universal API - Image Transform module: S_SIS_DATA::m_FrameCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_FrameCounter

frame count since last reset


AVT Universal API - Image Transform module: S_SIS_DATA::m_Shutter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_Shutter

camera shutter for the image


AVT Universal API - Image Transform module: S_SIS_DATA::m_CycleCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_CycleCounter

bus cycle count


AVT Universal API - Image Transform module: S_SIS_DATA::m_UserValue

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_UserValue

user defined value


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOITop

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOITop

inq top coordinate of the cameras AOI


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_ColorCoding

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_ColorCoding

inq IIDC color coding


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_InputState

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_InputState

inq input pin states


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIWidth

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIWidth

inq width of the AOI


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOILeft

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOILeft

inq left coordinate of the cameras AOI


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIHeight

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIHeight

inq height of the AOI


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_OutputState

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_OutputState

inq output pin states


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_TriggerCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_TriggerCounter

inq triggers received by the camera


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved0

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2a

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SequenceIndex

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SequenceIndex

inq position in sequence


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2b

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Valid

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Valid

Data in Enable is valid.


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Shutter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Shutter

inq camera shutter for the image


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_CycleCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_CycleCounter

inq cycle counter


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Gain

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Gain

inq camera gain for the image


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SerialNumber

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SerialNumber

inq serial number of the camera


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_UserValue

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_UserValue

inq user defined value


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_FrameCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_FrameCounter

inq frame count since last reset


AVT Universal API - Image Transform module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Image Transform module: S_SUPPORT_STATE::Processor

S_SUPPORT_STATE
OperatingSystem
Processor
bool S_SUPPORT_STATE::Processor

technology supported by the processor


AVT Universal API - Image Transform module: S_SUPPORT_STATE::OperatingSystem

S_SUPPORT_STATE
OperatingSystem
Processor
bool S_SUPPORT_STATE::OperatingSystem

technology supported by the OS


AVT Universal API - Image Transform module: S_TECHNO_INFO::AMD3DNow

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::AMD3DNow

AMD 3DNow.


AVT Universal API - Image Transform module: S_TECHNO_INFO::IntelSSE2

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE2

INTEL Streaming SIMD Extension 2.


AVT Universal API - Image Transform module: S_TECHNO_INFO::IntelSSE

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE

INTEL Streaming SIMD Extension.


AVT Universal API - Image Transform module: S_TECHNO_INFO::IntelSSE3

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE3

INTEL Streaming SIMD Extension 3.


AVT Universal API - Image Transform module: S_TECHNO_INFO::IntelSSSE3

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSSE3

INTEL Supplemental Streaming SIMD Extension 3.


AVT Universal API - Image Transform module: S_TECHNO_INFO::IntelMMX

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelMMX

INTEL first gen MultiMedia eXtension.


AVT Universal API - Image Transform module: S_YUV411::Y2

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y2

the intensity of the third pixel


AVT Universal API - Image Transform module: S_YUV411::Y0

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y0

the intensity of the first pixel


AVT Universal API - Image Transform module: S_YUV411::Y1

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y1

the intensity of the second pixel


AVT Universal API - Image Transform module: S_YUV411::Y3

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y3

the intensity of the fourth pixel


AVT Universal API - Image Transform module: S_YUV411::V

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::V

the V part for all four pixels


AVT Universal API - Image Transform module: S_YUV411::U

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::U

the U part for all four pixels


AVT Universal API - Image Transform module: S_YUV422::V

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::V

the V part for both pixels


AVT Universal API - Image Transform module: S_YUV422::Y1

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::Y1

the intensity of the second pixel


AVT Universal API - Image Transform module: S_YUV422::Y0

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::Y0

the intensity of the first pixel


AVT Universal API - Image Transform module: S_YUV422::U

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::U

the U part for both pixels


AVT Universal API - Image Transform module: S_YUV444::U

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::U

U.


AVT Universal API - Image Transform module: S_YUV444::V

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::V

V.


AVT Universal API - Image Transform module: S_YUV444::Y

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::Y

Luma.


AVT Universal API - Image Transform module: UNI_RESULT_UNKNOWN_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_UNKNOWN_ERROR 0x88000001

unclassified error


AVT Universal API - Image Transform module: E_UniFlipMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_FLIP_MODE E_UniFlipMode

Enumeration for the direction for flipping images.


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_10

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_10 0x8800000B

parameter 10 is invalid


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_5

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_5 0x88000006

parameter 5 is invalid


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_8

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_8 0x88000009

parameter 8 is invalid


AVT Universal API - Image Transform module: E_UNI_COLOR_CODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_COLOR_CODE

Enumeration for IIDC format 7 color codes / transfer formats.

Enumerator:
E_CC_MONO8 | no special byte order, one byte per pixel
E_CC_YUV411 | byte order is UYYVYYUYYVYY,
E_CC_YUV422 | byte order is UYVYUYVY,
E_CC_YUV444 | byte order is UYVUYV,
E_CC_RGB8 | byte order is RGBRGB,
E_CC_MONO16 | byte order is high_byte,low_byte
E_CC_RGB16 | byte order is Rh,Rl,Gh,Gl,Bh,Bl,
E_CC_SMONO16 | byte order is high_byte,low_byte
E_CC_SRGB16 | byte order is Rh,Rl,Gh,Gl,Bh,Bl,
E_CC_RAW8 | byte order is RGGB, GBRG, GRBG or BGGR
E_CC_RAW16 | same as RAW8, but each value: high_byte,low_byte
E_CC_MONOR | ->E_CC_MONO8
E_CC_MONOG | ->E_CC_MONO8
E_CC_MONOB | ->E_CC_MONO8
E_CC_MONO12 | two pixels in three bytes, see S_12BIT_2PACKED
E_CC_RGB12 | 12 bit RGB unused
E_CC_SMONO12 | see S_12BIT2PACKED
E_CC_SRGB12 | 12 SRGB unused
E_CC_RAW12 | two pixels in three bytes, see S_12BIT_2PACKED
00085 {
00086     E_CC_COLOR_CODE_BEGIN=0,
00087     E_CC_MONO8=0,
00088     E_CC_YUV411,
00089     E_CC_YUV422,
00090     E_CC_YUV444,
00091     E_CC_RGB8,
00092     E_CC_MONO16,
00093     E_CC_RGB16,
00094     E_CC_SMONO16,
00095     E_CC_SRGB16,
00096     E_CC_RAW8,
00097     E_CC_RAW16,
00098     E_CC_MONOR=128,
00099     E_CC_MONOG,
00100     E_CC_MONOB,
00101     E_CC_MONO12=132,
00102     E_CC_RGB12,
00103     E_CC_SMONO12,
00104     E_CC_SRGB12,
00105     E_CC_RAW12,
00106     E_CC_LAST=255,
00107     E_CC_COLOR_CODE_END=E_CC_LAST
00108 } E_UniColorCode, E_UNI_COLOR_CODE;


AVT Universal API - Image Transform module: E_UNI_FLIP_MODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_FLIP_MODE

Enumeration for the direction for flipping images.

Enumerator:
E_FLIP_MODE_HORIZONTAL | flip in horizontal direction
E_FLIP_MODE_LEFT_RIGHT | same as E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_VERTICAL | flip in vertical direction
E_FLIP_MODE_TOP_DOWN | same as E_FLIP_MODE_VERTICAL
E_FLIP_MODE_BOTH | flip in both directions
00127 {
00128     E_FLIP_MODE_NONE        = 0,
00129     E_FLIP_MODE_HORIZONTAL  = 1,
00130     E_FLIP_MODE_LEFT_RIGHT  = E_FLIP_MODE_HORIZONTAL,
00131
00132     E_FLIP_MODE_VERTICAL    = 2,
00133     E_FLIP_MODE_TOP_DOWN    = E_FLIP_MODE_VERTICAL,
00134     E_FLIP_MODE_BOTH        = 3
00135 }E_UniFlipMode,E_UNI_FLIP_MODE;


AVT Universal API - Image Transform module: S_OK

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR


AVT Universal API - Image Transform module: UNI_RESULT_COMMAND_ABORTED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_COMMAND_ABORTED 0x8800001E

the current command was aborted


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_11

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_11 0x8800000C

parameter 11 is invalid


AVT Universal API - Image Transform module: E_UniColorCode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_COLOR_CODE E_UniColorCode

Enumeration for IIDC format 7 color codes / transfer formats.


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_1

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_1 0x88000002

parameter 1 is invalid


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_9

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_9 0x8800000A

parameter 9 is invalid


AVT Universal API - Image Transform module: E_UniRopMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_ROPMODE E_UniRopMode

Enumeration for raster operation (used by re sampling methods).


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_6

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_6 0x88000007

parameter 6 is invalid


AVT Universal API - Image Transform module: S_BGR24

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR


AVT Universal API - Image Transform module: S_TechInfo

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef struct S_TECHNO_INFO S_TechInfo

states of the support for different multimedia technologies


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_2

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_2 0x88000003

parameter 2 is invalid


AVT Universal API - Image Transform module: E_UNI_BAYER_PATTERN

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_BAYER_PATTERN

Enumeration for the Bayer pattern.

Enumerator:
E_BP_AUTO | Set pattern to automatic mode (may not be used in conversion methods!!!).
E_BP_RGGB | RGGB pattern, red pixel comes first.
E_BP_GBRG | RGGB pattern, green pixel of blue row comes first.
E_BP_GRBG | RGGB pattern, green pixel of red row comes first.
E_BP_BGGR | RGGB pattern, blue pixel comes first.
E_BP_CYGM | CYGM pattern, cyan pixel comes first in the first row, green in the second row (of the sensor).
E_BP_GMCY | CYGM pattern, green pixel comes first in the first row, cyan in the second row (of the sensor).
E_BP_CYMG | CYGM pattern, cyan pixel comes first in the first row, magenta in the second row (of the sensor).
E_BP_MGCY | CYGM pattern, magenta pixel comes first in the first row, cyan in the second row (of the sensor).
00112 {
00113     E_BP_AUTO = -1,
00114     E_BP_RGGB=0,
00115     E_BP_GBRG,
00116     E_BP_GRBG,
00117     E_BP_BGGR,
00118     E_BP_CYGM=128,
00119     E_BP_GMCY,
00120     E_BP_CYMG,
00121     E_BP_MGCY,
00122     E_BP_LAST=255
00123 } E_UniBayerPattern, E_UNI_BAYER_PATTERN;


AVT Universal API - Image Transform module: S_SISData

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef struct S_SIS_DATA S_SISData

SIS data structure.


AVT Universal API - Image Transform module: E_UNI_SIMPLE_IMAGE_FORMAT

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_SIMPLE_IMAGE_FORMAT

Simple image type enum.

Enumeration for simple image types with one image plane consisting of consecutive pixel (starting at the top of the image).

Enumerator:
E_SIF_MONO8_REC601 | the Y value is defined by the Rec.601
E_SIF_BGR24 | windows 24 bit BGR
E_SIF_BGRA32 | windows 32 bit BGRA
E_SIF_MONO8_REC709 | the Y value is the Y from the CIE - XYZ color space defined in Rec 709
E_SIF_UYVY | IIDC YUV422 full color space.
00548 {
00549     E_SIF_MONO8_REC601       ,
00550     E_SIF_BGR24             ,
00551     E_SIF_BGRA32            ,
00552     E_SIF_MONO8_REC709       ,
00553     E_SIF_UYVY              ,
00554 }E_UniSimpleImageFormat, E_UNI_SIMPLE_IMAGE_FORMAT;


AVT Universal API - Image Transform module: E_UniSISType

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_SIS_TYPE E_UniSISType

enum for the secure image signatures


AVT Universal API - Image Transform module: E_UNI_SIS_TYPE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_SIS_TYPE

enum for the secure image signatures

Enumerator:
E_SIS_NOT_PRESENT | camera supports no SIS
E_SIS_MARLIN | Marlin Cycle,Frame,Trigger count.
E_SIS_PIKE | Pike 3.0 and Stingray SIS.
00166 {
00167     E_SIS_NOT_PRESENT,
00168     E_SIS_MARLIN,
00169     E_SIS_PIKE
00170 } E_UniSISType, E_UNI_SIS_TYPE;


AVT Universal API - Image Transform module: S_SISEnable

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef union S_SIS_ENABLE S_SISEnable

information about state of the fields of the S_SIS_DATA struct


AVT Universal API - Image Transform module: E_UniBayerPattern

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_BAYER_PATTERN E_UniBayerPattern

Enumeration for the Bayer pattern.


AVT Universal API - Image Transform module: S_SupportState

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef struct S_SUPPORT_STATE S_SupportState

states of the multi media technology support for operating system and processor.


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_7

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_7 0x88000008

parameter 7 is invalid


AVT Universal API - Image Transform module: S_BGRA32

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR


AVT Universal API - Image Transform module: UNI_RESULT_API_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_API_ERROR 0x88000000

mask for API error


AVT Universal API - Image Transform module: E_UniSimpleImageFormat

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
typedef enum E_UNI_SIMPLE_IMAGE_FORMAT E_UniSimpleImageFormat

Simple image type enum.

Enumeration for simple image types with one image plane consisting of consecutive pixel (starting at the top of the image).


AVT Universal API - Image Transform module: E_UNI_ROPMODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
enum E_UNI_ROPMODE

Enumeration for raster operation (used by re sampling methods).

Enumerator:
E_ROP_SRCCPY | nearest neighbor raster operation method
E_ROP_LININTERPOL | interpolating raster operation method
00078 {
00079     E_ROP_SRCCPY,
00080     E_ROP_LININTERPOL,
00081 } E_UniRopMode,E_UNI_ROPMODE;


AVT Universal API - Image Transform module: PS_12BIT_2PACKED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_3

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_3 0x88000004

parameter 3 is invalid


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_12

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_12 0x8800000D

parameter 12 is invalid


AVT Universal API - Image Transform module: UNI_RESULT_PARAMETER_INVALID_4

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_UNI_BAYER_PATTERN
E_UNI_COLOR_CODE
E_UNI_FLIP_MODE
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniColorCode
E_UniFlipMode
E_UniRopMode
E_UniSimpleImageFormat
E_UniSISType
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
UNI_RESULT_API_ERROR
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
#define UNI_RESULT_PARAMETER_INVALID_4 0x88000005

parameter 4 is invalid


AVT Universal API - Image Transform module: VOID_POINTER

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef VOID_TYPE* VOID_POINTER

pointer to void tyype


AVT Universal API - Image Transform module: UNICODE_CHAR

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef char UNICODE_CHAR

char type dependent on the UNICODE define multi byte or single byte


AVT Universal API - Image Transform module: INT32_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int32_t INT32_IN_TYPE

32 bit signed integer type for input


AVT Universal API - Image Transform module: INT8_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef signed char INT8_IN_TYPE

8 bit signed integer type for input


AVT Universal API - Image Transform module: UINT64_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint64_t UINT64_IN_TYPE

64 bit unsigned integer type for input


AVT Universal API - Image Transform module: INT64_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int64_t INT64_IN_TYPE

64 bit signed integer type for input


AVT Universal API - Image Transform module: UINT8_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned char UINT8_TYPE

8 bit unsigned integer


AVT Universal API - Image Transform module: WCHAR_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef WCHAR_TYPE* WCHAR_OUT_TYPE

valid pointer to a wchar_t, will return results from a function


AVT Universal API - Image Transform module: INT8_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT8_IN_TYPE* INT8_OUT_TYPE

8 bit signed integer type for output


AVT Universal API - Image Transform module: UINT32_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint32_t UINT32_IN_TYPE

32 bit unsigned integer type for input


AVT Universal API - Image Transform module: DOUBLE_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef double DOUBLE_IN_TYPE

8 byte floating point type for input


AVT Universal API - Image Transform module: WCHAR_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef wchar_t WCHAR_IN_TYPE

string with wide char


AVT Universal API - Image Transform module: INT16_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT16_IN_TYPE* INT16_INOUT_TYPE

16 bit signed integer type for input and output


AVT Universal API - Image Transform module: INT32_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int32_t INT32_TYPE

32 bit signed integer


AVT Universal API - Image Transform module: POINTER_SIZE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef size_t POINTER_SIZE

size of a pointer system dependent


AVT Universal API - Image Transform module: BOOL_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef BOOL_IN_TYPE* BOOL_INOUT_TYPE

"bool" type for input and output


AVT Universal API - Image Transform module: INT8_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT8_IN_TYPE* INT8_INOUT_TYPE

8 bit signed integer type for input and output


AVT Universal API - Image Transform module: int32_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int int32_t

32 bit signed integer on non-Microsoft systems


AVT Universal API - Image Transform module: UINT8_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned char UINT8_IN_TYPE

8 bit unsigned integer type for input


AVT Universal API - Image Transform module: CHAR_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UNICODE_CHAR CHAR_TYPE

string type will change with UNICODE builds from char to wchar_t


AVT Universal API - Image Transform module: HRESULT

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef long HRESULT

Definition just in case HRESULT is not defined (and winnt.h should not be included).


AVT Universal API - Image Transform module: ACHAR_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef ACHAR_TYPE* ACHAR_OUT_TYPE

8bit ASCII string returning a result from a function


AVT Universal API - Image Transform module: DOUBLE_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef double DOUBLE_TYPE

8 byte floating point


AVT Universal API - Image Transform module: INT16_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int16_t INT16_TYPE

16 bit signed integer


AVT Universal API - Image Transform module: INT16_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT16_IN_TYPE* INT16_OUT_TYPE

16 bit signed integer type for output


AVT Universal API - Image Transform module: uint16_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned short uint16_t

16 bit unsigned integer on non-Microsoft systems


AVT Universal API - Image Transform module: uint32_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned int uint32_t

32 bit unsigned integer on non-Microsoft systems


AVT Universal API - Image Transform module: ID_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE ID_TYPE

Type for identifying a camera.


AVT Universal API - Image Transform module: COLOR_CORRECTION_HANDLE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void* COLOR_CORRECTION_HANDLE

A handle for a color correction object to be used during debayering.


AVT Universal API - Image Transform module: UINT16_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT16_IN_TYPE* UINT16_OUT_TYPE

16 bit unsigned integer type for output


AVT Universal API - Image Transform module: UINT16_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint16_t UINT16_IN_TYPE

16 bit unsigned integer type for input


AVT Universal API - Image Transform module: int64_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef long long int64_t

64 bit signed integer on non-Microsoft systems


AVT Universal API - Image Transform module: INT64_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT64_IN_TYPE* INT64_INOUT_TYPE

64 bit signed integer type for input and output


AVT Universal API - Image Transform module: BOOL_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef BOOL_IN_TYPE* BOOL_OUT_TYPE

"bool" type for output


AVT Universal API - Image Transform module: UINT64_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT64_IN_TYPE* UINT64_INOUT_TYPE

64 bit unsigned integer type for input and output


AVT Universal API - Image Transform module: CHAR_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Image Transform module: INT32_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT32_IN_TYPE* INT32_OUT_TYPE

32 bit signed integer type for output


AVT Universal API - Image Transform module: wchar_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned short wchar_t

if not defined wchar_t define it


AVT Universal API - Image Transform module: UINT16_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint16_t UINT16_TYPE

16 bit unsigned integer


AVT Universal API - Image Transform module: FLOAT_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef FLOAT_IN_TYPE* FLOAT_INOUT_TYPE

4 byte floating point type for input and output


AVT Universal API - Image Transform module: UINT64_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT64_IN_TYPE* UINT64_OUT_TYPE

64 bit unsigned integer type for output


AVT Universal API - Image Transform module: INT64_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT64_IN_TYPE* INT64_OUT_TYPE

64 bit signed integer type for output


AVT Universal API - Image Transform module: UINT8_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT8_IN_TYPE* UINT8_INOUT_TYPE

8 bit unsigned integer type for input and output


AVT Universal API - Image Transform module: UINT64_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint64_t UINT64_TYPE

64 bit unsigned integer


AVT Universal API - Image Transform module: UINT32_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE* UINT32_OUT_TYPE

32 bit unsigned integer type for output


AVT Universal API - Image Transform module: DOUBLE_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef DOUBLE_IN_TYPE* DOUBLE_OUT_TYPE

8 byte floating point type for output


AVT Universal API - Image Transform module: UINT16_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT16_IN_TYPE* UINT16_INOUT_TYPE

16 bit unsigned integer type for input and output


AVT Universal API - Image Transform module: int16_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef short int16_t

16 bit signed integer on non-Microsoft systems


AVT Universal API - Image Transform module: CHAR_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef CHAR_TYPE* CHAR_INOUT_TYPE

a valid pointer to a mutable char/wchar_t as, will take values into a function and return the result


AVT Universal API - Image Transform module: uint64_t

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned long long uint64_t

64 bit unsigned integer on non-Microsoft systems


AVT Universal API - Image Transform module: ACHAR_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Image Transform module: ACHAR_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef ACHAR_TYPE* ACHAR_INOUT_TYPE

8bit ASCII char string taking values int a function and returning a result


AVT Universal API - Image Transform module: INT8_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef signed char INT8_TYPE

8 bit signed integer


AVT Universal API - Image Transform module: WCHAR_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Image Transform module: UINT32_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE* UINT32_INOUT_TYPE

32 bit unsigned integer type for input and output


AVT Universal API - Image Transform module: ACHAR_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef char ACHAR_IN_TYPE

string of 8bit ASCII chars


AVT Universal API - Image Transform module: INT16_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int16_t INT16_IN_TYPE

16 bit signed integer type for input


AVT Universal API - Image Transform module: UINT32_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint32_t UINT32_TYPE

32 bit unsigned integer


AVT Universal API - Image Transform module: FLOAT_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef float FLOAT_IN_TYPE

4 byte floating point type for input


AVT Universal API - Image Transform module: BOOL_IN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE BOOL_IN_TYPE

BOOL type for input.


AVT Universal API - Image Transform module: DOUBLE_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef DOUBLE_IN_TYPE* DOUBLE_INOUT_TYPE

8 byte floating point type for input and output


AVT Universal API - Image Transform module: CHAR_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef CHAR_TYPE* CHAR_OUT_TYPE

a valid pointer to a char/wchar_t, will return results from a function


AVT Universal API - Image Transform module: VOID_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void VOID_TYPE

void type


AVT Universal API - Image Transform module: UNI_RETURN_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef HRESULT UNI_RETURN_TYPE

Return value for all the methods of the API.


AVT Universal API - Image Transform module: WCHAR_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef WCHAR_TYPE* WCHAR_INOUT_TYPE

valid pointer to a mutable wchar_t, will take values into a function and return the ressult.


AVT Universal API - Image Transform module: INT64_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int64_t INT64_TYPE

64 bit signed integer


AVT Universal API - Image Transform module: UINT8_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT8_IN_TYPE* UINT8_OUT_TYPE

8 bit unsigned integer type for output


AVT Universal API - Image Transform module: FLOAT_OUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef FLOAT_IN_TYPE* FLOAT_OUT_TYPE

4 byte floating point type for output


AVT Universal API - Image Transform module: FLOAT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef float FLOAT_TYPE

4 byte floating point


AVT Universal API - Image Transform module: INT32_INOUT_TYPE

uni_types.h
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT32_IN_TYPE* INT32_INOUT_TYPE

32 bit signed integer type for input and output


AVT Universal API - Image Transform module: S_SIS_ENABLE::m_Data

S_SIS_ENABLE
m_Data
m_Enable
UINT32_TYPE S_SIS_ENABLE::m_Data

Enable as UINT32.


AVT Universal API - Image Transform module: S_SIS_ENABLE::m_Enable

S_SIS_ENABLE
m_Data
m_Enable
struct S_SIS_ENABLE::S_SIS_ENABLE_FIELDS S_SIS_ENABLE::m_Enable

states of the sis data

inq for supported sis data