AVT Universal API - Camera Control module: AVT Universal API Camera Control module

  • Main Page
  • Related Pages
  • Data Structures
  • Files

AVT Universal API Camera Control module

1.4

The AVT Universal API Camera Control module is a programming interface for those who want to address a frame grabber or a camera instead of bus resources like with the FireStack. It is designed to be as easy to use as possible while providing as much convenience as possible.
Since it is designed as a C-DLL interface, it is usable by many languages.
It is delivered in two versions:
  • A secure version that checks parameters
  • A faster version, not performing parameter checks

Main contents:

  • The Getting started page tells you the basic steps to get your first image.
  • The General Conventions page tells you basics for understanding and using the Universal API.
  • Learn how to do camera and API configuration
Generated on 27 Nov 2008 using doxygen 1.5.6 by Allied Vision Technologies


AVT Universal API - Camera Control module: Getting started

  • Files

Getting started

Introduction

The purpose of this section is to guide you to successfully grab your first images with your AVT camera. For information in greater depth consult the following chapters.

Initialization and camera identification

At first, the API needs to be initialized with UCC_Init. Then the camera has to be opened with UCC_OpenCamera. Cameras are generally identified by their camera ID (serial number). If the camera ID is unknown, UCC_GetCameras may be used to get a list of all available cameras.
Note:
An initialization example can be found here.

Optional camera configuration

You probably want to have your camera configured in a certain way before image acquisition. There are various configuration options, whose explanation goes far beyond the scope of a 'Getting Started' tutorial. See Camera configuration - Overview and subsequent chapters for further information.
You may also have a camera configuration file containing all configuration details in xml format. Configuration files can be loaded with UCC_LoadSettings.

Mandatory camera configuration: prepare grab

There are some configuration details directly affecting the camera communication like image resolution and color format, which need to be set before any image grabbing may be performed. These have to be specified by either UCC_PrepareFreeGrab or UCC_PrepareFixedGrab.
See Camera configuration - Image Format for detailed information.
Note:
Examples using UCC_PrepareFreeGrab can be found here.

Grabbing single images

Single images may be grabbed with UCC_GrabBitmapImage or UCC_GrabPlanesImage, depending on the image data structure to be filled. Page Image acquisition - Single images explains these functions in detail.
Note:
Examples for single image acquisition may be found here.

Grabbing a stream of images

To grab a stream of images, user notifications should be used to notify the application about incoming images. UCC_RegisterFrameReadyNotification and UCC_RegisterNotification allow the registration of notifications for E_UNI_NOTIFICATION_FRAME_READY events. Image grabbing can be started with UCC_GrabStart. Once the application has been notified about a received image, one of the UCC_Get...Image functions (UCC_GetImage, UCC_GetBitmapImage, UCC_GetNativeImage or UCC_GetPlanesImage) has to be called to obtain the image data.
See Image acquisition - Image stream for further information.

Deinitialization

Before program termination UCC_Release has to be called.


AVT Universal API - Camera Control module: General conventions

General conventions

Introductions

This section describes programming conventions and principles that apply to all functions and data types of the Universal API. It should be considered good practice to read this chapter completely before reading anything else, even though short examples may be completed without reading it at all.

Method names

All methods of this API have a prefix "UCC_". The subsequent part of the method names should be mostly self-explaining.

Method parameters

Integer parameters

For better interoperability between languages, only a small set of parameter types is used. The majority of parameters use '32 bit unsigned' types. Function parameters that return data are generally passed 'by pointer'. To indicate in which direction data is passed by function parameters, type definitions labeled with 'IN', 'OUT' and 'INOUT' are used. 32 bit parameter types are defined as follows:
 typedef UINT32_TYPE        UINT32_IN_TYPE;         // 32 bit unsigned integer type for input
 typedef UINT32_TYPE *      UINT32_INOUT_TYPE;      // 32 bit unsigned integer type for input and output
 typedef UINT32_TYPE *      UINT32_OUT_TYPE;        // 32 bit unsigned integer type for output
In terms of definition 'INOUT' and 'OUT' types are identical. There are also corresponding definitions for 8, 16 and 64 bit types.

Enumeration usage

Some function parameters' interpretation bases on enum definitions, although they are defined as UINT32 types for compatibility reasons. The documentation of these parameters contain references to the respective enum definitions. The example below shows an examplary call of the UCC_SerialIO_SetConfig function, which uses such parameters extensively:
 UINT32_TYPE nRate = E_SIOBAUDRATE_19200;
 UINT32_TYPE nCharsize = 8;
 UINT32_TYPE nParity = E_SIOPARITY_EVEN;
 UINT32_TYPE nStopbits = E_SIOSTOPBITS_1;
 UINT32_TYPE nMode = E_SIOMODE_RECEIVETRANSMIT;

 UCC_SerialIO_SetConfig(nCamId, nRate, nCharsize, nParity, nStopbits, nMode);

Handles

A few functions have specific handle type parameters. Like other handles these aren't meant to be created or modified by the user. The following handle types are used by the Universal API:
  • UNI_NOTIFICATION_HANDLE
  • PRESETS_ENUMERATION
  • COLORCODE_ENUMERATION

Camera ID parameter

All methods addressing a specific camera have the AVT camera ID (ID_TYPE) as their first parameter.

Method return codes

Return codes are always of type UNI_RETURN_TYPE, so that there is always the possibility to return error codes, which may then be evaluated. If everything was OK, a method returns S_OK, otherwise a specific error code. This may either be an API error, using codes 0x88xxxxxx, or a FireGrab error, using a code like 0x8Axxxxxx (see uni_defines.h). A translation of error codes into human-readable descriptions is provided by UCC_GetErrorInfo.
There are several errors that are more common, while others may only occur under certain conditions. The more common API errors are:

Basic return codes

UNI_RESULT_API_NOT_INITIALIZED
UCC_Init was not called
UNI_RESULT_CAMERA_NOT_FOUND
meaning that the camera with the given Id was not found on the bus, either bacause it has not been opened or because it is not accessible

Parameter return codes

UNI_RESULT_PARAMETER_INVALID_n
The nth parameter is not valid

(De-)Initialization

The Universal API must be initialized before beeing used. This is done using the UCC_Init() method. If you like, you can specify a callback method pointer or a windows handle and a message that will be called when events occur.
The API has to be deinitialized by UCC_Release after usage.


AVT Universal API - Camera Control module: Camera configuration - Overview

Camera configuration - Overview

Introduction

This chapter gives an overview about configuration options concerning a connected camera. Information about 1394 bus configuration and the Universal API's logging capabilities can be found here.

Manual camera configuration

Image format configuration

Image format configuration is the only mandatory configuration. Either UCC_PrepareFixedGrab or UCC_PrepareFreeGrab has to be called prior to image grabbing. More information can be found here.

Additional feature configuration

There are three possibilities for manipulating camera configuration:
  • Explicit function calls
    Example: UCC_Lut_Use
  • Configuration via Camera register access
    Use the methods UCC_SetRegister and UCC_GetRegister . These methods use a full long IIDC address (32 bit) and need a 32 bit value.
  • Configuration via unified feature access
    There are a few methods for configuring features in a unified manner:
    • UCC_HasFeature
    • UCC_GetFeatureValue
    • UCC_SetFeatureValue
    • UCC_GetFeatureStatus
    • UCC_SetFeatureStatus
    • UCC_HasFeatureStatus
    • UCC_GetFeatureMin
    • UCC_GetFeatureMax

    These functions work with feature identifiers of type E_UniFeature
    For more information see the next page.

Automatic camera configuration

One possibility to keep a camera configuration over session boundaries is to store a camera configuration into an XML file with the name of your choice. This is done with the method UCC_SaveSettings(). Restoring a camera configuration is as easy as that: UCC_LoadSettings() reads settings from a previously written file and writes them to a camera.
The DTD for the XML file used is described on page XML settings files . Remember to read the camera configuration back to your program so that you can adjust your display parameters to the parameters of the camera.


AVT Universal API - Camera Control module: Camera configuration - Image Format

Camera configuration - Image Format

Introduction

This page explains the configuration of the image format used by the camera for image transmission. Image format configuration is a necessary step prior to image acquisition.

Overview

The image format may be configured by either UCC_PrepareFixedGrab or UCC_PrepareFreeGrab. The reason for the existence of two such functions arises from the nature of the IIDC camera standard. IIDC cameras support several predefined image resolution and color format settings, which are addressed by 'format' and 'mode' indices. While most format/mode combinations describe fixed resolution presets, format 7 modes are referred to as 'free modes' with adjustable image resolution.

UCC_PrepareFixedGrab()

UCC_PrepareFixedGrab is primarily useful to configure IIDC formats 1-2. Only a few parameters are needed here due to the fixed resolution presets. For a description of predefined formats, refer to the IIDC standard specification.
Note:
Format 7 modes may also be set by UCC_PrepareFixedGrab, if some restrictions are considered. Format 7 modes require additional configuration parameters, none of which is adjusted by this function. If these have already been set ( e.g. by UCC_PrepareFreeGrab calls), UCC_PrepareFixedGrab may be used to switch between different modes quickly.

UCC_PrepareFreeGrab()

More options are provided by UCC_PrepareFreeGrab, which uses solely format 7 modes. For most cases UCC_PrepareFreeGrab is recommended: Because of the freely configurable nature of format 7 modes no restrictions have to be expected. UCC_PrepareFixedGrab is primarily meant for users that are already familiar with IIDC formats.
Note:
Examples for UCC_PrepareFreeGrab usage can be found here.


AVT Universal API - Camera Control module: Camera configuration - Explicit function calls

Camera configuration - Explicit function calls

Introduction

This section introduces several explicit functions used for camera configuration. Camera features not mentioned here are covered by the 'unified feature access' function set described in the previous chapter. Some features are accessible in both ways, though.

Autofunction AOI

The following functions apply to the auto function AOI feature:
  • UCC_AutoFunctionAOI_Set()
  • UCC_AutoFunctionAOI_Get()
The same funtionality is provided by unified feature access - see E_FEAT_AUTOFUNCTIONAOI_LEFT and subsequent entries.

White Balance

Standard white balance is controlled by:
  • UCC_Whitebalance_Set()
  • UCC_Whitebalance_Get()
Alternatively the unified features E_FEAT_WHITEBALANCE_UB and E_FEAT_WHITEBALANCE_VR may be used.

Advanced White Balance

White balance for complementary sensor cameras is controlled by:
  • UCC_Whitebalance_GMCY_Set()
  • UCC_Whitebalance_GMCY_Get()
Alternatively the unified features E_FEAT_WHITEBALANCE_GR, E_FEAT_WHITEBALANCE_MG, E_FEAT_WHITEBALANCE_CY and E_FEAT_WHITEBALANCE_YE may be used.

Shading correction

The following functions allow the generation, upload and download of shading images:
  • UCC_Shading_GetInfo()
  • UCC_Shading_Upload()
  • UCC_Shading_Download()
  • UCC_Shading_Build()
For activation of shading images see E_FEAT_SHADING.

Lookup Tables (LUT)

Configuration of the lookup table feature may be perfomed by:
  • UCC_Lut_GetInfo()
  • UCC_Lut_GetStatus()
  • UCC_Lut_Use()
  • UCC_Lut_Upload()
Some lookup table funtionality is also provided by the unified features E_FEAT_LUT, E_FEAT_LUT_BITSPERVAL and E_FEAT_LUT_MAXSIZE.

Serial IO (RS232)

These functions allow access to the camera's serial IO port:
  • UCC_SerialIO_SetConfig()
  • UCC_SerialIO_GetConfig()
  • UCC_SerialIO_Transmit()
  • UCC_SerialIO_Receive()

Digital IO

The camera's digital IO pins can be configured by the following functions:
  • UCC_InputPin_Get()
  • UCC_InputPin_Set()
  • UCC_OutputPin_Get()
  • UCC_OutputPin_Set()
For digital IO and trigger configuration see also Digital IO and trigger operation.

Trigger

Trigger based image acquisition may be controlled by:
  • UCC_Trigger_Get()
  • UCC_Trigger_Set()
For digital IO and trigger configuration see also Digital IO and trigger operation.

User profile

Camera-contained user profile management is done by:
  • UCC_UserProfile_Load()
  • UCC_UserProfile_Save()
  • UCC_UserProfile_SetDefault()
  • UCC_UserProfile_GetErrorStatus()
  • UCC_UserProfile_GetInfo()
A subset of the user profile functionality is also accessible via E_FEAT_USERPROFILE.

Test image

For activation of test images see:
  • UCC_TestImage_GetInfo()
  • UCC_TestImage_Set()

XML import/export of camera settings

Camera settings may be written to and read from XML files by:
  • UCC_LoadSettings()
  • UCC_SaveSettings()

Image format enumeration

The following functions allow an enumeration of standard image formats supported by a certain camera:
  • UCC_PresetToResolution()
  • UCC_CreatePresetsEnum()
  • UCC_DestroyPresetsEnum()
  • UCC_EnumPresets()
  • UCC_CreateColorCodeEnum()
  • UCC_DestroyColorCodeEnum()
  • UCC_EnumColorCode()
  • UCC_GetBitsPerPixel()
  • UCC_GetSupportedFixedFormats()
These functions are primarily useful for the creation of listings presenting supported standard image formats, as commonly found in viewer applications.


AVT Universal API - Camera Control module: Digital IO and trigger operation

Digital IO and trigger operation

Introduction

This chapter explains the usage of digital IO and trigger features.

Digital IO

Digital IO may be configured by the functions UCC_InputPin_Get(), UCC_InputPin_Set(), UCC_OutputPin_Get() and UCC_OutputPin_Set(). Each IO pin can be configured separately regarding the mode of operation and polarity. The state of output pins can be set by UCC_OutputPin_Set() and read back by UCC_OutputPin_Get(), while the state of input pins allow only read access (UCC_InputPin_Get).
For supported input and output modes consult the camera manual.

Trigger

The trigger feature allows image acquisition control based on the state of one or more input pins. For trigger configuration see also UCC_Trigger_Set() and UCC_Trigger_Get(). Usage of the trigger feature requires at least one input pin to be configured for trigger mode (mode 2).
The cameras trigger feature may support several modes of operation, initially defined by the IIDC standard. AVT cameras usually support the following trigger modes:

mode | description
0 | fixed shutter mode - The trigger starts the acquisition of single images with fixed exposure duration as configured by the features E_FEAT_SHUTTER and E_FEAT_EXTENDEDSHUTTER.
1 | integration enable mode - The image exposure lasts as long as the trigger input remains in active state.
15 | bulk trigger - Only the first trigger pulse will be taken into account. On detection of this trigger pulse either a single image or a series of images will be grabbed, depending on the image acquisition mode.

Trigger signals may be delayed by usage of the E_FEAT_TRIGGERDELAYADV feature. E_FEAT_DELAYEDINTEGRATIONENABLE allows additional customization of the 'integration enable' mode, as it delays only the start of the exposure period.

See the camera manual for further details about trigger operation.


AVT Universal API - Camera Control module: Image acquisition - Single images

Image acquisition - Single images

!

Introduction

The UniAPI provides functions to retrieve single images from an already configured camera, which are described on this page. Several image formats are supported. There are separate functions provided for each of the supported formats, as well as one generic function which may be used for any format.
The acquisition of single images is not recommended for applications that require high frame rates. Instead, images should be grabbed as a stream. However, users planning to grab a stream of images are advised to read this page first: Most image acquisition details like handling of data buffers and image formats apply for both methods. This page contains descriptions of these topics. The following page focuses on the details that apply solely to image stream acquisition.

Timing behaviour

Single image acquisition commands are processed synchronously: At function call, the camera is configured for image acquisition, a single image is exposed and transferred to the PC, image acquisition is stopped and the image data is optionally converted to output format. The function blocks until all of these steps have been completed.

Buffer Handling

Data buffers used for image data have to be provided by the user. Image acquisition functions expect pointers to sufficiently sized memory segments. Its the user's responsibility to provide memory space according to the selected image and color format.

Pixel formats

Windows bitmap

Images may be retrieved in 'BGR' bitmap format commonly used on windows systems. Single pixels are represented as 3 coherent bytes of image data. Images of this format may be retrieved by usage of UCC_GrabBitmapImage or UCC_GrabImage. In the latter case an S_UNI_IMAGE structure has to be initialized by the user before function call and S_UNI_IMAGE::uImageformat has to be set to E_IF_BGR. Usage of UCC_GrabImage is explained in greater detail below.
Alternatively, 'ABGR' bitmap format may be used. This format represents single pixels as 4 bytes of image data, including one byte reserved for alpha channel data. At the moment, 'ABGR' format is only supported by UCC_GrabImage ( with uImageformat set to E_IF_ABGR).
Note:
An example for UCC_GrabBitmapImage may be found here.

Native image formats

Formats used by the camera to transfer images over the underlying hardware interface are referred to as 'native' image formats. The actual structure and space requirements of native formats vary greatly depending on the chosen camera configuration. Possible native image formats are described in the camera's technical manual. UCC_GrabNativeImage may be used to grab images in native formats. UCC_GrabImage also returns native image data if the image format specifier is set to E_IF_NATIVE.

Planar formats

Planar image formats separate color channels in individual memory segments, called planes. Memory segments have to be provided for each color channel (Red, Green and Blue). Optionally, an additional plane with intensity data can be retrieved. Planar image data is returned by UCC_GrabPlanesImage(). Also UCC_GrabImage may be used to retrieve planar image data.

UCC_GrabImage method

In contrast to mentioned format-specific methods, UCC_GrabImage supports image acquisition for all supported formats. The S_UNI_IMAGE structure is used as format-independant container for image data. Prior to UCC_GrabImage function calls, an S_UNI_IMAGE has to be created and initialized by the user. At first, the S_UNI_IMAGE::uImageformat member has to be set according to the desired image format. Supported values are:
E_IF_MONO8
monochrome image format, 8 bit per pixel
E_IF_BGR
Windows 24-bit 'BGR' bitmap format
E_IF_ABGR
Windows 32-bit 'ABGR' bitmap format with (unused) alpha channel data
E_IF_RGB_PLANES
RGB planar format, 8 bit per pixel for each plane, 3 planes
E_IF_RGBY_PLANES
RGBY planar format, 8 bit per pixel for each plane, 4 planes
E_IF_NATIVE
native format, varying size requirements
If E_IF_MONO8, E_IF_BGR, E_IF_ABGR or E_IF_NATIVE is chosen, a single buffer of system memory has to be provided by the caller, and S_UNI_IMAGE::pImageAsSinglePlane "pImageAsSinglePlane" has to be set to point to this memory buffer. If one of the planar formats is used, 3 or 4 memory buffers have to be provided for the requested image planes. Space for red, green and blue image planes is expected at the addresses pointed to by pImageRed, pImageGreen and pImageBlue. Optionally, pImageY may point to memory space provided for intensity data.
Note:
An example for UCC_GrabImage may be found here.


AVT Universal API - Camera Control module: Image acquisition - Image stream

Image acquisition - Image stream

Introduction

This page explains the acquisition of continuous streams of images. Functions provided are similiar to those used for single image acquisition. In fact, there is a counterpart for each Grab...Image Function:
Single image | Image stream
UCC_GrabImage | UCC_GetImage
UCC_GrabBitmapImage | UCC_GetBitmapImage
UCC_GrabPlanesImage | UCC_GetPlanesImage
UCC_GrabNativeImage | UCC_GetNativeImage
Corresponding functions can be used in a similar way. There are no differences in terms of image format selection and buffer handling. Refer to the previous page for these topics.

Image stream control

Image stream acquisition has to be started with UCC_GrabStart (which requires a previously completed call of UCC_PrepareFixedGrab or UCC_PrepareFreeGrab). If UCC_GrabStart is called successfully, the camera will transmit a continuous stream of images, which will be received by the UniAPI and stored internally without user interaction.
Finally, UCC_GrabStop stops image grabbing.
If E_FEAT_STARTIMMEDIATELY is set to E_FEATSTATE_OFF the camera will not start transmission until transmission is triggered. Independent of the asynchron communication speed the transmission speed can be set with UCC_SetStreamSpeed , current and maximal speed can be queried with UCC_GetStreamSpeed UCC_GetStreamSpeedMax.

Retrieving images

Once the image stream acquisition has been started, the user may call one of the Get...Image functions. If an image has been received already, it is returned immediately. In case the internal image buffers are empty, a timeout value may be specified. The importance of this timeout value depends on the general application design: If the existance of new images is assured at the time of function call ( typically by User notifications ), a timeout of 0 should be used to eliminate function blocking. Simpler application designs may implement a polling mechanism instead to avoid notification usage. In this case a reasonable timeout value should be used.


AVT Universal API - Camera Control module: User notifications

User notifications

Introduction

Your application can be notified by the UniApi if certain events occur. A number of notification mechanisms are supported. Notification objects need to be registered for each event the application has to be informed about. There may be multiple notification objects registered for a single event as well as a single notification object may be registered for multiple events. In the latter case additional parameters have to be evaluated to determine the triggering event. There are dedicated registration functions for each particular event that may be tapped. Furthermore UCC_RegisterNotification may be used generally to register a notification object to a specified event. Information about the used notification mechanism and additionally committed parameters need to be filled into a structure S_UNI_NOTIFICATION that is used for registration.
Each registration of a notification object to a single event spawns a distinct UNI_NOTIFICATION_HANDLE that has to be used later for cancellation. The function UCC_UnRegisterNotification is provided for this purpose. To avoid side effects, notifications should be unregistered as soon as possible. Particular care has to be taken that S_UNI_NOTIFICATION data isn't deleted ( e.g. due to loss of focus ) before unregistration.

Event types

Notification objects can be registered for several events that are listed below. Dedicated functions provided for registration are written in parenthesis. Events are defined by E_UNI_NOTIFICATION_EVENTS.
  • E_UNI_NOTIFICATION_NODELIST_CHANGED - bus configuration changed (UCC_RegisterNodeListChangedNotification)
  • E_UNI_NOTIFICATION_FRAME_READY - frame transfer finished (UCC_RegisterFrameReadyNotification)
  • E_UNI_NOTIFICATION_FRAME_START - frame transfer started (UCC_RegisterFrameStartNotification)
  • E_UNI_NOTIFICATION_FRAME_DROPPED - frame was dropped (UCC_RegisterFrameDroppedNotification)

Supported notification mechanisms

The application can be notified about events by callback functions, Windows messages and Windows events. The notification mechanism has to be specified by m_NotificationType, which is part of S_UNI_NOTIFICATION. Depending on the notification type, either m_NotificationCallback , m_NotificationWindowsMessage or m_NotificationEvent have to be filled with valid information.
Note:
Example code for user notification registration may be found here.


AVT Universal API - Camera Control module: XML settings files

XML settings files

The XML settings files conform to the following document type definition (DTD):
 <!--  Root element
    Currently only contains IIDCCamera nodes, but later, an IIDCProgram element
    could be added -->
<!ELEMENT IIDCConfig ( IIDCCamera+ ) >

<!-- Camera element
    Contains information about IIDC cameras.
    Presently, only a Status is contained, but later, Capabilities could be
    added. -->
<!ELEMENT IIDCCamera ( Status ) >
<!ATTLIST IIDCCamera Firmware NMTOKEN #IMPLIED >
<!ATTLIST IIDCCamera GUID NMTOKEN #IMPLIED >
<!ATTLIST IIDCCamera IIDCSpec ( 100 | 102 ) #IMPLIED >
<!ATTLIST IIDCCamera Model CDATA #IMPLIED >
<!ATTLIST IIDCCamera Vendor NMTOKEN #IMPLIED >

<!-- Status element
    Contains several categories of status description elements -->
<!ELEMENT Status ( Camera, StdFeatures?, AdvFeatures? ) >

<!-- Entity for holding the names of the storable camera status registers -->
<!ENTITY % CameraRegisterNames 'CurVFrmRate_Revision|CurVMode|CurVFormat|ISOChannel_Speed|ISOChannel_Speed|CameraPower|ISO_EN|MemorySave|OneShot_MultiShot|MemSaveCh|CurMemCh|VmodeErrorStatus' >
<!-- Camera element
    Contains register settings and a format 7 element -->
<!ELEMENT Camera ( Register+, Format7? ) >

<!-- Entity for holding the names of the storable format 7 parameter registers -->
<!ENTITY % Format7RegisterNames 'ImagePosition|ImageSize|ColorCoding|BytePerPacket' >
<!-- Format 7 element
    Contains mode elements. If format 7 is active, one of the attributes
    must have a "current" attribute-->
<!ELEMENT Format7 ( Mode0, Mode1?, Mode2?, Mode3?, Mode4?, Mode5?, Mode6?, Mode7? ) >

<!-- Entity for holding the names of the storable standard feature registers -->
<!ENTITY % StdFeatureRegisterNames 'Brightness|AutoExposure|Sharpness|WhiteBalance|Hue|Saturation|Gamma|Shutter|Gain|Iris|Focus|Temperature|TriggerMode|Zoom|Pan|Tilt|OpticalFilter|CaptureSize|CaptureQuality' >
<!-- Standard features element
    Contains register elements for standard features -->
<!ELEMENT StdFeatures ( Register+ ) >

<!-- Entity for holding the names of the storable advanced I/O registers -->
<!ENTITY % IORegisterNames 'Input1|Input2|Input3|Output1|Output2|Output3' >
<!-- Entity for holding the names of the storable advanced IBIS-5-specific registers -->
<!ENTITY % Ibis5FeatureRegisterNames 'HdrMode|DsnuCorrection|BlemishCorrection' >
<!-- Entity for holding the names of the storable advanced auto-feature registers -->
<!ENTITY % AutoFeatureRegisterNames 'AutoFncAOI|AutoShutter|AutoGain' >
<!-- Entity for holding the names of the storable advanced auto-feature registers -->
<!ENTITY % LUTShadingFeatureRegisterNames 'LUT|Shading' >
<!-- Entity for holding the names of all the storable advanced feature registers -->
<!ENTITY % AdvFeatureRegisterNames 'TimeBase|ExtdShutter|TestImage|IntEnaDelay|ColorCorr|TriggerDelay|MirrorImage|HighSnr|ColorAntiAliasing|%Ibis5FeatureRegisterNames;|%AutoFeatureRegisterNames;|%IORegisterNames;' >
<!-- Advanced features element
    Contains register elements for advanced features -->
<!ELEMENT AdvFeatures ( (Register+|LUT|Shading)? ) >

<!-- Format 7 Mode 0 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode0 ( Register+ ) >
<!ATTLIST Mode0 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 1 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode1 ( Register+ ) >
<!ATTLIST Mode1 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 2 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode2 ( Register+ ) >
<!ATTLIST Mode2 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 3 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode3 ( Register+ ) >
<!ATTLIST Mode3 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 4 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode4 ( Register+ ) >
<!ATTLIST Mode4 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 5 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode5 ( Register+ ) >
<!ATTLIST Mode5 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 6 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode6 ( Register+ ) >
<!ATTLIST Mode6 current NMTOKEN #IMPLIED >

<!-- Format 7 Mode 7 element
    Contains register elements for controlling format 7 features  -->
<!ELEMENT Mode7 ( Register+ ) >
<!ATTLIST Mode7 current NMTOKEN #IMPLIED >

<!-- Look-up table element  NOT YET SUPPORTED!!!!
    Contains elements for controlling the AVT look-up table feature  -->
<!ELEMENT LUT ( Register, (LutFile+ | LutEnum) ) >

<!ELEMENT LutFile ( #PCDATA ) >
<!ATTLIST LutFile name NMTOKEN #IMPLIED >
<!ATTLIST LutFile startRow NMTOKEN #IMPLIED >
<!ATTLIST LutFile column NMTOKEN #IMPLIED >

<!ELEMENT LutEnum ( LutEntry+ ) >
<!ATTLIST LutEnum number NMTOKEN #IMPLIED >

<!ELEMENT LutEntry ( #PCDATA ) >
<!ATTLIST LutEntry row NMTOKEN #IMPLIED >

<!-- Shading image elements  NOT YET SUPPORTED!!!!
    Contains elements for controlling the AVT shading image feature  -->
<!ELEMENT Shading ( Register, (ShadingFile | ShadingImage) ) >
<!ELEMENT ShadingFile ( #PCDATA ) >
<!ATTLIST ShadingFile name NMTOKEN #IMPLIED >
<!ELEMENT ShadingImage ( #PCDATA ) >

<!ELEMENT Register ( #PCDATA ) >
<!ATTLIST Register name (%CameraRegisterNames;|%Format7RegisterNames;|%StdFeatureRegisterNames;|%AdvFeatureRegisterNames;|%LUTShadingFeatureRegisterNames;) #REQUIRED >
<!ATTLIST Register quadNr ( 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 ) #IMPLIED >


AVT Universal API - Camera Control module: Code snippets

Code snippets

Introduction

This page provides code snippets for typical image acquisition use cases.

Initialization

The following code initializes the API and opens the first camera listed:
 if ( FAILED( UCC_Init() ) )
  {
      ; // todo: error handling, init failed
  }

 // create an array for up to 64 camera ids
 UINT32_TYPE arrId[64], nCnt=64;

 // get camera ids
 if ( FAILED( UCC_GetCameras( &nCnt, arrId ) ) )
  {
      ; // todo: error handling, UCC_GetCameras failed
  }
 if ( nCnt == 0 )
  {
      ; // todo: error handling, no camera found
  }
  else
  {
      // select the first camera listed
      ID_TYPE nCamId = arrId[0];

      // open camera
      if ( FAILED( UCC_OpenCamera(nCamId) ) )
      {
          ; // todo: error handling, UCC_OpenCamera failed
      }

      // image acquisition code may be added here...

  }

Image Format Configuration

A fixed resolution of 320x200 Pixels and YUV422 color format can be configured with:
 UINT32_TYPE nMode = 0;
 UINT32_TYPE nColorFormat = E_CC_YUV422;
 UINT32_TYPE nHorizontalResolution = 320;
 UINT32_TYPE nVerticalResolution = 200;
 UCC_PrepareFreeGrab  ( nCamId, &nMode, &nColorFormat, &nHorizontalResolution, &nVerticalResolution, NULL, NULL, NULL, NULL);
A typical use case is the image acquisition at full camera resolution. The following code queries the camera for the highest supported resolution and calls UCC_PrepareFreeGrab accordingly:
 UINT32_TYPE nMode = 0;
 UINT32_TYPE nColorFormat = E_CC_YUV422;
 UINT32_TYPE nHorizontalResolution = 0;
 UINT32_TYPE nVerticalResolution = 0;
 UCC_GetCameraCapabilities ( nCamId, &nHorizontalResolution, &nVerticalResolution, NULL, NULL );
 UCC_PrepareFreeGrab  ( nCamId, &nMode, &nColorFormat, &nHorizontalResolution, &nVerticalResolution, NULL, NULL, NULL, NULL);
Note:
see Camera configuration - Image Format for details about image format configuration.

Synchronuous image acquisition

UCC_GrabBitmapImage

The following code uses UCC_GrabBitmapImage to grab a single image in 'BGR' bitmap format. The bitmap buffer of an ATL::CImage is used for data storage. The example assumes that the utilized camera is a color model.
 // The variables below are expected to be defined properly.
 // The 'extern' declaration is only chosen for syntactical correctness
 // as stand-alone example.
 extern ID_TYPE nCamId;                    // id of an already opened camera
 extern UINT32_TYPE nHorizontalResolution; // the currently configured image size
 extern UINT32_TYPE nVerticalResolution;   //

 ATL::CImage Image;
 Image.Create( nHorizontalResolution , -1 * nVerticalResolution , 24 );
 UNI_RETURN_TYPE hr = UCC_GrabBitmapImage( nCamId , (UINT8_TYPE*) Image.GetBits() , INFINITE );

UCC_GrabImage

Equivalent results may be achieved by usage of UCC_GrabImage:
 // The variables below are expected to be defined properly.
 // The 'extern' declaration is only chosen for syntactical correctness
 // as stand-alone example.
 extern ID_TYPE nCamId;                    // id of an already opened camera
 extern UINT32_TYPE nHorizontalResolution; // the currently configured image size
 extern UINT32_TYPE nVerticalResolution;   //

 ATL::CImage Image;
 Image.Create( nHorizontalResolution , -1 * nVerticalResolution , 24 );

 UINT32_TYPE bColor=0;
 S_UNI_IMAGE MyImageStruct;

 MyImageStruct.uImageformat = E_IF_BGR;
 MyImageStruct.sImageData.pImageAsSinglePlane = (UINT8_TYPE*) Image.GetBits();

 UNI_RETURN_TYPE hr = UCC_GrabImage( m_CamId, &MyImageStruct , &bColor, INFINITE );
Note:
see Image acquisition - Single images for details.

User Notifications

The code below shows how to register a notification for 'nodelist changed' events. Windows messages are used as notification mechanism.
 //register a windows message
 S_UNI_NOTIFICATION      Notification;
 UNI_NOTIFICATION_HANDLE Handle;
 Notification.m_NotificationType                     = E_UNI_NOTIFICATION_MESSAGE;
 Notification.m_NotificationWindowsMessage.m_hWnd    = YourWindowHandle;
 Notification.m_NotificationWindowsMessage.m_Msg     = WM_YOUR_USER_MESSAGE;
 Notification.m_NotificationWindowsMessage.m_wParam  = E_UNI_NOTIFICATION_NODELIST_CHANGED;
 UCC_RegisterNodeListChangedNotification( &Handle,&Notification);

 // add additional application code here

 UCC_UnRegisterNotification( Handle);    // unregisters a single notification explicitly
 UCC_Release()                           // implicitly unregisters all notifications
The following code also registers a 'nodelist changed' notification, but uses a callback function as notification mechanism:
 //register a callback function

 struct MyContext
 {
    // This custom defined struct may be used to provide context information for
    // the callback function below.
    // define arbitrary struct members here
 };
 VOID_TYPE NOTIFICATION_CALLING_CONVENTION MyCallback( S_UNI_CALLBACK_ARGUMENT arg)
 {
      MyContext *This =reinterpret_cast<MyContext*>(arg.m_Parameter);
      // add event handling code here
      // warning: time-consuming operations may cause severe performance issues
 }

 S_UNI_NOTIFICATION                      Notification;
 UNI_NOTIFICATION_HANDLE                 Handle;
 MyContext                               CallingContext;

 // add code to fill CallingContext with information

 Notification.m_NotificationType                        = E_UNI_NOTIFICATION_CALLBACK;
 Notification.m_CamId                                   = YOUR_FAV_CAMERA_TO_USE;
 Notification.m_NotificationCallback.m_Arg.m_Parameter  = &CallingContext;
 Notification.m_NotificationCallback.m_Callback         = MyCallback;
 UCC_RegisterNodeListChangedNotification( &Handle,&Notification);

 // add additional application code here

 UCC_UnRegisterNotification( Handle);    // unregisters a single notification explicitly
 UCC_Release()                           // implicitly unregisters all notifications
Windows event objects may also be used for notifications:
 //register a windows event
 S_UNI_NOTIFICATION                  Notification;
 UNI_NOTIFICATION_HANDLE             Handle;
 HANDLE                              BusResetEvent       = CreateEvent(NULL,TRUE,FALSE,NULL);

 if( NULL == BusResetEvent ) HandleError();
 Notification.m_NotificationType                         = E_UNI_NOTIFICATION_EVENT;
 Notification.m_CamId                                    = UNI_ALL_CAMERAS;
 Notification.m_NotificationEvent.m_Event                = BusResetEvent;

 UCC_RegisterNotification( &Handle,E_UNI_NOTIFICATION_NODELIST_CHANGED,&Notification);

 // add additional application code here

 UCC_UnRegisterNotification( Handle);    // unregisters a single notification explicitly
 UCC_Release()                           // implicitly unregisters all notifications
 ReleaseHandle(BusResetEvent);
Note:
see User notifications for details.


AVT Universal API - Camera Control module: Version information

Version information

  •  Changes from version 1.3.2 to 1.4:
    Additions/changes:
    • UCC_GetCameraInfo() UCC_GetCameraInfoString() return extended version info
    • new Feature E_FEAT_DO_MULTIBUSTRIGGER to set trigger on multiple busses
    • fixed handling of frame start notifications (did block if callback was in same thread context)
    • save/load settings now uses camera type or for camera GUID
    • fixed saving/loading settings from or to an empty file
    • new UniTransform with variable image transforms
    • fixed second deleting of pointer if opening the camera fails
    • removed double disconnect of the camera
    • corrected wrong reporting of states, min/max values and pesents in feature handling
    • added samples Grab2ConNative and MicroView::ShadingCtrl
  •  Changes from version 1.3.1 to 1.3.2:
    Additions/changes:
    • structure change in FGCamera.h for compatibility
  •  Changes from version 1.3 to 1.3.1:
    Additions/changes:
    • Extended secure build checks
    • Change UCC_Shading_Upload speed increased
    Solved bugs:
    • Fixed UCC_GetSupportedFixedFormats returns now not only Format0 information
    • Fixed UCC_GetCameras called with NULL array now returns the number of found cameras
    • Fixed UCC_PrepareFixedGrab setup of receiver reworked
    • Added missing UCC_GetErrorInfo strings
  •  Changes from version 1.2 to 1.3:
    Additions/changes:
    • Added E_UNI_LICENSE_TYPE
    • Added open from card support in UCC_OpenCameraEx
    • If E_UNI_NOTIFICATION_FRAME_DROPPED is sent, E_UNI_NOTIFICATION_FRAME_READY is also sent ( Notifications shouldn't stop then)
    • Added UCC_GetLicenseType / UCC_GetLicenseType_Global
    • Added UCC_ReadBlock / UCC_WriteBlock
    • Added UCC_SerialIO_ReceiveInfo
    • Added UCC_GetFreeBandwidth
    • Added UCC_Lut_LoadFromCsv
    • UCC_GetCameraInfoString CustomerKey/OrderID as string
    • Cleaned unnessesary typedefs from uni_types.h
    • Extended the documentation
    Solved bugs:
    • Freeing allocated Iso resources with UCC_GrabStop
    • UCC_GetCurrentImageFormat the returned image depth was not correct for some cameras
    • UCC_SerialIO_GetConfig pnMode not written when pBuffer is NULL
    • Added missing UCC_GetErrorInfo strings
  •  Changes from version 1.1 to 1.2:
    Additions/changes:
    • UCC_CheckAvailable now returns if UCC_OpenCamera should succeed
    • UCC_GetCameras and UCC_GetCamerasEx change in returned Cameras, dependend on parameter E_FEAT_LIST_ALL_CAMERAS (to hide busy cameras)
    • Added new function for standard format inquiry: UCC_GetSupportedFixedFormats
      • new types S_IIDC_VIDEOINFO_FORMAT,S_IIDC_VIDEOINFO_MODE,S_IIDC_VIDEOINFO_FPS will hold the information about the fixed modes.
    • UCC_PrepareFreeGrab now supports configurations that exceed the nominal maximum bandwidth allowed by the 1394 specification. Note that these configurations are only supported by certain cameras with non-standard firmware.
    • E_FEAT_LIST_ALL_CAMERAS defines if busy cameras are listed with UCC_GetCameras and UCC_GetCamerasEx.
    • E_FEAT_CAMERABUSY to query the current busy state of the camera.
    • E_FEAT_BURSTCOUNT defines the number of images a camera sends after being started.
    • E_FEAT_DO_BUSTRIGGER triggers all cameras found on the bus.
    • E_FEAT_STARTIMMEDIATELY determines if a camera starts integrating when UCC_GrabStart is called or waits for a trigger.
    • defines UNI_MAX_INPUT_PINS/ UNI_MAX_OUTPUT_PINS for the number of IOPins.
    • Extended error info for FireGrab errors.
    • UCC_GetStreamSpeedMax, UCC_GetStreamSpeed and UCC_SetStreamSpeed for image streaming speed control.
    Solved bugs:
    • Cleanup of UCC_MultiShotStop was not done properly
    • Corrected the depth info in UCC_GetCameraCapabilities in some cases
    • Feature E_FEAT_IRMFREEBW is now implemented correctly.
    • Issues with UCC_GrabBitmapImage addressing Guppy cameras have been solved.
    • In Version 1.1, UCC_OpenCamera configured the camera for S400 transfer mode, although S800 had been requested. S800 transfer mode is correctly configured now.
    • As a result of the above changes, problems with UCC_PrepareFreeGrab in specific situations are also fixed.
    • Multishot operation aborted one frame early in version 1.1. Now the total number of requested images is delivered.
    • Multi threading problem "call of pure virtual function" solved with improved thread sync.
    • FireGrab like parameter handling has been corrected.
    • UCC_CloseCamera had always left a open HANDLE (Mutex).
    • UCC_SetFeatureStatus for E_FEAT_SHADING with state E_FEATSTATE_OFF made camera deliver black images.
    • UCC_Trigger_Get Active was not returned, Value was no set.
    • UCC_InputPin_Set,UCC_InputPin_Get with nWidth larger then UNI_MAX_INPUT_PINS could lead to access violation.
    • UCC_OutputPin_Set,UCC_OutputPin_Get with nWidth larger then UNI_MAX_INPUT_PINS could lead to access violation.
    • UCC_OutputPin_Set with State was set in Polarity.
    • UCC_GetVersion now works before calling UCC_Init.
    • UCC_GetFeatureMax for E_FEAT_ISOCHANNEL returns now 16 for 1394a cameras
  •  Changes from version 1.0 to 1.1:
    Additions/changes:
    • The used CRT libraries are linked statically. Now, no additional libraries are needed at runtime
    • Added multi-shot methods: UCC_MultiShotStart and UCC_MultiShotStop
    • Added standard feature support for E_FEAT_TRIGGERDELAY, E_FEAT_SIS, E_FEAT_PARAMUPDATETIMING, E_FEAT_REDUCEDSMEAR
    • Added RAW12 and MONO12 formats as output formats for UCC_GetNativeImage and UCC_GrabNativeImage
    • Added methods for encapsulated parameter transfer, UCC_ParamUpdate_Begin and UCC_ParamUpdate_Apply (all parameters changes between the two commands are applied simultaneously, but the cammera is stopped during this period)
    • Added methods for parameter list transfer, UCC_SetFeatureList, UCC_SetRegisterList and UCC_GetRegisterListInfo
    Solved bugs:
    • In version 1.0, UCC_PrepareFixedGrab returned a boolean value; now, S_OK is returned in case of success
  •  1.0:
    Initial version


AVT Universal API - Camera Control module: Requirements

Requirements

Up to version 1.3.1., the version of the UniAPI was coupled directly to the version of FireGrab that it was delivered with.

For proper functionality, do not replace the FGCamera.dll with any other version.

If you'd like to use the current UniAPI 1.3.2 in your program (that was compiled against a version 1.3.1. or less of the UniAPI), it is recommended to use the FGCamera.dll and the driver with the following versions:

  • UniAPI 1.3.2
  • FGCamera.dll version 2.6.0.5
  • and the corresponding version of the FireDrv.sys (2.6.0.x)


AVT Universal API - Camera Control module: Universal API Image Transform module

Universal API Image Transform module

  • The Transformation overview page gives an overview of the source and target formats of this module
  • The Color conversion page describes methods to convert color images
  • The Image transformation page describes the methods to manipulate images


AVT Universal API - Camera Control module: Image Transformation - Introduction

Image Transformation - Introduction

General

Application

Image data received in raw formats needs to be debayered to retrieve color formats like RGB. Debayering algorithms are provided by a separate library 'UniTransform.dll'. The following pages explain the usage of this library.

Method names

All methods of this API have a prefix "UIT_", and the rest of the method names should be mostly self-explanatory. Definitions usually have a "UNI" as part of the name.

Method parameters

For better interoperability between languages, we have chosen our own definitions of the parameter types, and in this module, we restrict to the following types
  • INT32_TYPE or UINT32_TYPE (32 bit values) and pointers to these
  • pointer to UINT8_TYPE (unsigned 8 bit value) for data arrays
  • pointer to void for arrays to structs (e.g. for RGB)
  • COLOR_CORRECTION_HANDLE which is mainly a pointer to void
  • FLOAT_TYPE or pointer to this
See also:
uni_types.h

Method return codes

Return codes are always of type UNI_RETURN_TYPE (long), so that there is always the possibility to return error codes, which may then be evaluated. If everything was OK, a method returns S_OK, otherwise a specific error code.
The most common API error is:
UNI_RESULT_PARAMETER_INVALID_(X)
The xth parameter is not valid
See also:
uni_defines.h

Deployment

From version 1.1 of the UniTransform.dll on, you don't have to deploy more files with your application than the DLL itself. (Before, you needed to deploy the files MSVCRT_80.DLL and MSVCRP_80.DLL as well)

Image transformation

For a description on image transformation methods see Image transformation

Image format conversion

For a description on image format conversion methods see Image format conversion


AVT Universal API - Camera Control module: Image Transformation - Overview

Image Transformation - Overview

The following table gives an overview of the functions provided by the UniTransform.dll to perform corresponding format transformations of (memory) images stored on a PC

Target
Format

Source
Format

Mono8 (Y8)

Mono16 (Y16)

R8G8B8 (3 planes)

R8G8B8Y8 (4 planes)

BGR8 (RGB24 for Windows)

BGR16 (16Bit per color)

BGRA32 (BGRA32 windows)

YUV422 (UYVY windows)

Mono 8 (Y8)

X

X

X

Mono 16 (Y16)

X

X

X

YUV 422 (16Bit)

X

X

X

X

YUV 411 (12Bit)

X

X

X

X

RGB 8 (RGB24)

X

X

X

X

RAW 8

X 2 ,3

X 1 ,2 ,3

X 1 ,3

X

RAW 12

X

X

X 2

X 2

X

RAW 16

X 2

X

X 2

X

Table 1: Image Format Transformations provided by the UniTransform.dll

1 optionally with additional Debayering functionality

2 optionally with additional ColorConversion functionality

3 also available for interlaced cameras


AVT Universal API - Camera Control module: Image Transformation - Conversion Methods

Image Transformation - Conversion Methods

This section describes a collection of methods for handling images that may originate from AVT cameras.

It is made for those who use image formats that differ from the transfer formats the cameras provide directly.
It may also be used to transform raw images originating from color cameras to Windows bitmaps, which may be processed more easily.
The following transport formats are used (see the IIDC specification):

  • Mono 8
  • Mono 12
  • Mono 16
  • YUV 422
  • YUV 411
  • RGB 8
  • RAW 8
  • RAW 12
  • RAW 16
The following target formats are available:
  • 8 bit/pixel bitmap
  • 24 bit/pixel bitmap
  • 32 bit/pixel bitmap BGRA where the A(alpha channel)-component is unchanged
  • YUV422 (UYVY)
  • three color plane bitmaps (R,G,B)
  • four color plane bitmaps (R,G,B and Y)
  • special one-plane bitmap formatted like the transfer data
  • 16 bit/pixel bitmaps through debayering (from 16 bit data received with UIT_Raw16ToY16_CC and UIT_Raw16ToY16)
  • 16 bit/pixel RGB bitmaps through debayering (from 16 bit data received with UIT_Raw16ToBGR16_CC and UIT_Raw16ToBGR16)

Debayering, demosaicing, de-interlacing

The debayering methods may be called using the parameters:
  • A pointer to the destination image memory area
  • A pointer to the source image memory area
  • The width of the images
  • The height of the images
  • The number of pixels in the image
  • A parameter indicating the start pixel of the Bayer pattern used in the image. Possible values for the RGGB sensors:
    • 0 meaning the R pixel
    • 1 meaning the GB pixel
    • 2 meaning the GR pixel
    • 3 meaning the B pixel
  • Some 16-bit-to-16-bit methods also have a parameter to provide the number of bits the image should be shifted to the least significant position. (Normally, 16 bit images are MSB-aligned, so the lower four bits of real 12 bit images are 0.)
  • Some methods also allow a handle to a color correction object. If provided (means: !=NULL and created by methods like UIT_CreateColorCorrectionMatrix_Int8) the color correction pointed to by the given handle is applied to every pixel.
  • The UIT_XXXImageTransform functions use :E_UNI_SIMPLE_IMAGE_FORMAT to specify the output image format
See also:
Image Transformation - Debayering methods


AVT Universal API - Camera Control module: Image Transformation - Bayer patterns

Image Transformation - Bayer patterns

There are various Bayer patterns in use by sensor manufacturers for allowing color images with only one sensor.

RGGB sensors

The most common one has rows of alternating red and green pixels, followed by rows of alternating green and blue pixels.
This leads to a lower resolution for red and blue, plus the colors are measured at different spots, so a debayering algorithm has to cope with color displacement as well as with the different resolution for the colors.
The start pixel of the Bayer pattern varies between sensor manufacturers.
  • The Sony sensors in the Guppy GF-033C, GF-046C and the GF-080C and in the Marlin, Stingray, Oscar and Dolphin color cameras all use the red pixel as start, resulting in a pattern of
    R | G
    G | B
  • The Ibis5 sensor inside the Marlin 131C uses the GB pixel as start, resulting in a pattern of pattern of
    G | B
    R | G
  • The Kodak sensors in most Pike cameras use the GR pixel as start, resulting in a pattern of
    G | R
    B | G
  • The Micron sensor in the Guppy GF-036C use the blue pixel as start, resulting in a pattern of
    B | G
    G | R

CYMG sensors

A different color pattern is used in some interlaced sensors by Sony, used inside the Guppy GF-025C,GF-029C,GF-038C and GF-044C. It uses colors complementary to the usual R, G and B colors, and the pattern changes every four lines.
C | Y
G | M
C | Y
M | G


AVT Universal API - Camera Control module: Image Transformation - Debayering methods

Image Transformation - Debayering methods

RGGB debayering

The following debayering methods for RGGB sensors are provided:
  • The straightforward Simple 2x2 debayering (code)
  • A Simple 2x2 debayering with only monochrome output (code)
  • A 3x3 debayering provided by the Oscar cameras(code)
  • The 2x2 debayering with light horizontal smoothing of the old Marlin cameras(code)
  • The LCAA: 2x2 debayering with strong horizontal U and V smoothing of the newer Marlin and the Stingray cameras(code)
  • The LCAA+V: 2x2 debayering with strong horizontal and light vertical U and V smoothing used in the Pike cameras(code)
The first method is the fastest color debayering, but with well-known drawbacks in color quality (which are not visible in a monochrome image, so this is also the preferred debayering for the monochrome output). The three by three debayering is used in the Oscar cameras. It uses linear and bilinear interpolation. Since the green channel is also interpolated, the resulting images is less sharp than with a 2x2 debayering.
The fourth method is used in the Marlin 2 cameras, the Stingray cameras and certain firmware versions of newer Dolphin cameras, and it uses four consecutive values for smoothing the U and the V values, thus smoothing abrupt horizontal color changes. The fifth method also uses four values horizontally plus the four values of the following row to smooth U and V values, smoothing colors in horizontal as well as in vertical direction.

Simple 2x2 debayering

This algorithm works as nearest neighbor for R and B and interpolates G diagonally, so you lose one row and one column of data

Simple 2x2 debayering with only monochrome output

Same as above, but the Y value for each debayered pixel is computed and replaces R,G and B.

3x3 debayering

For R and B, bilinear interpolation is applied if four color pixels are available, and linear interpolation is used if two pixels are available in the 3x3 window. For the green pixels, the interpolation done is according to the following matrix:
0 | 0 | 1
0 | 2 | 0
1 | 0 | 0
alternating with
1 | 0 | 0
0 | 2 | 0
0 | 0 | 1
and at the locations in-between:
0 | 1 | 0
1 | 0 | 1
0 | 1 | 0

2x2 debayering with light horizontal smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of neighboring pixels are averaged, and the image is converted back to RGB.
Example: U1new=(U1old+U2old)/2

LCAA: 2x2 debayering with strong horizontal U and V smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of four neighboring pixels are averaged, and the image is converted back to RGB.(LCAA meaning local color anti-aliasing)
Example: U2new=(U1old+ U2old+U3old+U4old)/4

LCAA+V: 2x2 debayering with strong horizontal and light vertical U and V smoothing

The simple debayering is applied, then a conversion to YUV is performed, the U and V values of eight neighboring pixels on two rows are averaged, and the image is converted back to RGB. (LCAA+V meaning local color anti-aliasing plus vertical)
Example:
U1,2new= (U1,1old+U1,2old+U1,3 old+U1,4old
+U2,1old +U2,2old+U2,3old+U2,4old)/8

For the 2x2 simple algorithm, there are additional methods for color and b/w, for which you may create a color conversion object that is applied to your image data. For example, you might apply an additional color conversion matrix (UIT_Raw8ToY8_CC) after you created it with UIT_CreateColorCorrectionMatrix_Int8

CYMG debayering

At this time, there are only three debayering algorithms for the pure interlaced output (Format 7 mode 1 in the Guppy cameras) and one algorithm for the binned interlaced output (Format 7 mode 0 in the Guppy cameras). All of them result in an image in the Windows RGB format.
  • One 2x2 algorithm (UIT_IRaw8CYGMToBGR)
  • One algorithm working with a 3x3 matrix (UIT_IRaw8CYGMToBGR_3x3)
  • One 2x2 algorithm resulting in a monochrome image (UIT_IRaw8CYGMToMono)
  • One algorithm for converting a binned color image to an RGB image (UIT_IRaw8CYGMToBGR_Bin)


AVT Universal API - Camera Control module: Image Transformation - Special transformation methods

Image Transformation - Special transformation methods

There are some methods included in this library that are usable for converting images without changing image format.

  • UIT_InterlacedToProgressive just de-interlaces a raw or monochrome image resulting from an interlaced Guppy
  • UIT_GetResampledScanlineLength, UIT_ResampleScanlines and UIT_ResampleScanlinesEx may be used to convert an image to one with a different horizontal resolution. It should be used for monochrome images and also for raw images which have to be debayered afterwards.
  • UIT_RGB8ToBGR converts a Windows RGB image to a bitmap with R,G and B in the opposite order or vice versa
  • UIT_FlipVertical flips an image vertically
  • UIT_Flip flips an image in either direction


AVT Universal API - Camera Control module: Image Transformation - Version information

Image Transformation - Version information

  •  Changes from version 1.5.1 to 1.6:
    Additions/changes:
    • Added: E_UNI_SIMPLE_IMAGE_FORMAT enum for use with the UIT_XXXImageTransform functions
    • Added: UIT_RGB8ImageTransform
    • Added: UIT_YUV422ImageTransform
    • Added: UIT_YUV411ImageTransform
    • Added: UIT_Y8ImageTransform
    • Added: UIT_Y12ImageTransform
    • Added: UIT_Y16ImageTransform
    • Added: UIT_Raw8ImageTransform
    • Added: UIT_Raw12ImageTransform
    • Added: UIT_Raw16ImageTransform
    • Added: UIT_Raw8ImageTransform_3x3
    • Added: UIT_Raw8ImageTransform_IntYUV422
    • Added: UIT_Raw8ImageTransform_IntLCAA
    • Added: UIT_Raw8ImageTransform_IntLCAAV
    • Added: UIT_IRaw8CYGMImageTransform_Bin
    • Added: UIT_IRaw8CYGMImageTransform
    • Added: UIT_IRaw8CYGMImageTransform_3x3
  •  Changes from version 1.5 to 1.5.1:
    Additions/changes:
    • Added: UIT_Y8ToBGR
  •  Changes from version 1.4 to 1.5:
    Additions/changes:
    • UIT_GetSIS
      • added error handling for wrong colorcode
      • internal handling the return of GetBitsPerPixel
      • changed return from UNI_RESULT_INVALID_SETTINGS (not part of UniTransform) to UNI_RESULT_UNKNOWN_ERROR
    • UIT_GetBitsPerPixel color code out of bounds error return is now UNI_RESULT_PARAMETER_INVALID_1
    • UIT_GetErrorInfo missing error codes added
  •  Changes from version 1.3 to 1.4:
    Additions/changes:
    • Added UIT_RGB8ToY8 method for color-to-grayscale conversion
    • Corrected UIT_Raw12ToBGR16 and UIT_Raw12ToBGR16_CC method
    • Changed calling convention for x64 support
  •  Changes from version 1.2 to 1.3:
    Additions/changes:
    • Added UIT_GetSIS method to extract a Secure Image Stamp from a transfer image
    • Added methods to handle 12-bit images
      • UIT_Packed12BitTo8Bit
      • UIT_Packed12BitTo16Bit
      • UIT_Raw12ToBGR
      • UIT_Raw12ToBGR_CC
      • UIT_Raw12ToBGR16
      • UIT_Raw12ToBGR16_CC
    • Added method UIT_GetBitsPerPixel
    • Added method UIT_GetErrorInfo to be able to evaluate errors
    • Added methods UIT_GetTechnoInfo and UIT_Y16ToY8_MMX for accelerated conversions
    • Improved the documentation
    Solved bugs:
    • Removed a systematic error in the documentation concerning endianness of 16 bit images
  •  Changes from version 1.1 to 1.2:
    Additions/changes:
    • Renamed UIT_InterlacedToProgressive to UIT_InterlacedToProgressive (typo)
    • Improved the documentation
    Solved bugs:
    • Corrected bad return codes in UIT_ResampleScanlines
  •  Changes from version 1.0 to 1.1:
    Additions/changes:
    • The used CRT libraries are linked statically. Now, no additional libraries are needed at runtime
    • Added methods UIT_FlipVertical and UIT_Flip and enumeration E_UNI_FLIP_MODE
    • Color code enumeration ( E_UNI_COLOR_CODE) extended for future purposes
    • Bayer pattern enumeration ( E_UNI_BAYER_PATTERN): values for GRBG and GBRG switched to conform to IIDC (no code changes are necessary)
    • Bayer pattern enumeration ( E_UNI_BAYER_PATTERN): values for CYGM sensors added (not needed for debayering methods)
    Solved bugs:
    • Method UIT_YUV422ToRGBYPlanes was internally mapped to UIT_YUV411ToRGBYPlanes. Solved.
    • The internal computation for debayering CMYG images was corrected. Now, images resulting from the 3x3 algorithm have the same intensity as the images resulting from the 2x2 algorithm.
    • Re-used DEF file for undecorated method names
  •  1.0:
    Initial version


AVT Universal API - Camera Control module: Camera configuration - Unified feature access

Camera configuration - Unified feature access

Introduction

This chapter gives an overview about the features that may be controlled in a unified manner by the functions

  • UCC_HasFeature()
  • UCC_GetFeatureValue()
  • UCC_SetFeatureValue()
  • UCC_GetFeatureStatus()
  • UCC_SetFeatureStatus()
  • UCC_HasFeatureStatus()
  • UCC_GetFeatureMin()
  • UCC_GetFeatureMax().

These features are represented by a value and a state. A specific feature may support one or several states and may or may not imply a value, depending on the feature's nature. Some features' values support read/write accesses while others are write-only. A feature can have a minimum and/or maximum value.

Feature state overview

Each feature supports a subset of the following states:

  • E_FEATSTATE_OFF - The feature is deactivated
  • E_FEATSTATE_ON - The feature is in standard operating mode
  • E_FEATSTATE_ONEPUSH - This state is used to trigger certain events. The camera will leave this state automatically.
  • E_FEATSTATE_AUTO - The feature is controlled automatically
  • E_FEATSTATE_BUSY - The feature cannot be accessed at the moment
  • E_FEATSTATE_SHOWIMAGE - Images sent by the camera contain data normally used for image manipulation.
  • E_FEATSTATE_LOADDATA - The feature settings are restored from the camera memory.
  • E_FEATSTATE_SAVEDATA - The feature settings are stored in the camera memory.
  • E_FEATSTATE_CLEARDATA - The feature settings are resetted.
  • E_FEATSTATE_ERROR - The feature is in a bad state because of a previous error.

UCC_GetFeatureStatus and UCC_SetFeatureStatus provide read and write access to a feature's state. Some states (primarily E_FEATSTATE_BUSY and E_FEATSTATE_ERROR ) are only meaningful as a result of read operations. These states cannot be set explicitly. On the other hand its unlikely to receive certain states (e.g E_FEATSTATE_ONEPUSH , E_FEATSTATE_LOADDATA ) as the result of a read operation. A read operation subsequent to E_FEATSTATE_ONEPUSH and E_FEATSTATE_LOADDATA state write operations will most likely return a E_FEATSTATE_BUSY (indicating that the triggered action is still in progress) or E_FEATSTATE_ON (indicating that the triggered action has finished).

Feature value access

Most features imply a value, which can be accessed by the functions UCC_GetFeatureValue and UCC_SetFeatureValue UCC_GetFeatureMin and UCC_GetFeatureMax may be used to determine the valid range of a feature's value.

Feature reference

The features listed below are supported by the UniControl library. A certain camera will only support a subset of these. For a short summary of supported features see: E_UNI_FEATURE.

E_FEAT_BRIGHTNESS
Controls the image brightness (black level). The feature value represents the number of grey levels by which the image will be brightened.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Brightness is unaltered.
  • E_FEATSTATE_ON - Brightness is adjusted by the given value.
  • E_FEATSTATE_ONEPUSH - The brightness value is automatically adjusted once.
  • E_FEATSTATE_AUTO - The brightness value is automatically adjusted.
E_FEAT_AUTOEXPOSURE
Controls the target grey level for automatic shutter and gain operation. The feature value represents the targeted mean grey level.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - Standard mode of operation
E_FEAT_SHARPNESS
Controls the image sharpening performed by the camera. The feature value represents the degree of sharpening.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - no sharpening
  • E_FEATSTATE_ON - Image is sharpened.

E_FEAT_HUE
Controls the hue adjustment performed by the camera. The feature value represents the hue adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Hue is unaltered.
  • E_FEATSTATE_ON - Hue is adjusted by the given value.
  • E_FEATSTATE_ONEPUSH - The hue value is automatically adjusted once.
  • E_FEATSTATE_AUTO - The hue value is automatically adjusted.

E_FEAT_SATURATION
Controls the saturation adjustment performed by the camera. The feature value represents the saturation adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Saturation is unaltered.
  • E_FEATSTATE_ON - Saturation is adjusted by the given value.
  • E_FEATSTATE_ONEPUSH - The saturation value is automatically adjusted once.
  • E_FEATSTATE_AUTO - The saturation value is automatically adjusted.

E_FEAT_GAMMA
Controls the gamma adjustment performed by the camera. The feature value represents the gamma adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - no gamma correction applied
  • E_FEATSTATE_ON - gamma correction active
  • E_FEATSTATE_ONEPUSH - The gamma value is automatically adjusted once.
  • E_FEATSTATE_AUTO - The gamma value is automatically adjusted.

E_FEAT_SHUTTER
Controls the exposure time used for image acquisition. The feature value represents the exposure time in raw format affected by the feature E_FEAT_TIMEBASE . The actual exposure time implies an additional, camera-specific period of time represented by the feature E_FEAT_EXPOSUREOFFSET .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - fixed exposure time
  • E_FEATSTATE_ONEPUSH - Exposure time is automatically adjusted once.
  • E_FEATSTATE_AUTO - Exposure time is automatically adjusted.

E_FEAT_GAIN
Controls the gain applied to the sensor signal. The feature value represents the amount of gain applied.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - no gain applied
  • E_FEATSTATE_ON - sensor signal is amplified accordingly to the given gain value
  • E_FEATSTATE_ONEPUSH - The gain value is automatically adjusted once.
  • E_FEATSTATE_AUTO - The gain value is automatically adjusted.

E_FEAT_FRAMECOUNTER
Counter for acquired images. The feature value represents the number of images.
Access types supported by the feature's value:
  • Read Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - Standard mode of operation
  • E_FEATSTATE_ONEPUSH - Reset of frame counter.

E_FEAT_AUTOFUNCTIONAOI_LEFT
controls the left offset of the area examined by auto functions - The feature value represents a number of pixels. The value has to comply with a certain step size represented by E_FEAT_AUTOFUNCTIONAOI_XUNITS .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_AUTOFUNCTIONAOI_TOP
controls the top offset of the area examined by auto functions - The feature value represents a number of pixels. The value has to comply with a certain step size represented by E_FEAT_AUTOFUNCTIONAOI_YUNITS .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_AUTOFUNCTIONAOI_WIDTH
controls the width of the area examined by auto functions - The feature value represents a number of pixels. The value has to comply with a certain step size represented by E_FEAT_AUTOFUNCTIONAOI_XUNITS .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_AUTOFUNCTIONAOI_HEIGHT
controls the height of the area examined by auto functions - The feature value represents a number of pixels. The value has to comply with a certain step size represented by E_FEAT_AUTOFUNCTIONAOI_YUNITS .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_AUTOFUNCTIONAOI_XUNITS
Indicates the step size which the AutoFunctionAOI left and width settings have to comply with. The feature value represents a number of pixels.
Access types supported by the feature's value:
  • Read Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_AUTOFUNCTIONAOI_YUNITS
Indicates the step size which the AutoFunctionAOI top and height settings have to comply with. The feature value represents a number of pixels.
Access types supported by the feature's value:
  • Read Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - The whole image is examined by auto functions.
  • E_FEATSTATE_ON - Auto functions examine only the specified area.
  • E_FEATSTATE_SHOWIMAGE - The specified area is marked in transmitted images.
All AutoFunctionAOI features internally share the same state. SetState functions applied to any AutoFunctionAOI feature affect all AutoFunctionAOI features.

E_FEAT_WHITEBALANCE_UB
Controls the white balance (UB) adjustment performed by the camera. The feature value represents the UB adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - White balance is unaltered.
  • E_FEATSTATE_ON - White balance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The white balance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The white balance values are automatically adjusted.
The white balance features 'UB' and 'VR' internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_WHITEBALANCE_VR
Controls the white balance (VR) adjustment performed by the camera. The feature value represents the VR adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - White balance is unaltered.
  • E_FEATSTATE_ON - White balance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The white balance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The white balance values are automatically adjusted.
The white balance features 'UB' and 'VR' internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_WHITEBALANCE_GR
Controls the advanced whitebalance (GR) adjustment performed by the camera. Advanced whitebalance is only supported by cameras based on complementary sensors. Advanced whitebalance may be also controlled by UCC_Whitebalance_GMCY_Get and UCC_Whitebalance_GMCY_Set .
The feature value represents the GR (mode 0) or GR/CY (mode 1) channel adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Advanced whitebalance is unaltered.
  • E_FEATSTATE_ON - Advanced whitebalance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The advanced whitebalance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The advanced whitebalance values are automatically adjusted.
The advanced white balance features internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_WHITEBALANCE_MG
Controls the advanced whitebalance (MG) adjustment performed by the camera. Advanced whitebalance is only supported by cameras based on complementary sensors. Advanced whitebalance may be also controlled by UCC_Whitebalance_GMCY_Get and UCC_Whitebalance_GMCY_Set .
The feature value represents the MG (mode 0) or MG/YE (mode 1) channel adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Advanced whitebalance is unaltered.
  • E_FEATSTATE_ON - Advanced whitebalance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The advanced whitebalance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The advanced whitebalance values are automatically adjusted.
The advanced white balance features internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_WHITEBALANCE_CY
Controls the advanced whitebalance (CY) adjustment performed by the camera. Advanced whitebalance is only supported by cameras based on complementary sensors. Advanced whitebalance may be also controlled by UCC_Whitebalance_GMCY_Get and UCC_Whitebalance_GMCY_Set .
The feature value represents the CY (mode 0) or CY/MG (mode 1) channel adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Advanced whitebalance is unaltered.
  • E_FEATSTATE_ON - Advanced whitebalance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The advanced whitebalance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The advanced whitebalance values are automatically adjusted.
The advanced white balance features internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_WHITEBALANCE_YE
Controls the advanced whitebalance (YE) adjustment performed by the camera. Advanced whitebalance is only supported by cameras based on complementary sensors. Advanced whitebalance may be also controlled by UCC_Whitebalance_GMCY_Get and UCC_Whitebalance_GMCY_Set .
The feature value represents the YE (mode 0) or YE/GR (mode 1) channel adjustment.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - Advanced whitebalance is unaltered.
  • E_FEATSTATE_ON - Advanced whitebalance is adjusted by the given values.
  • E_FEATSTATE_ONEPUSH - The advanced whitebalance values are automatically adjusted once.
  • E_FEATSTATE_AUTO - The advanced whitebalance values are automatically adjusted.
The advanced white balance features internally share the same state. SetState functions applied to any white balance feature affect both features.

E_FEAT_EXPOSUREOFFSET
Indicates the camera-specific offset added to the chosen exposure time. The feature value represents the offset in microseconds.
Access types supported by the feature's value:
  • Read Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_TIMEBASE
Controls the timebase applied to the shutter value. The feature value represents an index of the chosen timebase.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
ID | Timebase
0 | 1 us
1 | 2 us
2 | 5 us
3 | 10 us
4 | 20 us
5 | 50 us
6 | 100 us
7 | 200 us
8 | 500 us
9 | 1000 us
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_EXTENDEDSHUTTER
Controls the exposure time used for image acquisition. The feature value represents the exposure time in microseconds additional to E_FEAT_EXPOSUREOFFSET .
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_AUTOSHUTTER_LOW
Controls the minimum shutter time for auto-shutter operation. The feature value represents the minimum exposure time in microseconds.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_AUTOSHUTTER_HIGH
Controls the maximum shutter time for auto-shutter operation. The feature value represents the minimum exposure time in microseconds.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_AUTOGAIN_LOW
Controls the minimum gain value for auto-gain operation.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_AUTOGAIN_HIGH
Controls the maximum gain value for auto-gain operation.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation
E_FEAT_LUT
Controls the lookup table feature. The feature value represent the index of the applied lookup table. For complete coverage of the lookup table feature also see

UCC_Lut_GetInfo, UCC_Lut_GetStatus, UCC_Lut_Upload, UCC_Lut_Use .

Access types supported by the feature's value:

  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - lookup table is used
  • E_FEATSTATE_OFF - lookup table is not used

E_FEAT_LUT_BITSPERVAL
Indicates the size of a single lookup table entry. The feature value represent the number of bits a single table entry consists of.
Access types supported by the feature's value:
  • Read Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_LUT_MAXSIZE
Indicates the size of an entire lookup table. The feature value represent the size in bytes.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_COLORCORRECTION
Controls the cameras color correction. This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ON - color correction enabled
  • E_FEATSTATE_OFF - color correction disabled

E_FEAT_TRIGGERDELAYADV
Controls the time interval by which trigger signals are delayed in microseconds.
See Trigger for a trigger feature overview.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - Trigger is delayed by the given value.
  • E_FEATSTATE_OFF - no trigger delay

E_FEAT_XMIRRORIMAGE
Controls the horizontal image mirror feature. This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ON - Image is mirrored horizontally by camera.
  • E_FEATSTATE_OFF - standard mode of operation

E_FEAT_SOFTRESET
Triggers the cameras soft reset.
This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ONEPUSH - Softreset is triggered.
  • E_FEATSTATE_OFF - standard mode of operation

E_FEAT_HIGHSNR
Controls the high SNR mode. The feature value represents the number of images acquired for a single averaged image.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - high SNR mode enabled
  • E_FEATSTATE_OFF - high SNR mode disabled

E_FEAT_USERPROFILE
Controls the user profile feature. The feature value represents the user profile id (also called memory channel).
For complete coverage of the user profile feature also see

UCC_UserProfile_GetErrorStatus, UCC_UserProfile_GetInfo, UCC_UserProfile_Load, UCC_UserProfile_Save, UCC_UserProfile_SetDefault .

Access types supported by the feature's value:

  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_OFF - standard mode of operation
  • E_FEATSTATE_ONEPUSH - sets the currently selected profile id as default. (will be restored at camera startup)
  • E_FEATSTATE_LOADDATA - load a user profile from camera memory
  • E_FEATSTATE_SAVEDATA - stores the active settings as user profile

E_FEAT_DELAYEDINTEGRATIONENABLE
Controls the delayed 'integration enable' feature. The feature value represents the delay time in microseconds.
See Trigger for more information.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - Delayed 'Integration Enable'
  • E_FEATSTATE_OFF - No Delayed 'Integration Enable'

E_FEAT_DSNUCORRECTION
Controls the DSNU correction. The feature value represents the number of images taken into account for DSNU data computation.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - DSNU correction active
  • E_FEATSTATE_OFF - No DSNU correction
  • E_FEATSTATE_SHOWIMAGE - Transfer DSNU data as image
  • E_FEATSTATE_ONEPUSH - Compute DSNU data
  • E_FEATSTATE_BUSY - DSNU data computation in progress
  • E_FEATSTATE_LOADDATA - Load DSNU data from camera memory
  • E_FEATSTATE_SAVEDATA - Save DSNU data to camera memory
  • E_FEATSTATE_CLEARDATA - Clear DSNU data

E_FEAT_BLEMISHCORRECTION
Controls the blemish pixel correction. The feature value represents the number of images taken into account for blemish pixel data computation.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - blemish pixel correction active
  • E_FEATSTATE_OFF - No blemish pixel correction
  • E_FEATSTATE_SHOWIMAGE - Transfer blemish pixel data as image
  • E_FEATSTATE_ONEPUSH - Compute blemish pixel data
  • E_FEATSTATE_BUSY - blemish pixel data computation in progress
  • E_FEATSTATE_LOADDATA - Load blemish pixel data from camera memory
  • E_FEATSTATE_SAVEDATA - Save blemish pixel data to camera memory
  • E_FEATSTATE_CLEARDATA - Clear blemish pixel data

E_FEAT_SHADING
Controls the shading correction. The feature value represents the number of images taken into account for shading data computation.
For complete shading correction feature coverage see also

UCC_Shading_Build, UCC_Shading_Download, UCC_Shading_GetInfo, UCC_Shading_Upload.

Access types supported by the feature's value:

  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - shading correction active
  • E_FEATSTATE_OFF - No shading correction
  • E_FEATSTATE_SHOWIMAGE - Transfer shading data as image
  • E_FEATSTATE_ONEPUSH - Compute shading data
  • E_FEATSTATE_BUSY - shading data computation in progress
  • E_FEATSTATE_LOADDATA - Load shading data from camera memory
  • E_FEATSTATE_SAVEDATA - Save shading data to camera memory

E_FEAT_HDR_KNEEPOINTCOUNT
Controls the number of kneepoints used in HDR mode. The feature value represents the number of kneepoints.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - HDR mode enabled
  • E_FEATSTATE_OFF - HDR mode disabled
All HDR features internally share the same state. SetState functions applied to any HDR feature affect all HDR features.

E_FEAT_HDR_KNEEPOINT1
Controls the first kneepoint used in HDR mode. The feature value represents the exposure time in microseconds.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - HDR mode enabled
  • E_FEATSTATE_OFF - HDR mode disabled
All HDR features internally share the same state. SetState functions applied to any HDR feature affect all HDR features.

E_FEAT_HDR_KNEEPOINT2
Controls the second kneepoint used in HDR mode. The feature value represents the exposure time in microseconds.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - HDR mode enabled
  • E_FEATSTATE_OFF - HDR mode disabled
All HDR features internally share the same state. SetState functions applied to any HDR feature affect all HDR features.

E_FEAT_HDR_KNEEPOINT3
Controls the third kneepoint used in HDR mode. The feature value represents the exposure time in microseconds.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - HDR mode enabled
  • E_FEATSTATE_OFF - HDR mode disabled
All HDR features internally share the same state. SetState functions applied to any HDR feature affect all HDR features.

E_FEAT_FRAMEMEMORYSIZE
Only available for Firewire devices. This feature provides a read-only value representing the size of one complete image in bytes.
Access types supported by the feature's value:
  • Read Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_REDUCEDSMEAR
Controls the 'Low Smear' mode. This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ON - low smear mode enabled
  • E_FEATSTATE_OFF - low smear mode disabled

E_FEAT_PARAMUPDATETIMING
Controls the 'Parameter Update Timing' feature. The feature value represents the timing mode.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_SIS
Controls the 'Secure Image Signature' feature. The feature value represents the vertical position of the image signature.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - secure image signature enabled
  • E_FEATSTATE_OFF - secure image signature disabled

E_FEAT_SIS_MARLIN
camera support for marlin secure image signature.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - secure image signature enabled
  • E_FEATSTATE_OFF - secure image signature disabled

E_FEAT_SIS_PIKE
camera support for the pike secure image signature.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - secure image signature enabled
  • E_FEATSTATE_OFF - secure image signature disabled

E_FEAT_CAMERABUSY
busy state of the camera.
Supported States:
  • E_FEATSTATE_ON - camera is busy
  • E_FEATSTATE_OFF - camera is available

E_FEAT_LIST_ALL_CAMERAS
determines the behaviour of the UCC_GetCameras() method .
Access types supported by the feature's value:
  • Read/Write Value
Supported States:
  • E_FEATSTATE_ON - all cameras on bus will be listed by UCC_GetCameras() method
  • E_FEATSTATE_OFF - only cameras not busy are listed by UCC_GetCameras() method

E_FEAT_STARTIMMEDIATELY
determines the behaviour of UCC_GrabStart() if FALSE the camera waits for a iso enable.
Access types supported by the feature's value:
  • Read/Write Value
Supported States:
  • E_FEATSTATE_ON - camera starts immediately
  • E_FEATSTATE_OFF - camera waits for trigger
Supported Values:
  • TRUE - camera starts immediately
  • FALSE - camera waits for trigger

E_FEAT_BURSTCOUNT
determines the number of images send by the camera after UCC_GrabStart() method, INFINITE defines continuously grabbing.
Access types supported by the feature's value:
  • Read/Write Value
  • Min/Max Value
Supported States:
  • E_FEATSTATE_ON - camera starts immediately
  • E_FEATSTATE_OFF - camera waits for trigger

E_FEAT_DO_BUSTRIGGER
broadcast command to trigger all cameras on bus.
Access types supported by the feature's value:
  • Read/Write Value
Supported States:
  • E_FEATSTATE_ON - camera do a bustrigger
Supported Values:
  • TRUE - do a busstrigger
E_FEAT_DO_MULTIBUSTRIGGER
broadcast command to trigger all cameras on the selected cards.
Access types supported by the feature's value:
  • Read/Write Value
Supported Values:
  • Bitmask - Mask defining what cards shall recive the trigger


AVT Universal API - Camera Control module: Camera-unrelated configuration

Camera-unrelated configuration

Introduction

This chapter covers configuration topics that aren't directly related to a specific camera. Most configuration matters are handled by the 'unified feature access' function set also used for camera configuration. General informations about this functions can be found there.

Firewire bus configuration

The following unified features represent additional parameters that affect the underlying Firewire interface. These parameters may have great influence on the system performance.
E_FEAT_PHYSPEED
Only available for Firewire devices. This parameter controls the real physical speed that is used to talk with the connected device. The feature value represents an index of the chosen speed.
ID | Bus Speed
0 | 100 MBit/s
1 | 200 MBit/s
2 | 400 MBit/s
3 | 800 MBit/s
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_FRAMEBUFFERCOUNT
Only available for Firewire devices. Number of frame buffers that shall be allocated when the capture is started. Per default this value is set to 16.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_USEIRMFORBW
Only available for Firewire devices. This feature determines, whether the packet size used for image transfer shall be registered with the isochronous resource manager.
This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ON - register bandwidth
  • E_FEATSTATE_OFF - do not register bandwidth (default)

E_FEAT_USEIRMFORCHN
Only available for Firewire devices. This parameter determines whether to use the isochronous resource manager for allocating the isochronous channel the camera runs on or to use the isochronous channel that was set with E_FEAT_ISOCHANNEL .
This feature cannot be controlled by a value.
Supported States:
  • E_FEATSTATE_ON - use the isochronous resource manager
  • E_FEATSTATE_OFF - use the channel set with E_FEAT_ISOCHANNEL

E_FEAT_CAMACCEPTDELAY
Only available for Firewire devices. After some register writes on camera registers the system waits and lets the camera device process data. The feature value represents this time in milliseconds. The default value is 3 milliseconds.
Access types supported by the feature's value:
  • Read/Write Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_ISOCHANNEL
Only available for Firewire devices. This parameter sets the isochronous channel that shall be used by the camera. To make this parameter become effective you must set E_FEAT_USEIRMFORCHNto E_FEATSTATE_OFF .
Access types supported by the feature's value:
  • Read/Write Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_IRMFREEBW
Only available for Firewire devices. This feature provides a read-only value representing the still available bandwidth of the FireWire bus how it is reported by the isochronous resource manager.
Access types supported by the feature's value:
  • Read Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

E_FEAT_CYCLETIME
Only available for Firewire devices. This parameter's value represents the actual bus time in the following format:
            struct
            {
                UINT32 CycleOffset : 12;
                UINT32 CycleCount : 13;
                UINT32 Second : 7;
            }BUSTIME;
or also
            Bit[11..0] = Cycle Offset in parts of 1/3072 (=24.576 MHz)
            Bit[24..12] = Cycle Count
            Bit[31..25] = Second Count
Access types supported by the feature's value:
  • Read Value
Supported States:
  • E_FEATSTATE_ON - standard mode of operation

Logging

Overview

The Universal API provides logging capabilities for debug purposes. Log messages may be either written to harddisk directly or buffered in system memory to minimize harddisk access. Buffered output is flushed when the internal buffer is filled, on request and on dll unloading. The logging verbosity may be set to one of the following levels:
  • Fatal (0) for unrecoverable errors
  • Error (1) for recoverable errors
  • Warning (2) for unanticipated behavior
  • Info (3) for information about the current flow
  • Debug (4) for information mainly useful for the developers of this API

Usage

If you'd like to enable logging for your UniAPI application, provide a "UniControl.ini" file in the same directory as the file UniControl.dll or in the startup directory of your application with the following contents:
[Logging]
Targets = File
TargetParam = F:\Projects\UniAPI\UniControl.log
TargetIdent = Uni_Log
TargetLevel=3       ; LOG_FATAL = 0, LOG_ERROR = 1, LOG_WARNING = 2, LOG_INFO = 3, LOG_DEBUG = 4
The section [Logging] must be used. The following properties are possible:
  • Targets may have values None and File. In the first case, no logging is performed (and no file is created). In the second case, the following values are needed:
  • TargetParam is the file name if the logging target is a file
  • TargetIdent may contain the identifier for this logging target
  • TargetLevel describes the logging level as defined above
Logging may be configured at runtime via the unified feature E_FEAT_LOGGING

E_FEAT_LOGGING
Controls the library's logging feature. The feature value represents the logging verbosity level.
Access types supported by the feature's value:
  • Read/Write Value
  • Get Min/Max
Supported States:
  • E_FEATSTATE_AUTO - logfile will be flushed automatically
  • E_FEATSTATE_ON - logfile needs to be flushed manually
  • E_FEATSTATE_ONEPUSH - flush logfile manually
The logging feature may be accessed without any camera present. The camera ID will be ignored.
General information about the usage of unified features can be found here. The following example changes the verbosity to 'fatal' (0):

        UCC_SetFeatureValue(UNI_UNDEFINED,E_FEAT_LOGGING,E_LOG_FATAL)

User logging

Applications using the Universal API may produce their own logging output by utilizing the user logging feature. User log files are created by UCC_CreateUserLog() and logging messages are written by UCC_WriteUserLog() .


AVT Universal API - Camera Control module: Data Structures

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
S_12BIT_2PACKED | Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes
S_BGR16 | Structure for accessing 16-bit Windows-type RGB data
S_BGR8 | Structure for accessing Windows RGB data
S_BGRA8 | Structure for accessing Windows RGBA data
S_IIDC_VIDEOINFO_FORMAT | IIDC video formats
S_IIDC_VIDEOINFO_FPS | Frame rates for IIDC video modes
S_IIDC_VIDEOINFO_MODE | IIDC video modes
S_RGB8 | Structure for accessing Windows RGB data
S_SIS_DATA | SIS data structure
S_SIS_ENABLE | Information about state of the fields of the S_SIS_DATA struct
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS | States of the sis data
S_SUPPORT_STATE | States of the multi media technology support for operating system and processor
S_TECHNO_INFO | States of the support for different multimedia technologies
S_UNI_CALLBACK_ARGUMENT | Callback function argument
S_UNI_IMAGE | Structure for image data access supporting different formats
S_UNI_NOTIFICATION | Uni api notification
S_UNI_NOTIFICATION_CALLBACK | Notification Callback struct
S_UNI_NOTIFICATION_EVENT | Win API event notification
S_UNI_WINDOWS_MESSAGE | Windows message to send on notification
S_YUV411 | Structure for accessing data in the YUV 4:1:1 format (UYYVYY)
S_YUV422 | Structure for accessing data in the YUV 4:2:2 format (UYVY)
S_YUV444 | Structure for accessing data in the YUV 4:4:4 format (YUV)


AVT Universal API - Camera Control module: S_12BIT_2PACKED Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_12BIT_2PACKED Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes.

Data Fields

UINT8_TYPE m_nVal8_1
High byte of the first Pixel.
UINT8_TYPE | m_nVal8_1Low: 4
Low nibble of the first pixel.
UINT8_TYPE | m_nVal8_2Low: 4
Low nibble of the second pixel.
UINT8_TYPE m_nVal8_2
High byte of the second pixel.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_BGR16 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGR16 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing 16-bit Windows-type RGB data.

Data Fields

UINT16_TYPE B
blue part
UINT16_TYPE G
green part
UINT16_TYPE R
red part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_BGR8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGR8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGB data.

Data Fields

UINT8_TYPE B
blue part
UINT8_TYPE G
green part
UINT8_TYPE R
red part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_BGRA8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_BGRA8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGBA data.

Data Fields

UINT8_TYPE B
blue part
UINT8_TYPE G
green part
UINT8_TYPE R
red part
UINT8_TYPE A
unused

The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_FORMAT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_IIDC_VIDEOINFO_FORMAT Struct Reference

#include <uni_defines.h>

Detailed Description

IIDC video formats.

Data Fields

S_IIDC_VIDEOINFO_MODE m_FormatInq [3]
modes for the formats
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_FPS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_IIDC_VIDEOINFO_FPS Struct Reference

#include <uni_defines.h>

Detailed Description

Frame rates for IIDC video modes.

Data Fields

UINT32_TYPE m_FpsInq [8]
support for IIDC frame rate
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_MODE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_IIDC_VIDEOINFO_MODE Struct Reference

#include <uni_defines.h>

Detailed Description

IIDC video modes.

Data Fields

S_IIDC_VIDEOINFO_FPS m_ModeInq [8]
frame rates for the modes
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_RGB8 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_RGB8 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing Windows RGB data.

Data Fields

UINT8_TYPE R
red part
UINT8_TYPE G
green part
UINT8_TYPE B
blue part
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_SIS_DATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SIS_DATA Struct Reference

#include <uni_defines.h>

Detailed Description

SIS data structure.

Data Fields

UINT32_TYPE m_CycleCounter
bus cycle count
UINT32_TYPE m_FrameCounter
frame count since last reset
UINT32_TYPE m_TriggerCounter
from camera received triggers
UINT16_TYPE m_AOILeft
left coordinate of the AOI begin
UINT16_TYPE m_AOITop
top coordinate of the AOI begin
UINT16_TYPE m_AOIWidth
width of the AOI
UINT16_TYPE m_AOIHeight
height of the AOI
UINT32_TYPE m_Shutter
camera shutter for the image
UINT16_TYPE m_Gain
camera gain for the image
UINT16_TYPE m_Reserved0
reserved for future use
UINT8_TYPE | m_OutputState [4]
state of the output pins
UINT8_TYPE | m_InputState [2]
state of the input pins
UINT8_TYPE | m_Reservec1 [2]
reserved for future use
UINT8_TYPE m_SequenceIndex
position in the sequence
UINT8_TYPE m_Reserved2a
reserved for future use
UINT8_TYPE m_ColorCoding
IIDC color coding for the transport format.
UINT8_TYPE m_Reserved2b
reserved for future use
UINT32_TYPE m_SerialNumber
camera serial number
UINT32_TYPE m_UserValue
user defined value
S_SIS_ENABLE m_SISEnable
state inq struct
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_SIS_ENABLE Union Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SIS_ENABLE Union Reference

#include <uni_defines.h>

Detailed Description

information about state of the fields of the S_SIS_DATA struct

Data Fields

struct
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS 		m_Enable
states of the sis data
UINT32_TYPE m_Data
Enable as UINT32.

Data Structures

struct S_SIS_ENABLE_FIELDS
states of the sis data More...
The documentation for this union was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields
S_SIS_ENABLE::S_SIS_ENABLE_FIELDS

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS Struct Reference

#include <uni_defines.h>

Detailed Description

states of the sis data

Data Fields

UINT32_TYPE | m_CycleCounter: 1
inq cycle counter
UINT32_TYPE | m_FrameCounter: 1
inq frame count since last reset
UINT32_TYPE | m_TriggerCounter: 1
inq triggers received by the camera
UINT32_TYPE | m_AOILeft: 1
inq left coordinate of the cameras AOI
UINT32_TYPE | m_AOITop: 1
inq top coordinate of the cameras AOI
UINT32_TYPE | m_AOIWidth: 1
inq width of the AOI
UINT32_TYPE | m_AOIHeight: 1
inq height of the AOI
UINT32_TYPE | m_Shutter: 1
inq camera shutter for the image
UINT32_TYPE | m_Gain: 1
inq camera gain for the image
UINT32_TYPE | m_OutputState: 1
inq output pin states
UINT32_TYPE | m_InputState: 1
inq input pin states
UINT32_TYPE | m_SequenceIndex: 1
inq position in sequence
UINT32_TYPE | m_ColorCoding: 1
inq IIDC color coding
UINT32_TYPE | m_SerialNumber: 1
inq serial number of the camera
UINT32_TYPE | m_UserValue: 1
inq user defined value
UINT32_TYPE | m_Valid: 1
Data in Enable is valid.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_SUPPORT_STATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_SUPPORT_STATE Struct Reference

#include <uni_defines.h>

Detailed Description

states of the multi media technology support for operating system and processor.

Data Fields

bool | Processor
technology supported by the processor
bool | OperatingSystem
technology supported by the OS
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_TECHNO_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_TECHNO_INFO Struct Reference

#include <uni_defines.h>

Detailed Description

states of the support for different multimedia technologies

Data Fields

S_SUPPORT_STATE IntelMMX
INTEL first gen MultiMedia eXtension.
S_SUPPORT_STATE IntelSSE
INTEL Streaming SIMD Extension.
S_SUPPORT_STATE IntelSSE2
INTEL Streaming SIMD Extension 2.
S_SUPPORT_STATE IntelSSE3
INTEL Streaming SIMD Extension 3.
S_SUPPORT_STATE IntelSSSE3
INTEL Supplemental Streaming SIMD Extension 3.
S_SUPPORT_STATE AMD3DNow
AMD 3DNow.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_CALLBACK_ARGUMENT Struct Reference

#include <uni_notification.h>

Detailed Description

Callback function argument.

Public Member Functions

S_UNI_CALLBACK_ARGUMENT ()
default constructor if c++.
S_UNI_CALLBACK_ARGUMENT (VOID_POINTER Prm, UINT32_TYPE CamId=0xFFffFFff)
constructor with init if c++.

Data Fields

VOID_POINTER m_Parameter
User defined parameter will be returned as-is.
UINT32_TYPE m_CamId
Will be filled with the sending camera id when called.
UINT32_TYPE m_Reserved
reserved

The documentation for this struct was generated from the following file:
  • uni_notification.h


AVT Universal API - Camera Control module: S_UNI_IMAGE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_IMAGE Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for image data access supporting different formats.

Using this structure, it is possible to request any of the supported image formats with the same function, e.g. UCC_GrabImage(). An instance of this structure has to be created and initialized by the user before function call. For initialization uImageformat has to be set to the desired image format. Memory space used for image data has to be provided by the user. According to the selected format, one or more memory segments are used. Therefore, one or more of S_UniImage's data pointers are needed to point to sufficiently sized memory segments. Image formats other than E_IF_RGB_PLANES and E_IF_RGBY_PLANES generally use pImageAsSinglePlane.
Example:

        UINT8_TYPE * pImgBytes=NULL;
        if( !m_Img.IsNull() )
            pImgBytes = (BYTE *)m_Img.GetBits();

        UINT32_TYPE bColor=0;
        S_UNI_IMAGE MyImageStruct;

        MyImageStruct.uImageformat = E_IF_MONO8;
        MyImageStruct.sImageData.pImageAsSinglePlane = pImgBytes;

        UNI_RETURN_TYPE hr = UNI_GrabImage( m_CamId, &MyImageStruct , &bColor, INFINITE );

Data Fields

UINT32_TYPE uImageformat
significator of the image format - for valid values see E_UNI_IMAGE_FORMAT
S_SIS_DATA SISData
secure image signature for the current image
bool SISEnabled
meta info about SISData, if true SISData holds the secure image signature
UINT8_TYPE * pImageAsSinglePlane
Bitmap.
UINT8_TYPE * pImageRed
Pointer to red plane.
UINT8_TYPE * pImageGreen
Pointer to green plane.
UINT8_TYPE * pImageBlue
Pointer to blue plane.
UINT8_TYPE * pImageY
Pointer to intensity plane.
struct {
UINT8_TYPE * pImageRed
Pointer to red plane.
UINT8_TYPE * pImageGreen
Pointer to green plane.
UINT8_TYPE * pImageBlue
Pointer to blue plane.
UINT8_TYPE * pImageY
Pointer to intensity plane.
} ImageAsMultiPlanes
RGBY planes image.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_NOTIFICATION Struct Reference

#include <uni_notification.h>

Detailed Description

uni api notification.

Data Fields

UINT32_TYPE m_NotificationType
id of the notification type - see E_UNI_NOTIFICATION_TYPE
UINT32_TYPE m_CamId
camera to register the notification for */
S_UNI_NOTIFICATION_CALLBACK m_NotificationCallback
callback used if m_NotificationType == E_UNI_NOTIFICATION_CALLBACK - see S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_EVENT m_NotificationEvent
structure defining the event used if m_NotificationType == E_UNI_NOTIFICATION_EVENT - see S_UNI_NOTIFICATION_EVENT
S_UNI_WINDOWS_MESSAGE m_NotificationWindowsMessage
structure defining the windows message used if m_NotificationType == E_UNI_NOTIFICATION_MESSAGE - see S_UNI_WINDOWS_MESSAGE

The documentation for this struct was generated from the following file:
  • uni_notification.h


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_CALLBACK Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_NOTIFICATION_CALLBACK Struct Reference

#include <uni_notification.h>

Detailed Description

Notification Callback struct.

Will hold the callback function and the function argument

Public Member Functions

S_UNI_NOTIFICATION_CALLBACK ()
default constructor if c++.
S_UNI_NOTIFICATION_CALLBACK (UNI_NOTIFICATION_CALLBACK_FUNCTION callback, S_UNI_CALLBACK_ARGUMENT arg)
constructor with init.

Data Fields

UNI_NOTIFICATION_CALLBACK_FUNCTION m_Callback
Callbackfunction which will be called as notification.
S_UNI_CALLBACK_ARGUMENT m_Arg
Function argument which is passed with the callback function.

The documentation for this struct was generated from the following file:
  • uni_notification.h


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_NOTIFICATION_EVENT Struct Reference

#include <uni_notification.h>

Detailed Description

Win API event notification.

Public Member Functions

S_UNI_NOTIFICATION_EVENT ()
default constructor if c++
S_UNI_NOTIFICATION_EVENT (HANDLE *Event, UINT32_TYPE CamId=0xFFffFFff)
constructor with variable init if c++.

Data Fields

HANDLE m_Event
the initialized Event to use for notification
UINT32_TYPE m_CamId
non-syncronized serial number from camera which triggered the last event
UINT32_TYPE m_Reserved
reserved for internal use

The documentation for this struct was generated from the following file:
  • uni_notification.h


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_UNI_WINDOWS_MESSAGE Struct Reference

#include <uni_notification.h>

Detailed Description

Windows message to send on notification.

lParam will hold the sending camera id

Public Member Functions

S_UNI_WINDOWS_MESSAGE ()
default Ctor if c++
S_UNI_WINDOWS_MESSAGE (HWND hWnd, UINT Msg=0, WPARAM wParam=0, LPARAM lParam=0)
Ctor with args.

Data Fields

HWND | m_hWnd
Handle to the window to post the message.
UINT | m_Msg
Message id.
WPARAM | m_wParam
Reserved.
LPARAM | m_lParam
ID of sending camera.

The documentation for this struct was generated from the following file:
  • uni_notification.h


AVT Universal API - Camera Control module: S_YUV411 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV411 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:1:1 format (UYYVYY).

Data Fields

UINT8_TYPE U
the U part for all four pixels
UINT8_TYPE Y0
the intensity of the first pixel
UINT8_TYPE Y1
the intensity of the second pixel
UINT8_TYPE V
the V part for all four pixels
UINT8_TYPE Y2
the intensity of the third pixel
UINT8_TYPE Y3
the intensity of the fourth pixel
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_YUV422 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV422 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:2:2 format (UYVY).

Data Fields

UINT8_TYPE U
the U part for both pixels
UINT8_TYPE Y0
the intensity of the first pixel
UINT8_TYPE V
the V part for both pixels
UINT8_TYPE Y1
the intensity of the second pixel
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: S_YUV444 Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

S_YUV444 Struct Reference

#include <uni_defines.h>

Detailed Description

Structure for accessing data in the YUV 4:4:4 format (YUV).

Data Fields

UINT8_TYPE Y
Luma.
UINT8_TYPE U
U.
UINT8_TYPE V
V.
The documentation for this struct was generated from the following file:
  • uni_defines.h


AVT Universal API - Camera Control module: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Functions
  • Variables
  • a
  • b
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • u
  • v
  • y
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • A : S_BGRA8
  • AMD3DNow : S_TECHNO_INFO

- b -

  • B : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- g -

  • G : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- i -

  • ImageAsMultiPlanes : S_UNI_IMAGE
  • IntelMMX : S_TECHNO_INFO
  • IntelSSE : S_TECHNO_INFO
  • IntelSSE2 : S_TECHNO_INFO
  • IntelSSE3 : S_TECHNO_INFO
  • IntelSSSE3 : S_TECHNO_INFO

- m -

  • m_AOIHeight : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOILeft : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_AOITop : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOIWidth : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Arg : S_UNI_NOTIFICATION_CALLBACK
  • m_Callback : S_UNI_NOTIFICATION_CALLBACK
  • m_CamId : S_UNI_CALLBACK_ARGUMENT , S_UNI_NOTIFICATION_EVENT , S_UNI_NOTIFICATION
  • m_ColorCoding : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_CycleCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Data : S_SIS_ENABLE
  • m_Enable : S_SIS_ENABLE
  • m_Event : S_UNI_NOTIFICATION_EVENT
  • m_FormatInq : S_IIDC_VIDEOINFO_FORMAT
  • m_FpsInq : S_IIDC_VIDEOINFO_FPS
  • m_FrameCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Gain : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_hWnd : S_UNI_WINDOWS_MESSAGE
  • m_InputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_lParam : S_UNI_WINDOWS_MESSAGE
  • m_ModeInq : S_IIDC_VIDEOINFO_MODE
  • m_Msg : S_UNI_WINDOWS_MESSAGE
  • m_NotificationCallback : S_UNI_NOTIFICATION
  • m_NotificationEvent : S_UNI_NOTIFICATION
  • m_NotificationType : S_UNI_NOTIFICATION
  • m_NotificationWindowsMessage : S_UNI_NOTIFICATION
  • m_nVal8_1 : S_12BIT_2PACKED
  • m_nVal8_1Low : S_12BIT_2PACKED
  • m_nVal8_2 : S_12BIT_2PACKED
  • m_nVal8_2Low : S_12BIT_2PACKED
  • m_OutputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Parameter : S_UNI_CALLBACK_ARGUMENT
  • m_Reservec1 : S_SIS_DATA
  • m_Reserved : S_UNI_NOTIFICATION_EVENT , S_UNI_CALLBACK_ARGUMENT
  • m_Reserved0 : S_SIS_DATA
  • m_Reserved2a : S_SIS_DATA
  • m_Reserved2b : S_SIS_DATA
  • m_SequenceIndex : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_SerialNumber : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Shutter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_SISEnable : S_SIS_DATA
  • m_TriggerCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_UserValue : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Valid : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_wParam : S_UNI_WINDOWS_MESSAGE

- o -

  • OperatingSystem : S_SUPPORT_STATE

- p -

  • pImageAsSinglePlane : S_UNI_IMAGE
  • pImageBlue : S_UNI_IMAGE
  • pImageGreen : S_UNI_IMAGE
  • pImageRed : S_UNI_IMAGE
  • pImageY : S_UNI_IMAGE
  • Processor : S_SUPPORT_STATE

- r -

  • R : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- s -

  • S_UNI_CALLBACK_ARGUMENT() : S_UNI_CALLBACK_ARGUMENT
  • S_UNI_NOTIFICATION_CALLBACK() : S_UNI_NOTIFICATION_CALLBACK
  • S_UNI_NOTIFICATION_EVENT() : S_UNI_NOTIFICATION_EVENT
  • S_UNI_WINDOWS_MESSAGE() : S_UNI_WINDOWS_MESSAGE
  • SISData : S_UNI_IMAGE
  • SISEnabled : S_UNI_IMAGE

- u -

  • U : S_YUV444 , S_YUV422 , S_YUV411
  • uImageformat : S_UNI_IMAGE

- v -

  • V : S_YUV444 , S_YUV411 , S_YUV422

- y -

  • Y : S_YUV444
  • Y0 : S_YUV422 , S_YUV411
  • Y1 : S_YUV411 , S_YUV422
  • Y2 : S_YUV411
  • Y3 : S_YUV411


AVT Universal API - Camera Control module: File Index

  • File List
  • Globals

File List

Here is a list of all documented files with brief descriptions:
uni_defines.h | Definitions for the Universal API methods
uni_notification.h | Defines for API notifications
uni_types.h | Definitions for the types used in the Universal API methods
UniControl.h | This file describes all the available AVT Universal API Camera Control methods
UniTransform.h | The available AVT Universal API Image Transformation methods


AVT Universal API - Camera Control module: uni_defines.h File Reference

uni_defines.h File Reference

Detailed Description

Definitions for the Universal API methods.

This file describes all necessary definitions for using the Universal API methods.

Version:
1.10
Date:
03-Mar-2008
Author:
Philipp Beyer, Holger Eddelbuettel, Matthias Heidenreich
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_types.h"

Data Structures

struct | S_12BIT_2PACKED
Structure for accessing data in 12-bit transfer mode, two pixel are coded into 3 bytes. More...
struct | S_SUPPORT_STATE
states of the multi media technology support for operating system and processor. More...
struct | S_TECHNO_INFO
states of the support for different multimedia technologies More...
union | S_SIS_ENABLE
information about state of the fields of the S_SIS_DATA struct More...
struct | S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
states of the sis data More...
struct | S_SIS_DATA
SIS data structure. More...
struct | S_RGB8
Structure for accessing Windows RGB data. More...
struct | S_BGR8
Structure for accessing Windows RGB data. More...
struct | S_BGRA8
Structure for accessing Windows RGBA data. More...
struct | S_BGR16
Structure for accessing 16-bit Windows-type RGB data. More...
struct | S_YUV444
Structure for accessing data in the YUV 4:4:4 format (YUV). More...
struct | S_YUV422
Structure for accessing data in the YUV 4:2:2 format (UYVY). More...
struct | S_YUV411
Structure for accessing data in the YUV 4:1:1 format (UYYVYY). More...
struct | S_UNI_IMAGE
Structure for image data access supporting different formats. More...
struct | S_IIDC_VIDEOINFO_FPS
Frame rates for IIDC video modes. More...
struct | S_IIDC_VIDEOINFO_MODE
IIDC video modes. More...
struct | S_IIDC_VIDEOINFO_FORMAT
IIDC video formats. More...

Defines

#define | UNI_RESULT_API_ERROR 0x88000000
mask for API error
#define | UNI_RESULT_UNKNOWN_ERROR 0x88000001
unclassified error
#define | UNI_RESULT_PARAMETER_INVALID_1 0x88000002
parameter 1 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_2 0x88000003
parameter 2 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_3 0x88000004
parameter 3 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_4 0x88000005
parameter 4 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_5 0x88000006
parameter 5 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_6 0x88000007
parameter 6 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_7 0x88000008
parameter 7 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_8 0x88000009
parameter 8 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_9 0x8800000A
parameter 9 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_10 0x8800000B
parameter 10 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_11 0x8800000C
parameter 11 is invalid
#define | UNI_RESULT_PARAMETER_INVALID_12 0x8800000D
parameter 12 is invalid
#define | UNI_RESULT_CAMERA_NOT_FOUND 0x88000010
#define | UNI_RESULT_AVT_CAMERA_NOT_FOUND 0x88000011
AVT camera not found.
#define | UNI_RESULT_FEATURE_NOT_IMPLEMENTED 0x88000012
feature support is not implemented (yet?)
#define | UNI_RESULT_FEATURE_NOT_SUPPORTED 0x88000013
feature not supported by camera
#define | UNI_RESULT_INVALID_FEATURECAPABILITY 0x88000014
invalid operation for the selected feature
#define | UNI_RESULT_API_NOT_INITIALIZED 0x88000015
the API was not initialized - UCC_Init() has to be called first
#define | UNI_RESULT_GRAB_NOT_INITIALIZED 0x88000016
the camera was not initialized before grabbing
#define | UNI_RESULT_CAMERA_BUSY 0x88000017
the camera is busy
#define | UNI_RESULT_INVALID_SETTINGS 0x88000018
invalid camera settings selected
#define | UNI_RESULT_INSUFFICIENT_RESOURCES 0x88000019
insufficient FireWire resources
#define | UNI_RESULT_OUT_OF_MEMORY 0x8800001A
out of memory
#define | UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE 0x8800001B
operation not allowed in this mode
#define | UNI_RESULT_CAMERA_TIMEOUT 0x8800001C
timeout period expired
#define | UNI_RESULT_API_ALREADY_INITIALIZED 0x8800001D
second call to UCC_Init; the API was already initialized
#define | UNI_RESULT_COMMAND_ABORTED 0x8800001E
the current command was aborted
#define | UNI_RESULT_NOTIFICATION_NO_TYPE 0x8800001F
#define | UNI_RESULT_MORE_DATA ERROR_MORE_DATA
timeout period expired
#define | UNI_UNDEFINED 0xFFFFFFFF
represents an undefined input parameter
#define | UNI_ALL_CAMERAS 0xFFffFFff
special camera id to address all connected cameras
#define | UNI_RESULT_FIREGRAB_ERROR 0x8A000000
Mask for a FireGrab error.
#define | UNI_MAX_INPUT_PINS 4
Maximal number of input Pins.
#define | UNI_MAX_OUTPUT_PINS 4
Maximal number of output pins.

Typedefs

typedef enum E_UNI_ROPMODE | E_UniRopMode
Enumeration for raster operation (used by re sampling methods).
typedef enum E_UNI_COLOR_CODE | E_UniColorCode
Enumeration for IIDC format 7 color codes / transfer formats.
typedef enum E_UNI_BAYER_PATTERN | E_UniBayerPattern
Enumeration for the Bayer pattern.
typedef enum E_UNI_FLIP_MODE | E_UniFlipMode
Enumeration for the direction for flipping images.
typedef struct S_SUPPORT_STATE | S_SupportState
states of the multi media technology support for operating system and processor.
typedef struct S_TECHNO_INFO | S_TechInfo
states of the support for different multimedia technologies
typedef enum E_UNI_SIS_TYPE | E_UniSISType
enum for the secure image signatures
typedef union S_SIS_ENABLE | S_SISEnable
information about state of the fields of the S_SIS_DATA struct
typedef struct S_SIS_DATA | S_SISData
SIS data structure.
typedef enum E_UNI_FEATURE | E_UniFeature
typedef enum E_UNI_FEATURE_STATE | E_UniFeatureState
Enumeration for feature states.
typedef enum E_UNI_CAMERA_INFO | E_UniCameraInfo
Enumeration for retrieval of camera information.
typedef enum E_UNI_FREE_MODE_INFO | E_UniFreeModeInfo
Enumeration for Format 7 Mode information used by UCC_GetFreeModeInfo.
typedef enum E_UNI_SIO_MODE | E_UniSioMode
Enumeration for I/O speed (for configuration of serial I/O communication).
typedef enum E_UNI_SIO_STOPBITS | E_UniSioStopbits
Enumeration for I/O stop bits (for configuration of serial I/O communication).
typedef enum E_UNI_SIO_PARITY | E_UniSioParity
Enumeration for I/O parity (for configuration of serial I/O communication).
typedef enum E_UNI_SIO_BAUDRATE | E_UniSioBaudRate
Enumeration for I/O speed (for configuration of serial I/O communication).
typedef enum E_UNI_1394_SPEED | E_Uni1394Speed
Enumeration for 1394 speed (needed for feature E_FEAT_PHYSPEED).
typedef enum E_UNI_IMAGE_FORMAT | E_UniImageFormat
Enumeration for target image formats.
typedef enum E_UNI_FRAME_RATE | E_UniFrameRate
Enumeration for frame rates.
typedef enum E_UNI_LOGGING | E_UniLogging
Enumeration for controlling logging.
typedef enum
E_UNI_RESOLUTION_PRESETS 		E_UniResolutionPresets
Enumeration for resolution presets.
typedef enum
E_UNI_SIMPLE_IMAGE_FORMAT 		E_UniSimpleImageFormat
Simple image type enum.
typedef struct S_UNI_IMAGE | S_UniImage
Structure for image data access supporting different formats.
typedef struct S_IIDC_VIDEOINFO_FPS | S_IIDCVideoInfoFps
Frame rates for IIDC video modes.
typedef struct
S_IIDC_VIDEOINFO_MODE 		S_IIDC_VideoInfoMode
IIDC video modes.
typedef struct
S_IIDC_VIDEOINFO_FORMAT 		S_IIDC_VideoInfoFormat
IIDC video formats.
typedef enum E_INPUTPIN_MODES | E_InputPinModes
Input Pin Modes.
typedef enum E_OUTPUTPIN_MODES | E_OutputPinModes
Output Pin Modes.
typedef enum E_UNI_LICENSE_TYPE | E_UniLicenseType
License modes of Firegrab.

Enumerations

enum | E_UNI_ROPMODE { E_ROP_SRCCPY, E_ROP_LININTERPOL }
Enumeration for raster operation (used by re sampling methods). More...
enum E_UNI_COLOR_CODE { ,
E_CC_MONO8 = 0, E_CC_YUV411, E_CC_YUV422, E_CC_YUV444,
E_CC_RGB8, E_CC_MONO16, E_CC_RGB16, E_CC_SMONO16,
E_CC_SRGB16, E_CC_RAW8, E_CC_RAW16, E_CC_MONOR = 128,
E_CC_MONOG, E_CC_MONOB, E_CC_MONO12 = 132, E_CC_RGB12,
E_CC_SMONO12, E_CC_SRGB12, E_CC_RAW12
}
Enumeration for IIDC format 7 color codes / transfer formats. More...
enum E_UNI_BAYER_PATTERN {
E_BP_AUTO = -1, E_BP_RGGB = 0, E_BP_GBRG, E_BP_GRBG,
E_BP_BGGR, E_BP_CYGM = 128, E_BP_GMCY, E_BP_CYMG,
E_BP_MGCY
}
Enumeration for the Bayer pattern. More...
enum E_UNI_FLIP_MODE { ,
E_FLIP_MODE_HORIZONTAL = 1, E_FLIP_MODE_LEFT_RIGHT = E_FLIP_MODE_HORIZONTAL, E_FLIP_MODE_VERTICAL = 2, E_FLIP_MODE_TOP_DOWN = E_FLIP_MODE_VERTICAL,
E_FLIP_MODE_BOTH = 3
}
Enumeration for the direction for flipping images. More...
enum | E_UNI_SIS_TYPE { E_SIS_NOT_PRESENT, E_SIS_MARLIN, E_SIS_PIKE }
enum for the secure image signatures More...
enum E_UNI_FEATURE {
E_FEAT_NONE = 0x0, E_FEAT_BRIGHTNESS = 0x0100, E_FEAT_AUTOEXPOSURE = 0x0101, E_FEAT_SHARPNESS = 0x0102,
E_FEAT_WHITEBALANCE_UB = 0x0103, E_FEAT_WHITEBALANCE_VR = 0x0104, E_FEAT_HUE = 0x0105, E_FEAT_SATURATION = 0x0106,
E_FEAT_GAMMA = 0x0107, E_FEAT_SHUTTER = 0x0108, E_FEAT_GAIN = 0x0109, E_FEAT_TRIGGERDELAY = 0x010a,
E_FEAT_TIMEBASE = 0x0200, E_FEAT_EXPOSUREOFFSET = 0x0201, E_FEAT_EXTENDEDSHUTTER = 0x0202, E_FEAT_LUT = 0x0203,
E_FEAT_LUT_BITSPERVAL = 0x0204, E_FEAT_LUT_MAXSIZE = 0x0205, E_FEAT_SHADING = 0x0206, E_FEAT_FRAMECOUNTER = 0x0208,
E_FEAT_COLORCORRECTION = 0x0209, E_FEAT_SOFTRESET = 0x020a, E_FEAT_XMIRRORIMAGE = 0x020b, E_FEAT_TRIGGERDELAYADV = 0x020c,
E_FEAT_DSNUCORRECTION = 0x020e, E_FEAT_BLEMISHCORRECTION = 0x020f, E_FEAT_DELAYEDINTEGRATIONENABLE = 0x0210, E_FEAT_AUTOSHUTTER_LOW = 0x0211,
E_FEAT_AUTOSHUTTER_HIGH = 0x0212, E_FEAT_AUTOGAIN_LOW = 0x0213, E_FEAT_AUTOGAIN_HIGH = 0x0214, E_FEAT_AUTOFUNCTIONAOI_XUNITS = 0x0215,
E_FEAT_AUTOFUNCTIONAOI_YUNITS = 0x0216, E_FEAT_AUTOFUNCTIONAOI_LEFT = 0x0217, E_FEAT_AUTOFUNCTIONAOI_TOP = 0x0218, E_FEAT_AUTOFUNCTIONAOI_WIDTH = 0x0219,
E_FEAT_AUTOFUNCTIONAOI_HEIGHT = 0x021a, E_FEAT_HIGHSNR = 0x021b, E_FEAT_USERPROFILE = 0x021c, E_FEAT_HDR_KNEEPOINTCOUNT = 0x021d,
E_FEAT_HDR_KNEEPOINT1 = 0x021e, E_FEAT_HDR_KNEEPOINT2 = 0x021f, E_FEAT_HDR_KNEEPOINT3 = 0x0220, E_FEAT_WHITEBALANCE_GR = 0x0221,
E_FEAT_WHITEBALANCE_MG = 0x0222, E_FEAT_WHITEBALANCE_CY = 0x0223, E_FEAT_WHITEBALANCE_YE = 0x0224, E_FEAT_REDUCEDSMEAR = 0x0225,
E_FEAT_PARAMUPDATETIMING = 0x0226, E_FEAT_SIS = 0x0227, E_FEAT_SIS_MARLIN = 0x0228, E_FEAT_SIS_PIKE = 0x0229,
E_FEAT_CAMERABUSY = 0x032a, E_FEAT_LOGGING = 0x0300, E_FEAT_LIST_ALL_CAMERAS = 0x0301, E_FEAT_STARTIMMEDIATELY = 0x0400,
E_FEAT_PHYSPEED = 0x0401, E_FEAT_FRAMEBUFFERCOUNT = 0x0402, E_FEAT_USEIRMFORBW = 0x0403, E_FEAT_FRAMEMEMORYSIZE = 0x0404,
E_FEAT_IRMFREEBW = 0x0405, E_FEAT_USEIRMFORCHN = 0x0406, E_FEAT_CAMACCEPTDELAY = 0x0407, E_FEAT_ISOCHANNEL = 0x0408,
E_FEAT_CYCLETIME = 0x0409, E_FEAT_BURSTCOUNT = 0x040a, E_FEAT_DO_BUSTRIGGER = 0x040b, E_FEAT_DO_MULTIBUSTRIGGER = 0x040c
}
enum E_UNI_FEATURE_STATE {
E_FEATSTATE_OFF = 0, E_FEATSTATE_ON = 1, E_FEATSTATE_ONEPUSH = 2, E_FEATSTATE_AUTO = 3,
E_FEATSTATE_BUSY = 4, E_FEATSTATE_SHOWIMAGE = 5, E_FEATSTATE_LOADDATA = 6, E_FEATSTATE_SAVEDATA = 7,
E_FEATSTATE_CLEARDATA = 8, E_FEATSTATE_ERROR = 9, E_FEATSTATE_UNDEFINED = 10
}
Enumeration for feature states. More...
enum E_UNI_CAMERA_INFO {
E_CAMINFO_MODEL = 0, E_CAMINFO_VENDOR, E_CAMINFO_IIDCVERSION, E_CAMINFO_SN,
E_CAMINFO_ORDERID, E_CAMINFO_MCVERSION, E_CAMINFO_FPGAVERSION, E_CAMINFO_CUSTOMERKEY,
E_CAMINFO_MAXWIDTH = 20, E_CAMINFO_MAXHEIGHT, E_CAMINFO_MAXDEPTH, E_CAMINFO_COLORCAMERA,
E_CAMINFO_BAYERPATTERN, E_CAMINFO_INTERLACED, E_CAMINFO_SISTYPE
}
Enumeration for retrieval of camera information. More...
enum E_UNI_FREE_MODE_INFO {
E_FREE_MODE_WIDTH = 0, E_FREE_MODE_HEIGHT = 1, E_FREE_MODE_PIXELCOUNT = 2, E_FREE_MODE_BYTE_PER_FRAME = 3,
E_FREE_MODE_UNIT_SIZE_H = 4, E_FREE_MODE_UNIT_SIZE_V = 5, E_FREE_MODE_UNIT_POS_H = 6, E_FREE_MODE_UNIT_POS_V = 7
}
Enumeration for Format 7 Mode information used by UCC_GetFreeModeInfo. More...
enum | E_UNI_SIO_MODE { E_SIOMODE_DISABLED = 0, E_SIOMODE_RECEIVE, E_SIOMODE_TRANSMIT, E_SIOMODE_RECEIVETRANSMIT }
Enumeration for I/O speed (for configuration of serial I/O communication). More...
enum | E_UNI_SIO_STOPBITS { E_SIOSTOPBITS_1 = 0, E_SIOSTOPBITS_1_5, E_SIOSTOPBITS_2 }
Enumeration for I/O stop bits (for configuration of serial I/O communication). More...
enum | E_UNI_SIO_PARITY { E_SIOPARITY_NONE = 0, E_SIOPARITY_ODD, E_SIOPARITY_EVEN }
Enumeration for I/O parity (for configuration of serial I/O communication). More...
enum E_UNI_SIO_BAUDRATE {
E_SIOBAUDRATE_300 = 0, E_SIOBAUDRATE_600, E_SIOBAUDRATE_1200, E_SIOBAUDRATE_2400,
E_SIOBAUDRATE_4800, E_SIOBAUDRATE_9600, E_SIOBAUDRATE_19200, E_SIOBAUDRATE_38400,
E_SIOBAUDRATE_57600, E_SIOBAUDRATE_115200, E_SIOBAUDRATE_230400
}
Enumeration for I/O speed (for configuration of serial I/O communication). More...
enum E_UNI_1394_SPEED {
E_SPEED_AUTO = -1, E_SPEED100 = 0, E_SPEED200, E_SPEED400,
E_SPEED800, E_SPEED_LAST
}
Enumeration for 1394 speed (needed for feature E_FEAT_PHYSPEED). More...
enum E_UNI_IMAGE_FORMAT {
E_IF_MONO8 = 0, E_IF_BGR, E_IF_ABGR, E_IF_RGB_PLANES,
E_IF_RGBY_PLANES, E_IF_NATIVE
}
Enumeration for target image formats. More...
enum E_UNI_FRAME_RATE {
E_FR_1_875 = 0, E_FR_3_75, E_FR_7_5, E_FR_15,
E_FR_30, E_FR_60, E_FR_120, E_FR_240
}
Enumeration for frame rates. More...
enum E_UNI_LOGGING {
E_LOG_FATAL = 0, E_LOG_ERROR, E_LOG_WARNING, E_LOG_INFO,
E_LOG_DEBUG, E_LOG_LEVELMASK = 7
}
Enumeration for controlling logging. More...
enum E_UNI_RESOLUTION_PRESETS { ,
E_PRESET_QVGA = 0, E_PRESET_VGA, E_PRESET_PAL, E_PRESET_SVGA,
E_PRESET_XGA, E_PRESET_XVGA, E_PRESET_SXGAP, E_PRESET_UXGA,
E_PRESET_QXGA, E_PRESET_SXGA, E_PRESET_QSXGA, E_PRESET_WVGA,
E_PRESET_HD720, E_PRESET_HD1080, E_PRESET_DC2K, E_PRESET_DC4K
}
Enumeration for resolution presets. More...
enum E_UNI_SIMPLE_IMAGE_FORMAT {
E_SIF_MONO8_REC601, E_SIF_BGR24, E_SIF_BGRA32, E_SIF_MONO8_REC709,
E_SIF_UYVY
}
Simple image type enum. More...
enum | E_INPUTPIN_MODES { E_IPINMODE_OFF = 0x00, E_IPINMODE_TRIGGER = 0x02 }
Input Pin Modes. More...
enum E_OUTPUTPIN_MODES {
E_OPINMODE_OFF = 0x00, E_OPINMODE_PINSTATE = 0x01, E_OPINMODE_INTENA = 0x02, E_OPINMODE_FRAMEVALID = 0x06,
E_OPINMODE_BUSY = 0x07, E_OPINMODE_FOLLOW_IN = 0x08
}
Output Pin Modes. More...
enum E_UNI_LICENSE_TYPE {
E_LT_NOLICENSE = 0, E_LT_CARDGUID = 1, E_LT_HARDDISK = 2, E_LT_ETHERNET = 3,
E_LT_VENDOR = 4, E_LT_DATELIMITED = 5, E_LT_DEVICE = 6, E_T_FRAMELIMITED = 7
}
License modes of Firegrab. More...


AVT Universal API - Camera Control module: uni_notification.h File Reference

uni_notification.h File Reference

Detailed Description

defines for API notifications.

Version:
1.1
Date:
03-03-2008
Author:
Matthias Heidenreich, Holger Eddelbuettel
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_defines.h"
#include "windows.h"

Data Structures

struct | S_UNI_CALLBACK_ARGUMENT
Callback function argument. More...
struct | S_UNI_NOTIFICATION_CALLBACK
Notification Callback struct. More...
struct | S_UNI_NOTIFICATION_EVENT
Win API event notification. More...
struct | S_UNI_WINDOWS_MESSAGE
Windows message to send on notification. More...
struct | S_UNI_NOTIFICATION
uni api notification. More...

Typedefs

typedef UINT32_TYPE | UNI_NOTIFICATION_HANDLE
Declaration of the notification handle.

Enumerations

enum | E_UNI_NOTIFICATION_TYPE { E_UNI_NOTIFICATION_CALLBACK, E_UNI_NOTIFICATION_EVENT, E_UNI_NOTIFICATION_MESSAGE, E_UNI_NOTIFICATION_NO_TYPE }
Enumeration to id the notification type. More...
enum E_UNI_NOTIFICATION_EVENTS {
E_UNI_NOTIFICATION_NODELIST_CHANGED, E_UNI_NOTIFICATION_ERROR_BUS, E_UNI_NOTIFICATION_FRAME_READY, E_UNI_NOTIFICATION_FRAME_START,
E_UNI_NOTIFICATION_FRAME_DROPPED, E_UNI_NOTIFICATION_ERROR_FRAME, E_UNI_NOTIFICATION_ERROR_DMA, E_UNI_NOTIFICATION_ERROR_MISC
}
Events you can register a notification for. More...

Functions

typedef | VOID_TYPE (__cdecl *UNI_NOTIFICATION_CALLBACK_FUNCTION)(S_UNI_CALLBACK_ARGUMENT)
Declaration of callback type.


AVT Universal API - Camera Control module: uni_types.h File Reference

uni_types.h File Reference

Detailed Description

Definitions for the types used in the Universal API methods.

This file describes all necessary type definitions for using methods of AVT's Universal API. These type definitions are designed to be portable in the sense of Microsoft, means: also usable in VB and C#.

Version:
1.1
Date:
03-Mar-2008
Author:
Matthias Heidenreich, Holger Eddelbuettel
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

Typedefs

typedef UINT64_TYPE | __1394GUID
typedef void * | PRESETS_ENUMERATION
Type for an enumeration of presets.
typedef void * | COLORCODE_ENUMERATION
Type for an enumeration of color codes.
Basic types used to define the types really used
Don't use these typedefs directly!

typedef short | int16_t
16 bit signed integer on non-Microsoft systems
typedef int | int32_t
32 bit signed integer on non-Microsoft systems
typedef long long | int64_t
64 bit signed integer on non-Microsoft systems
typedef unsigned short | uint16_t
16 bit unsigned integer on non-Microsoft systems
typedef unsigned int | uint32_t
32 bit unsigned integer on non-Microsoft systems
typedef unsigned long long | uint64_t
64 bit unsigned integer on non-Microsoft systems
Portable types.
Use these types.

typedef signed char | INT8_TYPE
8 bit signed integer
typedef signed char | INT8_IN_TYPE
8 bit signed integer type for input
typedef INT8_IN_TYPE * | INT8_INOUT_TYPE
8 bit signed integer type for input and output
typedef INT8_IN_TYPE * | INT8_OUT_TYPE
8 bit signed integer type for output
typedef int16_t | INT16_TYPE
16 bit signed integer
typedef int16_t | INT16_IN_TYPE
16 bit signed integer type for input
typedef INT16_IN_TYPE * | INT16_INOUT_TYPE
16 bit signed integer type for input and output
typedef INT16_IN_TYPE * | INT16_OUT_TYPE
16 bit signed integer type for output
typedef int32_t | INT32_TYPE
32 bit signed integer
typedef int32_t | INT32_IN_TYPE
32 bit signed integer type for input
typedef INT32_IN_TYPE * | INT32_INOUT_TYPE
32 bit signed integer type for input and output
typedef INT32_IN_TYPE * | INT32_OUT_TYPE
32 bit signed integer type for output
typedef int64_t | INT64_TYPE
64 bit signed integer
typedef int64_t | INT64_IN_TYPE
64 bit signed integer type for input
typedef INT64_IN_TYPE * | INT64_INOUT_TYPE
64 bit signed integer type for input and output
typedef INT64_IN_TYPE * | INT64_OUT_TYPE
64 bit signed integer type for output
typedef unsigned char | UINT8_TYPE
8 bit unsigned integer
typedef unsigned char | UINT8_IN_TYPE
8 bit unsigned integer type for input
typedef UINT8_IN_TYPE * | UINT8_INOUT_TYPE
8 bit unsigned integer type for input and output
typedef UINT8_IN_TYPE * | UINT8_OUT_TYPE
8 bit unsigned integer type for output
typedef uint16_t | UINT16_TYPE
16 bit unsigned integer
typedef uint16_t | UINT16_IN_TYPE
16 bit unsigned integer type for input
typedef UINT16_IN_TYPE * | UINT16_INOUT_TYPE
16 bit unsigned integer type for input and output
typedef UINT16_IN_TYPE * | UINT16_OUT_TYPE
16 bit unsigned integer type for output
typedef uint32_t | UINT32_TYPE
32 bit unsigned integer
typedef uint32_t | UINT32_IN_TYPE
32 bit unsigned integer type for input
typedef UINT32_IN_TYPE * | UINT32_INOUT_TYPE
32 bit unsigned integer type for input and output
typedef UINT32_IN_TYPE * | UINT32_OUT_TYPE
32 bit unsigned integer type for output
typedef uint64_t | UINT64_TYPE
64 bit unsigned integer
typedef uint64_t | UINT64_IN_TYPE
64 bit unsigned integer type for input
typedef UINT64_IN_TYPE * | UINT64_INOUT_TYPE
64 bit unsigned integer type for input and output
typedef UINT64_IN_TYPE * | UINT64_OUT_TYPE
64 bit unsigned integer type for output
typedef float | FLOAT_TYPE
4 byte floating point
typedef float | FLOAT_IN_TYPE
4 byte floating point type for input
typedef FLOAT_IN_TYPE * | FLOAT_INOUT_TYPE
4 byte floating point type for input and output
typedef FLOAT_IN_TYPE * | FLOAT_OUT_TYPE
4 byte floating point type for output
typedef double | DOUBLE_TYPE
8 byte floating point
typedef double | DOUBLE_IN_TYPE
8 byte floating point type for input
typedef DOUBLE_IN_TYPE * | DOUBLE_INOUT_TYPE
8 byte floating point type for input and output
typedef DOUBLE_IN_TYPE * | DOUBLE_OUT_TYPE
8 byte floating point type for output
typedef UINT32_IN_TYPE | BOOL_IN_TYPE
BOOL type for input.
typedef BOOL_IN_TYPE * | BOOL_INOUT_TYPE
"bool" type for input and output
typedef BOOL_IN_TYPE * | BOOL_OUT_TYPE
"bool" type for output
typedef void | VOID_TYPE
void type
typedef VOID_TYPE * | VOID_POINTER
pointer to void tyype
typedef size_t | POINTER_SIZE
size of a pointer system dependent
Character types.
Types for character handling.

typedef unsigned short | wchar_t
if not defined wchar_t define it
typedef char | UNICODE_CHAR
char type dependent on the UNICODE define multi byte or single byte
typedef UNICODE_CHAR | CHAR_IN_TYPE
typedef UNICODE_CHAR | CHAR_TYPE
string type will change with UNICODE builds from char to wchar_t
typedef CHAR_TYPE * | CHAR_INOUT_TYPE
a valid pointer to a mutable char/wchar_t as, will take values into a function and return the result
typedef CHAR_TYPE * | CHAR_OUT_TYPE
a valid pointer to a char/wchar_t, will return results from a function
typedef wchar_t | WCHAR_TYPE
typedef wchar_t | WCHAR_IN_TYPE
string with wide char
typedef WCHAR_TYPE * | WCHAR_INOUT_TYPE
valid pointer to a mutable wchar_t, will take values into a function and return the ressult.
typedef WCHAR_TYPE * | WCHAR_OUT_TYPE
valid pointer to a wchar_t, will return results from a function
typedef char | ACHAR_TYPE
typedef char | ACHAR_IN_TYPE
string of 8bit ASCII chars
typedef ACHAR_TYPE * | ACHAR_INOUT_TYPE
8bit ASCII char string taking values int a function and returning a result
typedef ACHAR_TYPE * | ACHAR_OUT_TYPE
8bit ASCII string returning a result from a function
Special types.
Types for special purposes.

typedef long | HRESULT
Definition just in case HRESULT is not defined (and winnt.h should not be included).
typedef HRESULT | UNI_RETURN_TYPE
Return value for all the methods of the API.
typedef UINT32_IN_TYPE | ID_TYPE
Type for identifying a camera.
typedef void * | COLOR_CORRECTION_HANDLE
A handle for a color correction object to be used during debayering.


AVT Universal API - Camera Control module: UniControl.h File Reference

UniControl.h File Reference

Detailed Description

This file describes all the available AVT Universal API Camera Control methods.

All the AVT Universal API methods for controlling cameras that are publicly available are described in this part of the help. For a description see the section "Getting started " of this help.

Version:
1.9
Date:
19-10-2008
Author:
Philipp Beyer, Holger Eddelbuettel, Matthias Heidenreich, Olaf Reuter
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_defines.h"
#include "uni_notification.h"

Functions

Non-camera methods.
A set of methods to deal with all actions not directly related to cameras.

UNI_RETURN_TYPE UCC_Init ()
Initialization of the API.
UNI_RETURN_TYPE UCC_Release ()
Deinitialization of the API.
UNI_RETURN_TYPE | UCC_GetVersion (UINT32_OUT_TYPE pnValue)
Get the version number of the API.
UNI_RETURN_TYPE | UCC_GetLicenseType_Global (UINT32_OUT_TYPE pnUniLicenseType)
get the api global fire grab license information.
UNI_RETURN_TYPE | UCC_GetLicenseType (ID_TYPE CamId, UINT32_OUT_TYPE pnUniLicenseType)
get active fire grab license information for the camera.
UNI_RETURN_TYPE | UCC_GetErrorInfo (UNI_RETURN_TYPE nErrCode, ACHAR_INOUT_TYPE pszInfoString, UINT32_IN_TYPE nMaxStrLen)
Get error information.
UNI_RETURN_TYPE | UCC_GetCameras (UINT32_INOUT_TYPE pnSize, UINT32_OUT_TYPE vecIds)
Count connected Cameras and return an array of camera IDs, if desired.
UNI_RETURN_TYPE | UCC_GetCamerasEx (UINT32_INOUT_TYPE pnSize, UINT32_OUT_TYPE vecIds, UINT32_OUT_TYPE vecExtraInfo)
Count connected Cameras and return arrays of camera IDs and extra information, if desired.
UNI_RETURN_TYPE | UCC_WaitForBusReset (UINT32_OUT_TYPE vecSNs, UINT32_INOUT_TYPE pCount, UINT32_IN_TYPE lTimeOut, UINT32_OUT_TYPE pRetErr)
Wait for a bus reset.
UNI_RETURN_TYPE | UCC_CloseAllCameras (void)
Close all cameras.
UNI_RETURN_TYPE | UCC_DisconnectAllCameras (void)
Disconnect all cameras.
UNI_RETURN_TYPE | UCC_ReconnectAllCameras (UINT32_IN_TYPE bAutoReLoadSettings)
Reconnect all cameras.
UNI_RETURN_TYPE | UCC_CreateUserLog (UINT32_IN_TYPE nMaxLevel, const ACHAR_TYPE *pszFileName)
Create a user log file.
UNI_RETURN_TYPE | UCC_WriteUserLog (UINT32_IN_TYPE nLevel, const ACHAR_TYPE *pszMsg)
Log a message.
UNI_RETURN_TYPE | UCC_GetBitsPerPixel (UINT32_IN_TYPE ColorCode, UINT32_OUT_TYPE BitsPerPixel)
Get the number of pixels required for the transport of an image with the given color coding.
Notification methods.
A set of methods to deal with user notifications

UNI_RETURN_TYPE | UCC_RegisterNodeListChangedNotification (UNI_NOTIFICATION_HANDLE *pHandle, S_UNI_NOTIFICATION *pNotification)
Register a notification object for 'node list changed' events (bus reset end).
UNI_RETURN_TYPE | UCC_RegisterFrameStartNotification (UNI_NOTIFICATION_HANDLE *pHandle, S_UNI_NOTIFICATION *pNotification)
Register a notification object for 'frame start' events.
UNI_RETURN_TYPE | UCC_RegisterFrameReadyNotification (UNI_NOTIFICATION_HANDLE *pHandle, S_UNI_NOTIFICATION *pNotification)
Register a notification object for 'frame ready' events.
UNI_RETURN_TYPE | UCC_RegisterFrameDroppedNotification (UNI_NOTIFICATION_HANDLE *pHandle, S_UNI_NOTIFICATION *pNotification)
Register a notification object for 'frame dropped' events.
UNI_RETURN_TYPE | UCC_RegisterNotification (UNI_NOTIFICATION_HANDLE *pHandle, E_UNI_NOTIFICATION_EVENTS NotificationEvent, S_UNI_NOTIFICATION *pNotification)
Register a notification object for a specified event type.
UNI_RETURN_TYPE | UCC_UnRegisterNotification (UNI_NOTIFICATION_HANDLE Handle)
Unregister a single notification object registration.
Camera methods.
A set of methods to deal with all actions related to cameras in general.

UNI_RETURN_TYPE | UCC_OpenCamera (ID_TYPE CamId, INT32_IN_TYPE lSpeedLimit=-1)
Open a Camera.
UNI_RETURN_TYPE | UCC_OpenCameraEx (ID_TYPE CamId, INT32_TYPE CardNr, INT32_IN_TYPE lSpeedLimit=-1)
Open a camera with extended functionality.
UNI_RETURN_TYPE | UCC_CloseCamera (ID_TYPE CamId)
Close a specific camera.
Camera information methods.
A set of methods to get information about the camera.

UNI_RETURN_TYPE | UCC_CheckAvailable (ID_TYPE CamId, UINT32_OUT_TYPE pbResult)
Check if a camera is currently available.
UNI_RETURN_TYPE | UCC_GetCameraInfo (ID_TYPE CamId, UINT32_IN_TYPE nId, UINT32_INOUT_TYPE pnValue)
Get numerical information about the specified camera.
UNI_RETURN_TYPE | UCC_GetCameraInfoString (ID_TYPE CamId, UINT32_IN_TYPE nId, ACHAR_INOUT_TYPE pszInfoString, UINT32_INOUT_TYPE pLength)
Get textual information about the specified camera.
UNI_RETURN_TYPE | UCC_GetCameraCapabilities (ID_TYPE CamId, UINT32_OUT_TYPE pnMaxImageWidth, UINT32_OUT_TYPE pnMaxImageHeight, UINT32_OUT_TYPE pbColorInfo, UINT32_OUT_TYPE pnMaxImageDepth)
Tell fundamental camera capabilities.
UNI_RETURN_TYPE | UCC_GetCurrentImageFormat (ID_TYPE CamId, UINT32_OUT_TYPE pnImageWidth, UINT32_OUT_TYPE pnImageHeight, UINT32_OUT_TYPE pnColorCoding, UINT32_OUT_TYPE pnImageDepth)
Get current image format properties.
UNI_RETURN_TYPE | UCC_GetCurrentFixedFormat (ID_TYPE CamId, UINT32_OUT_TYPE pFormat, UINT32_OUT_TYPE pMode, UINT32_OUT_TYPE pFpsColId)
Get current IIDC format properties.
UNI_RETURN_TYPE | UCC_GetFreeModeInfo (ID_TYPE CamId, UINT32_TYPE nMode, UINT32_TYPE nParamId, UINT32_OUT_TYPE pnValue)
Retrieve information about the free format (IIDC:format 7) parameters of a given mode.
UNI_RETURN_TYPE | UCC_EnumFreeModes (ID_TYPE CamId, UINT32_INOUT_TYPE pnPos, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnColorId, UINT32_OUT_TYPE pnXMax, UINT32_OUT_TYPE pnYMax)
Enumerate through available free/scalable image formats.
Image acquisition.
A set of methods to deal with the acquisition of images

UNI_RETURN_TYPE | UCC_PrepareFreeGrab (ID_TYPE CamId, UINT32_INOUT_TYPE pMode, UINT32_INOUT_TYPE pColorFormatId, UINT32_INOUT_TYPE pWidth, UINT32_INOUT_TYPE pHeight, UINT32_INOUT_TYPE pBufferCount, UINT32_INOUT_TYPE pXOffset, UINT32_INOUT_TYPE pYOffset, UINT32_INOUT_TYPE pBusLoad)
Prepare camera for format-free image acquisition.
UNI_RETURN_TYPE | UCC_GetSupportedFixedFormats (ID_TYPE CamId, S_IIDC_VIDEOINFO_FORMAT *pFormats)
Query the Supported IIDC video modes of a camera.
UNI_RETURN_TYPE | UCC_PrepareFixedGrab (ID_TYPE CamId, UINT32_IN_TYPE nFormat, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nFpsId)
Prepare camera for image acquisition.
UNI_RETURN_TYPE | UCC_GetAOI (ID_TYPE CamId, UINT32_OUT_TYPE pLeft, UINT32_OUT_TYPE pTop, UINT32_OUT_TYPE pWidth, UINT32_OUT_TYPE pHeight)
Get the AOI for the current free IIDC mode (Format 7) Every AOI parameter may be omitted.
UNI_RETURN_TYPE | UCC_GetFreeBandwidth (ID_TYPE CamId, UINT32_OUT_TYPE pnBandwidth)
Get the free bandwidth.
UNI_RETURN_TYPE | UCC_GrabImage (ID_TYPE CamId, S_UNI_IMAGE *psImage, UINT32_OUT_TYPE pbIsColor, UINT32_IN_TYPE nTimeOut)
Grab an image synchronously.
UNI_RETURN_TYPE | UCC_GrabBitmapImage (ID_TYPE CamId, UINT8_OUT_TYPE pImage, UINT32_OUT_TYPE pbIsColor, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Grab data synchronously into a Windows bitmap.
UNI_RETURN_TYPE | UCC_GrabPlanesImage (ID_TYPE CamId, UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, UINT32_OUT_TYPE pbIsColor, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Grab data synchronously to a planes image.
UNI_RETURN_TYPE | UCC_GrabNativeImage (ID_TYPE CamId, UINT8_OUT_TYPE pImage, UINT32_OUT_TYPE pbIsColor, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Grab data synchronously to a bitmap image that will receive the raw transfer image.
UNI_RETURN_TYPE | UCC_GrabStart (ID_TYPE CamId, UINT32_IN_TYPE nTimeOut)
Start grabbing images asynchronously.
UNI_RETURN_TYPE | UCC_MultiShotStart (ID_TYPE CamId, UINT32_IN_TYPE nGrabCount)
Start multi shot image grabbing asynchronously.
UNI_RETURN_TYPE | UCC_MultiShotStop (ID_TYPE CamId)
Stopping a running multi shot.
UNI_RETURN_TYPE | UCC_GrabStop (ID_TYPE CamId, UINT32_IN_TYPE nStopOption)
Stops the grabbing of images.
UNI_RETURN_TYPE | UCC_GetImage (ID_TYPE CamId, S_UNI_IMAGE *psImage, UINT32_IN_TYPE nTimeOut)
Request an image from the async receive buffer.
UNI_RETURN_TYPE | UCC_GetBitmapImage (ID_TYPE CamId, UINT8_OUT_TYPE pImage, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Request a bitmap from the async receive buffer
Uses a byte pointer for the target image.
UNI_RETURN_TYPE | UCC_GetPlanesImage (ID_TYPE CamId, UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Request a planes image from async receive buffer
Uses byte pointers for all the target planes.
UNI_RETURN_TYPE | UCC_GetNativeImage (ID_TYPE CamId, UINT8_OUT_TYPE pImage, UINT32_IN_TYPE nTimeOut, S_SIS_DATA *pSISData=0)
Request a image data from the async receive buffer as transmitted over the firewire bus.
Camera configuration.
A set of methods to deal with camera features and how to set them.

UNI_RETURN_TYPE | UCC_LoadSettings (ID_TYPE CamId, const ACHAR_TYPE *pszFileName, UINT32_IN_TYPE nUseOnlyTypeInfo)
Load the camera settings from file.
UNI_RETURN_TYPE | UCC_SaveSettings (ID_TYPE CamId, const ACHAR_TYPE *pszFileName)
Save the camera setting.
UNI_RETURN_TYPE | UCC_SaveSettingsEx (ID_TYPE CamId, const ACHAR_TYPE *pszFileName, UINT32_TYPE bSaveByCameraFamily)
Save the camera setting.
UNI_RETURN_TYPE | UCC_SetRegister (ID_TYPE CamId, UINT32_IN_TYPE uAddress, UINT32_IN_TYPE uValue)
Set the given register value.
UNI_RETURN_TYPE | UCC_GetRegister (ID_TYPE CamId, UINT32_IN_TYPE uAddress, UINT32_OUT_TYPE pnValue)
Get the value of the given register.
UNI_RETURN_TYPE | UCC_WriteBlock (ID_TYPE CamId, UINT32_IN_TYPE uAddress, UINT32_IN_TYPE *pnValue, UINT32_IN_TYPE uLength)
Write memory block to camera.
UNI_RETURN_TYPE | UCC_ReadBlock (ID_TYPE CamId, UINT32_IN_TYPE uAddress, UINT32_OUT_TYPE pnValue, UINT32_IN_TYPE uLength)
Read memory block from camera.
UNI_RETURN_TYPE | UCC_HasFeature (ID_TYPE CamId, UINT32_IN_TYPE nFeature)
Check whether a specific 'unified feature' is supported by the camera.
UNI_RETURN_TYPE | UCC_HasFeatureStatus (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_IN_TYPE nState)
Check whether a specific state is supported for the mentioned feature.
UNI_RETURN_TYPE | UCC_GetFeatureStatus (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_OUT_TYPE pnState)
Get the status of the mentioned feature.
UNI_RETURN_TYPE | UCC_SetFeatureStatus (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_IN_TYPE nState)
Set the status of the mentioned feature.
UNI_RETURN_TYPE | UCC_GetFeatureValue (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_OUT_TYPE pnValue)
Get the value of the mentioned feature.
UNI_RETURN_TYPE | UCC_SetFeatureValue (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_IN_TYPE nValue)
Set the value of the mentioned feature.
UNI_RETURN_TYPE | UCC_GetFeatureMin (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_OUT_TYPE pnValue)
Get the minimum value of the mentioned feature.
UNI_RETURN_TYPE | UCC_GetFeatureMax (ID_TYPE CamId, UINT32_IN_TYPE nFeature, UINT32_OUT_TYPE pnValue)
Get the maximum value of the mentioned feature.
UNI_RETURN_TYPE | UCC_GetStreamSpeedMax (ID_TYPE CamId, UINT32_OUT_TYPE nMaxSpeed)
Get maximum speed for image streaming.
UNI_RETURN_TYPE | UCC_GetStreamSpeed (ID_TYPE CamId, UINT32_OUT_TYPE pnSpeed)
Get current speed for image streaming.
UNI_RETURN_TYPE | UCC_SetStreamSpeed (ID_TYPE CamId, UINT32_IN_TYPE nSpeed)
Set speed for image streaming.
AVT-specific camera features.
A set of methods to deal with AVT-specific camera features.

UNI_RETURN_TYPE | UCC_Lut_GetInfo (ID_TYPE CamId, UINT32_OUT_TYPE pnNumOfLuts, UINT32_OUT_TYPE pnMaxValue, UINT32_OUT_TYPE pnNumOfValues, UINT32_OUT_TYPE pnMaxDataSize)
Get a number of details about the look-up table feature.
UNI_RETURN_TYPE | UCC_Lut_GetStatus (ID_TYPE CamId, UINT32_OUT_TYPE pbActive, UINT32_OUT_TYPE pnLutIndex)
Get the current status of the LUT feature.
UNI_RETURN_TYPE | UCC_Lut_Use (ID_TYPE CamId, UINT32_IN_TYPE nLutNo, UINT32_IN_TYPE nActive)
Use the given look-up table and set the status.
UNI_RETURN_TYPE | UCC_Lut_Upload (ID_TYPE CamId, UINT32_IN_TYPE nLutNr, UINT8_TYPE *arrValue, UINT32_IN_TYPE nSize)
Upload the given LUT.
UNI_RETURN_TYPE | UCC_Lut_LoadFromCsv (ID_TYPE CamId, const ACHAR_TYPE *pszPath, UINT32_IN_TYPE nLength, UINT32_IN_TYPE nLutNr, UINT32_IN_TYPE nCvsPos)
Load LUT to camera from CSV file.
UNI_RETURN_TYPE | UCC_Shading_GetInfo (ID_TYPE CamId, UINT32_OUT_TYPE puSizeMax)
Get information about the capabilities of the shading correction feature.
UNI_RETURN_TYPE | UCC_Shading_Upload (ID_TYPE CamId, UINT8_TYPE *pImage, UINT32_IN_TYPE nImageSize)
Upload shading correction image data into the camera.
UNI_RETURN_TYPE | UCC_Shading_Download (ID_TYPE CamId, UINT8_TYPE *pImage, UINT32_INOUT_TYPE pnImageSize)
Download shading correction image data from the camera.
UNI_RETURN_TYPE | UCC_Shading_Build (ID_TYPE CamId, UINT32_IN_TYPE nFrames, UINT32_IN_TYPE nBlock)
Invoke the build operation of a shading image inside the camera.
UNI_RETURN_TYPE | UCC_InputPin_Get (ID_TYPE CamId, UINT32_IN_TYPE nWhich, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnPolarity, UINT32_OUT_TYPE pnState)
Get state of input pins.
UNI_RETURN_TYPE | UCC_InputPin_Set (ID_TYPE CamId, UINT32_IN_TYPE nWhich, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nPolarity)
Set state of input pins.
UNI_RETURN_TYPE | UCC_OutputPin_Get (ID_TYPE CamId, UINT32_IN_TYPE nWhich, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnPolarity, UINT32_OUT_TYPE pnState)
Get state of output pins.
UNI_RETURN_TYPE | UCC_OutputPin_Set (ID_TYPE CamId, UINT32_IN_TYPE nWhich, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nPolarity, UINT32_IN_TYPE nState)
Set state of output pins.
UNI_RETURN_TYPE | UCC_SerialIO_SetConfig (ID_TYPE CamId, UINT32_IN_TYPE nBaudRate, UINT32_IN_TYPE nCharLength, UINT32_IN_TYPE nParity, UINT32_IN_TYPE nStopBit, UINT32_IN_TYPE nMode)
Configure the serial communication.
UNI_RETURN_TYPE | UCC_SerialIO_GetConfig (ID_TYPE CamId, UINT32_OUT_TYPE pnBaudRate, UINT32_OUT_TYPE pnCharLength, UINT32_OUT_TYPE pnParity, UINT32_OUT_TYPE pnStopBit, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnBufferSize)
Get the configuration of the serial interface.
UNI_RETURN_TYPE | UCC_SerialIO_Transmit (ID_TYPE CamId, UINT8_TYPE *pnData, UINT32_INOUT_TYPE pnLength, UINT32_IN_TYPE nTimeout)
Transmit data via the cameras serial IO interface.
UNI_RETURN_TYPE | UCC_SerialIO_ReceiveInfo (ID_TYPE CamId, UINT32_OUT_TYPE pbRxStatus, UINT32_OUT_TYPE puBytesPending)
get information of the internal state of the SIO receiver.
UNI_RETURN_TYPE | UCC_SerialIO_Receive (ID_TYPE CamId, UINT8_TYPE *pnData, UINT32_INOUT_TYPE pnLength, UINT32_IN_TYPE nTimeout)
Receive data via the cameras serial IO interface.
UNI_RETURN_TYPE | UCC_AutoFunctionAOI_Set (ID_TYPE CamId, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nLeft, UINT32_IN_TYPE nTop, UINT32_IN_TYPE nWidth, UINT32_IN_TYPE nHeight)
Configure the Autofunction AOI.
UNI_RETURN_TYPE | UCC_AutoFunctionAOI_Get (ID_TYPE CamId, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnLeft, UINT32_OUT_TYPE pnTop, UINT32_OUT_TYPE pnWidth, UINT32_OUT_TYPE pnHeight)
Get the current status of the Autofunction AOI feature.
UNI_RETURN_TYPE | UCC_Whitebalance_Set (ID_TYPE CamId, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nUBVal, UINT32_IN_TYPE nVRVal)
Configure the Whitebalance.
UNI_RETURN_TYPE | UCC_Whitebalance_Get (ID_TYPE CamId, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnUBVal, UINT32_OUT_TYPE pnVRVal)
Get the status of the whitebalance feature.
UNI_RETURN_TYPE | UCC_Whitebalance_GMCY_Set (ID_TYPE CamId, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nGr_CyVal, UINT32_IN_TYPE nMg_YeVal, UINT32_IN_TYPE nCy_MgVal, UINT32_IN_TYPE nYe_GrVal)
Configure the Whitebalance for GMCY sensors.
UNI_RETURN_TYPE | UCC_Whitebalance_GMCY_Get (ID_TYPE CamId, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnGr_CyVal, UINT32_OUT_TYPE pnMg_YeVal, UINT32_OUT_TYPE pnCy_MgVal, UINT32_OUT_TYPE pnYe_GrVal)
Get the status of the whitebalance feature for GMCY sensors Parameters the caller is not interested in may be set to NULL.
UNI_RETURN_TYPE | UCC_UserProfile_Load (ID_TYPE CamId, UINT32_IN_TYPE nProfileID)
Load a user profile from camera memory.
UNI_RETURN_TYPE | UCC_UserProfile_Save (ID_TYPE CamId, UINT32_IN_TYPE nProfileID)
Save a user profile to camera memory.
UNI_RETURN_TYPE | UCC_UserProfile_SetDefault (ID_TYPE CamId, UINT32_IN_TYPE nProfileID)
Set the default user profile id.
UNI_RETURN_TYPE | UCC_UserProfile_GetErrorStatus (ID_TYPE CamId, UINT32_OUT_TYPE pnErrorCode)
Get the user profile error status.
UNI_RETURN_TYPE | UCC_UserProfile_GetInfo (ID_TYPE CamId, UINT32_OUT_TYPE pnProfileID, UINT32_OUT_TYPE pnProfileCount)
Get the currently selected user profile id.
UNI_RETURN_TYPE | UCC_Trigger_Get (ID_TYPE CamId, UINT32_OUT_TYPE pnMode, UINT32_OUT_TYPE pnActive, UINT32_OUT_TYPE pnPolarity, UINT32_OUT_TYPE pnValue)
Get the current configuration of the trigger feature.
UNI_RETURN_TYPE | UCC_Trigger_Set (ID_TYPE CamId, UINT32_IN_TYPE nMode, UINT32_IN_TYPE nActive, UINT32_IN_TYPE nPolarity)
Configure the trigger feature.
UNI_RETURN_TYPE | UCC_TestImage_GetInfo (ID_TYPE CamId, UINT32_OUT_TYPE pnImageNr, UINT32_OUT_TYPE pnImageCount)
Get information about the test image feature.
UNI_RETURN_TYPE | UCC_TestImage_Set (ID_TYPE CamId, UINT32_IN_TYPE nImageNr)
Set the active test image.
UNI_RETURN_TYPE | UCC_ParamUpdate_Begin (ID_TYPE CamId)
Start a configuration update procedure that may consist of several configuration changes, which will take effect simultaneously when UCC_ParamUpdate_Apply is called.
UNI_RETURN_TYPE | UCC_ParamUpdate_Apply (ID_TYPE CamId)
Finish a configuration update procedure that has been started by UCC_ParamUpdate_Begin and apply all changes simultaneously.
UNI_RETURN_TYPE | UCC_SetFeatureList (ID_TYPE CamId, UINT32_IN_TYPE *pnListPtr, UINT32_IN_TYPE nNumOfEntries, UINT32_OUT_TYPE pnErronousItem=NULL)
Apply a list of feature configuration changes simultaneously.
UNI_RETURN_TYPE | UCC_SetRegisterList (ID_TYPE CamId, UINT32_IN_TYPE *pnListPtr, UINT32_INOUT_TYPE pnNumOfEntries)
Apply a list of direct register writes simultaneously.
UNI_RETURN_TYPE | UCC_GetRegisterListInfo (ID_TYPE CamId, UINT32_OUT_TYPE pnMaxNumOfEntries)
Provides information about the cameras 'register list update' feature.
Resolution enumeration methods.
A group of methods for enumerating the resolutions of a camera.

UNI_RETURN_TYPE | UCC_PresetToResolution (UINT32_IN_TYPE Preset, UINT32_OUT_TYPE Width, UINT32_OUT_TYPE Height)
Convert a preset to Width and Height.
UNI_RETURN_TYPE | UCC_CreatePresetsEnum (ID_TYPE CamId, PRESETS_ENUMERATION *PresetsEnum, UINT32_OUT_TYPE PresetCount)
Create a screen mode resolution preset Enumeration for the Camera.
UNI_RETURN_TYPE | UCC_DestroyPresetsEnum (PRESETS_ENUMERATION PresetsEnum)
Clean up the data needed for the preset enumeration.
UNI_RETURN_TYPE | UCC_EnumPresets (UINT32_OUT_TYPE Preset, PRESETS_ENUMERATION PresetsEnum, UINT32_IN_TYPE PresetNr)
Select a preset from the enumeration.
UNI_RETURN_TYPE | UCC_CreateColorCodeEnum (ID_TYPE CamId, COLORCODE_ENUMERATION *ColorCodeEnum, UINT32_OUT_TYPE ColorCodeCount, UINT32_IN_TYPE Preset)
Create an enumeration of all supported color codings for a camera with a given preset.
UNI_RETURN_TYPE | UCC_DestroyColorCodeEnum (COLORCODE_ENUMERATION ColorCodeEnum)
Clean up the data needed for the color code enumeration.
UNI_RETURN_TYPE | UCC_EnumColorCode (UINT32_TYPE *ColorCode, COLORCODE_ENUMERATION ColorCodeEnum, UINT32_IN_TYPE CodeNr)
Select a color code from an enumeration.


AVT Universal API - Camera Control module: UniTransform.h File Reference

UniTransform.h File Reference

Detailed Description

The available AVT Universal API Image Transformation methods.

All the AVT Universal API methods for image transformation publicly available are described in this part of the help. For a description see the section "Introduction " of this help.

Version:
1.6
Date:
27-Oct-2008
Author:
Holger Eddelbuettel, Matthias Heidenreich, Olaf Reuter
license
This code is the property of Allied Vision Technologies. Nevertheless, you are absolutely free to use and modify it. The code is provided "as is" with no expressed or implied warranty. The author and AVT accept no liability if it causes any damage to your computer.

#include "uni_defines.h"

Functions

Miscellaneous methods
UNI_RETURN_TYPE | UIT_GetVersion (UINT32_OUT_TYPE pnValue)
Get Library Version.
UNI_RETURN_TYPE | UIT_GetTechnoInfo (S_TECHNO_INFO *pTechnoInfo)
Get information about processor supported features.
UNI_RETURN_TYPE | UIT_GetSIS (S_SIS_DATA *pSISData, const UINT8_TYPE *pImage, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE eColorCode, INT32_TYPE nSISPos, UINT32_TYPE eSISType)
extract the Secure Image Signature from a transport image.
UNI_RETURN_TYPE | UIT_GetBitsPerPixel (UINT32_IN_TYPE ColorCode, UINT32_OUT_TYPE BitsPerPixel)
get t he bits per pixel for the transport image with the given color coding.
UNI_RETURN_TYPE | UIT_GetErrorInfo (UNI_RETURN_TYPE nErrCode, char *pszInfoString, UINT32_IN_TYPE nMaxStrLen)
translates UNI_RETURN_TYPE into an human readable description.
Format conversions to BGR with simple 2x2 debayering w/o color conversion
Simple format conversions from IIDC transfer formats to the Windows RGB format.

UNI_RETURN_TYPE | UIT_YUV422ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert YUV 4:2:2 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_YUV411ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert YUV 4:1:1 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_RGB8ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert RGB8 data to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw16ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw16 (YH YL) to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Y8ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nPixelCount)
Convert MONO8 to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Y16ToBGR (void *pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to the Windows RGB format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_mono (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to the Windows RGB format with R=G=B.
Format conversions to BGR format with more sophisticated debayering w/o color conversion
Format conversions from raw color images resulting from a RGGB sensor to the Windows RGB format.

UNI_RETURN_TYPE | UIT_Raw8ToBGR_3x3 (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to the Windows RGB format using a 3x3 interpolation.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntYUV422 (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntLCAA (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via a stronglier interpolated YUV422 format.
UNI_RETURN_TYPE | UIT_Raw8ToBGR_IntLCAAV (void *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.
Format conversions to BGR format with color conversion
Format conversions to the Windows RGB with simple 2x2 debayering.

UNI_RETURN_TYPE | UIT_Raw8ToBGR_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Convert a RAW8 image to the Windows RGB format.
Format conversions
Format conversions to the Windows Mono8 format with and without color conversion.

UNI_RETURN_TYPE | UIT_RGB8ToY8 (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert RGB8 data to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Y16ToY8 (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to a monochrome 8BPP image.
Format conversions
Format conversions to the Windows Mono8 format with and without color conversion.

UNI_RETURN_TYPE | UIT_Y16ToY8_MMX (UINT8_OUT_TYPE pDst, const void *pSrc, UINT32_IN_TYPE nPixelCount)
Convert big endian MONO16 to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Raw8ToY8 (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert Raw8 to a monochrome 8BPP image.
UNI_RETURN_TYPE | UIT_Raw8ToY8_CC (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Convert Raw8 to a monochrome 8BPP image with additional color conversion.
12 bit format conversions/depacking to 8 or 16 bit, with support of 2x2 debayering, color conversion
Format conversions between 12 bit formats with support of 2x2 debayering, color conversion

UNI_RETURN_TYPE | UIT_Packed12BitTo8Bit (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize)
Convert a packed 12 bit format to 8 bit data.
UNI_RETURN_TYPE | UIT_Packed12BitTo16Bit (UINT16_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize)
Convert a packed 12 bit format to 16 bit data.
UNI_RETURN_TYPE | UIT_Raw12ToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern)
12Bit packed RAW mode to Windows BGR.
UNI_RETURN_TYPE | UIT_Raw12ToBGR_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern, COLOR_CORRECTION_HANDLE ColCor)
12Bit packed RAW mode to Windows BGR with color conversion.
UNI_RETURN_TYPE | UIT_Raw12ToBGR16 (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern)
Pike 12Bit Packed to windows 16 BGR.
UNI_RETURN_TYPE | UIT_Raw12ToBGR16_CC (void *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE BayerPattern, COLOR_CORRECTION_HANDLE ColCor)
Pike 12Bit Packed to windows 16 bit three channel BGR with color conversion.
16 bit format conversions with 2x2 debayering, some with color conversion
Format conversions between 16 bit formats with simple 2x2 debayering, but some with color conversion.

UNI_RETURN_TYPE | UIT_Raw16ToBGR16 (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits)
Convert Raw16 (YH YL) to a 16 bit RGB format (big endian).
UNI_RETURN_TYPE | UIT_Raw16ToBGR16_CC (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits, COLOR_CORRECTION_HANDLE hColCor)
Convert Raw16 (YH YL) to a 16 bit RGB format (big endian) added color correction.
UNI_RETURN_TYPE | UIT_Raw16ToY16 (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits)
Convert Raw16 (YH YL) to the MONO16 format (big endian).
UNI_RETURN_TYPE | UIT_Raw16ToY16_CC (void *pDst, const void *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern, UINT32_IN_TYPE nShiftBits, COLOR_CORRECTION_HANDLE hColCor)
Convert Raw16 (YH YL) to the MONO16 format (big endian) with added color conversion.
Methods for controling color conversion
Methods for use with format conversion methods ending with "_CC" (UIT_Raw8ToBGR_CC, UIT_Raw8ToY8_CC, UIT_Raw16ToBGR16_CC, UIT_Raw16ToY16_CC).

UNI_RETURN_TYPE | UIT_CreateColorCorrectionMatrix_Int8 (const FLOAT_TYPE *fArrayCorr, COLOR_CORRECTION_HANDLE *phCC)
Create a color conversion object and return the handle to it.
UNI_RETURN_TYPE | UIT_CreateColorCorrectionMatrix_Int16 (const FLOAT_TYPE *fArrayCorr, COLOR_CORRECTION_HANDLE *phCC)
Create a color conversion object and return the handle to it.
UNI_RETURN_TYPE | UIT_DestroyColorCorrection (COLOR_CORRECTION_HANDLE hCC)
Destroy the color correction object identified by the given handle.
Methods for interlaced cameras
Methods for use with interlaced cameras which also have a CYGM sensor.

UNI_RETURN_TYPE | UIT_InterlacedToProgressive (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an interlaced format to a progressive format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR_3x3 (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format with 3x3 matrix interpolation.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToBGR_Bin (void *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM binning format into progressive RGB format.
UNI_RETURN_TYPE | UIT_IRaw8CYGMToMono (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE nBayerPattern)
Convert a raw interlaced CYGM binning format into progressive RGB format with R=G=B.
Format conversions to image planes
Format conversions from IIDC transfer formats to image planes

UNI_RETURN_TYPE | UIT_YUV422ToRGBPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image in YUV422 format to R,G and B planes.
UNI_RETURN_TYPE | UIT_YUV411ToRGBPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image in YUV411 format to R,G and B planes.
UNI_RETURN_TYPE | UIT_YUV422ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from YUV422 format to R,G,B and additional Y planes.
UNI_RETURN_TYPE | UIT_YUV411ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from YUV411 format to R,G,B and additional Y planes.
UNI_RETURN_TYPE | UIT_RGB8ToRGBYPlanes (UINT8_OUT_TYPE pR, UINT8_OUT_TYPE pG, UINT8_OUT_TYPE pB, UINT8_OUT_TYPE pY, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize)
Convert an image from RGB format to R,G,B and additional Y planes.
Image transformation.
Methods for transforming images without image type change.

Logically, UIT_RGB8ToBGR and UIT_InterlacedToProgressive would also fall into this category, but since they are already listed in different categories, they do not appear here.

UNI_RETURN_TYPE | UIT_GetResampledScanlineLength (INT32_OUT_TYPE pDstXSize, INT32_TYPE nSrcXSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize)
Calculate the needed destination image width for images with non-square pixels.
UNI_RETURN_TYPE | UIT_ResampleScanlines (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, INT32_TYPE nDstXSize, INT32_TYPE nSrcXSize, INT32_TYPE nSrcYSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize, UINT32_TYPE nBytesPerPixel, UINT32_TYPE nRopMode)
Do resampling along lines.
UNI_RETURN_TYPE | UIT_ResampleScanlinesEx (UINT8_OUT_TYPE pDst, const UINT8_TYPE *pSrc, INT32_TYPE nDstXSize, INT32_TYPE nDstPitch, INT32_TYPE nSrcXSize, INT32_TYPE nSrcPitch, INT32_TYPE nSrcYSize, FLOAT_TYPE nDstPixelSize, FLOAT_TYPE nSrcPixelSize, UINT32_TYPE nBytesPerPixel, UINT32_TYPE nRopMode)
Do resampling along lines.
UNI_RETURN_TYPE | UIT_FlipVertical (UINT8_INOUT_TYPE pImage, UINT32_TYPE nBytesPerLine, UINT32_TYPE nLines)
Flip image vertically.
UNI_RETURN_TYPE | UIT_Flip (UINT8_INOUT_TYPE pImage, UINT32_TYPE nXSize, UINT32_TYPE nYSize, UINT32_TYPE eFlipMode, UINT32_TYPE eccColorCode)
Generic flip of image.
Format conversions to variable image formats
Format conversions from IIDC transfer formats to BGR24, BGRA32 or YUV422 UYVY

UNI_RETURN_TYPE | UIT_RGB8ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC RGB8 to variable image format.
UNI_RETURN_TYPE | UIT_YUV422ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC UYVY YUV422 to variable image format.
UNI_RETURN_TYPE | UIT_YUV411ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC YUV411 to variable image.
UNI_RETURN_TYPE | UIT_Y8ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
Convert Mono8 to variable image.
UNI_RETURN_TYPE | UIT_Y16ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE nPixelCount, UINT32_IN_TYPE eImageFormat)
convert IIDC Mono16 to variable image.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image.
UNI_RETURN_TYPE | UIT_Raw16ImageTransform (VOID_TYPE *pDst, const VOID_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert IIDC RAW16 to variable image.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_3x3 (VOID_TYPE *pDst, const UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
RAW8 to variable image with 3x3 local filtering.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntYUV422 (VOID_TYPE *pDst, UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with U/V interpolation in the YUV color space.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntLCAA (VOID_TYPE *pDst, UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with local color anti aliasing.
UNI_RETURN_TYPE | UIT_Raw8ImageTransform_IntLCAAV (VOID_TYPE *pDst, UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert RAW8 to variable image with local color anti aliasing vertical interpolation.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform_Bin (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 binning format to variable image.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform (VOID_TYPE *pDst, const UINT8_IN_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 CYMG to variable image.
UNI_RETURN_TYPE | UIT_IRaw8CYGMImageTransform_3x3 (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE XSize, UINT32_IN_TYPE YSize, UINT32_IN_TYPE eImageFormat, UINT32_IN_TYPE bayerPattern)
convert interlaced RAW8 CYMG to variable image with 3x3 local filtering.
UNI_RETURN_TYPE | UIT_Raw12ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_IN_TYPE nXSize, UINT32_IN_TYPE nYSize, UINT32_IN_TYPE eImageFormat, UINT32_TYPE BayerPattern)
AVT RAW12 to variable image.
UNI_RETURN_TYPE | UIT_Y12ImageTransform (VOID_TYPE *pDst, const UINT8_TYPE *pSrc, UINT32_TYPE nPixelCount, UINT32_TYPE eImageFormat)
Convert a packed 12 bit format to variable image.


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- _ -

  • __1394GUID : uni_types.h


AVT Universal API - Camera Control module: UCC_UserProfile_GetErrorStatus

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UserProfile_GetErrorStatus | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnErrorCode
 | ) |  |

Get the user profile error status.

Parameters:
[in] CamId the ID of the camera to use
[out] pnErrorCode pointer to UINT32_TYPE that will receive the error code of the user profile feature
for interpretation of error codes see camera manual, chapter 'User Profiles'
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the user profile feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_SetFeatureStatus

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetFeatureStatus | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_IN_TYPE | nState
 | ) |  |

Set the status of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[in] | nState | status of the feature to set ( see E_UNI_FEATURE_STATE for valid values )
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature nFeature does not support the state nState
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature isn't supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_GetCameras

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCameras | ( | UINT32_INOUT_TYPE | pnSize,
 |  | UINT32_OUT_TYPE | vecIds
 | ) |  |

Count connected Cameras and return an array of camera IDs, if desired.

The given array is filled up to the number of entries specified by *pnSize except if NULL is given as array pointer.

Parameters:
[in,out] pnSize
  • in: array size
  • out: actual number of cameras filled into the array
[out] vecIds pointer to an Id-array of nSize elements
Returns:
S_OK
if the operation was successful
UNI_RESULT_PARAMETER_INVALID_1
if pnSize is NULL or *pnSize==0 or *pnSize>64
UNI_RESULT_PARAMETER_INVALID_2
if not the full range inside the array vecIds was writable
UNI_RESULT_MORE_DATA
if there was more data than space provided by the given array
a FireGrab error


AVT Universal API - Camera Control module: UCC_GetImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetImage | ( | ID_TYPE | CamId,
 |  | S_UNI_IMAGE * | psImage,
 |  | UINT32_IN_TYPE | nTimeOut
 | ) |  |

Request an image from the async receive buffer.

The image format has to be specified by the uImageformat member of the provided S_UNI_IMAGE struct. The corresponding data pointers of psImage have to point to a sufficiently sized memory block.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | psImage | Pointer to image struct
See also:
S_UNI_IMAGE
Parameters:
[in] nTimeOut timeout
Returns:
S_OK
if the operation was successful
Note:
Alternatively one the following functions may be used to acquire image data in a certain format:
  • UCC_GetBitmapImage() - returns image data in bitmap format
  • UCC_GetPlanesImage() - returns image data in planar format
  • UCC_GetNativeImage() - returns image data in native format, as transfered over the firewire bus


AVT Universal API - Camera Control module: UCC_RegisterFrameDroppedNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_RegisterFrameDroppedNotification | ( | UNI_NOTIFICATION_HANDLE * | pHandle,
 |  | S_UNI_NOTIFICATION * | pNotification
 | ) |  |

Register a notification object for 'frame dropped' events.

Parameters:
[out] | pHandle | returns a handle to the notification object registration
[in] | pNotification | notification object to be registered for 'frame dropped' events
Returns:
S_OK
if successful
Note:
The notification object pointed to by pNotification must not be deleted as long as its registration persists. Therefore notification object registrations should be canceled immediately when they aren't needed anymore (see UCC_UnRegisterNotification ). Notification objects may be registered for a certain camera or for all available cameras(UNI_ALL_CAMERAS).


AVT Universal API - Camera Control module: UCC_SaveSettings

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SaveSettings | ( | ID_TYPE | CamId,
 |  | const ACHAR_TYPE * | pszFileName
 | ) |  |

Save the camera setting.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | pszFileName | The name of the file to use for storing settings
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_SerialIO_Receive

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SerialIO_Receive | ( | ID_TYPE | CamId,
 |  | UINT8_TYPE * | pnData,
 |  | UINT32_INOUT_TYPE | pnLength,
 |  | UINT32_IN_TYPE | nTimeout
 | ) |  |

Receive data via the cameras serial IO interface.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnData | pointer to the data buffer to be filled
pnLength | pointer to UINT32_TYPE that indicates the number of bytes to be received after function call this value will be set to the number of bytes actually received
[in] | nTimeout | the maximum period of time in milliseconds this function will wait for the data to be received
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if serial IO is not supported by the camera
UNI_RESULT_CAMERA_TIMEOUT
if the timeout condition occurred before all data was received


AVT Universal API - Camera Control module: UCC_WaitForBusReset

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_WaitForBusReset | ( | UINT32_OUT_TYPE | vecSNs,
 |  | UINT32_INOUT_TYPE | pCount,
 |  | UINT32_IN_TYPE | lTimeOut,
 |  | UINT32_OUT_TYPE | pRetErr
 | ) |  |

Wait for a bus reset.

After, additional data is returned, if desired

Parameters:
[out] | vecSNs | array of camera IDs
[out] | pCount | count
[in] | lTimeOut | TimeOut
[out] | pRetErr | Error code of WaitForSingleObject
Returns:
S_OK
if the operation was successful
deprecated, may be replaced by the following code:
    S_UNI_NOTIFICATION Notification;
    Notification.m_NotificationType          = E_UNI_NOTIFICATION_EVENT;
    Notification.m_NotificationEvent.m_Event = CreateEvent(NULL, false, false, "BusReset");
    NOTIFICATION_HANDLE hNotf = RegisterNodeListChangedNotification( &Notification);

    DWORD dwRet = WaitForSingleObject( Notification.m_NotificationEvent.m_Event, lTimeOut );
    if( dwRet == WAIT_OBJECT_0 )
    {
        UCC_GetCameras ( pCount, vecSNs );
    }
    *pRetErr = dwRet;
    UnregisterNotification(hNotf);


AVT Universal API - Camera Control module: UCC_LoadSettings

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_LoadSettings | ( | ID_TYPE | CamId,
 |  | const ACHAR_TYPE * | pszFileName,
 |  | UINT32_IN_TYPE | nUseOnlyTypeInfo
 | ) |  |

Load the camera settings from file.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | pszFileName | The name of the file to use for storing settings
[in] nUseOnlyTypeInfo
  • 0 means: the exact ID is used
  • 1 means: the camera type is used
for finding camera settings inside the file
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_SerialIO_SetConfig

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SerialIO_SetConfig | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nBaudRate,
 |  | UINT32_IN_TYPE | nCharLength,
 |  | UINT32_IN_TYPE | nParity,
 |  | UINT32_IN_TYPE | nStopBit,
 |  | UINT32_IN_TYPE | nMode
 | ) |  |

Configure the serial communication.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nBaudRate | the baud rate to be used see the definition of E_UNI_SIO_BAUDRATE for valid values
[in] | nCharLength | character length setting, may be set to 7 or 8
[in] | nParity | parity setting - see the definition of E_UNI_SIO_PARITY for valid values
[in] | nStopBit | stop bits - see the definition of E_UNI_SIO_STOPBITS for valid values
[in] | nMode | receive/transmit mode - see the definition of E_UNI_SIO_MODE for valid values
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if serial io is not supported by the camera
UNI_RESULT_PARAMETER_INVALID_2
if enBaudRate is set to an undefined value
UNI_RESULT_PARAMETER_INVALID_3
if nCharLength is set to something other than 7 or 8
UNI_RESULT_PARAMETER_INVALID_4
if enParity is set to an undefined value
UNI_RESULT_PARAMETER_INVALID_5
if enStopBit is set to an undefined value
UNI_RESULT_PARAMETER_INVALID_6
if enMode is set to an undefined value


AVT Universal API - Camera Control module: UCC_TestImage_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_TestImage_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nImageNr
 | ) |  |

Set the active test image.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nImageNr | test image to be used A value of 0 deactivates the test image feature. In this case the actual camera image will be received. (normal mode of operation)
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the test image feature is not supported by the camera
UNI_RESULT_PARAMETER_INVALID_2
if the chosen test image is not supported by the camera


AVT Universal API - Camera Control module: UCC_HasFeature

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_HasFeature | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature
 | ) |  |

Check whether a specific 'unified feature' is supported by the camera.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
Returns:
S_OK
if feature enFeature is supported by the camera
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature is not supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_CloseCamera

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CloseCamera ( ID_TYPE CamId )

Close a specific camera.

Parameters:
[in] CamId camera identifier (serial number)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_Shading_GetInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Shading_GetInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | puSizeMax
 | ) |  |

Get information about the capabilities of the shading correction feature.

Parameters:
[in] | CamId | The ID of the camera to use
[out] | puSizeMax | A pointer to an integer that will receive the maximum size of a shading image
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the shading correction feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_EnumFreeModes

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_EnumFreeModes | ( | ID_TYPE | CamId,
 |  | UINT32_INOUT_TYPE | pnPos,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnColorId,
 |  | UINT32_OUT_TYPE | pnXMax,
 |  | UINT32_OUT_TYPE | pnYMax
 | ) |  |

Enumerate through available free/scalable image formats.

Start the complete enumeration by setting the index of the format to 0. On return, this value is incremented. If nothing is found, -1 is returned in *pnPos

Parameters:
[in] | CamId | Camera identifier (serial number)
[in,out] | pnPos | Pointer to UINT32_TYPE holding the index of the format. Is updated after the call.
[out] | pnMode | Pointer to UINT32_TYPE receiving the mode
[out] | pnColorId | Pointer to UINT32_TYPE receiving the color coding id, see: E_UNI_COLOR_CODE
[out] | pnXMax | Pointer to UINT32_TYPE receiving the maximum width in this mode
[out] | pnYMax | Pointer to UINT32_TYPE receiving the maximum width in this mode
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_ReconnectAllCameras

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_ReconnectAllCameras ( UINT32_IN_TYPE bAutoReLoadSettings )

Reconnect all cameras.

Parameters:
[in] bAutoReLoadSettings (a "boolean" UINT32_TYPE value)
Returns:
S_OK
if the operation was successful
UNI_RESULT_API_NOT_INITIALIZED
if UCC_Init was not called


AVT Universal API - Camera Control module: UCC_CreateColorCodeEnum

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CreateColorCodeEnum | ( | ID_TYPE | CamId,
 |  | COLORCODE_ENUMERATION * | ColorCodeEnum,
 |  | UINT32_OUT_TYPE | ColorCodeCount,
 |  | UINT32_IN_TYPE | Preset
 | ) |  |

Create an enumeration of all supported color codings for a camera with a given preset.

Parameters:
[in] | CamId | Camera to enumerate
[out] | ColorCodeEnum | return the Enumeration of the color modes not NULL
[out] | ColorCodeCount | Element count of the returned color codes not NULL
[in] | Preset | a UINT32_TYPE value representing a resolution preset, the valid color codings of which will be enumerated see the definition of E_UNI_RESOLUTION_PRESETS for valid values
Returns:
S_OK
if the operation was successful
Note:
For a given Camera and preset enumerate all supported color codings. use UCC_EnumColorCode to select a coding. destroy the enumeration after use with UCC_DestroyColorCodeEnum
See also:
UCC_EnumColorCode, UCC_DestroyColorCodeEnum


AVT Universal API - Camera Control module: UCC_GetVersion

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetVersion ( UINT32_OUT_TYPE pnValue )

Get the version number of the API.

The format is 0x01020304 for version 1.2.3.4

Parameters:
[out] pnValue pointer to UINT32_TYPE, which returns the library version (Major,Minor,SubMinor,Build)
Returns:
S_OK
if the operation was successful
UNI_RESULT_API_NOT_INITIALIZED
if this module was not initialized before this call


AVT Universal API - Camera Control module: UCC_GrabNativeImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabNativeImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pImage,
 |  | UINT32_OUT_TYPE | pbIsColor,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Grab data synchronously to a bitmap image that will receive the raw transfer image.

Uses a byte pointer for the target image. The target format depends on the color ID that was selected during grab preparation (see UCC_PrepareFreeGrab). This is the method to receive e.g. YUV 4:2:2 data or MONO16 data.

Note:
Raw images are not debayered. Use own debayering methods afterwards.
Since:
0.3.0
Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pImage | The pointer to the image
[out] | pbIsColor | Pointer to a "boolean" UINT32_TYPE value to receive if this is a color camera
[in] | nTimeOut | Timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetAOI

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetAOI | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pLeft,
 |  | UINT32_OUT_TYPE | pTop,
 |  | UINT32_OUT_TYPE | pWidth,
 |  | UINT32_OUT_TYPE | pHeight
 | ) |  |

Get the AOI for the current free IIDC mode (Format 7) Every AOI parameter may be omitted.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pLeft | Pointer to UINT32_TYPE receiving the left position of the current AOI.
[out] | pTop | Pointer to UINT32_TYPE receiving the top position of the current AOI.
[out] | pWidth | Pointer to UINT32_TYPE receiving the width of the current AOI.
[out] | pHeight | Pointer to UINT32_TYPE receiving the height of the current AOI.
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_MultiShotStart

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_MultiShotStart | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nGrabCount
 | ) |  |

Start multi shot image grabbing asynchronously.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | nGrabCount | Image count to grab (has to be greater then 0)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetCamerasEx

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCamerasEx | ( | UINT32_INOUT_TYPE | pnSize,
 |  | UINT32_OUT_TYPE | vecIds,
 |  | UINT32_OUT_TYPE | vecExtraInfo
 | ) |  |

Count connected Cameras and return arrays of camera IDs and extra information, if desired.

The given array is filled up to the number of entries specified by *pnSize except if NULL is given as array pointer.

Parameters:
[in,out] pnSize
  • in: array size
  • out: actual number of cameras filled into the array
[out] | vecIds | Pointer to an Id-array of nSize elements.
[out] | vecExtraInfo | 1:1 mapping of additional info for identifying of the vecIds
Note:
vecExtraInfo gives bus specific information to a given camera [CardID:8][NodeId:8][reserved:16]
Returns:
S_OK
if the operation was successful,
UNI_RESULT_PARAMETER_INVALID_1
if pnSize is NULL or *pnSize==0 or *pnSize>64
UNI_RESULT_PARAMETER_INVALID_2
if not the full range inside the array vecIds was writable
UNI_RESULT_MORE_DATA
if there was more data than space provided by the given array
a FireGrab error


AVT Universal API - Camera Control module: UCC_GetCameraInfoString

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCameraInfoString | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nId,
 |  | ACHAR_INOUT_TYPE | pszInfoString,
 |  | UINT32_INOUT_TYPE | pLength
 | ) |  |

Get textual information about the specified camera.

Parameters:
[in] | CamId | camera identifier (serial number)
[in] | nId | identifier to the camera info you'd like to receive (see E_UNI_CAMERA_INFO)
[out] | pszInfoString | pointer to a zero terminated String of length (*pLength) max.
[in,out] pLength
  • [in]pointer to an integer holding the available space in pszInfoString
  • [out]pointer to the length of the string that was filled
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_ParamUpdate_Apply

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_ParamUpdate_Apply ( ID_TYPE CamId )

Finish a configuration update procedure that has been started by UCC_ParamUpdate_Begin and apply all changes simultaneously.

Parameters:
[in] CamId the ID of the camera to use
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the test image feature is not supported by the camera
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE


AVT Universal API - Camera Control module: UCC_Lut_Upload

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Lut_Upload | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nLutNr,
 |  | UINT8_TYPE * | arrValue,
 |  | UINT32_IN_TYPE | nSize
 | ) |  |

Upload the given LUT.

The data array may contain 8 bit or 16 bit values depending on the cameras capabilities. Use UCC_Lut_GetInfo to determine the appropriate data format. LUT data may only be uploaded when the camera is not grabbing.

Parameters:
[in] | CamId | the ID of the camera to configure
[in] | nLutNr | the number of the LUT to use for storing the given data
[out] | arrValue | pointer to the LUT data
[in] | nSize | size of LUT data in bytes
Returns:
S_OK
if the operation was successful
UNI_RESULT_CAMERA_BUSY
if the camera is grabbing


AVT Universal API - Camera Control module: UCC_DestroyColorCodeEnum

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_DestroyColorCodeEnum ( COLORCODE_ENUMERATION ColorCodeEnum )

Clean up the data needed for the color code enumeration.

Parameters:
[in] ColorCodeEnum the Enumeration to clean up
Returns:
S_OK
if the parameter is valid
Note:
after desrtuction the enumeration is not valid all selected color codings are still valid


AVT Universal API - Camera Control module: UCC_DestroyPresetsEnum

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_DestroyPresetsEnum ( PRESETS_ENUMERATION PresetsEnum )

Clean up the data needed for the preset enumeration.

Parameters:
[in] PresetsEnum the preset enumeration to destroy
Note:
after UCC_DestroyPresetsEnum the enumeration is no longer valid. But all acquired presets are still valid.
Returns:
S_OK
if all parameter are valid
See also:
UCC_CreatePresetsEnum, UCC_EnumPresets


AVT Universal API - Camera Control module: UCC_RegisterFrameReadyNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_RegisterFrameReadyNotification | ( | UNI_NOTIFICATION_HANDLE * | pHandle,
 |  | S_UNI_NOTIFICATION * | pNotification
 | ) |  |

Register a notification object for 'frame ready' events.

Parameters:
[out] | pHandle | returns a handle to the notification object registration
[in] | pNotification | notification object to be registered for 'frame ready' events
Returns:
S_OK
if successful
Note:
The notification object pointed to by pNotification must not be deleted as long as its registration persists. Therefore notification object registrations should be canceled immediately when they aren't needed anymore (see UCC_UnRegisterNotification()). Notification objects may be registered for a certain camera or for all available cameras(UNI_ALL_CAMERAS).


AVT Universal API - Camera Control module: UCC_CreatePresetsEnum

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CreatePresetsEnum | ( | ID_TYPE | CamId,
 |  | PRESETS_ENUMERATION * | PresetsEnum,
 |  | UINT32_OUT_TYPE | PresetCount
 | ) |  |

Create a screen mode resolution preset Enumeration for the Camera.

Parameters:
[in] | CamId | Camera to test for supported presets
[out] | PresetsEnum | Enumeration of supported presets not NULL
[out] | PresetCount | Element count of returned presets not NULL
Note:
Enumerate all supported presets for your Camera, then use UCC_EnumPresets to get a individual preset for the camera. A Preset may be converted to Width and Height with UCC_PresetToResolution. you have to use UCC_DestroyPresets to clean up after use.
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetSupportedFixedFormats

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetSupportedFixedFormats | ( | ID_TYPE | CamId,
 |  | S_IIDC_VIDEOINFO_FORMAT * | pFormats
 | ) |  |

Query the Supported IIDC video modes of a camera.

used to identify the IIDC video modes implemented in the camera. setting one of the modes can fail due to the current set bus speed.

Parameters:
[in] | CamId | Camera identifier [ serial number)
[out] | pFormats | pointer to a S_IIDC_VIDEOINFO_FORMAT struct


AVT Universal API - Camera Control module: UCC_GetFeatureMax

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFeatureMax | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Get the maximum value of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[out] | pnValue | A pointer to UINT32_TYPE that will receive the features maximum value
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature nFeature does not imply a value
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature is not supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_SerialIO_GetConfig

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SerialIO_GetConfig | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnBaudRate,
 |  | UINT32_OUT_TYPE | pnCharLength,
 |  | UINT32_OUT_TYPE | pnParity,
 |  | UINT32_OUT_TYPE | pnStopBit,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnBufferSize
 | ) |  |

Get the configuration of the serial interface.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnBaudRate | pointer to UINT32_TYPE that will receive the configured baud rate see the definition of E_UNI_SIO_BAUDRATE for valid values
[out] | pnCharLength | pointer to UINT32_TYPE that will receive the character length setting possible values are 7 and 8
[out] | pnParity | pointer to UINT32_TYPE that will receive the parity setting see the definition of E_UNI_SIO_PARITY for valid values
[out] | pnStopBit | pointer to UINT32_TYPE that will receive the current stop bit setting see the definition of E_UNI_SIO_STOPBITS for valid values
[out] | pnMode | pointer to UINT32_TYPE that will receive the current Receive/Transmit Mode see the definition of E_UNI_SIO_MODE for valid values
[out] | pnBufferSize | pointer to UINT32_TYPE that will receive the maximum size of the receive/transmit data buffer
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if serial io is not supported by the camera


AVT Universal API - Camera Control module: UCC_EnumPresets

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_EnumPresets | ( | UINT32_OUT_TYPE | Preset,
 |  | PRESETS_ENUMERATION | PresetsEnum,
 |  | UINT32_IN_TYPE | PresetNr
 | ) |  |

Select a preset from the enumeration.

Parameters:
[out] | Preset | a UINT32_TYPE value representing a resolution preset see the definition of E_UNI_RESOLUTION_PRESETS for valid values
[in] | PresetsEnum | Enumeration to select the preset from not NULL
[in] | PresetNr | Position in the enumeration inside the range [0,value returned from UCC_CreatePresetsEnum]
Returns:
S_OK
if all parameter are valid
See also:
UCC_CreatePresetEnum


AVT Universal API - Camera Control module: UCC_GetRegister

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetRegister | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | uAddress,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Get the value of the given register.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | uAddress | The address of the register
[out] | pnValue | Pointer to UINT32_TYPE that receives the registers value
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_OutputPin_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_OutputPin_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nWhich,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nPolarity,
 |  | UINT32_IN_TYPE | nState
 | ) |  |

Set state of output pins.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nWhich | The number of the output pin see MAX_OUTPUT_PINS
[in] | nMode | The output mode see E_OUTPUTPIN_MODES
[in] | nPolarity | The polarity
[in] | nState | The output state
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the chosen output pin is not supported by the camera
Note:
For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UCC_ParamUpdate_Begin

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_ParamUpdate_Begin ( ID_TYPE CamId )

Start a configuration update procedure that may consist of several configuration changes, which will take effect simultaneously when UCC_ParamUpdate_Apply is called.

Parameters:
[in] CamId the ID of the camera to use
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_AutoFunctionAOI_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_AutoFunctionAOI_Get | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnLeft,
 |  | UINT32_OUT_TYPE | pnTop,
 |  | UINT32_OUT_TYPE | pnWidth,
 |  | UINT32_OUT_TYPE | pnHeight
 | ) |  |

Get the current status of the Autofunction AOI feature.

Parameters the caller is not interested in may be set to NULL.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnMode | pointer to UINT32_TYPE that will receive the current mode of operation. For valid values see E_UNI_FEATURE_STATE.
[out] | pnTop | pointer to UINT32_TYPE that will receive the top offset
[out] | pnLeft | pointer to UINT32_TYPE that will receive the left offset
[out] | pnHeight | pointer to UINT32_TYPE that will receive the height
[out] | pnWidth | pointer to UINT32_TYPE that will receive the width
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if autofunction AOI io is not supported by the camera


AVT Universal API - Camera Control module: UCC_UserProfile_Save

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UserProfile_Save | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nProfileID
 | ) |  |

Save a user profile to camera memory.

The camera must not be grabbing for this function to succeed. user profile 0 is not writable

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nProfileID | number of profile to be saved
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the user profile feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_SerialIO_Transmit

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SerialIO_Transmit | ( | ID_TYPE | CamId,
 |  | UINT8_TYPE * | pnData,
 |  | UINT32_INOUT_TYPE | pnLength,
 |  | UINT32_IN_TYPE | nTimeout
 | ) |  |

Transmit data via the cameras serial IO interface.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | pnData | pointer to the data to be transmitted
pnLength | pointer to UINT32_TYPE that indicates the number of bytes to transmit after function call this value will be set to the number of bytes actually transmitted
[in] | nTimeout | the maximum period of time in milliseconds this function will wait for the data to be transmitted
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if serial io is not supported by the camera
UNI_RESULT_CAMERA_TIMEOUT
if the timeout condition occurred before all data was transmitted


AVT Universal API - Camera Control module: UCC_GetNativeImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetNativeImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pImage,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Request a image data from the async receive buffer as transmitted over the firewire bus.

Image format conversions may be necessary to retrieve displayable data. A byte pointer for the target image is used. Sufficient memory space has to be provided by the caller.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pImage | Pointer to image bitmap
[in] | nTimeOut | timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_SetFeatureList

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetFeatureList | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE * | pnListPtr,
 |  | UINT32_IN_TYPE | nNumOfEntries,
 |  | UINT32_OUT_TYPE | pnErronousItem = NULL
 | ) |  |

Apply a list of feature configuration changes simultaneously.

Most of the camera-related features controllable by unified feature access are supported. Feature configuration changes have to be provided as a UINT32_TYPE array. Each list entry is expected to span 3 UINT32_TYPE values, the first of which is interpreted as feature identifier according to E_UNI_FEATURE, followed by the desired value and state ( see E_UNI_FEATURE_STATE ). Value or state data set to UNI_UNDEFINED will be ignored. This allows to change only the feature state or the feature value while keeping the other unchanged.

In case of failure a partial list may have been applied. Parameter pnErronousItem can be interpreted after function call to determine erroneous items and failure cases which lead to partial applied lists.

A simple example without any error handling is shown below:

 UINT32_TYPE arrFeatureList[] =
    {
        E_FEAT_SHUTTER,         UNI_UNDEFINED,  E_FEATSTATE_AUTO,
        E_FEAT_GAIN,            5,              E_FEATSTATE_ON
    };

    UINT32_TYPE index;
    UCC_SetFeatureList(m_CamId, arrFeatureList, 2);
Parameters:
[in] | CamId | the ID of the camera to use
[in] | pnListPtr | pointer to the first element of the feature configuration list
[in] | nNumOfEntries | Number of items contained by the feature configuration list
[out] pnErronousItem reveals details in case of failure. The following values are possible:
0
An error occured which could not be traced to a certain list entry. Camera configuration remains unchanged.
1...nNumOfEntries
(one-based) index of the erronous item - Camera configuration remains unchanged.
nNumOfEntries+1
function succeeded without errors
UNI_UNDEFINED
An error occured which could not be traced to a certain list entry - the list has been applied partially.
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the register list update feature is not supported by the camera
Note:
This method provides easy but limited access to the camera's 'register list update' feature. Alternatively, UCC_SetRegisterList may be used for a more flexible, low-level control.


AVT Universal API - Camera Control module: UCC_Init

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Init ( )

Initialization of the API.

This operation must be executed before any other call in this API. To end your usage of this API, use UCC_Release

Returns:
S_OK
if the Initialization was successful
UNI_RESULT_API_NOT_INITIALIZED
if this module could not be initialized


AVT Universal API - Camera Control module: UCC_PrepareFreeGrab

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_PrepareFreeGrab | ( | ID_TYPE | CamId,
 |  | UINT32_INOUT_TYPE | pMode,
 |  | UINT32_INOUT_TYPE | pColorFormatId,
 |  | UINT32_INOUT_TYPE | pWidth,
 |  | UINT32_INOUT_TYPE | pHeight,
 |  | UINT32_INOUT_TYPE | pBufferCount,
 |  | UINT32_INOUT_TYPE | pXOffset,
 |  | UINT32_INOUT_TYPE | pYOffset,
 |  | UINT32_INOUT_TYPE | pBusLoad
 | ) |  |

Prepare camera for format-free image acquisition.

May be used for setting grabbing parameters for preparing your image transport in just one call.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in,out] | pMode | As a rule, use the format 7 mode
[in,out] | pColorFormatId | Pointer to the color id (see E_UNI_COLOR_CODE)
[in,out] | pWidth | Pointer to the height of the image
[in,out] | pHeight | Pointer to the width of the image
[in,out] | pBufferCount | Pointer to the number of buffer (if NULL, the pre-defined value is taken)
[in,out] | pXOffset | Pointer to the horizontal position of the image (if NULL, 0 is assumed)
[in,out] | pYOffset | Pointer to the vertical position of the image (if NULL, 0 is assumed)
[in,out] | pBusLoad | Pointer to the desired bus load (in 1/1000) (return: the real bus load) (if NULL, 1000 is assumed)
Returns:
S_OK
if the operation was successful
Note:
This method automatically sets the packet size via the ‘busload’ parameter, which is representing the payload in per mille. Thereby, the following calculation is used: PacketSize = ROUND(Busload) x (1024 x 2^PhySpeed)/4000) x 4 With: PhySpeed:
  • 0 for S100,
  • 1 for S200,
  • 2 for S400,
  • 3 for S800. for examples see Image Format Configuration.


AVT Universal API - Camera Control module: UCC_CreateUserLog

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CreateUserLog | ( | UINT32_IN_TYPE | nMaxLevel,
 |  | const ACHAR_TYPE * | pszFileName
 | ) |  |

Create a user log file.

Parameters:
[in] | nMaxLevel | The maximum logging level to log see: E_UNI_LOGGING
[in] | pszFileName | The name of the file to create
Returns:
S_OK
if the operation was successful
UNI_RESULT_API_NOT_INITIALIZED
UCC_Init was not called
For general information about logging see Logging


AVT Universal API - Camera Control module: UCC_SetStreamSpeed

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetStreamSpeed | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nSpeed
 | ) |  |

Set speed for image streaming.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nSpeed | streaming speed
Returns:
S_OK if successful


AVT Universal API - Camera Control module: UCC_PresetToResolution

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_PresetToResolution | ( | UINT32_IN_TYPE | Preset,
 |  | UINT32_OUT_TYPE | Width,
 |  | UINT32_OUT_TYPE | Height
 | ) |  |

Convert a preset to Width and Height.

Parameters:
[in] | Preset | an UINT32_TYPE value defining a resolution preset see the definition of E_UNI_RESOLUTION_PRESETS for valid values
[out] | Width | return the width for this preset not NULL
[out] | Height | return the Height for this preset not NULL
Returns:
S_OK
if all parameter are valid


AVT Universal API - Camera Control module: UCC_RegisterFrameStartNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_RegisterFrameStartNotification | ( | UNI_NOTIFICATION_HANDLE * | pHandle,
 |  | S_UNI_NOTIFICATION * | pNotification
 | ) |  |

Register a notification object for 'frame start' events.

Parameters:
[out] | pHandle | returns a handle to the notification object registration
[in] | pNotification | notification object to be registered for 'frame start' events
Returns:
S_OK
if successful
Note:
The notification object pointed to by pNotification must not be deleted as long as its registration persists. Therefore notification object registrations should be canceled immediately when they aren't needed anymore (see UCC_UnRegisterNotification()). Notification objects may be registered for a certain camera or for all available cameras(UNI_ALL_CAMERAS).


AVT Universal API - Camera Control module: UCC_WriteUserLog

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_WriteUserLog | ( | UINT32_IN_TYPE | nLevel,
 |  | const ACHAR_TYPE * | pszMsg
 | ) |  |

Log a message.

Parameters:
[in] | nLevel | logging level
[in] | pszMsg | text message to be logged
Returns:
S_OK
if the operation was successful
For general information about logging see Logging


AVT Universal API - Camera Control module: UCC_GetCameraCapabilities

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCameraCapabilities | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMaxImageWidth,
 |  | UINT32_OUT_TYPE | pnMaxImageHeight,
 |  | UINT32_OUT_TYPE | pbColorInfo,
 |  | UINT32_OUT_TYPE | pnMaxImageDepth
 | ) |  |

Tell fundamental camera capabilities.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pnMaxImageWidth | Pointer to an UINT32_TYPE variable receiving maximal possible image width
[out] | pnMaxImageHeight | Pointer to an UINT32_TYPE variable receiving maximal possible image height
[out] | pbColorInfo | Pointer to an UINT32_TYPE boolean indicating colour camera
[out] | pnMaxImageDepth | Pointer to an UINT32_TYPE variable receiving the maximal possible bit depth
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_DisconnectAllCameras

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_DisconnectAllCameras ( void )

Disconnect all cameras.

Returns:
S_OK
if the operation was successful
UNI_RESULT_API_NOT_INITIALIZED
UCC_Init was not called


AVT Universal API - Camera Control module: UCC_SetFeatureValue

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetFeatureValue | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_IN_TYPE | nValue
 | ) |  |

Set the value of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[in] | nValue | The value of the feature to set
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature nFeature does not imply a value or the value is read-only
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature is not supported by the camera
UNI_RESULT_PARAMETER_INVALID_3
if nValue exceeds the range allowed for the chosen feature
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_MultiShotStop

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_MultiShotStop ( ID_TYPE CamId )

Stopping a running multi shot.

Parameters:
[in] CamId Camera identifier (serial number)
Returns:
S_OK
if the operation was successful
Note:
Get[xxx]Image might afterwards return UNI_RESULT_COMMAND_ABORTED


AVT Universal API - Camera Control module: UCC_ReadBlock

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_ReadBlock | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | uAddress,
 |  | UINT32_OUT_TYPE | pnValue,
 |  | UINT32_IN_TYPE | uLength
 | ) |  |

Read memory block from camera.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | uAddress | The start address of the register block
[out] | pnValue | Pointer to UINT32_TYPE array that receives the registers values
[in] | uLength | element count to read
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_SetRegister

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetRegister | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | uAddress,
 |  | UINT32_IN_TYPE | uValue
 | ) |  |

Set the given register value.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | uAddress | The address of the register
[in] | uValue | The new value to set
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_CheckAvailable

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CheckAvailable | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pbResult
 | ) |  |

Check if a camera is currently available.

Parameters:
[in] | CamId | camera identifier (serial number)
[out] | pbResult | pointer to a "boolean" UINT32_TYPE value for receiving the availability state
Returns:
S_OK
if the node is available
Note:
a camera is available if it is opened by the API or not in busy state


AVT Universal API - Camera Control module: UCC_GetPlanesImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetPlanesImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Request a planes image from async receive buffer
Uses byte pointers for all the target planes.

Sufficient memory space has to be provided by the caller.

Note:
Raw images are not debayered yet. Use debayering methods afterwards.
Since:
0.1.2
Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pR | The pointer to the red plane
[out] | pG | The pointer to the green plane
[out] | pB | The pointer to the blue plane
[out] | pY | The pointer to the intensity plane ( may be set to NULL )
[in] | nTimeOut | timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_Lut_Use

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Lut_Use | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nLutNo,
 |  | UINT32_IN_TYPE | nActive
 | ) |  |

Use the given look-up table and set the status.

Parameters:
[in] | CamId | The ID of the camera to configure
[in] | nLutNo | The number of the LUT to use or UNI_UNDEFINED
[in] | nActive | A "boolean" UINT32_TYPE value to determine the activity status or UNI_UNDEFINED
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the LUT feature
UNI_RESULT_PARAMETER_INVALID_2
if nLutNo exceeds the range of [0 ... (NumOfLuts-1)]


AVT Universal API - Camera Control module: UCC_Whitebalance_GMCY_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Whitebalance_GMCY_Get | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnGr_CyVal,
 |  | UINT32_OUT_TYPE | pnMg_YeVal,
 |  | UINT32_OUT_TYPE | pnCy_MgVal,
 |  | UINT32_OUT_TYPE | pnYe_GrVal
 | ) |  |

Get the status of the whitebalance feature for GMCY sensors Parameters the caller is not interested in may be set to NULL.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnMode | pointer to UINT32_TYPE that will receive the current mode of operation. See UCC_Whitebalance_Set for possible values
[out] | pnGr_CyVal | pointer to UINT32_TYPE that will receive the value: Mode 1:Gr Value; Mode 0:Gr/Cy
[out] | pnMg_YeVal | pointer to UINT32_TYPE that will receive the value: Mode 1:Mg Value; Mode 0:Mg/Ye
[out] | pnCy_MgVal | pointer to UINT32_TYPE that will receive the value: Mode 1:Cy Value; Mode 0:Cy/Mg
[out] | pnYe_GrVal | pointer to UINT32_TYPE that will receive the value: Mode 1:Ye Value; Mode 0:Ye/Gr
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the whitebalance feature for GMCY sensors


AVT Universal API - Camera Control module: UCC_UnRegisterNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UnRegisterNotification ( UNI_NOTIFICATION_HANDLE Handle )

Unregister a single notification object registration.

Parameters:
[out] Handle handle to registration to be canceled
Returns:
S_OK
if successful
Note:
For examples see code snippets


AVT Universal API - Camera Control module: UCC_Lut_GetInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Lut_GetInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnNumOfLuts,
 |  | UINT32_OUT_TYPE | pnMaxValue,
 |  | UINT32_OUT_TYPE | pnNumOfValues,
 |  | UINT32_OUT_TYPE | pnMaxDataSize
 | ) |  |

Get a number of details about the look-up table feature.

Parameters the caller is not interested in may be set to NULL. However, not all parameters may be set to NULL. The size of single LUT entries is either 8 or 16 bit depending on pnMaxValue: cameras with pnMaxValue>255 expect a LUT entry size of 16 bit.

Parameters:
[in] | CamId | The ID of the camera to configure
[out] | pnNumOfLuts | A pointer to UINT32_TYPE that will receive the maximum number of look-up tables (optional may be NULL)
[out] | pnMaxValue | A pointer to UINT32_TYPE that will receive the maximum value possible for a LUT entry (optional may be NULL)
[out] | pnNumOfValues | A pointer to UINT32_TYPE that will receive the number of entries per lookup table (optional may be NULL)
[out] | pnMaxDataSize | A pointer to UINT32_TYPE that will receive the maximum size of a LUT in bytes (optional may be NULL)
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the LUT feature


AVT Universal API - Camera Control module: UCC_GetFreeBandwidth

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFreeBandwidth | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnBandwidth
 | ) |  |

Get the free bandwidth.

The free bandwidth for the bus the camera is connected to is returned

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pnBandwidth | Pointer to UINT32_TYPE receiving the free bandwith for the bus the camera is connected to
Returns:
S_OK
if all parameter are valid


AVT Universal API - Camera Control module: UCC_InputPin_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_InputPin_Get | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nWhich,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnPolarity,
 |  | UINT32_OUT_TYPE | pnState
 | ) |  |

Get state of input pins.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nWhich | The number of the input pin see UNI_MAX_INPUT_PINS
[out] | pnMode | Pointer to UINT32_TYPE that will receive the input mode see E_INPUTPIN_MODES
[out] | pnPolarity | Pointer to UINT32_TYPE that will receive the polarity
[out] | pnState | Pointer to UINT32_TYPE that will receive the input state
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the chosen input pin is not supported by the camera
Note:
For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UCC_Whitebalance_GMCY_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Whitebalance_GMCY_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nGr_CyVal,
 |  | UINT32_IN_TYPE | nMg_YeVal,
 |  | UINT32_IN_TYPE | nCy_MgVal,
 |  | UINT32_IN_TYPE | nYe_GrVal
 | ) |  |

Configure the Whitebalance for GMCY sensors.

Parameters set to UNI_UNDEFINED/E_FEATSTATE_UNDEFINED will not be changed

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nMode | mode of operation possible values are: E_FEATSTATE_OFF E_FEATSTATE_ON E_FEATSTATE_AUTO E_FEATSTATE_UNDEFINED
[in] | nGr_CyVal | mode 1:Gr Value; Mode 0:Gr/Cy Value
[in] | nMg_YeVal | mode 1:Mg Value; Mode 0:Mg/Ye Value
[in] | nCy_MgVal | mode 1:Cy Value; Mode 0:Cy/Mg Value
[in] | nYe_GrVal | mode 1:Ye Value; Mode 0:Ye/Gr Value
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the whitebalance feature
UNI_RESULT_PARAMETER_INVALID_2
if enMode is set to a value not supported
UNI_RESULT_PARAMETER_INVALID_3
if nGr_CyVal exceeds the allowed range for whitebalance values
UNI_RESULT_PARAMETER_INVALID_4
if nMg_YeVal exceeds the allowed range for whitebalance values
UNI_RESULT_PARAMETER_INVALID_5
if nCy_MgVal exceeds the allowed range for whitebalance values
UNI_RESULT_PARAMETER_INVALID_6
if nYe_GrVal exceeds the allowed range for whitebalance values


AVT Universal API - Camera Control module: UCC_AutoFunctionAOI_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_AutoFunctionAOI_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nLeft,
 |  | UINT32_IN_TYPE | nTop,
 |  | UINT32_IN_TYPE | nWidth,
 |  | UINT32_IN_TYPE | nHeight
 | ) |  |

Configure the Autofunction AOI.

Parameters set to UNI_UNDEFINED/E_FEATSTATE_UNDEFINED will not be changed

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nMode | mode of operation see: E_UNI_FEATURE_STATE
[in] | nLeft | left offset of Autofunction AOI
[in] | nTop | top offset of Autofunction AOI
[in] | nWidth | width of Autofunction AOI
[in] | nHeight | height of Autofunction AOI
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if autofunction AOI io is not supported by the camera
UNI_RESULT_PARAMETER_INVALID_2
if enMode is set to a value not supported
UNI_RESULT_PARAMETER_INVALID_3
if nLeft is greater than the current image width
UNI_RESULT_PARAMETER_INVALID_4
if nTop is geater than the current image height
UNI_RESULT_PARAMETER_INVALID_5
if nWidth is greater than the current image width minus the autofunction aoi left value
UNI_RESULT_PARAMETER_INVALID_6/dt>
if nHeight is greater than the current image height minus the autofunction aoi top value


AVT Universal API - Camera Control module: UCC_HasFeatureStatus

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_HasFeatureStatus | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_IN_TYPE | nState
 | ) |  |

Check whether a specific state is supported for the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[in] | nState | status of the feature to be checked ( see E_UNI_FEATURE_STATE for valid values )
Returns:
S_OK
if feature enFeature supports the state enState
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature enFeature does not support the state enState
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature enFeature is not supported by the camera
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_GetFeatureValue

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFeatureValue | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Get the value of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[out] | pnValue | A pointer to UINT32_TYPE that will receive the features current value
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature nFeature does not imply a value
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature is not supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_GetErrorInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetErrorInfo | ( | UNI_RETURN_TYPE | nErrCode,
 |  | ACHAR_INOUT_TYPE | pszInfoString,
 |  | UINT32_IN_TYPE | nMaxStrLen
 | ) |  |

Get error information.

The error code you supply is evaluated and the given string is filled with an error description.

Parameters:
[in] | nErrCode | error code to be described
[out] | pszInfoString | the error code description
[in] | nMaxStrLen | length of the provided string buffer
Returns:
S_OK
if the operation was successful
Note:
The following code shows an example of a UniAPI function call with subsequent error code evaluation:
 UNI_RETURN_TYPE ret = UCC_Init();
 if FAILED( ret )
 {
      char text[256];
      UCC_GetErrorInfo ( ret, text, 256 );
      printf( "UCC_Init() returned error code 0x%X (%s)", (unsigned long)ret, text );
 }


AVT Universal API - Camera Control module: UCC_SetRegisterList

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SetRegisterList | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE * | pnListPtr,
 |  | UINT32_INOUT_TYPE | pnNumOfEntries
 | ) |  |

Apply a list of direct register writes simultaneously.

This function utilizes the camera's 'register list update' feature to change the contents of several configuration registers. Register addresses and values have to be provided as a UINT32_TYPE array. Each list entry is expected to span 2 UINT32_TYPE values, the first of which is interpreted as register address followed by the value to be written.

In case of failure a partial list may have been applied. Parameter pnNumOfEntries is adjusted to the number of applied register entries at the time of function call.

Note:
The maximum supported register list size may be determined via UCC_GetRegisterListInfo.
Parameters:
[in] | CamId | the ID of the camera to use
[in] | pnListPtr | pointer to the first element of the register configuration list
pnNumOfEntries | Number of items contained by the register configuration list - will be adjusted to the number of register writes actually performed at the time of function call.
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the register list update feature is not supported by the camera
Note:
This function provides a flexible, low-level access to the camera's 'register list update' feature. Alternatively, UCC_SetFeatureList may be used as an easier access method.


AVT Universal API - Camera Control module: UCC_UserProfile_SetDefault

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UserProfile_SetDefault | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nProfileID
 | ) |  |

Set the default user profile id.

The default user profile will be loaded on startup.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nProfileID | new default profile id
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the user profile feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_OpenCamera

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_OpenCamera | ( | ID_TYPE | CamId,
 |  | INT32_IN_TYPE | lSpeedLimit = -1
 | ) |  |

Open a Camera.

updates the internal camera object to a physical camera object.

Note:
causes a NodeListChange event.
Parameters:
[in] | CamId | camera identifier (serial number)
[in] | lSpeedLimit | maximum communication bit rate to be used E_UNI_1394_SPEED
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_SaveSettingsEx

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SaveSettingsEx | ( | ID_TYPE | CamId,
 |  | const ACHAR_TYPE * | pszFileName,
 |  | UINT32_TYPE | bSaveByCameraFamily
 | ) |  |

Save the camera setting.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | pszFileName | The name of the file to use for storing settings
[in] | bSaveByCameraFamily | saves camera settings for a whole camera family
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetFeatureMin

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFeatureMin | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Get the minimum value of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[out] | pnValue | A pointer to UINT32_TYPE that will receive the features minimum value
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_FEATURECAPABILITY
if feature nFeature does not imply a value
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature is not supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_Whitebalance_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Whitebalance_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nUBVal,
 |  | UINT32_IN_TYPE | nVRVal
 | ) |  |

Configure the Whitebalance.

Parameters set to UNI_UNDEFINED/E_FEATSTATE_UNDEFINED will not be changed

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nMode | mode of operation possible values are: E_FEATSTATE_OFF E_FEATSTATE_ON E_FEATSTATE_AUTO E_FEATSTATE_ONEPUSH E_FEATSTATE_UNDEFINED
[in] | nUBVal | U / B Value
[in] | nVRVal | V / R Value
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the whitebalance feature
UNI_RESULT_PARAMETER_INVALID_2
if enMode is set to a value not supported
UNI_RESULT_PARAMETER_INVALID_3
if nUBVal exceeds the allowed range for whitebalance values
UNI_RESULT_PARAMETER_INVALID_4
if nVRVal exceeds the allowed range for whitebalance values


AVT Universal API - Camera Control module: UCC_Release

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Release ( )

Deinitialization of the API.

All actions needed to clean up the API is done. This operation must be executed after the usage of this API has ended.

Returns:
S_OK
if the operation was successful
UNI_RESULT_API_NOT_INITIALIZED
if this module was not initialized before this call


AVT Universal API - Camera Control module: UCC_Shading_Build

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Shading_Build | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFrames,
 |  | UINT32_IN_TYPE | nBlock
 | ) |  |

Invoke the build operation of a shading image inside the camera.

This function blocks until the build process finishes if nBlock is true. Otherwise it returns without blocking. The camera must not be grabbing for this function to succeed.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFrames | The number of images to use for the build operation
[in] | nBlock | A "boolean" long value to determine whether the function should block until the build process finishes
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the shading correction feature is not supported by the camera
UNI_RESULT_CAMERA_BUSY
if the camera is grabbing
UNI_RESULT_CAMERA_TIMEOUT
if the camera is still busy building the shading image at the time the function returns


AVT Universal API - Camera Control module: UCC_GetRegisterListInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetRegisterListInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMaxNumOfEntries
 | ) |  |

Provides information about the cameras 'register list update' feature.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnMaxNumOfEntries | pointer to UINT32_TYPE that will receive the maximum possible size of register update lists.
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the register list update feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_GetStreamSpeed

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetStreamSpeed | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnSpeed
 | ) |  |

Get current speed for image streaming.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnSpeed | A pointer to UINT32_TYPE that will receive the currently used streaming speed


AVT Universal API - Camera Control module: UCC_CloseAllCameras

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_CloseAllCameras ( void )

Close all cameras.

Returns:
UNI_RESULT_API_NOT_INITIALIZED
UCC_Init was not called
UNI_RESULT_CAMERA_NOT_FOUND
meaning that the camera with the given Id was not found on the bus, either bacause it has not been opened or because it is not accessible


AVT Universal API - Camera Control module: UCC_UserProfile_Load

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UserProfile_Load | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nProfileID
 | ) |  |

Load a user profile from camera memory.

The camera must not be grabbing for this function to succeed.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nProfileID | number of profile to be loaded
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the user profile feature is not supported by the camera
UNI_RESULT_CAMERA_BUSY
if the camera is grabbing


AVT Universal API - Camera Control module: UCC_GetBitmapImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetBitmapImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pImage,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Request a bitmap from the async receive buffer
Uses a byte pointer for the target image.

Sufficient memory space has to be provided by the caller.

Note:
Raw images are not debayered yet. Use debayering methods afterwards.
Since:
0.1.2
Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pImage | Pointer to image bitmap
[in] | nTimeOut | timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetBitsPerPixel

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetBitsPerPixel | ( | UINT32_IN_TYPE | ColorCode,
 |  | UINT32_OUT_TYPE | BitsPerPixel
 | ) |  |

Get the number of pixels required for the transport of an image with the given color coding.

Parameters:
[in] | ColorCode | The color coding see: E_UNI_COLOR_CODE
[out] | BitsPerPixel | The number of bits (8,12,16,24 or 48)
Returns:
S_OK
if a known color coding was submitted


AVT Universal API - Camera Control module: UCC_Trigger_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Trigger_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nActive,
 |  | UINT32_IN_TYPE | nPolarity
 | ) |  |

Configure the trigger feature.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | nMode | trigger mode (according to IIDC)
[in] | nActive | "boolean" long value to set the current activity status
[in] | nPolarity | "boolean" long value to set the status of the trigger signal inverter
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the trigger feature is not supported by the camera
UNI_RESULT_PARAMETER_INVALID_2
if the trigger mode uMode is not supported by the camera
Note:
For triggered image acquisition at least one input pin has to be chosen as trigger input by using the UCC_InputPin functions. For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UCC_Lut_GetStatus

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Lut_GetStatus | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pbActive,
 |  | UINT32_OUT_TYPE | pnLutIndex
 | ) |  |

Get the current status of the LUT feature.

Parameters:
[in] | CamId | The ID of the camera to get information about
[out] | *pbActive | A pointer to a "boolean" UINT32_TYPE value to receive the current activity status, optional can be NULL.
[out] | *pnLutIndex | A pointer to an UINT32_TYPE to receive the current LUT number, optional can be NULL.
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the LUT feature


AVT Universal API - Camera Control module: UCC_GetFreeModeInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFreeModeInfo | ( | ID_TYPE | CamId,
 |  | UINT32_TYPE | nMode,
 |  | UINT32_TYPE | nParamId,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Retrieve information about the free format (IIDC:format 7) parameters of a given mode.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | nMode | Mode Pos returned from UCC_EnumFreeModes()
[in] | nParamId | E_UNI_FREE_MODE_INFO identifier of the parameter
[out] | pnValue | returns the requested value
Returns:
S_OK
if the parameter could be retrived, for return code info use UCC_GetErrorInfo()


AVT Universal API - Camera Control module: UCC_WriteBlock

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_WriteBlock | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | uAddress,
 |  | UINT32_IN_TYPE * | pnValue,
 |  | UINT32_IN_TYPE | uLength
 | ) |  |

Write memory block to camera.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | uAddress | The start address of the register block
[out] | pnValue | Pointer to UINT32_TYPE array that holds the registers values
[in] | uLength | element count to write
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_OutputPin_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_OutputPin_Get | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nWhich,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnPolarity,
 |  | UINT32_OUT_TYPE | pnState
 | ) |  |

Get state of output pins.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nWhich | The number of the output pin see MAX_OUTPUT_PINS
[out] | pnMode | Pointer to UINT32_TYPE that will receive the input mode see E_OUTPUTPIN_MODES
[out] | pnPolarity | Pointer to UINT32_TYPE that will receive the polarity
[out] | pnState | Pointer to UINT32_TYPE that will receive the output state
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the chosen output pin is not supported by the camera
Note:
For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UCC_GetStreamSpeedMax

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetStreamSpeedMax | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | nMaxSpeed
 | ) |  |

Get maximum speed for image streaming.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | nMaxSpeed | A pointer to UINT32_TYPE that will receive the maximum supported streaming speed


AVT Universal API - Camera Control module: UCC_GrabPlanesImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabPlanesImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | UINT32_OUT_TYPE | pbIsColor,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Grab data synchronously to a planes image.

Uses byte pointers for all target planes.

Note:
Raw images are not debayered yet. Use debayering methods afterwards.
Since:
0.1.2
Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pR | The pointer to the red plane
[out] | pG | The pointer to the green plane
[out] | pB | The pointer to the blue plane
[out] | pY | The pointer to the intensity plane ( may be set to NULL )
[out] | pbIsColor | Pointer to a "boolean" UINT32_TYPE value to receive if this is a color camera
[in] | nTimeOut | Timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_OpenCameraEx

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_OpenCameraEx | ( | ID_TYPE | CamId,
 |  | INT32_TYPE | CardNr,
 |  | INT32_IN_TYPE | lSpeedLimit = -1
 | ) |  |

Open a camera with extended functionality.

updates the internal camera object to a physical camera object.

Note:
causes a NodeListChange event.
Parameters:
[in] | CamId | camera identifier (serial number)
[in] | CardNr | if Camera on more then one card choose this card
[in] | lSpeedLimit | maximum communication bit rate to be used E_UNI_1394_SPEED
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_EnumColorCode

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_EnumColorCode | ( | UINT32_TYPE * | ColorCode,
 |  | COLORCODE_ENUMERATION | ColorCodeEnum,
 |  | UINT32_IN_TYPE | CodeNr
 | ) |  |

Select a color code from an enumeration.

Parameters:
[out] | ColorCode | return the selected color coding not NULL see: E_UNI_COLOR_CODE
[in] | ColorCodeEnum | the enumeration to select from not NULL
[in] | CodeNr | position of the color coding to select
Returns:
S_OK
if all parameter are valid


AVT Universal API - Camera Control module: UCC_GrabStart

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabStart | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nTimeOut
 | ) |  |

Start grabbing images asynchronously.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | nTimeOut | timeout to wait for image to be ready
Note:
dependent on SetFeatureState with E_FEAT_STARTIMMEDIATELY the ISO stream is started or delayed.
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_UserProfile_GetInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_UserProfile_GetInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnProfileID,
 |  | UINT32_OUT_TYPE | pnProfileCount
 | ) |  |

Get the currently selected user profile id.

This function may be used after camera startup to determine the loaded user set.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnProfileID | pointer to UINT32_TYPE that will receive the profile id
[out] | pnProfileCount | pointer to UINT32_TYPE that will receive the number of profiles supported by the camera
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the user profile feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_GetCurrentImageFormat

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCurrentImageFormat | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnImageWidth,
 |  | UINT32_OUT_TYPE | pnImageHeight,
 |  | UINT32_OUT_TYPE | pnColorCoding,
 |  | UINT32_OUT_TYPE | pnImageDepth
 | ) |  |

Get current image format properties.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pnImageWidth | Pointer to UINT32_TYPE receiving the current image width
[out] | pnImageHeight | Pointer to UINT32_TYPE receiving the current image height
[out] | pnColorCoding | Pointer to UINT32_TYPE receiving the current color coding id see: E_UNI_COLOR_CODE
[out] | pnImageDepth | Pointer to UINT32_TYPE receiving the current image depth
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetCameraInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCameraInfo | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nId,
 |  | UINT32_INOUT_TYPE | pnValue
 | ) |  |

Get numerical information about the specified camera.

Parameters:
[in] | CamId | camera identifier (serial number)
[in] | nId | identifier to the camera info you'd like to receive (see E_UNI_CAMERA_INFO)
[out] | pnValue | pointer to the parameter info value
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GrabBitmapImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabBitmapImage | ( | ID_TYPE | CamId,
 |  | UINT8_OUT_TYPE | pImage,
 |  | UINT32_OUT_TYPE | pbIsColor,
 |  | UINT32_IN_TYPE | nTimeOut,
 |  | S_SIS_DATA * | pSISData = 0
 | ) |  |

Grab data synchronously into a Windows bitmap.

Uses a byte pointer for the target image.

Note:
Raw images are not debayered yet. Use debayering methods afterwards.
Since:
0.1.2
Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pImage | The pointer to the image
[out] | pbIsColor | Pointer to a "boolean" UINT32_TYPE value to receive information whether this is a color camera
[in] | nTimeOut | Timeout
[out] | pSISData | Optional secure image signature data (set E_FEAT_SIS to E_FEATSTATE_ON to receive images with embedded signature)
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GrabStop

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabStop | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nStopOption
 | ) |  |

Stops the grabbing of images.

Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | nStopOption | Option for stopping: 0 just stops grabbing (delivering all pending images), 1 cancels
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_Shading_Download

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Shading_Download | ( | ID_TYPE | CamId,
 |  | UINT8_TYPE * | pImage,
 |  | UINT32_INOUT_TYPE | pnImageSize
 | ) |  |

Download shading correction image data from the camera.

The camera must not be grabbing for this function to succeed.

Parameters:
[in] | CamId | The ID of the camera to use
[out] | pImage | Pointer to an image data buffer that will be filled with the downloaded shading image (MONO8)
pnImageSize | Pointer to an UNIT32_TYPE that will receive the size of the downloaded image (in bytes)
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the shading correction feature is not supported by the camera
UNI_RESULT_CAMERA_BUSY
if the camera is grabbing


AVT Universal API - Camera Control module: UCC_PrepareFixedGrab

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_PrepareFixedGrab | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFormat,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nFpsId
 | ) |  |

Prepare camera for image acquisition.

May be used for setting grabbing parameters for preparing your image transport in just one call. This function is primarily intended for the configuration of the fixed IIDC formats 0-2. It may be also used to configure format 7 modes with certain restrictions. Format 7 modes require additional configuration parameters, none of which is adjusted by this function. If these have already been set ( e.g. by UCC_PrepareFreeGrab calls), UCC_PrepareFixedGrab may be used to switch between different modes quickly.

Note:
the nFpsId Parameter is ignored for Format 7 Modes.
Parameters:
[in] | CamId | Camera identifier (serial number)
[in] | nFormat | The IIDC format id (0<=nFormat<=7)
[in] | nMode | The IIDC mode id (0<=nMode<=7)
[in] | nFpsId | The IIDC framerate id (see E_UNI_FRAME_RATE for valid values)
Returns:
S_OK
if the operation was successful
UNI_RESULT_INVALID_SETTINGS
if the parameters are not supported by the camera


AVT Universal API - Camera Control module: UCC_Whitebalance_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Whitebalance_Get | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnUBVal,
 |  | UINT32_OUT_TYPE | pnVRVal
 | ) |  |

Get the status of the whitebalance feature.

Parameters the caller is not interested in may be set to NULL.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnMode | pointer to UINT32_TYPE that will receive the current mode of operation. See UCC_Whitebalance_Set for possible values
[out] | pnUBVal | pointer to UINT32_TYPE that will receive the U or B value
[out] | pnVRVal | pointer to UINT32_TYPE that will receive the V or R value
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the camera does not support the whitebalance feature


AVT Universal API - Camera Control module: UCC_Lut_LoadFromCsv

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Lut_LoadFromCsv | ( | ID_TYPE | CamId,
 |  | const ACHAR_TYPE * | pszPath,
 |  | UINT32_IN_TYPE | nLength,
 |  | UINT32_IN_TYPE | nLutNr,
 |  | UINT32_IN_TYPE | nCvsPos
 | ) |  |

Load LUT to camera from CSV file.

Parameters:
[in] | CamId | id of the camera to use
[in] | pszPath | full path to the CSV file
[in] | nLength | length of the path string
[in] | nLutNr | number of LUT to load to
[in] | nCvsPos | position of the data in the CSV file


AVT Universal API - Camera Control module: UCC_Trigger_Get

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Trigger_Get | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnMode,
 |  | UINT32_OUT_TYPE | pnActive,
 |  | UINT32_OUT_TYPE | pnPolarity,
 |  | UINT32_OUT_TYPE | pnValue
 | ) |  |

Get the current configuration of the trigger feature.

Parameters:
[in] | CamId | the ID of the camera to use
[out] | pnMode | pointer to UINT32_TYPE that will receive the current trigger mode (according to IIDC)
[out] | pnActive | a pointer to a "boolean" long value to receive the current activity status
[out] | pnPolarity | a pointer to a "boolean" long value to receive the status of the trigger signal inverter
[out] | pnValue | a pointer to a "boolean" long value to receive the status of the trigger signal
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the trigger feature is not supported by the camera


AVT Universal API - Camera Control module: UCC_GetLicenseType_Global

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetLicenseType_Global ( UINT32_OUT_TYPE pnUniLicenseType )

get the api global fire grab license information.

Parameters:
[out] pnUniLicenseType active license type
See also:
E_UNI_LICENSE_TYPE


AVT Universal API - Camera Control module: UCC_GetFeatureStatus

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetFeatureStatus | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nFeature,
 |  | UINT32_OUT_TYPE | pnState
 | ) |  |

Get the status of the mentioned feature.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nFeature | ID of the feature ( see E_UNI_FEATURE for valid values )
[out] | pnState | A pointer to UINT32_TYPE that will receive the status of the feature. ( see E_UNI_FEATURE_STATE for valid values )
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if feature nFeature isn't supported by the camera
Note:
For general information about unified features see Camera configuration - Unified feature access.


AVT Universal API - Camera Control module: UCC_RegisterNodeListChangedNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_RegisterNodeListChangedNotification | ( | UNI_NOTIFICATION_HANDLE * | pHandle,
 |  | S_UNI_NOTIFICATION * | pNotification
 | ) |  |

Register a notification object for 'node list changed' events (bus reset end).

Parameters:
[out] | pHandle | returns a handle to the notification object registration
[in] | pNotification | notification object to be registered for 'bus reset end' events
Returns:
S_OK
if successful
Note:
The notification object pointed to by pNotification must not be deleted as long as its registration persists. Therefore notification object registrations should be canceled immediately when they aren't needed anymore (see UCC_UnRegisterNotification()). Notification objects may be registered for a certain camera or for all available cameras(UNI_ALL_CAMERAS).

For examples see code snippets


AVT Universal API - Camera Control module: UCC_SerialIO_ReceiveInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_SerialIO_ReceiveInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pbRxStatus,
 |  | UINT32_OUT_TYPE | puBytesPending
 | ) |  |

get information of the internal state of the SIO receiver.

Parameters:
[in] | CamId | id of the camera to query
[out] | pbRxStatus | bool receiver state ready
[out] | puBytesPending | number of bytes pending for delivery


AVT Universal API - Camera Control module: UCC_GetCurrentFixedFormat

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetCurrentFixedFormat | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pFormat,
 |  | UINT32_OUT_TYPE | pMode,
 |  | UINT32_OUT_TYPE | pFpsColId
 | ) |  |

Get current IIDC format properties.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | pFormat | Pointer to UINT32_TYPE receiving the current IIDC format
[out] | pMode | Pointer to UINT32_TYPE receiving the current IIDC mode
[out] | pFpsColId | Pointer to UINT32_TYPE receiving the current FPS id or color coding id see: :E_UNI_FRAME_RATE
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_GetLicenseType

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GetLicenseType | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnUniLicenseType
 | ) |  |

get active fire grab license information for the camera.

Parameters:
[in] | CamId | id of the camera to query the information for
[out] | pnUniLicenseType | the license type for the camera
See also:
E_UNI_LICENSE_TYPE


AVT Universal API - Camera Control module: UCC_RegisterNotification

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_RegisterNotification | ( | UNI_NOTIFICATION_HANDLE * | pHandle,
 |  | E_UNI_NOTIFICATION_EVENTS | NotificationEvent,
 |  | S_UNI_NOTIFICATION * | pNotification
 | ) |  |

Register a notification object for a specified event type.

Parameters:
[out] | pHandle | returns a handle to the notification object registration
[in] | NotificationEvent | the type of event the notification object should be registered for
[in] | pNotification | notification object to be registered
Returns:
S_OK
if successful
Note:
The notification object pointed to by pNotification must not be deleted as long as its registration persists. Therefore notification object registrations should be canceled immediately when they aren't needed anymore (see UCC_UnRegisterNotification()). Notification objects may be registered for a certain camera or for all available cameras(UNI_ALL_CAMERAS).

For examples see code snippets


AVT Universal API - Camera Control module: UCC_InputPin_Set

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_InputPin_Set | ( | ID_TYPE | CamId,
 |  | UINT32_IN_TYPE | nWhich,
 |  | UINT32_IN_TYPE | nMode,
 |  | UINT32_IN_TYPE | nPolarity
 | ) |  |

Set state of input pins.

The current states are returned

Parameters:
[in] | CamId | The ID of the camera to use
[in] | nWhich | The number of the input pin see UNI_MAX_INPUT_PINS
[in] | nMode | The input mode see E_INPUTPIN_MODES
[in] | nPolarity | The polarity
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the chosen input pin is not supported by the camera
Note:
For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UCC_Shading_Upload

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_Shading_Upload | ( | ID_TYPE | CamId,
 |  | UINT8_TYPE * | pImage,
 |  | UINT32_IN_TYPE | nImageSize
 | ) |  |

Upload shading correction image data into the camera.

The camera must not be grabbing for this function to succeed.

Parameters:
[in] | CamId | The ID of the camera to use
[in] | pImage | Pointer to image data to be uploaded
[in] | nImageSize | The size of the image in bytes
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the shading correction feature is not supported by the camera
UNI_RESULT_CAMERA_BUSY
if the camera is grabbing


AVT Universal API - Camera Control module: UCC_GrabImage

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_GrabImage | ( | ID_TYPE | CamId,
 |  | S_UNI_IMAGE * | psImage,
 |  | UINT32_OUT_TYPE | pbIsColor,
 |  | UINT32_IN_TYPE | nTimeOut
 | ) |  |

Grab an image synchronously.

Uses a structure for specifying the target format.

Parameters:
[in] | CamId | Camera identifier (serial number)
[out] | psImage | Pointer to image struct
[out] | pbIsColor | Pointer to a "boolean" UINT32_TYPE value to receive information whether this is a colour camera
[in] | nTimeOut | Timeout
Returns:
S_OK
if the operation was successful


AVT Universal API - Camera Control module: UCC_TestImage_GetInfo

UniControl.h
UCC_AutoFunctionAOI_Get
UCC_AutoFunctionAOI_Set
UCC_CheckAvailable
UCC_CloseAllCameras
UCC_CloseCamera
UCC_CreateColorCodeEnum
UCC_CreatePresetsEnum
UCC_CreateUserLog
UCC_DestroyColorCodeEnum
UCC_DestroyPresetsEnum
UCC_DisconnectAllCameras
UCC_EnumColorCode
UCC_EnumFreeModes
UCC_EnumPresets
UCC_GetAOI
UCC_GetBitmapImage
UCC_GetBitsPerPixel
UCC_GetCameraCapabilities
UCC_GetCameraInfo
UCC_GetCameraInfoString
UCC_GetCameras
UCC_GetCamerasEx
UCC_GetCurrentFixedFormat
UCC_GetCurrentImageFormat
UCC_GetErrorInfo
UCC_GetFeatureMax
UCC_GetFeatureMin
UCC_GetFeatureStatus
UCC_GetFeatureValue
UCC_GetFreeBandwidth
UCC_GetFreeModeInfo
UCC_GetImage
UCC_GetLicenseType
UCC_GetLicenseType_Global
UCC_GetNativeImage
UCC_GetPlanesImage
UCC_GetRegister
UCC_GetRegisterListInfo
UCC_GetStreamSpeed
UCC_GetStreamSpeedMax
UCC_GetSupportedFixedFormats
UCC_GetVersion
UCC_GrabBitmapImage
UCC_GrabImage
UCC_GrabNativeImage
UCC_GrabPlanesImage
UCC_GrabStart
UCC_GrabStop
UCC_HasFeature
UCC_HasFeatureStatus
UCC_Init
UCC_InputPin_Get
UCC_InputPin_Set
UCC_LoadSettings
UCC_Lut_GetInfo
UCC_Lut_GetStatus
UCC_Lut_LoadFromCsv
UCC_Lut_Upload
UCC_Lut_Use
UCC_MultiShotStart
UCC_MultiShotStop
UCC_OpenCamera
UCC_OpenCameraEx
UCC_OutputPin_Get
UCC_OutputPin_Set
UCC_ParamUpdate_Apply
UCC_ParamUpdate_Begin
UCC_PrepareFixedGrab
UCC_PrepareFreeGrab
UCC_PresetToResolution
UCC_ReadBlock
UCC_ReconnectAllCameras
UCC_RegisterFrameDroppedNotification
UCC_RegisterFrameReadyNotification
UCC_RegisterFrameStartNotification
UCC_RegisterNodeListChangedNotification
UCC_RegisterNotification
UCC_Release
UCC_SaveSettings
UCC_SaveSettingsEx
UCC_SerialIO_GetConfig
UCC_SerialIO_Receive
UCC_SerialIO_ReceiveInfo
UCC_SerialIO_SetConfig
UCC_SerialIO_Transmit
UCC_SetFeatureList
UCC_SetFeatureStatus
UCC_SetFeatureValue
UCC_SetRegister
UCC_SetRegisterList
UCC_SetStreamSpeed
UCC_Shading_Build
UCC_Shading_Download
UCC_Shading_GetInfo
UCC_Shading_Upload
UCC_TestImage_GetInfo
UCC_TestImage_Set
UCC_Trigger_Get
UCC_Trigger_Set
UCC_UnRegisterNotification
UCC_UserProfile_GetErrorStatus
UCC_UserProfile_GetInfo
UCC_UserProfile_Load
UCC_UserProfile_Save
UCC_UserProfile_SetDefault
UCC_WaitForBusReset
UCC_Whitebalance_Get
UCC_Whitebalance_GMCY_Get
UCC_Whitebalance_GMCY_Set
UCC_Whitebalance_Set
UCC_WriteBlock
UCC_WriteUserLog
UNI_RETURN_TYPE UCC_TestImage_GetInfo | ( | ID_TYPE | CamId,
 |  | UINT32_OUT_TYPE | pnImageNr,
 |  | UINT32_OUT_TYPE | pnImageCount
 | ) |  |

Get information about the test image feature.

Parameters:
[in] | CamId | the ID of the camera to use
[in] | pnImageNr | pointer to UINT32_TYPE that will receive the number of the currently activated test image A value of 0 indicates that the test image feature is not active. (normal mode of operation)
[in] | pnImageCount | pointer to UINT32_TYPE that will receive the number of supported test images
Returns:
S_OK
if the operation was successful
UNI_RESULT_FEATURE_NOT_SUPPORTED
if the test image feature is not supported by the camera
Note:
For general information see Digital IO and trigger operation.


AVT Universal API - Camera Control module: UIT_Flip

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Flip | ( | UINT8_INOUT_TYPE | pImage,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | eFlipMode,
 |  | UINT32_TYPE | eccColorCode
 | ) |  |

Generic flip of image.

Parameters:
[in,out] | pImage | Valid pointer to source/destination image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | eFlipMode | Use valid values from E_UNI_FLIP_MODE
[in] | eccColorCode | Use E_UNI_COLOR_CODE to allow for correct image flipping in horizontal and both modes
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_RGB8ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from RGB format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_IRaw8CYGMImageTransform_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform_3x3 | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 CYMG to variable image with 3x3 local filtering.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 CYMG image source
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Convert a RAW8 image to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | ColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int8. If NULL, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_Y8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

Convert Mono8 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | Mono8 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Note:
also supports E_SIF_UYVY_MONO output
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw12ToBGR16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR16 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

Pike 12Bit Packed to windows 16 BGR.

Parameters:
[out] | pDst | destination 16bit BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_GetVersion

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetVersion ( UINT32_OUT_TYPE pnValue )

Get Library Version.

Parameters:
[out] pnValue pointer, returns the library version (Major,Minor,SubMinor,Build)
Returns:
will always return S_OK


AVT Universal API - Camera Control module: UIT_GetTechnoInfo

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetTechnoInfo ( S_TECHNO_INFO * pTechnoInfo )

Get information about processor supported features.

Parameters:
[out] pTechnoInfo returns the supported SIMD technologies
Note:
This should be called before using any SIMD (MMX,SSE) optimmized functions


AVT Universal API - Camera Control module: UIT_Raw12ToBGR_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

12Bit packed RAW mode to Windows BGR with color conversion.

Parameters:
[out] | pDst | destination windows BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
[in] | ColCor | ColorCorrection used while debayering
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_IRaw8CYGMImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 CYMG to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 image source
[in] | XSize | width of the image
[in] | YSize | height off the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_YUV411ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert YUV 4:1:1 data to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (U Y Y V Y Y U Y Y V Y Y ...)
[in] | nPixelCount | The number of pixels to be converted n>1
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_IRaw8CYGMImageTransform_Bin

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMImageTransform_Bin | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert interlaced RAW8 binning format to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | interlaced RAW8 image source
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_YUV422ToRGBPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToRGBPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image in YUV422 format to R,G and B planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_CreateColorCorrectionMatrix_Int8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_CreateColorCorrectionMatrix_Int8 | ( | const FLOAT_TYPE * | fArrayCorr,
 |  | COLOR_CORRECTION_HANDLE * | phCC
 | ) |  |

Create a color conversion object and return the handle to it.

This handle may then be used in some 8 bit debayering methods. This color conversion is then used as the last operation on the image data (in RGB space). Every RGB pixel is virtually multiplied with a RGB2RGB conversion matrix and a range check is performed. The actual multiplications are implemented as integer multiplications.

Parameters:
*fArrayCorr | A float vector with nine elements containing the color conversion matrix (3 by 3)
*phCC | The pointer to the conversion object handle
Returns:
Always S_OK


AVT Universal API - Camera Control module: UIT_Raw8ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory locations
See also:
Debayering methods


AVT Universal API - Camera Control module: UIT_YUV411ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from YUV411 format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw16ToY16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToY16_CC | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits,
 |  | COLOR_CORRECTION_HANDLE | hColCor
 | ) |  |

Convert Raw16 (YH YL) to the MONO16 format (big endian) with added color conversion.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
[in] | hColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int16. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory location


AVT Universal API - Camera Control module: UIT_Packed12BitTo16Bit

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Packed12BitTo16Bit | ( | UINT16_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize
 | ) |  |

Convert a packed 12 bit format to 16 bit data.

This method may be used to convert RAW12 to RAW16 or MONO12 to MONO16, for example

Parameters:
[out] | pDst | A pointer to the destination image (see E
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
Note:
the 12bit packed data will be output as continuous 16 bit data stream without most significat 4 bit padding [p1_8bit][p1_4bit|p2_4bit][p2_8bit]...[p(n)_8bit][p(n)_4bit|p(n+1)_4bit][p(n+1)_8bit]
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_YUV422ToRGBYPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToRGBYPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | UINT8_OUT_TYPE | pY,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image from YUV422 format to R,G,B and additional Y planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[out] | pY | A pointer to the intensity plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Y8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y8ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert MONO8 to the Windows RGB format.

the Mono8 value is copied to each rgb pixel

Parameters:
[out] | pDst | A pointer to the destination image ( B G R B G R ...)
[in] | pSrc | A pointer to the source image
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_RGB8ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert RGB8 data to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y Y Y ...)
[in] | pSrc | A pointer to the source image (R G B R G B ...)
[in] | nPixelCount | The number of pixels (not: bytes) to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw8ToY8_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToY8_CC | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Convert Raw8 to a monochrome 8BPP image with additional color conversion.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | ColCor | A handle to the color conversion object, e.g. created by UIT_CreateColorCorrectionMatrix_Int8. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination can point to the same memory locations


AVT Universal API - Camera Control module: UIT_CreateColorCorrectionMatrix_Int16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_CreateColorCorrectionMatrix_Int16 | ( | const FLOAT_TYPE * | fArrayCorr,
 |  | COLOR_CORRECTION_HANDLE * | phCC
 | ) |  |

Create a color conversion object and return the handle to it.

This handle may then be used in some 16 bit debayering methods. This color conversion is then used as the last operation on the image data (in RGB space). Every RGB pixel is virtually multiplied with a RGB2RGB conversion matrix and a range check is performed. The actual multiplications are implemented as integer multiplications.

Parameters:
fArrayCorr | A float vector with nine elements containing the color conversion matrix (3 by 3)
phCC | The pointer to the conversion object handle
Returns:
Always S_OK


AVT Universal API - Camera Control module: UIT_IRaw8CYGMToBGR_Bin

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR_Bin | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM binning format into progressive RGB format.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_RGB8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC RGB8 to variable image format.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC RGB8 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_GetErrorInfo

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetErrorInfo | ( | UNI_RETURN_TYPE | nErrCode,
 |  | char * | pszInfoString,
 |  | UINT32_IN_TYPE | nMaxStrLen
 | ) |  |

translates UNI_RETURN_TYPE into an human readable description.

Parameters:
[in] | nErrCode | return code to translate
[in,out] | pszInfoString | pointer to string for output
[in] | nMaxStrLen | length of the string


AVT Universal API - Camera Control module: UIT_Y16ToY8_MMX

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToY8_MMX | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 Y4 ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful
See also:
GetTechnoInfo


AVT Universal API - Camera Control module: UIT_Raw8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_mono

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_mono | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to the Windows RGB format with R=G=B.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_RGB8ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_RGB8ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert RGB8 data to the Windows RGB format.

In the IIDC RGB format, the R,G and B values appear in inverse order, so to be displayed in Windows systems, they have to be swapped.
Naturally, this method may also be used to convert Windows RGB images to RGB images with a different byte order.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (R G B R G B ...)
[in] | nPixelCount | The number of pixels (not: bytes) to be converted
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_YUV411ToRGBPlanes

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ToRGBPlanes | ( | UINT8_OUT_TYPE | pR,
 |  | UINT8_OUT_TYPE | pG,
 |  | UINT8_OUT_TYPE | pB,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an image in YUV411 format to R,G and B planes.

Parameters:
[out] | pR | A pointer to the red plane
[out] | pG | A pointer to the green plane
[out] | pB | A pointer to the blue plane
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_GetSIS

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetSIS | ( | S_SIS_DATA * | pSISData,
 |  | const UINT8_TYPE * | pImage,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | eColorCode,
 |  | INT32_TYPE | nSISPos,
 |  | UINT32_TYPE | eSISType
 | ) |  |

extract the Secure Image Signature from a transport image.

Parameters:
[in,out] | pSISData | pointer to S_SIS_DATA struct to be filled
[in] | pImage | pointer to transport image with embedded SIS
[in] | nXSize | width of the image in pixel
[in] | nYSize | height of the image in pixel
[in] | eColorCode | IIDC color code for transport format, use E_UNI_COLOR_CODE
[in] | nSISPos | Line number where the SIS is embedded into the image
[in] | eSISType | Type of SIS, use E_UNI_SIS_TYPE


AVT Universal API - Camera Control module: UIT_Y16ToY8

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToY8 | ( | UINT8_OUT_TYPE | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to a monochrome 8BPP image.

Parameters:
[out] | pDst | A pointer to the destination image (Y1 Y2 Y3 Y4 ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_FlipVertical

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_FlipVertical | ( | UINT8_INOUT_TYPE | pImage,
 |  | UINT32_TYPE | nBytesPerLine,
 |  | UINT32_TYPE | nLines
 | ) |  |

Flip image vertically.

Creates a top-down version of the provided image (in place). This method is made for all kinds of images since the pixel format is not relevant if the correct number of overall bytes per line is submitted.

Parameters:
[in,out] | pImage | Valid pointer to source/destination image
[in] | nBytesPerLine | The number of bytes (not pixels!) per line
[in] | nLines | The number of lines
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw8ImageTransform_IntLCAA

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntLCAA | ( | VOID_TYPE * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with local color anti aliasing.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 source image, will be altered while processing
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_InterlacedToProgressive

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_InterlacedToProgressive | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize
 | ) |  |

Convert an interlaced format to a progressive format.

This method may be used to convert raw or mono images consisting of two half-images to progressive-data images. Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-0xx NIR.

Parameters:
[out] | pDst | A pointer to the destination image
[in] | pSrc | A pointer to the source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_Raw12ToBGR16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR16_CC | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern,
 |  | COLOR_CORRECTION_HANDLE | ColCor
 | ) |  |

Pike 12Bit Packed to windows 16 bit three channel BGR with color conversion.

Parameters:
[out] | pDst | destination 16bit BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
[in] | ColCor | ColorCorrection used while debayering
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw8ImageTransform_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_3x3 | ( | VOID_TYPE * | pDst,
 |  | const UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

RAW8 to variable image with 3x3 local filtering.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | RAW8 source image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_YUV422ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert YUV 4:2:2 data to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (U Y V Y U Y V Y ...)
[in] | nPixelCount | The number of pixels to be converted n>1
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_IRaw8CYGMToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_Raw8ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | RAW8 source image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Note:
also supports E_SIF_UYVY output
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_ResampleScanlinesEx

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_ResampleScanlinesEx | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | INT32_TYPE | nDstXSize,
 |  | INT32_TYPE | nDstPitch,
 |  | INT32_TYPE | nSrcXSize,
 |  | INT32_TYPE | nSrcPitch,
 |  | INT32_TYPE | nSrcYSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize,
 |  | UINT32_TYPE | nBytesPerPixel,
 |  | UINT32_TYPE | nRopMode
 | ) |  |

Do resampling along lines.

This method is made for Mono8 images as well as for Raw8 images. Extended version.

Parameters:
[out] | pDst | valid pointer to destination image
[in] | pSrc | valid const pointer to source image
[in] | nDstXSize | destination image width
[in] | nDstPitch | distance between consecutive lines in the destination image
[in] | nSrcXSize | source image width
[in] | nSrcPitch | distance between consecutive line in the source image
[in] | nSrcYSize | source image height
[in] | nDstPixelSize | destination image pixel width
[in] | nSrcPixelSize | source image pixel width
[in] | nBytesPerPixel | The number of bytes per pixel (e.g. 1 for mono, 3 for RGB)
[in] | nRopMode | use E_UNI_ROPMODE
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_DestroyColorCorrection

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_DestroyColorCorrection ( COLOR_CORRECTION_HANDLE hCC )

Destroy the color correction object identified by the given handle.

After using this operation, the handle may not be used any more.

Parameters:
hCC The handle of the conversion object to be destroyed
Returns:
  • S_OK if successful,
  • UNI_RESULT_PARAMETER_INVALID_1 if the handle is NULL
  • UNI_RESULT_COMMAND_ABORTED if the object could not be destroyed


AVT Universal API - Camera Control module: UIT_IRaw8CYGMToMono

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToMono | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM binning format into progressive RGB format with R=G=B.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B ...)
[in] | pSrc | A pointer to the Binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_Y16ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount
 | ) |  |

Convert big endian MONO16 to the Windows RGB format.

The resulting mostly monochrome image format (the R,G and B values are more or less equal to one another) lets you extract at least a 10 bit monochrome image by applying the following formula: I = 4*G + 2*(R-G) + (B-G) = 2*R + G + B

Parameters:
[out] | pDst | A pointer to the destination image ( B G R B G R ...)
[in] | pSrc | A pointer to the source image (big endian: YH YL YH YL ...)
[in] | nPixelCount | The number of pixels to be converted
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_IntLCAA

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntLCAA | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via a stronglier interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of four consecutive pixels is taken (indexes -1, 0 1 and 2)

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Camera Control module: UIT_Packed12BitTo8Bit

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Packed12BitTo8Bit | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize
 | ) |  |

Convert a packed 12 bit format to 8 bit data.

This method may be used to convert RAW12 to RAW8 or MONO12 to MONO8, for example

Parameters:
[out] | pDst | A pointer to the destination image
[in] | pSrc | A pointer to the binned interlaced image
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows (must be a multiple of 4)


AVT Universal API - Camera Control module: UIT_Y16ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y16ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC Mono16 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC Mono16 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw8ImageTransform_IntYUV422

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntYUV422 | ( | VOID_TYPE * | pDst,
 |  | UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with U/V interpolation in the YUV color space.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 image, will be altered in processing
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw16ToY16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToY16 | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits
 | ) |  |

Convert Raw16 (YH YL) to the MONO16 format (big endian).

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw16ToBGR16

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR16 | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits
 | ) |  |

Convert Raw16 (YH YL) to a 16 bit RGB format (big endian).

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw16ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert IIDC RAW16 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC RAW16 image
[in] | XSize | width of the image
[in] | YSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw16ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw16 (YH YL) to the Windows RGB format.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_Raw12ToBGR

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ToBGR | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nXSize,
 |  | UINT32_TYPE | nYSize,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

12Bit packed RAW mode to Windows BGR.

Parameters:
[out] | pDst | destination windows BGR image buffer
[in] | pSrc | 12bit packed source image
[in] | nXSize | image width
[in] | nYSize | Image height
[in] | BayerPattern | BayerPattern to debayer the image, use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_YUV411ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV411ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC YUV411 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC YUV411 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Y12ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Y12ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_TYPE | nPixelCount,
 |  | UINT32_TYPE | eImageFormat
 | ) |  |

Convert a packed 12 bit format to variable image.

Parameters:
[out] | pDst | a pointer to the destination image (according to eImageFormat)
[in] | pSrc | a pointer to the binned interlaced image
[in] | nPixelCount | number of pixels of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT


AVT Universal API - Camera Control module: UIT_GetBitsPerPixel

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetBitsPerPixel | ( | UINT32_IN_TYPE | ColorCode,
 |  | UINT32_OUT_TYPE | BitsPerPixel
 | ) |  |

get t he bits per pixel for the transport image with the given color coding.

Parameters:
[in] | ColorCode | The color coding E_UNI_COLOR_CODE (0..255)
[out] | BitsPerPixel | The number of bits (8,12,16,24 or 48)
Returns:
S_OK
if a known color coding was submitted


AVT Universal API - Camera Control module: UIT_Raw16ToBGR16_CC

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw16ToBGR16_CC | ( | void * | pDst,
 |  | const void * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern,
 |  | UINT32_IN_TYPE | nShiftBits,
 |  | COLOR_CORRECTION_HANDLE | hColCor
 | ) |  |

Convert Raw16 (YH YL) to a 16 bit RGB format (big endian) added color correction.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the raw source image (big endian:RH RL GH GL ...)
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>0
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
[in] | nShiftBits | The number of bits the result should be shifted to the right (0<=nShiftBits<=8)
[in] | hColCor | A handle to the color conversion object, e.g created by UIT_CreateColorCorrectionMatrix_Int16. If zero, no color correction is performed (faster).
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_IRaw8CYGMToBGR_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_IRaw8CYGMToBGR_3x3 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a raw interlaced CYGM format like raw or mono to a progressive RGB format with 3x3 matrix interpolation.

Only images that start with the second half-image are supported, like those that are resulting from the Guppy GF-038.

Parameters:
[out] | pDst | A pointer to the destination image ( [B,G,R] ...)
[in] | pSrc | A pointer to the raw source image
[in] | nXSize | The width of the image in columns
[in] | nYSize | The height of the image in rows (must be a multiple of 4)
[in] | nBayerPattern | The code of the start pixel -- UNUSED so far ( otherwise, see E_UNI_BAYER_PATTERN)
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations


AVT Universal API - Camera Control module: UIT_GetResampledScanlineLength

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_GetResampledScanlineLength | ( | INT32_OUT_TYPE | pDstXSize,
 |  | INT32_TYPE | nSrcXSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize
 | ) |  |

Calculate the needed destination image width for images with non-square pixels.

This method is made for Mono8 images as well as for Raw8 images.

Parameters:
[out] | pDstXSize | pointer, returns the needed destination image width
[in] | nSrcXSize | source image width
[in] | nDstPixelSize | destination image pixel size
[in] | nSrcPixelSize | source image pixel size
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_ResampleScanlines

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_ResampleScanlines | ( | UINT8_OUT_TYPE | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | INT32_TYPE | nDstXSize,
 |  | INT32_TYPE | nSrcXSize,
 |  | INT32_TYPE | nSrcYSize,
 |  | FLOAT_TYPE | nDstPixelSize,
 |  | FLOAT_TYPE | nSrcPixelSize,
 |  | UINT32_TYPE | nBytesPerPixel,
 |  | UINT32_TYPE | nRopMode
 | ) |  |

Do resampling along lines.

Parameters:
[out] | pDst | valid pointer to destination image
[in] | pSrc | valid const pointer to source image
[in] | nDstXSize | destination image width
[in] | nSrcXSize | source image width
[in] | nSrcYSize | source image height
[in] | nDstPixelSize | destination image pixel width
[in] | nSrcPixelSize | source image pixel width
[in] | nBytesPerPixel | The number of bytes per pixel (e.g. 1 for mono, 3 for RGB)
[in] | nRopMode | use E_UNI_ROPMODE
Returns:
S_OK if the operation was successful


AVT Universal API - Camera Control module: UIT_YUV422ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_YUV422ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const VOID_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nPixelCount,
 |  | UINT32_IN_TYPE | eImageFormat
 | ) |  |

convert IIDC UYVY YUV422 to variable image format.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | IIDC UYVY YUV422 source image
[in] | nPixelCount | number of pixels per image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw12ImageTransform

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw12ImageTransform | ( | VOID_TYPE * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_TYPE | BayerPattern
 | ) |  |

AVT RAW12 to variable image.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in] | pSrc | AVT RAW12 image source
[in] | nXSize | width of the image
[in] | nYSize | height of the image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | BayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_IntLCAAV

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntLCAAV | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of a four by two pixel window is taken (indexes -1, 0 1 and 2 of each row)

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R...)
[in] | pSrc | A pointer to the raw source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_IntYUV422

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_IntYUV422 | ( | void * | pDst,
 |  | UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert a RAW8 image to the Windows RGB format via an interpolated YUV422 format.

As the U resp. V value, the average of the U/V values of consecutive pixels is taken

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns n>1
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Camera Control module: UIT_Raw8ToBGR_3x3

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ToBGR_3x3 | ( | void * | pDst,
 |  | const UINT8_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | nXSize,
 |  | UINT32_IN_TYPE | nYSize,
 |  | UINT32_IN_TYPE | nBayerPattern
 | ) |  |

Convert Raw8 to the Windows RGB format using a 3x3 interpolation.

Parameters:
[out] | pDst | A pointer to the destination image (B G R B G R ...)
[in] | pSrc | A pointer to the source image (start pixel depends on parameter "nBayerPattern" )
[in] | nXSize | The width of the image in columns (must be a multiple of 2)
[in] | nYSize | The height of the image in rows n>1
[in] | nBayerPattern | The code of the start pixel , use E_UNI_BAYER_PATTERN
Returns:
S_OK if the operation was successful
Note:
Source and Destination have to point to different memory locations
See also:
Debayering methods


AVT Universal API - Camera Control module: UIT_Raw8ImageTransform_IntLCAAV

UniTransform.h
UIT_CreateColorCorrectionMatrix_Int16
UIT_CreateColorCorrectionMatrix_Int8
UIT_DestroyColorCorrection
UIT_Flip
UIT_FlipVertical
UIT_GetBitsPerPixel
UIT_GetErrorInfo
UIT_GetResampledScanlineLength
UIT_GetSIS
UIT_GetTechnoInfo
UIT_GetVersion
UIT_InterlacedToProgressive
UIT_IRaw8CYGMImageTransform
UIT_IRaw8CYGMImageTransform_3x3
UIT_IRaw8CYGMImageTransform_Bin
UIT_IRaw8CYGMToBGR
UIT_IRaw8CYGMToBGR_3x3
UIT_IRaw8CYGMToBGR_Bin
UIT_IRaw8CYGMToMono
UIT_Packed12BitTo16Bit
UIT_Packed12BitTo8Bit
UIT_Raw12ImageTransform
UIT_Raw12ToBGR
UIT_Raw12ToBGR16
UIT_Raw12ToBGR16_CC
UIT_Raw12ToBGR_CC
UIT_Raw16ImageTransform
UIT_Raw16ToBGR
UIT_Raw16ToBGR16
UIT_Raw16ToBGR16_CC
UIT_Raw16ToY16
UIT_Raw16ToY16_CC
UIT_Raw8ImageTransform
UIT_Raw8ImageTransform_3x3
UIT_Raw8ImageTransform_IntLCAA
UIT_Raw8ImageTransform_IntLCAAV
UIT_Raw8ImageTransform_IntYUV422
UIT_Raw8ToBGR
UIT_Raw8ToBGR_3x3
UIT_Raw8ToBGR_CC
UIT_Raw8ToBGR_IntLCAA
UIT_Raw8ToBGR_IntLCAAV
UIT_Raw8ToBGR_IntYUV422
UIT_Raw8ToBGR_mono
UIT_Raw8ToY8
UIT_Raw8ToY8_CC
UIT_ResampleScanlines
UIT_ResampleScanlinesEx
UIT_RGB8ImageTransform
UIT_RGB8ToBGR
UIT_RGB8ToRGBYPlanes
UIT_RGB8ToY8
UIT_Y12ImageTransform
UIT_Y16ImageTransform
UIT_Y16ToBGR
UIT_Y16ToY8
UIT_Y16ToY8_MMX
UIT_Y8ImageTransform
UIT_Y8ToBGR
UIT_YUV411ImageTransform
UIT_YUV411ToBGR
UIT_YUV411ToRGBPlanes
UIT_YUV411ToRGBYPlanes
UIT_YUV422ImageTransform
UIT_YUV422ToBGR
UIT_YUV422ToRGBPlanes
UIT_YUV422ToRGBYPlanes
UNI_RETURN_TYPE UIT_Raw8ImageTransform_IntLCAAV | ( | VOID_TYPE * | pDst,
 |  | UINT8_IN_TYPE * | pSrc,
 |  | UINT32_IN_TYPE | XSize,
 |  | UINT32_IN_TYPE | YSize,
 |  | UINT32_IN_TYPE | eImageFormat,
 |  | UINT32_IN_TYPE | bayerPattern
 | ) |  |

convert RAW8 to variable image with local color anti aliasing vertical interpolation.

Parameters:
[out] | pDst | variable image format destination (according to eImageFormat)
[in,out] | pSrc | RAW8 image, will be altered in processing
[in] | XSize | width of image
[in] | YSize | height of image
[in] | eImageFormat | destination E_UNI_SIMPLE_IMAGE_FORMAT
[in] | bayerPattern | bayer pattern E_UNI_BAYER_PATTERN
Returns:
UNI_RETURN_TYPE


AVT Universal API - Camera Control module: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structure Index

S

S
S_IIDC_VIDEOINFO_FORMAT S_SIS_ENABLE S_UNI_IMAGE S_UNI_WINDOWS_MESSAGE
S_12BIT_2PACKED S_IIDC_VIDEOINFO_FPS S_SIS_ENABLE::S_SIS_ENABLE_FIELDS S_UNI_NOTIFICATION S_YUV411
S_BGR16 S_IIDC_VIDEOINFO_MODE S_SUPPORT_STATE S_UNI_NOTIFICATION_CALLBACK S_YUV422
S_BGR8 S_RGB8 S_TECHNO_INFO S_UNI_NOTIFICATION_EVENT S_YUV444
S_BGRA8 S_SIS_DATA S_UNI_CALLBACK_ARGUMENT

S


AVT Universal API - Camera Control module: Data Fields - Functions

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Functions
  • Variables

  • S_UNI_CALLBACK_ARGUMENT() : S_UNI_CALLBACK_ARGUMENT
  • S_UNI_NOTIFICATION_CALLBACK() : S_UNI_NOTIFICATION_CALLBACK
  • S_UNI_NOTIFICATION_EVENT() : S_UNI_NOTIFICATION_EVENT
  • S_UNI_WINDOWS_MESSAGE() : S_UNI_WINDOWS_MESSAGE


AVT Universal API - Camera Control module: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Functions
  • Variables
  • a
  • b
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • u
  • v
  • y

- a -

  • A : S_BGRA8
  • AMD3DNow : S_TECHNO_INFO

- b -

  • B : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- g -

  • G : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- i -

  • ImageAsMultiPlanes : S_UNI_IMAGE
  • IntelMMX : S_TECHNO_INFO
  • IntelSSE : S_TECHNO_INFO
  • IntelSSE2 : S_TECHNO_INFO
  • IntelSSE3 : S_TECHNO_INFO
  • IntelSSSE3 : S_TECHNO_INFO

- m -

  • m_AOIHeight : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOILeft : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_AOITop : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_AOIWidth : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Arg : S_UNI_NOTIFICATION_CALLBACK
  • m_Callback : S_UNI_NOTIFICATION_CALLBACK
  • m_CamId : S_UNI_CALLBACK_ARGUMENT , S_UNI_NOTIFICATION_EVENT , S_UNI_NOTIFICATION
  • m_ColorCoding : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_CycleCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Data : S_SIS_ENABLE
  • m_Enable : S_SIS_ENABLE
  • m_Event : S_UNI_NOTIFICATION_EVENT
  • m_FormatInq : S_IIDC_VIDEOINFO_FORMAT
  • m_FpsInq : S_IIDC_VIDEOINFO_FPS
  • m_FrameCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Gain : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_hWnd : S_UNI_WINDOWS_MESSAGE
  • m_InputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_lParam : S_UNI_WINDOWS_MESSAGE
  • m_ModeInq : S_IIDC_VIDEOINFO_MODE
  • m_Msg : S_UNI_WINDOWS_MESSAGE
  • m_NotificationCallback : S_UNI_NOTIFICATION
  • m_NotificationEvent : S_UNI_NOTIFICATION
  • m_NotificationType : S_UNI_NOTIFICATION
  • m_NotificationWindowsMessage : S_UNI_NOTIFICATION
  • m_nVal8_1 : S_12BIT_2PACKED
  • m_nVal8_1Low : S_12BIT_2PACKED
  • m_nVal8_2 : S_12BIT_2PACKED
  • m_nVal8_2Low : S_12BIT_2PACKED
  • m_OutputState : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Parameter : S_UNI_CALLBACK_ARGUMENT
  • m_Reservec1 : S_SIS_DATA
  • m_Reserved : S_UNI_NOTIFICATION_EVENT , S_UNI_CALLBACK_ARGUMENT
  • m_Reserved0 : S_SIS_DATA
  • m_Reserved2a : S_SIS_DATA
  • m_Reserved2b : S_SIS_DATA
  • m_SequenceIndex : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_SerialNumber : S_SIS_DATA , S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_Shutter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_SISEnable : S_SIS_DATA
  • m_TriggerCounter : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_UserValue : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS , S_SIS_DATA
  • m_Valid : S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
  • m_wParam : S_UNI_WINDOWS_MESSAGE

- o -

  • OperatingSystem : S_SUPPORT_STATE

- p -

  • pImageAsSinglePlane : S_UNI_IMAGE
  • pImageBlue : S_UNI_IMAGE
  • pImageGreen : S_UNI_IMAGE
  • pImageRed : S_UNI_IMAGE
  • pImageY : S_UNI_IMAGE
  • Processor : S_SUPPORT_STATE

- r -

  • R : S_RGB8 , S_BGR16 , S_BGRA8 , S_BGR8

- s -

  • SISData : S_UNI_IMAGE
  • SISEnabled : S_UNI_IMAGE

- u -

  • U : S_YUV444 , S_YUV422 , S_YUV411
  • uImageformat : S_UNI_IMAGE

- v -

  • V : S_YUV444 , S_YUV411 , S_YUV422

- y -

  • Y : S_YUV444
  • Y0 : S_YUV422 , S_YUV411
  • Y1 : S_YUV411 , S_YUV422
  • Y2 : S_YUV411
  • Y3 : S_YUV411


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • ACHAR_IN_TYPE : uni_types.h
  • ACHAR_INOUT_TYPE : uni_types.h
  • ACHAR_OUT_TYPE : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • BOOL_IN_TYPE : uni_types.h
  • BOOL_INOUT_TYPE : uni_types.h
  • BOOL_OUT_TYPE : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CHAR_INOUT_TYPE : uni_types.h
  • CHAR_OUT_TYPE : uni_types.h
  • CHAR_TYPE : uni_types.h
  • COLOR_CORRECTION_HANDLE : uni_types.h
  • COLORCODE_ENUMERATION : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • DOUBLE_IN_TYPE : uni_types.h
  • DOUBLE_INOUT_TYPE : uni_types.h
  • DOUBLE_OUT_TYPE : uni_types.h
  • DOUBLE_TYPE : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • E_BP_AUTO : uni_defines.h
  • E_BP_BGGR : uni_defines.h
  • E_BP_CYGM : uni_defines.h
  • E_BP_CYMG : uni_defines.h
  • E_BP_GBRG : uni_defines.h
  • E_BP_GMCY : uni_defines.h
  • E_BP_GRBG : uni_defines.h
  • E_BP_MGCY : uni_defines.h
  • E_BP_RGGB : uni_defines.h
  • E_CAMINFO_BAYERPATTERN : uni_defines.h
  • E_CAMINFO_COLORCAMERA : uni_defines.h
  • E_CAMINFO_CUSTOMERKEY : uni_defines.h
  • E_CAMINFO_FPGAVERSION : uni_defines.h
  • E_CAMINFO_IIDCVERSION : uni_defines.h
  • E_CAMINFO_INTERLACED : uni_defines.h
  • E_CAMINFO_MAXDEPTH : uni_defines.h
  • E_CAMINFO_MAXHEIGHT : uni_defines.h
  • E_CAMINFO_MAXWIDTH : uni_defines.h
  • E_CAMINFO_MCVERSION : uni_defines.h
  • E_CAMINFO_MODEL : uni_defines.h
  • E_CAMINFO_ORDERID : uni_defines.h
  • E_CAMINFO_SISTYPE : uni_defines.h
  • E_CAMINFO_SN : uni_defines.h
  • E_CAMINFO_VENDOR : uni_defines.h
  • E_CC_MONO12 : uni_defines.h
  • E_CC_MONO16 : uni_defines.h
  • E_CC_MONO8 : uni_defines.h
  • E_CC_MONOB : uni_defines.h
  • E_CC_MONOG : uni_defines.h
  • E_CC_MONOR : uni_defines.h
  • E_CC_RAW12 : uni_defines.h
  • E_CC_RAW16 : uni_defines.h
  • E_CC_RAW8 : uni_defines.h
  • E_CC_RGB12 : uni_defines.h
  • E_CC_RGB16 : uni_defines.h
  • E_CC_RGB8 : uni_defines.h
  • E_CC_SMONO12 : uni_defines.h
  • E_CC_SMONO16 : uni_defines.h
  • E_CC_SRGB12 : uni_defines.h
  • E_CC_SRGB16 : uni_defines.h
  • E_CC_YUV411 : uni_defines.h
  • E_CC_YUV422 : uni_defines.h
  • E_CC_YUV444 : uni_defines.h
  • E_FEAT_AUTOEXPOSURE : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_HEIGHT : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_LEFT : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_TOP : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_WIDTH : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_XUNITS : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_YUNITS : uni_defines.h
  • E_FEAT_AUTOGAIN_HIGH : uni_defines.h
  • E_FEAT_AUTOGAIN_LOW : uni_defines.h
  • E_FEAT_AUTOSHUTTER_HIGH : uni_defines.h
  • E_FEAT_AUTOSHUTTER_LOW : uni_defines.h
  • E_FEAT_BLEMISHCORRECTION : uni_defines.h
  • E_FEAT_BRIGHTNESS : uni_defines.h
  • E_FEAT_BURSTCOUNT : uni_defines.h
  • E_FEAT_CAMACCEPTDELAY : uni_defines.h
  • E_FEAT_CAMERABUSY : uni_defines.h
  • E_FEAT_COLORCORRECTION : uni_defines.h
  • E_FEAT_CYCLETIME : uni_defines.h
  • E_FEAT_DELAYEDINTEGRATIONENABLE : uni_defines.h
  • E_FEAT_DO_BUSTRIGGER : uni_defines.h
  • E_FEAT_DO_MULTIBUSTRIGGER : uni_defines.h
  • E_FEAT_DSNUCORRECTION : uni_defines.h
  • E_FEAT_EXPOSUREOFFSET : uni_defines.h
  • E_FEAT_EXTENDEDSHUTTER : uni_defines.h
  • E_FEAT_FRAMEBUFFERCOUNT : uni_defines.h
  • E_FEAT_FRAMECOUNTER : uni_defines.h
  • E_FEAT_FRAMEMEMORYSIZE : uni_defines.h
  • E_FEAT_GAIN : uni_defines.h
  • E_FEAT_GAMMA : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT1 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT2 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT3 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINTCOUNT : uni_defines.h
  • E_FEAT_HIGHSNR : uni_defines.h
  • E_FEAT_HUE : uni_defines.h
  • E_FEAT_IRMFREEBW : uni_defines.h
  • E_FEAT_ISOCHANNEL : uni_defines.h
  • E_FEAT_LIST_ALL_CAMERAS : uni_defines.h
  • E_FEAT_LOGGING : uni_defines.h
  • E_FEAT_LUT : uni_defines.h
  • E_FEAT_LUT_BITSPERVAL : uni_defines.h
  • E_FEAT_LUT_MAXSIZE : uni_defines.h
  • E_FEAT_NONE : uni_defines.h
  • E_FEAT_PARAMUPDATETIMING : uni_defines.h
  • E_FEAT_PHYSPEED : uni_defines.h
  • E_FEAT_REDUCEDSMEAR : uni_defines.h
  • E_FEAT_SATURATION : uni_defines.h
  • E_FEAT_SHADING : uni_defines.h
  • E_FEAT_SHARPNESS : uni_defines.h
  • E_FEAT_SHUTTER : uni_defines.h
  • E_FEAT_SIS : uni_defines.h
  • E_FEAT_SIS_MARLIN : uni_defines.h
  • E_FEAT_SIS_PIKE : uni_defines.h
  • E_FEAT_SOFTRESET : uni_defines.h
  • E_FEAT_STARTIMMEDIATELY : uni_defines.h
  • E_FEAT_TIMEBASE : uni_defines.h
  • E_FEAT_TRIGGERDELAY : uni_defines.h
  • E_FEAT_TRIGGERDELAYADV : uni_defines.h
  • E_FEAT_USEIRMFORBW : uni_defines.h
  • E_FEAT_USEIRMFORCHN : uni_defines.h
  • E_FEAT_USERPROFILE : uni_defines.h
  • E_FEAT_WHITEBALANCE_CY : uni_defines.h
  • E_FEAT_WHITEBALANCE_GR : uni_defines.h
  • E_FEAT_WHITEBALANCE_MG : uni_defines.h
  • E_FEAT_WHITEBALANCE_UB : uni_defines.h
  • E_FEAT_WHITEBALANCE_VR : uni_defines.h
  • E_FEAT_WHITEBALANCE_YE : uni_defines.h
  • E_FEAT_XMIRRORIMAGE : uni_defines.h
  • E_FEATSTATE_AUTO : uni_defines.h
  • E_FEATSTATE_BUSY : uni_defines.h
  • E_FEATSTATE_CLEARDATA : uni_defines.h
  • E_FEATSTATE_ERROR : uni_defines.h
  • E_FEATSTATE_LOADDATA : uni_defines.h
  • E_FEATSTATE_OFF : uni_defines.h
  • E_FEATSTATE_ON : uni_defines.h
  • E_FEATSTATE_ONEPUSH : uni_defines.h
  • E_FEATSTATE_SAVEDATA : uni_defines.h
  • E_FEATSTATE_SHOWIMAGE : uni_defines.h
  • E_FEATSTATE_UNDEFINED : uni_defines.h
  • E_FLIP_MODE_BOTH : uni_defines.h
  • E_FLIP_MODE_HORIZONTAL : uni_defines.h
  • E_FLIP_MODE_LEFT_RIGHT : uni_defines.h
  • E_FLIP_MODE_TOP_DOWN : uni_defines.h
  • E_FLIP_MODE_VERTICAL : uni_defines.h
  • E_FR_120 : uni_defines.h
  • E_FR_15 : uni_defines.h
  • E_FR_1_875 : uni_defines.h
  • E_FR_240 : uni_defines.h
  • E_FR_30 : uni_defines.h
  • E_FR_3_75 : uni_defines.h
  • E_FR_60 : uni_defines.h
  • E_FR_7_5 : uni_defines.h
  • E_FREE_MODE_BYTE_PER_FRAME : uni_defines.h
  • E_FREE_MODE_HEIGHT : uni_defines.h
  • E_FREE_MODE_PIXELCOUNT : uni_defines.h
  • E_FREE_MODE_UNIT_POS_H : uni_defines.h
  • E_FREE_MODE_UNIT_POS_V : uni_defines.h
  • E_FREE_MODE_UNIT_SIZE_H : uni_defines.h
  • E_FREE_MODE_UNIT_SIZE_V : uni_defines.h
  • E_FREE_MODE_WIDTH : uni_defines.h
  • E_IF_ABGR : uni_defines.h
  • E_IF_BGR : uni_defines.h
  • E_IF_MONO8 : uni_defines.h
  • E_IF_NATIVE : uni_defines.h
  • E_IF_RGB_PLANES : uni_defines.h
  • E_IF_RGBY_PLANES : uni_defines.h
  • E_INPUTPIN_MODES : uni_defines.h
  • E_InputPinModes : uni_defines.h
  • E_IPINMODE_OFF : uni_defines.h
  • E_IPINMODE_TRIGGER : uni_defines.h
  • E_LOG_DEBUG : uni_defines.h
  • E_LOG_ERROR : uni_defines.h
  • E_LOG_FATAL : uni_defines.h
  • E_LOG_INFO : uni_defines.h
  • E_LOG_LEVELMASK : uni_defines.h
  • E_LOG_WARNING : uni_defines.h
  • E_LT_CARDGUID : uni_defines.h
  • E_LT_DATELIMITED : uni_defines.h
  • E_LT_DEVICE : uni_defines.h
  • E_LT_ETHERNET : uni_defines.h
  • E_LT_HARDDISK : uni_defines.h
  • E_LT_NOLICENSE : uni_defines.h
  • E_LT_VENDOR : uni_defines.h
  • E_OPINMODE_BUSY : uni_defines.h
  • E_OPINMODE_FOLLOW_IN : uni_defines.h
  • E_OPINMODE_FRAMEVALID : uni_defines.h
  • E_OPINMODE_INTENA : uni_defines.h
  • E_OPINMODE_OFF : uni_defines.h
  • E_OPINMODE_PINSTATE : uni_defines.h
  • E_OUTPUTPIN_MODES : uni_defines.h
  • E_OutputPinModes : uni_defines.h
  • E_PRESET_DC2K : uni_defines.h
  • E_PRESET_DC4K : uni_defines.h
  • E_PRESET_HD1080 : uni_defines.h
  • E_PRESET_HD720 : uni_defines.h
  • E_PRESET_PAL : uni_defines.h
  • E_PRESET_QSXGA : uni_defines.h
  • E_PRESET_QVGA : uni_defines.h
  • E_PRESET_QXGA : uni_defines.h
  • E_PRESET_SVGA : uni_defines.h
  • E_PRESET_SXGA : uni_defines.h
  • E_PRESET_SXGAP : uni_defines.h
  • E_PRESET_UXGA : uni_defines.h
  • E_PRESET_VGA : uni_defines.h
  • E_PRESET_WVGA : uni_defines.h
  • E_PRESET_XGA : uni_defines.h
  • E_PRESET_XVGA : uni_defines.h
  • E_ROP_LININTERPOL : uni_defines.h
  • E_ROP_SRCCPY : uni_defines.h
  • E_SIF_BGR24 : uni_defines.h
  • E_SIF_BGRA32 : uni_defines.h
  • E_SIF_MONO8_REC601 : uni_defines.h
  • E_SIF_MONO8_REC709 : uni_defines.h
  • E_SIF_UYVY : uni_defines.h
  • E_SIOBAUDRATE_115200 : uni_defines.h
  • E_SIOBAUDRATE_1200 : uni_defines.h
  • E_SIOBAUDRATE_19200 : uni_defines.h
  • E_SIOBAUDRATE_230400 : uni_defines.h
  • E_SIOBAUDRATE_2400 : uni_defines.h
  • E_SIOBAUDRATE_300 : uni_defines.h
  • E_SIOBAUDRATE_38400 : uni_defines.h
  • E_SIOBAUDRATE_4800 : uni_defines.h
  • E_SIOBAUDRATE_57600 : uni_defines.h
  • E_SIOBAUDRATE_600 : uni_defines.h
  • E_SIOBAUDRATE_9600 : uni_defines.h
  • E_SIOMODE_DISABLED : uni_defines.h
  • E_SIOMODE_RECEIVE : uni_defines.h
  • E_SIOMODE_RECEIVETRANSMIT : uni_defines.h
  • E_SIOMODE_TRANSMIT : uni_defines.h
  • E_SIOPARITY_EVEN : uni_defines.h
  • E_SIOPARITY_NONE : uni_defines.h
  • E_SIOPARITY_ODD : uni_defines.h
  • E_SIOSTOPBITS_1 : uni_defines.h
  • E_SIOSTOPBITS_1_5 : uni_defines.h
  • E_SIOSTOPBITS_2 : uni_defines.h
  • E_SIS_MARLIN : uni_defines.h
  • E_SIS_NOT_PRESENT : uni_defines.h
  • E_SIS_PIKE : uni_defines.h
  • E_SPEED100 : uni_defines.h
  • E_SPEED200 : uni_defines.h
  • E_SPEED400 : uni_defines.h
  • E_SPEED800 : uni_defines.h
  • E_SPEED_AUTO : uni_defines.h
  • E_SPEED_LAST : uni_defines.h
  • E_T_FRAMELIMITED : uni_defines.h
  • E_Uni1394Speed : uni_defines.h
  • E_UNI_1394_SPEED : uni_defines.h
  • E_UNI_BAYER_PATTERN : uni_defines.h
  • E_UNI_CAMERA_INFO : uni_defines.h
  • E_UNI_COLOR_CODE : uni_defines.h
  • E_UNI_FEATURE : uni_defines.h
  • E_UNI_FEATURE_STATE : uni_defines.h
  • E_UNI_FLIP_MODE : uni_defines.h
  • E_UNI_FRAME_RATE : uni_defines.h
  • E_UNI_FREE_MODE_INFO : uni_defines.h
  • E_UNI_IMAGE_FORMAT : uni_defines.h
  • E_UNI_LICENSE_TYPE : uni_defines.h
  • E_UNI_LOGGING : uni_defines.h
  • E_UNI_NOTIFICATION_CALLBACK : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_BUS : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_DMA : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_FRAME : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_MISC : uni_notification.h
  • E_UNI_NOTIFICATION_EVENT : uni_notification.h
  • E_UNI_NOTIFICATION_EVENTS : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_DROPPED : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_READY : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_START : uni_notification.h
  • E_UNI_NOTIFICATION_MESSAGE : uni_notification.h
  • E_UNI_NOTIFICATION_NO_TYPE : uni_notification.h
  • E_UNI_NOTIFICATION_NODELIST_CHANGED : uni_notification.h
  • E_UNI_NOTIFICATION_TYPE : uni_notification.h
  • E_UNI_RESOLUTION_PRESETS : uni_defines.h
  • E_UNI_ROPMODE : uni_defines.h
  • E_UNI_SIMPLE_IMAGE_FORMAT : uni_defines.h
  • E_UNI_SIO_BAUDRATE : uni_defines.h
  • E_UNI_SIO_MODE : uni_defines.h
  • E_UNI_SIO_PARITY : uni_defines.h
  • E_UNI_SIO_STOPBITS : uni_defines.h
  • E_UNI_SIS_TYPE : uni_defines.h
  • E_UniBayerPattern : uni_defines.h
  • E_UniCameraInfo : uni_defines.h
  • E_UniColorCode : uni_defines.h
  • E_UniFeature : uni_defines.h
  • E_UniFeatureState : uni_defines.h
  • E_UniFlipMode : uni_defines.h
  • E_UniFrameRate : uni_defines.h
  • E_UniFreeModeInfo : uni_defines.h
  • E_UniImageFormat : uni_defines.h
  • E_UniLicenseType : uni_defines.h
  • E_UniLogging : uni_defines.h
  • E_UniResolutionPresets : uni_defines.h
  • E_UniRopMode : uni_defines.h
  • E_UniSimpleImageFormat : uni_defines.h
  • E_UniSioBaudRate : uni_defines.h
  • E_UniSioMode : uni_defines.h
  • E_UniSioParity : uni_defines.h
  • E_UniSioStopbits : uni_defines.h
  • E_UniSISType : uni_defines.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FLOAT_IN_TYPE : uni_types.h
  • FLOAT_INOUT_TYPE : uni_types.h
  • FLOAT_OUT_TYPE : uni_types.h
  • FLOAT_TYPE : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- h -

  • HRESULT : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • ID_TYPE : uni_types.h
  • INT16_IN_TYPE : uni_types.h
  • INT16_INOUT_TYPE : uni_types.h
  • INT16_OUT_TYPE : uni_types.h
  • int16_t : uni_types.h
  • INT16_TYPE : uni_types.h
  • INT32_IN_TYPE : uni_types.h
  • INT32_INOUT_TYPE : uni_types.h
  • INT32_OUT_TYPE : uni_types.h
  • int32_t : uni_types.h
  • INT32_TYPE : uni_types.h
  • INT64_IN_TYPE : uni_types.h
  • INT64_INOUT_TYPE : uni_types.h
  • INT64_OUT_TYPE : uni_types.h
  • int64_t : uni_types.h
  • INT64_TYPE : uni_types.h
  • INT8_IN_TYPE : uni_types.h
  • INT8_INOUT_TYPE : uni_types.h
  • INT8_OUT_TYPE : uni_types.h
  • INT8_TYPE : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • POINTER_SIZE : uni_types.h
  • PRESETS_ENUMERATION : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • S_IIDC_VideoInfoFormat : uni_defines.h
  • S_IIDC_VideoInfoMode : uni_defines.h
  • S_IIDCVideoInfoFps : uni_defines.h
  • S_SISData : uni_defines.h
  • S_SISEnable : uni_defines.h
  • S_SupportState : uni_defines.h
  • S_TechInfo : uni_defines.h
  • S_UniImage : uni_defines.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • UCC_AutoFunctionAOI_Get() : UniControl.h
  • UCC_AutoFunctionAOI_Set() : UniControl.h
  • UCC_CheckAvailable() : UniControl.h
  • UCC_CloseAllCameras() : UniControl.h
  • UCC_CloseCamera() : UniControl.h
  • UCC_CreateColorCodeEnum() : UniControl.h
  • UCC_CreatePresetsEnum() : UniControl.h
  • UCC_CreateUserLog() : UniControl.h
  • UCC_DestroyColorCodeEnum() : UniControl.h
  • UCC_DestroyPresetsEnum() : UniControl.h
  • UCC_DisconnectAllCameras() : UniControl.h
  • UCC_EnumColorCode() : UniControl.h
  • UCC_EnumFreeModes() : UniControl.h
  • UCC_EnumPresets() : UniControl.h
  • UCC_GetAOI() : UniControl.h
  • UCC_GetBitmapImage() : UniControl.h
  • UCC_GetBitsPerPixel() : UniControl.h
  • UCC_GetCameraCapabilities() : UniControl.h
  • UCC_GetCameraInfo() : UniControl.h
  • UCC_GetCameraInfoString() : UniControl.h
  • UCC_GetCameras() : UniControl.h
  • UCC_GetCamerasEx() : UniControl.h
  • UCC_GetCurrentFixedFormat() : UniControl.h
  • UCC_GetCurrentImageFormat() : UniControl.h
  • UCC_GetErrorInfo() : UniControl.h
  • UCC_GetFeatureMax() : UniControl.h
  • UCC_GetFeatureMin() : UniControl.h
  • UCC_GetFeatureStatus() : UniControl.h
  • UCC_GetFeatureValue() : UniControl.h
  • UCC_GetFreeBandwidth() : UniControl.h
  • UCC_GetFreeModeInfo() : UniControl.h
  • UCC_GetImage() : UniControl.h
  • UCC_GetLicenseType() : UniControl.h
  • UCC_GetLicenseType_Global() : UniControl.h
  • UCC_GetNativeImage() : UniControl.h
  • UCC_GetPlanesImage() : UniControl.h
  • UCC_GetRegister() : UniControl.h
  • UCC_GetRegisterListInfo() : UniControl.h
  • UCC_GetStreamSpeed() : UniControl.h
  • UCC_GetStreamSpeedMax() : UniControl.h
  • UCC_GetSupportedFixedFormats() : UniControl.h
  • UCC_GetVersion() : UniControl.h
  • UCC_GrabBitmapImage() : UniControl.h
  • UCC_GrabImage() : UniControl.h
  • UCC_GrabNativeImage() : UniControl.h
  • UCC_GrabPlanesImage() : UniControl.h
  • UCC_GrabStart() : UniControl.h
  • UCC_GrabStop() : UniControl.h
  • UCC_HasFeature() : UniControl.h
  • UCC_HasFeatureStatus() : UniControl.h
  • UCC_Init() : UniControl.h
  • UCC_InputPin_Get() : UniControl.h
  • UCC_InputPin_Set() : UniControl.h
  • UCC_LoadSettings() : UniControl.h
  • UCC_Lut_GetInfo() : UniControl.h
  • UCC_Lut_GetStatus() : UniControl.h
  • UCC_Lut_LoadFromCsv() : UniControl.h
  • UCC_Lut_Upload() : UniControl.h
  • UCC_Lut_Use() : UniControl.h
  • UCC_MultiShotStart() : UniControl.h
  • UCC_MultiShotStop() : UniControl.h
  • UCC_OpenCamera() : UniControl.h
  • UCC_OpenCameraEx() : UniControl.h
  • UCC_OutputPin_Get() : UniControl.h
  • UCC_OutputPin_Set() : UniControl.h
  • UCC_ParamUpdate_Apply() : UniControl.h
  • UCC_ParamUpdate_Begin() : UniControl.h
  • UCC_PrepareFixedGrab() : UniControl.h
  • UCC_PrepareFreeGrab() : UniControl.h
  • UCC_PresetToResolution() : UniControl.h
  • UCC_ReadBlock() : UniControl.h
  • UCC_ReconnectAllCameras() : UniControl.h
  • UCC_RegisterFrameDroppedNotification() : UniControl.h
  • UCC_RegisterFrameReadyNotification() : UniControl.h
  • UCC_RegisterFrameStartNotification() : UniControl.h
  • UCC_RegisterNodeListChangedNotification() : UniControl.h
  • UCC_RegisterNotification() : UniControl.h
  • UCC_Release() : UniControl.h
  • UCC_SaveSettings() : UniControl.h
  • UCC_SaveSettingsEx() : UniControl.h
  • UCC_SerialIO_GetConfig() : UniControl.h
  • UCC_SerialIO_Receive() : UniControl.h
  • UCC_SerialIO_ReceiveInfo() : UniControl.h
  • UCC_SerialIO_SetConfig() : UniControl.h
  • UCC_SerialIO_Transmit() : UniControl.h
  • UCC_SetFeatureList() : UniControl.h
  • UCC_SetFeatureStatus() : UniControl.h
  • UCC_SetFeatureValue() : UniControl.h
  • UCC_SetRegister() : UniControl.h
  • UCC_SetRegisterList() : UniControl.h
  • UCC_SetStreamSpeed() : UniControl.h
  • UCC_Shading_Build() : UniControl.h
  • UCC_Shading_Download() : UniControl.h
  • UCC_Shading_GetInfo() : UniControl.h
  • UCC_Shading_Upload() : UniControl.h
  • UCC_TestImage_GetInfo() : UniControl.h
  • UCC_TestImage_Set() : UniControl.h
  • UCC_Trigger_Get() : UniControl.h
  • UCC_Trigger_Set() : UniControl.h
  • UCC_UnRegisterNotification() : UniControl.h
  • UCC_UserProfile_GetErrorStatus() : UniControl.h
  • UCC_UserProfile_GetInfo() : UniControl.h
  • UCC_UserProfile_Load() : UniControl.h
  • UCC_UserProfile_Save() : UniControl.h
  • UCC_UserProfile_SetDefault() : UniControl.h
  • UCC_WaitForBusReset() : UniControl.h
  • UCC_Whitebalance_Get() : UniControl.h
  • UCC_Whitebalance_GMCY_Get() : UniControl.h
  • UCC_Whitebalance_GMCY_Set() : UniControl.h
  • UCC_Whitebalance_Set() : UniControl.h
  • UCC_WriteBlock() : UniControl.h
  • UCC_WriteUserLog() : UniControl.h
  • UINT16_IN_TYPE : uni_types.h
  • UINT16_INOUT_TYPE : uni_types.h
  • UINT16_OUT_TYPE : uni_types.h
  • uint16_t : uni_types.h
  • UINT16_TYPE : uni_types.h
  • UINT32_IN_TYPE : uni_types.h
  • UINT32_INOUT_TYPE : uni_types.h
  • UINT32_OUT_TYPE : uni_types.h
  • uint32_t : uni_types.h
  • UINT32_TYPE : uni_types.h
  • UINT64_IN_TYPE : uni_types.h
  • UINT64_INOUT_TYPE : uni_types.h
  • UINT64_OUT_TYPE : uni_types.h
  • uint64_t : uni_types.h
  • UINT64_TYPE : uni_types.h
  • UINT8_IN_TYPE : uni_types.h
  • UINT8_INOUT_TYPE : uni_types.h
  • UINT8_OUT_TYPE : uni_types.h
  • UINT8_TYPE : uni_types.h
  • UIT_CreateColorCorrectionMatrix_Int16() : UniTransform.h
  • UIT_CreateColorCorrectionMatrix_Int8() : UniTransform.h
  • UIT_DestroyColorCorrection() : UniTransform.h
  • UIT_Flip() : UniTransform.h
  • UIT_FlipVertical() : UniTransform.h
  • UIT_GetBitsPerPixel() : UniTransform.h
  • UIT_GetErrorInfo() : UniTransform.h
  • UIT_GetResampledScanlineLength() : UniTransform.h
  • UIT_GetSIS() : UniTransform.h
  • UIT_GetTechnoInfo() : UniTransform.h
  • UIT_GetVersion() : UniTransform.h
  • UIT_InterlacedToProgressive() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_3x3() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToBGR() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_3x3() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToMono() : UniTransform.h
  • UIT_Packed12BitTo16Bit() : UniTransform.h
  • UIT_Packed12BitTo8Bit() : UniTransform.h
  • UIT_Raw12ImageTransform() : UniTransform.h
  • UIT_Raw12ToBGR() : UniTransform.h
  • UIT_Raw12ToBGR16() : UniTransform.h
  • UIT_Raw12ToBGR16_CC() : UniTransform.h
  • UIT_Raw12ToBGR_CC() : UniTransform.h
  • UIT_Raw16ImageTransform() : UniTransform.h
  • UIT_Raw16ToBGR() : UniTransform.h
  • UIT_Raw16ToBGR16() : UniTransform.h
  • UIT_Raw16ToBGR16_CC() : UniTransform.h
  • UIT_Raw16ToY16() : UniTransform.h
  • UIT_Raw16ToY16_CC() : UniTransform.h
  • UIT_Raw8ImageTransform() : UniTransform.h
  • UIT_Raw8ImageTransform_3x3() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAA() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAAV() : UniTransform.h
  • UIT_Raw8ImageTransform_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR() : UniTransform.h
  • UIT_Raw8ToBGR_3x3() : UniTransform.h
  • UIT_Raw8ToBGR_CC() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAA() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAAV() : UniTransform.h
  • UIT_Raw8ToBGR_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR_mono() : UniTransform.h
  • UIT_Raw8ToY8() : UniTransform.h
  • UIT_Raw8ToY8_CC() : UniTransform.h
  • UIT_ResampleScanlines() : UniTransform.h
  • UIT_ResampleScanlinesEx() : UniTransform.h
  • UIT_RGB8ImageTransform() : UniTransform.h
  • UIT_RGB8ToBGR() : UniTransform.h
  • UIT_RGB8ToRGBYPlanes() : UniTransform.h
  • UIT_RGB8ToY8() : UniTransform.h
  • UIT_Y12ImageTransform() : UniTransform.h
  • UIT_Y16ImageTransform() : UniTransform.h
  • UIT_Y16ToBGR() : UniTransform.h
  • UIT_Y16ToY8() : UniTransform.h
  • UIT_Y16ToY8_MMX() : UniTransform.h
  • UIT_Y8ImageTransform() : UniTransform.h
  • UIT_Y8ToBGR() : UniTransform.h
  • UIT_YUV411ImageTransform() : UniTransform.h
  • UIT_YUV411ToBGR() : UniTransform.h
  • UIT_YUV411ToRGBPlanes() : UniTransform.h
  • UIT_YUV411ToRGBYPlanes() : UniTransform.h
  • UIT_YUV422ImageTransform() : UniTransform.h
  • UIT_YUV422ToBGR() : UniTransform.h
  • UIT_YUV422ToRGBPlanes() : UniTransform.h
  • UIT_YUV422ToRGBYPlanes() : UniTransform.h
  • UNI_ALL_CAMERAS : uni_defines.h
  • UNI_MAX_INPUT_PINS : uni_defines.h
  • UNI_MAX_OUTPUT_PINS : uni_defines.h
  • UNI_NOTIFICATION_HANDLE : uni_notification.h
  • UNI_RESULT_API_ALREADY_INITIALIZED : uni_defines.h
  • UNI_RESULT_API_ERROR : uni_defines.h
  • UNI_RESULT_API_NOT_INITIALIZED : uni_defines.h
  • UNI_RESULT_AVT_CAMERA_NOT_FOUND : uni_defines.h
  • UNI_RESULT_CAMERA_BUSY : uni_defines.h
  • UNI_RESULT_CAMERA_NOT_FOUND : uni_defines.h
  • UNI_RESULT_CAMERA_TIMEOUT : uni_defines.h
  • UNI_RESULT_COMMAND_ABORTED : uni_defines.h
  • UNI_RESULT_FEATURE_NOT_IMPLEMENTED : uni_defines.h
  • UNI_RESULT_FEATURE_NOT_SUPPORTED : uni_defines.h
  • UNI_RESULT_FIREGRAB_ERROR : uni_defines.h
  • UNI_RESULT_GRAB_NOT_INITIALIZED : uni_defines.h
  • UNI_RESULT_INSUFFICIENT_RESOURCES : uni_defines.h
  • UNI_RESULT_INVALID_FEATURECAPABILITY : uni_defines.h
  • UNI_RESULT_INVALID_SETTINGS : uni_defines.h
  • UNI_RESULT_MORE_DATA : uni_defines.h
  • UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE : uni_defines.h
  • UNI_RESULT_NOTIFICATION_NO_TYPE : uni_defines.h
  • UNI_RESULT_OUT_OF_MEMORY : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_1 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_10 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_11 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_12 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_2 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_3 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_4 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_5 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_6 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_7 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_8 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_9 : uni_defines.h
  • UNI_RESULT_UNKNOWN_ERROR : uni_defines.h
  • UNI_RETURN_TYPE : uni_types.h
  • UNI_UNDEFINED : uni_defines.h
  • UNICODE_CHAR : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- v -

  • VOID_POINTER : uni_types.h
  • VOID_TYPE() : uni_notification.h , uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- w -

  • WCHAR_IN_TYPE : uni_types.h
  • WCHAR_INOUT_TYPE : uni_types.h
  • WCHAR_OUT_TYPE : uni_types.h
  • wchar_t : uni_types.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • u

- u -

  • UNI_ALL_CAMERAS : uni_defines.h
  • UNI_MAX_INPUT_PINS : uni_defines.h
  • UNI_MAX_OUTPUT_PINS : uni_defines.h
  • UNI_RESULT_API_ALREADY_INITIALIZED : uni_defines.h
  • UNI_RESULT_API_ERROR : uni_defines.h
  • UNI_RESULT_API_NOT_INITIALIZED : uni_defines.h
  • UNI_RESULT_AVT_CAMERA_NOT_FOUND : uni_defines.h
  • UNI_RESULT_CAMERA_BUSY : uni_defines.h
  • UNI_RESULT_CAMERA_NOT_FOUND : uni_defines.h
  • UNI_RESULT_CAMERA_TIMEOUT : uni_defines.h
  • UNI_RESULT_COMMAND_ABORTED : uni_defines.h
  • UNI_RESULT_FEATURE_NOT_IMPLEMENTED : uni_defines.h
  • UNI_RESULT_FEATURE_NOT_SUPPORTED : uni_defines.h
  • UNI_RESULT_FIREGRAB_ERROR : uni_defines.h
  • UNI_RESULT_GRAB_NOT_INITIALIZED : uni_defines.h
  • UNI_RESULT_INSUFFICIENT_RESOURCES : uni_defines.h
  • UNI_RESULT_INVALID_FEATURECAPABILITY : uni_defines.h
  • UNI_RESULT_INVALID_SETTINGS : uni_defines.h
  • UNI_RESULT_MORE_DATA : uni_defines.h
  • UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE : uni_defines.h
  • UNI_RESULT_NOTIFICATION_NO_TYPE : uni_defines.h
  • UNI_RESULT_OUT_OF_MEMORY : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_1 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_10 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_11 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_12 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_2 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_3 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_4 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_5 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_6 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_7 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_8 : uni_defines.h
  • UNI_RESULT_PARAMETER_INVALID_9 : uni_defines.h
  • UNI_RESULT_UNKNOWN_ERROR : uni_defines.h
  • UNI_UNDEFINED : uni_defines.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • E_INPUTPIN_MODES : uni_defines.h
  • E_OUTPUTPIN_MODES : uni_defines.h
  • E_UNI_1394_SPEED : uni_defines.h
  • E_UNI_BAYER_PATTERN : uni_defines.h
  • E_UNI_CAMERA_INFO : uni_defines.h
  • E_UNI_COLOR_CODE : uni_defines.h
  • E_UNI_FEATURE : uni_defines.h
  • E_UNI_FEATURE_STATE : uni_defines.h
  • E_UNI_FLIP_MODE : uni_defines.h
  • E_UNI_FRAME_RATE : uni_defines.h
  • E_UNI_FREE_MODE_INFO : uni_defines.h
  • E_UNI_IMAGE_FORMAT : uni_defines.h
  • E_UNI_LICENSE_TYPE : uni_defines.h
  • E_UNI_LOGGING : uni_defines.h
  • E_UNI_NOTIFICATION_EVENTS : uni_notification.h
  • E_UNI_NOTIFICATION_TYPE : uni_notification.h
  • E_UNI_RESOLUTION_PRESETS : uni_defines.h
  • E_UNI_ROPMODE : uni_defines.h
  • E_UNI_SIMPLE_IMAGE_FORMAT : uni_defines.h
  • E_UNI_SIO_BAUDRATE : uni_defines.h
  • E_UNI_SIO_MODE : uni_defines.h
  • E_UNI_SIO_PARITY : uni_defines.h
  • E_UNI_SIO_STOPBITS : uni_defines.h
  • E_UNI_SIS_TYPE : uni_defines.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • e

- e -

  • E_BP_AUTO : uni_defines.h
  • E_BP_BGGR : uni_defines.h
  • E_BP_CYGM : uni_defines.h
  • E_BP_CYMG : uni_defines.h
  • E_BP_GBRG : uni_defines.h
  • E_BP_GMCY : uni_defines.h
  • E_BP_GRBG : uni_defines.h
  • E_BP_MGCY : uni_defines.h
  • E_BP_RGGB : uni_defines.h
  • E_CAMINFO_BAYERPATTERN : uni_defines.h
  • E_CAMINFO_COLORCAMERA : uni_defines.h
  • E_CAMINFO_CUSTOMERKEY : uni_defines.h
  • E_CAMINFO_FPGAVERSION : uni_defines.h
  • E_CAMINFO_IIDCVERSION : uni_defines.h
  • E_CAMINFO_INTERLACED : uni_defines.h
  • E_CAMINFO_MAXDEPTH : uni_defines.h
  • E_CAMINFO_MAXHEIGHT : uni_defines.h
  • E_CAMINFO_MAXWIDTH : uni_defines.h
  • E_CAMINFO_MCVERSION : uni_defines.h
  • E_CAMINFO_MODEL : uni_defines.h
  • E_CAMINFO_ORDERID : uni_defines.h
  • E_CAMINFO_SISTYPE : uni_defines.h
  • E_CAMINFO_SN : uni_defines.h
  • E_CAMINFO_VENDOR : uni_defines.h
  • E_CC_MONO12 : uni_defines.h
  • E_CC_MONO16 : uni_defines.h
  • E_CC_MONO8 : uni_defines.h
  • E_CC_MONOB : uni_defines.h
  • E_CC_MONOG : uni_defines.h
  • E_CC_MONOR : uni_defines.h
  • E_CC_RAW12 : uni_defines.h
  • E_CC_RAW16 : uni_defines.h
  • E_CC_RAW8 : uni_defines.h
  • E_CC_RGB12 : uni_defines.h
  • E_CC_RGB16 : uni_defines.h
  • E_CC_RGB8 : uni_defines.h
  • E_CC_SMONO12 : uni_defines.h
  • E_CC_SMONO16 : uni_defines.h
  • E_CC_SRGB12 : uni_defines.h
  • E_CC_SRGB16 : uni_defines.h
  • E_CC_YUV411 : uni_defines.h
  • E_CC_YUV422 : uni_defines.h
  • E_CC_YUV444 : uni_defines.h
  • E_FEAT_AUTOEXPOSURE : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_HEIGHT : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_LEFT : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_TOP : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_WIDTH : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_XUNITS : uni_defines.h
  • E_FEAT_AUTOFUNCTIONAOI_YUNITS : uni_defines.h
  • E_FEAT_AUTOGAIN_HIGH : uni_defines.h
  • E_FEAT_AUTOGAIN_LOW : uni_defines.h
  • E_FEAT_AUTOSHUTTER_HIGH : uni_defines.h
  • E_FEAT_AUTOSHUTTER_LOW : uni_defines.h
  • E_FEAT_BLEMISHCORRECTION : uni_defines.h
  • E_FEAT_BRIGHTNESS : uni_defines.h
  • E_FEAT_BURSTCOUNT : uni_defines.h
  • E_FEAT_CAMACCEPTDELAY : uni_defines.h
  • E_FEAT_CAMERABUSY : uni_defines.h
  • E_FEAT_COLORCORRECTION : uni_defines.h
  • E_FEAT_CYCLETIME : uni_defines.h
  • E_FEAT_DELAYEDINTEGRATIONENABLE : uni_defines.h
  • E_FEAT_DO_BUSTRIGGER : uni_defines.h
  • E_FEAT_DO_MULTIBUSTRIGGER : uni_defines.h
  • E_FEAT_DSNUCORRECTION : uni_defines.h
  • E_FEAT_EXPOSUREOFFSET : uni_defines.h
  • E_FEAT_EXTENDEDSHUTTER : uni_defines.h
  • E_FEAT_FRAMEBUFFERCOUNT : uni_defines.h
  • E_FEAT_FRAMECOUNTER : uni_defines.h
  • E_FEAT_FRAMEMEMORYSIZE : uni_defines.h
  • E_FEAT_GAIN : uni_defines.h
  • E_FEAT_GAMMA : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT1 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT2 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINT3 : uni_defines.h
  • E_FEAT_HDR_KNEEPOINTCOUNT : uni_defines.h
  • E_FEAT_HIGHSNR : uni_defines.h
  • E_FEAT_HUE : uni_defines.h
  • E_FEAT_IRMFREEBW : uni_defines.h
  • E_FEAT_ISOCHANNEL : uni_defines.h
  • E_FEAT_LIST_ALL_CAMERAS : uni_defines.h
  • E_FEAT_LOGGING : uni_defines.h
  • E_FEAT_LUT : uni_defines.h
  • E_FEAT_LUT_BITSPERVAL : uni_defines.h
  • E_FEAT_LUT_MAXSIZE : uni_defines.h
  • E_FEAT_NONE : uni_defines.h
  • E_FEAT_PARAMUPDATETIMING : uni_defines.h
  • E_FEAT_PHYSPEED : uni_defines.h
  • E_FEAT_REDUCEDSMEAR : uni_defines.h
  • E_FEAT_SATURATION : uni_defines.h
  • E_FEAT_SHADING : uni_defines.h
  • E_FEAT_SHARPNESS : uni_defines.h
  • E_FEAT_SHUTTER : uni_defines.h
  • E_FEAT_SIS : uni_defines.h
  • E_FEAT_SIS_MARLIN : uni_defines.h
  • E_FEAT_SIS_PIKE : uni_defines.h
  • E_FEAT_SOFTRESET : uni_defines.h
  • E_FEAT_STARTIMMEDIATELY : uni_defines.h
  • E_FEAT_TIMEBASE : uni_defines.h
  • E_FEAT_TRIGGERDELAY : uni_defines.h
  • E_FEAT_TRIGGERDELAYADV : uni_defines.h
  • E_FEAT_USEIRMFORBW : uni_defines.h
  • E_FEAT_USEIRMFORCHN : uni_defines.h
  • E_FEAT_USERPROFILE : uni_defines.h
  • E_FEAT_WHITEBALANCE_CY : uni_defines.h
  • E_FEAT_WHITEBALANCE_GR : uni_defines.h
  • E_FEAT_WHITEBALANCE_MG : uni_defines.h
  • E_FEAT_WHITEBALANCE_UB : uni_defines.h
  • E_FEAT_WHITEBALANCE_VR : uni_defines.h
  • E_FEAT_WHITEBALANCE_YE : uni_defines.h
  • E_FEAT_XMIRRORIMAGE : uni_defines.h
  • E_FEATSTATE_AUTO : uni_defines.h
  • E_FEATSTATE_BUSY : uni_defines.h
  • E_FEATSTATE_CLEARDATA : uni_defines.h
  • E_FEATSTATE_ERROR : uni_defines.h
  • E_FEATSTATE_LOADDATA : uni_defines.h
  • E_FEATSTATE_OFF : uni_defines.h
  • E_FEATSTATE_ON : uni_defines.h
  • E_FEATSTATE_ONEPUSH : uni_defines.h
  • E_FEATSTATE_SAVEDATA : uni_defines.h
  • E_FEATSTATE_SHOWIMAGE : uni_defines.h
  • E_FEATSTATE_UNDEFINED : uni_defines.h
  • E_FLIP_MODE_BOTH : uni_defines.h
  • E_FLIP_MODE_HORIZONTAL : uni_defines.h
  • E_FLIP_MODE_LEFT_RIGHT : uni_defines.h
  • E_FLIP_MODE_TOP_DOWN : uni_defines.h
  • E_FLIP_MODE_VERTICAL : uni_defines.h
  • E_FR_120 : uni_defines.h
  • E_FR_15 : uni_defines.h
  • E_FR_1_875 : uni_defines.h
  • E_FR_240 : uni_defines.h
  • E_FR_30 : uni_defines.h
  • E_FR_3_75 : uni_defines.h
  • E_FR_60 : uni_defines.h
  • E_FR_7_5 : uni_defines.h
  • E_FREE_MODE_BYTE_PER_FRAME : uni_defines.h
  • E_FREE_MODE_HEIGHT : uni_defines.h
  • E_FREE_MODE_PIXELCOUNT : uni_defines.h
  • E_FREE_MODE_UNIT_POS_H : uni_defines.h
  • E_FREE_MODE_UNIT_POS_V : uni_defines.h
  • E_FREE_MODE_UNIT_SIZE_H : uni_defines.h
  • E_FREE_MODE_UNIT_SIZE_V : uni_defines.h
  • E_FREE_MODE_WIDTH : uni_defines.h
  • E_IF_ABGR : uni_defines.h
  • E_IF_BGR : uni_defines.h
  • E_IF_MONO8 : uni_defines.h
  • E_IF_NATIVE : uni_defines.h
  • E_IF_RGB_PLANES : uni_defines.h
  • E_IF_RGBY_PLANES : uni_defines.h
  • E_IPINMODE_OFF : uni_defines.h
  • E_IPINMODE_TRIGGER : uni_defines.h
  • E_LOG_DEBUG : uni_defines.h
  • E_LOG_ERROR : uni_defines.h
  • E_LOG_FATAL : uni_defines.h
  • E_LOG_INFO : uni_defines.h
  • E_LOG_LEVELMASK : uni_defines.h
  • E_LOG_WARNING : uni_defines.h
  • E_LT_CARDGUID : uni_defines.h
  • E_LT_DATELIMITED : uni_defines.h
  • E_LT_DEVICE : uni_defines.h
  • E_LT_ETHERNET : uni_defines.h
  • E_LT_HARDDISK : uni_defines.h
  • E_LT_NOLICENSE : uni_defines.h
  • E_LT_VENDOR : uni_defines.h
  • E_OPINMODE_BUSY : uni_defines.h
  • E_OPINMODE_FOLLOW_IN : uni_defines.h
  • E_OPINMODE_FRAMEVALID : uni_defines.h
  • E_OPINMODE_INTENA : uni_defines.h
  • E_OPINMODE_OFF : uni_defines.h
  • E_OPINMODE_PINSTATE : uni_defines.h
  • E_PRESET_DC2K : uni_defines.h
  • E_PRESET_DC4K : uni_defines.h
  • E_PRESET_HD1080 : uni_defines.h
  • E_PRESET_HD720 : uni_defines.h
  • E_PRESET_PAL : uni_defines.h
  • E_PRESET_QSXGA : uni_defines.h
  • E_PRESET_QVGA : uni_defines.h
  • E_PRESET_QXGA : uni_defines.h
  • E_PRESET_SVGA : uni_defines.h
  • E_PRESET_SXGA : uni_defines.h
  • E_PRESET_SXGAP : uni_defines.h
  • E_PRESET_UXGA : uni_defines.h
  • E_PRESET_VGA : uni_defines.h
  • E_PRESET_WVGA : uni_defines.h
  • E_PRESET_XGA : uni_defines.h
  • E_PRESET_XVGA : uni_defines.h
  • E_ROP_LININTERPOL : uni_defines.h
  • E_ROP_SRCCPY : uni_defines.h
  • E_SIF_BGR24 : uni_defines.h
  • E_SIF_BGRA32 : uni_defines.h
  • E_SIF_MONO8_REC601 : uni_defines.h
  • E_SIF_MONO8_REC709 : uni_defines.h
  • E_SIF_UYVY : uni_defines.h
  • E_SIOBAUDRATE_115200 : uni_defines.h
  • E_SIOBAUDRATE_1200 : uni_defines.h
  • E_SIOBAUDRATE_19200 : uni_defines.h
  • E_SIOBAUDRATE_230400 : uni_defines.h
  • E_SIOBAUDRATE_2400 : uni_defines.h
  • E_SIOBAUDRATE_300 : uni_defines.h
  • E_SIOBAUDRATE_38400 : uni_defines.h
  • E_SIOBAUDRATE_4800 : uni_defines.h
  • E_SIOBAUDRATE_57600 : uni_defines.h
  • E_SIOBAUDRATE_600 : uni_defines.h
  • E_SIOBAUDRATE_9600 : uni_defines.h
  • E_SIOMODE_DISABLED : uni_defines.h
  • E_SIOMODE_RECEIVE : uni_defines.h
  • E_SIOMODE_RECEIVETRANSMIT : uni_defines.h
  • E_SIOMODE_TRANSMIT : uni_defines.h
  • E_SIOPARITY_EVEN : uni_defines.h
  • E_SIOPARITY_NONE : uni_defines.h
  • E_SIOPARITY_ODD : uni_defines.h
  • E_SIOSTOPBITS_1 : uni_defines.h
  • E_SIOSTOPBITS_1_5 : uni_defines.h
  • E_SIOSTOPBITS_2 : uni_defines.h
  • E_SIS_MARLIN : uni_defines.h
  • E_SIS_NOT_PRESENT : uni_defines.h
  • E_SIS_PIKE : uni_defines.h
  • E_SPEED100 : uni_defines.h
  • E_SPEED200 : uni_defines.h
  • E_SPEED400 : uni_defines.h
  • E_SPEED800 : uni_defines.h
  • E_SPEED_AUTO : uni_defines.h
  • E_SPEED_LAST : uni_defines.h
  • E_T_FRAMELIMITED : uni_defines.h
  • E_UNI_NOTIFICATION_CALLBACK : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_BUS : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_DMA : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_FRAME : uni_notification.h
  • E_UNI_NOTIFICATION_ERROR_MISC : uni_notification.h
  • E_UNI_NOTIFICATION_EVENT : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_DROPPED : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_READY : uni_notification.h
  • E_UNI_NOTIFICATION_FRAME_START : uni_notification.h
  • E_UNI_NOTIFICATION_MESSAGE : uni_notification.h
  • E_UNI_NOTIFICATION_NO_TYPE : uni_notification.h
  • E_UNI_NOTIFICATION_NODELIST_CHANGED : uni_notification.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • u
  • v

- u -

  • UCC_AutoFunctionAOI_Get() : UniControl.h
  • UCC_AutoFunctionAOI_Set() : UniControl.h
  • UCC_CheckAvailable() : UniControl.h
  • UCC_CloseAllCameras() : UniControl.h
  • UCC_CloseCamera() : UniControl.h
  • UCC_CreateColorCodeEnum() : UniControl.h
  • UCC_CreatePresetsEnum() : UniControl.h
  • UCC_CreateUserLog() : UniControl.h
  • UCC_DestroyColorCodeEnum() : UniControl.h
  • UCC_DestroyPresetsEnum() : UniControl.h
  • UCC_DisconnectAllCameras() : UniControl.h
  • UCC_EnumColorCode() : UniControl.h
  • UCC_EnumFreeModes() : UniControl.h
  • UCC_EnumPresets() : UniControl.h
  • UCC_GetAOI() : UniControl.h
  • UCC_GetBitmapImage() : UniControl.h
  • UCC_GetBitsPerPixel() : UniControl.h
  • UCC_GetCameraCapabilities() : UniControl.h
  • UCC_GetCameraInfo() : UniControl.h
  • UCC_GetCameraInfoString() : UniControl.h
  • UCC_GetCameras() : UniControl.h
  • UCC_GetCamerasEx() : UniControl.h
  • UCC_GetCurrentFixedFormat() : UniControl.h
  • UCC_GetCurrentImageFormat() : UniControl.h
  • UCC_GetErrorInfo() : UniControl.h
  • UCC_GetFeatureMax() : UniControl.h
  • UCC_GetFeatureMin() : UniControl.h
  • UCC_GetFeatureStatus() : UniControl.h
  • UCC_GetFeatureValue() : UniControl.h
  • UCC_GetFreeBandwidth() : UniControl.h
  • UCC_GetFreeModeInfo() : UniControl.h
  • UCC_GetImage() : UniControl.h
  • UCC_GetLicenseType() : UniControl.h
  • UCC_GetLicenseType_Global() : UniControl.h
  • UCC_GetNativeImage() : UniControl.h
  • UCC_GetPlanesImage() : UniControl.h
  • UCC_GetRegister() : UniControl.h
  • UCC_GetRegisterListInfo() : UniControl.h
  • UCC_GetStreamSpeed() : UniControl.h
  • UCC_GetStreamSpeedMax() : UniControl.h
  • UCC_GetSupportedFixedFormats() : UniControl.h
  • UCC_GetVersion() : UniControl.h
  • UCC_GrabBitmapImage() : UniControl.h
  • UCC_GrabImage() : UniControl.h
  • UCC_GrabNativeImage() : UniControl.h
  • UCC_GrabPlanesImage() : UniControl.h
  • UCC_GrabStart() : UniControl.h
  • UCC_GrabStop() : UniControl.h
  • UCC_HasFeature() : UniControl.h
  • UCC_HasFeatureStatus() : UniControl.h
  • UCC_Init() : UniControl.h
  • UCC_InputPin_Get() : UniControl.h
  • UCC_InputPin_Set() : UniControl.h
  • UCC_LoadSettings() : UniControl.h
  • UCC_Lut_GetInfo() : UniControl.h
  • UCC_Lut_GetStatus() : UniControl.h
  • UCC_Lut_LoadFromCsv() : UniControl.h
  • UCC_Lut_Upload() : UniControl.h
  • UCC_Lut_Use() : UniControl.h
  • UCC_MultiShotStart() : UniControl.h
  • UCC_MultiShotStop() : UniControl.h
  • UCC_OpenCamera() : UniControl.h
  • UCC_OpenCameraEx() : UniControl.h
  • UCC_OutputPin_Get() : UniControl.h
  • UCC_OutputPin_Set() : UniControl.h
  • UCC_ParamUpdate_Apply() : UniControl.h
  • UCC_ParamUpdate_Begin() : UniControl.h
  • UCC_PrepareFixedGrab() : UniControl.h
  • UCC_PrepareFreeGrab() : UniControl.h
  • UCC_PresetToResolution() : UniControl.h
  • UCC_ReadBlock() : UniControl.h
  • UCC_ReconnectAllCameras() : UniControl.h
  • UCC_RegisterFrameDroppedNotification() : UniControl.h
  • UCC_RegisterFrameReadyNotification() : UniControl.h
  • UCC_RegisterFrameStartNotification() : UniControl.h
  • UCC_RegisterNodeListChangedNotification() : UniControl.h
  • UCC_RegisterNotification() : UniControl.h
  • UCC_Release() : UniControl.h
  • UCC_SaveSettings() : UniControl.h
  • UCC_SaveSettingsEx() : UniControl.h
  • UCC_SerialIO_GetConfig() : UniControl.h
  • UCC_SerialIO_Receive() : UniControl.h
  • UCC_SerialIO_ReceiveInfo() : UniControl.h
  • UCC_SerialIO_SetConfig() : UniControl.h
  • UCC_SerialIO_Transmit() : UniControl.h
  • UCC_SetFeatureList() : UniControl.h
  • UCC_SetFeatureStatus() : UniControl.h
  • UCC_SetFeatureValue() : UniControl.h
  • UCC_SetRegister() : UniControl.h
  • UCC_SetRegisterList() : UniControl.h
  • UCC_SetStreamSpeed() : UniControl.h
  • UCC_Shading_Build() : UniControl.h
  • UCC_Shading_Download() : UniControl.h
  • UCC_Shading_GetInfo() : UniControl.h
  • UCC_Shading_Upload() : UniControl.h
  • UCC_TestImage_GetInfo() : UniControl.h
  • UCC_TestImage_Set() : UniControl.h
  • UCC_Trigger_Get() : UniControl.h
  • UCC_Trigger_Set() : UniControl.h
  • UCC_UnRegisterNotification() : UniControl.h
  • UCC_UserProfile_GetErrorStatus() : UniControl.h
  • UCC_UserProfile_GetInfo() : UniControl.h
  • UCC_UserProfile_Load() : UniControl.h
  • UCC_UserProfile_Save() : UniControl.h
  • UCC_UserProfile_SetDefault() : UniControl.h
  • UCC_WaitForBusReset() : UniControl.h
  • UCC_Whitebalance_Get() : UniControl.h
  • UCC_Whitebalance_GMCY_Get() : UniControl.h
  • UCC_Whitebalance_GMCY_Set() : UniControl.h
  • UCC_Whitebalance_Set() : UniControl.h
  • UCC_WriteBlock() : UniControl.h
  • UCC_WriteUserLog() : UniControl.h
  • UIT_CreateColorCorrectionMatrix_Int16() : UniTransform.h
  • UIT_CreateColorCorrectionMatrix_Int8() : UniTransform.h
  • UIT_DestroyColorCorrection() : UniTransform.h
  • UIT_Flip() : UniTransform.h
  • UIT_FlipVertical() : UniTransform.h
  • UIT_GetBitsPerPixel() : UniTransform.h
  • UIT_GetErrorInfo() : UniTransform.h
  • UIT_GetResampledScanlineLength() : UniTransform.h
  • UIT_GetSIS() : UniTransform.h
  • UIT_GetTechnoInfo() : UniTransform.h
  • UIT_GetVersion() : UniTransform.h
  • UIT_InterlacedToProgressive() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_3x3() : UniTransform.h
  • UIT_IRaw8CYGMImageTransform_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToBGR() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_3x3() : UniTransform.h
  • UIT_IRaw8CYGMToBGR_Bin() : UniTransform.h
  • UIT_IRaw8CYGMToMono() : UniTransform.h
  • UIT_Packed12BitTo16Bit() : UniTransform.h
  • UIT_Packed12BitTo8Bit() : UniTransform.h
  • UIT_Raw12ImageTransform() : UniTransform.h
  • UIT_Raw12ToBGR() : UniTransform.h
  • UIT_Raw12ToBGR16() : UniTransform.h
  • UIT_Raw12ToBGR16_CC() : UniTransform.h
  • UIT_Raw12ToBGR_CC() : UniTransform.h
  • UIT_Raw16ImageTransform() : UniTransform.h
  • UIT_Raw16ToBGR() : UniTransform.h
  • UIT_Raw16ToBGR16() : UniTransform.h
  • UIT_Raw16ToBGR16_CC() : UniTransform.h
  • UIT_Raw16ToY16() : UniTransform.h
  • UIT_Raw16ToY16_CC() : UniTransform.h
  • UIT_Raw8ImageTransform() : UniTransform.h
  • UIT_Raw8ImageTransform_3x3() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAA() : UniTransform.h
  • UIT_Raw8ImageTransform_IntLCAAV() : UniTransform.h
  • UIT_Raw8ImageTransform_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR() : UniTransform.h
  • UIT_Raw8ToBGR_3x3() : UniTransform.h
  • UIT_Raw8ToBGR_CC() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAA() : UniTransform.h
  • UIT_Raw8ToBGR_IntLCAAV() : UniTransform.h
  • UIT_Raw8ToBGR_IntYUV422() : UniTransform.h
  • UIT_Raw8ToBGR_mono() : UniTransform.h
  • UIT_Raw8ToY8() : UniTransform.h
  • UIT_Raw8ToY8_CC() : UniTransform.h
  • UIT_ResampleScanlines() : UniTransform.h
  • UIT_ResampleScanlinesEx() : UniTransform.h
  • UIT_RGB8ImageTransform() : UniTransform.h
  • UIT_RGB8ToBGR() : UniTransform.h
  • UIT_RGB8ToRGBYPlanes() : UniTransform.h
  • UIT_RGB8ToY8() : UniTransform.h
  • UIT_Y12ImageTransform() : UniTransform.h
  • UIT_Y16ImageTransform() : UniTransform.h
  • UIT_Y16ToBGR() : UniTransform.h
  • UIT_Y16ToY8() : UniTransform.h
  • UIT_Y16ToY8_MMX() : UniTransform.h
  • UIT_Y8ImageTransform() : UniTransform.h
  • UIT_Y8ToBGR() : UniTransform.h
  • UIT_YUV411ImageTransform() : UniTransform.h
  • UIT_YUV411ToBGR() : UniTransform.h
  • UIT_YUV411ToRGBPlanes() : UniTransform.h
  • UIT_YUV411ToRGBYPlanes() : UniTransform.h
  • UIT_YUV422ImageTransform() : UniTransform.h
  • UIT_YUV422ToBGR() : UniTransform.h
  • UIT_YUV422ToRGBPlanes() : UniTransform.h
  • UIT_YUV422ToRGBYPlanes() : UniTransform.h

- v -

  • VOID_TYPE() : uni_notification.h


AVT Universal API - Camera Control module: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • p
  • s
  • u
  • v
  • w

- _ -

  • __1394GUID : uni_types.h

- a -

  • ACHAR_IN_TYPE : uni_types.h
  • ACHAR_INOUT_TYPE : uni_types.h
  • ACHAR_OUT_TYPE : uni_types.h

- b -

  • BOOL_IN_TYPE : uni_types.h
  • BOOL_INOUT_TYPE : uni_types.h
  • BOOL_OUT_TYPE : uni_types.h

- c -

  • CHAR_INOUT_TYPE : uni_types.h
  • CHAR_OUT_TYPE : uni_types.h
  • CHAR_TYPE : uni_types.h
  • COLOR_CORRECTION_HANDLE : uni_types.h
  • COLORCODE_ENUMERATION : uni_types.h

- d -

  • DOUBLE_IN_TYPE : uni_types.h
  • DOUBLE_INOUT_TYPE : uni_types.h
  • DOUBLE_OUT_TYPE : uni_types.h
  • DOUBLE_TYPE : uni_types.h

- e -

  • E_InputPinModes : uni_defines.h
  • E_OutputPinModes : uni_defines.h
  • E_Uni1394Speed : uni_defines.h
  • E_UniBayerPattern : uni_defines.h
  • E_UniCameraInfo : uni_defines.h
  • E_UniColorCode : uni_defines.h
  • E_UniFeature : uni_defines.h
  • E_UniFeatureState : uni_defines.h
  • E_UniFlipMode : uni_defines.h
  • E_UniFrameRate : uni_defines.h
  • E_UniFreeModeInfo : uni_defines.h
  • E_UniImageFormat : uni_defines.h
  • E_UniLicenseType : uni_defines.h
  • E_UniLogging : uni_defines.h
  • E_UniResolutionPresets : uni_defines.h
  • E_UniRopMode : uni_defines.h
  • E_UniSimpleImageFormat : uni_defines.h
  • E_UniSioBaudRate : uni_defines.h
  • E_UniSioMode : uni_defines.h
  • E_UniSioParity : uni_defines.h
  • E_UniSioStopbits : uni_defines.h
  • E_UniSISType : uni_defines.h

- f -

  • FLOAT_IN_TYPE : uni_types.h
  • FLOAT_INOUT_TYPE : uni_types.h
  • FLOAT_OUT_TYPE : uni_types.h
  • FLOAT_TYPE : uni_types.h

- h -

  • HRESULT : uni_types.h

- i -

  • ID_TYPE : uni_types.h
  • INT16_IN_TYPE : uni_types.h
  • INT16_INOUT_TYPE : uni_types.h
  • INT16_OUT_TYPE : uni_types.h
  • int16_t : uni_types.h
  • INT16_TYPE : uni_types.h
  • INT32_IN_TYPE : uni_types.h
  • INT32_INOUT_TYPE : uni_types.h
  • INT32_OUT_TYPE : uni_types.h
  • int32_t : uni_types.h
  • INT32_TYPE : uni_types.h
  • INT64_IN_TYPE : uni_types.h
  • INT64_INOUT_TYPE : uni_types.h
  • INT64_OUT_TYPE : uni_types.h
  • int64_t : uni_types.h
  • INT64_TYPE : uni_types.h
  • INT8_IN_TYPE : uni_types.h
  • INT8_INOUT_TYPE : uni_types.h
  • INT8_OUT_TYPE : uni_types.h
  • INT8_TYPE : uni_types.h

- p -

  • POINTER_SIZE : uni_types.h
  • PRESETS_ENUMERATION : uni_types.h

- s -

  • S_IIDC_VideoInfoFormat : uni_defines.h
  • S_IIDC_VideoInfoMode : uni_defines.h
  • S_IIDCVideoInfoFps : uni_defines.h
  • S_SISData : uni_defines.h
  • S_SISEnable : uni_defines.h
  • S_SupportState : uni_defines.h
  • S_TechInfo : uni_defines.h
  • S_UniImage : uni_defines.h

- u -

  • UINT16_IN_TYPE : uni_types.h
  • UINT16_INOUT_TYPE : uni_types.h
  • UINT16_OUT_TYPE : uni_types.h
  • uint16_t : uni_types.h
  • UINT16_TYPE : uni_types.h
  • UINT32_IN_TYPE : uni_types.h
  • UINT32_INOUT_TYPE : uni_types.h
  • UINT32_OUT_TYPE : uni_types.h
  • uint32_t : uni_types.h
  • UINT32_TYPE : uni_types.h
  • UINT64_IN_TYPE : uni_types.h
  • UINT64_INOUT_TYPE : uni_types.h
  • UINT64_OUT_TYPE : uni_types.h
  • uint64_t : uni_types.h
  • UINT64_TYPE : uni_types.h
  • UINT8_IN_TYPE : uni_types.h
  • UINT8_INOUT_TYPE : uni_types.h
  • UINT8_OUT_TYPE : uni_types.h
  • UINT8_TYPE : uni_types.h
  • UNI_NOTIFICATION_HANDLE : uni_notification.h
  • UNI_RETURN_TYPE : uni_types.h
  • UNICODE_CHAR : uni_types.h

- v -

  • VOID_POINTER : uni_types.h
  • VOID_TYPE : uni_types.h

- w -

  • WCHAR_IN_TYPE : uni_types.h
  • WCHAR_INOUT_TYPE : uni_types.h
  • WCHAR_OUT_TYPE : uni_types.h
  • wchar_t : uni_types.h


AVT Universal API - Camera Control module: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Getting started
  • General conventions
  • Camera configuration - Overview
  • Camera configuration - Image Format
  • Camera configuration - Explicit function calls
  • Digital IO and trigger operation
  • Image acquisition - Single images
  • Image acquisition - Image stream
  • User notifications
  • XML settings files
  • Code snippets
  • Version information
  • Requirements
  • Universal API Image Transform module
  • Image Transformation - Introduction
  • Image Transformation - Overview
  • Image Transformation - Conversion Methods
  • Image Transformation - Bayer patterns
  • Image Transformation - Debayering methods
  • Image Transformation - Special transformation methods
  • Image Transformation - Version information
  • Camera configuration - Unified feature access
  • Camera-unrelated configuration


AVT Universal API - Camera Control module: S_12BIT_2PACKED::m_nVal8_1

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_1

High byte of the first Pixel.


AVT Universal API - Camera Control module: S_12BIT_2PACKED::m_nVal8_2Low

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_2Low

Low nibble of the second pixel.


AVT Universal API - Camera Control module: S_12BIT_2PACKED::m_nVal8_2

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_2

High byte of the second pixel.


AVT Universal API - Camera Control module: S_12BIT_2PACKED::m_nVal8_1Low

S_12BIT_2PACKED
m_nVal8_1
m_nVal8_1Low
m_nVal8_2
m_nVal8_2Low
UINT8_TYPE S_12BIT_2PACKED::m_nVal8_1Low

Low nibble of the first pixel.


AVT Universal API - Camera Control module: S_BGR8::B

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::B

blue part


AVT Universal API - Camera Control module: S_BGR8::R

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::R

red part


AVT Universal API - Camera Control module: S_BGR8::G

S_BGR8
B
G
R
UINT8_TYPE S_BGR8::G

green part


AVT Universal API - Camera Control module: S_BGR16::G

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::G

green part


AVT Universal API - Camera Control module: S_BGR16::R

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::R

red part


AVT Universal API - Camera Control module: S_BGR16::B

S_BGR16
B
G
R
UINT16_TYPE S_BGR16::B

blue part


AVT Universal API - Camera Control module: S_BGRA8::G

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::G

green part


AVT Universal API - Camera Control module: S_BGRA8::B

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::B

blue part


AVT Universal API - Camera Control module: S_BGRA8::A

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::A

unused


AVT Universal API - Camera Control module: S_BGRA8::R

S_BGRA8
A
B
G
R
UINT8_TYPE S_BGRA8::R

red part


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_FORMAT::m_FormatInq

S_IIDC_VIDEOINFO_FORMAT
m_FormatInq
S_IIDC_VIDEOINFO_MODE S_IIDC_VIDEOINFO_FORMAT::m_FormatInq[3]

modes for the formats


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_FPS::m_FpsInq

S_IIDC_VIDEOINFO_FPS
m_FpsInq
UINT32_TYPE S_IIDC_VIDEOINFO_FPS::m_FpsInq[8]

support for IIDC frame rate


AVT Universal API - Camera Control module: S_IIDC_VIDEOINFO_MODE::m_ModeInq

S_IIDC_VIDEOINFO_MODE
m_ModeInq
S_IIDC_VIDEOINFO_FPS S_IIDC_VIDEOINFO_MODE::m_ModeInq[8]

frame rates for the modes


AVT Universal API - Camera Control module: S_RGB8::B

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::B

blue part


AVT Universal API - Camera Control module: S_RGB8::R

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::R

red part


AVT Universal API - Camera Control module: S_RGB8::G

S_RGB8
B
G
R
UINT8_TYPE S_RGB8::G

green part


AVT Universal API - Camera Control module: S_SIS_DATA::m_AOILeft

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOILeft

left coordinate of the AOI begin


AVT Universal API - Camera Control module: S_SIS_DATA::m_Reserved0

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_Reserved0

reserved for future use


AVT Universal API - Camera Control module: S_SIS_DATA::m_SerialNumber

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_SerialNumber

camera serial number


AVT Universal API - Camera Control module: S_SIS_DATA::m_AOIWidth

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOIWidth

width of the AOI


AVT Universal API - Camera Control module: S_SIS_DATA::m_InputState

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_InputState[2]

state of the input pins


AVT Universal API - Camera Control module: S_SIS_DATA::m_AOITop

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOITop

top coordinate of the AOI begin


AVT Universal API - Camera Control module: S_SIS_DATA::m_Gain

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_Gain

camera gain for the image


AVT Universal API - Camera Control module: S_SIS_DATA::m_SISEnable

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
S_SIS_ENABLE S_SIS_DATA::m_SISEnable

state inq struct


AVT Universal API - Camera Control module: S_SIS_DATA::m_AOIHeight

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT16_TYPE S_SIS_DATA::m_AOIHeight

height of the AOI


AVT Universal API - Camera Control module: S_SIS_DATA::m_OutputState

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_OutputState[4]

state of the output pins


AVT Universal API - Camera Control module: S_SIS_DATA::m_Reserved2b

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reserved2b

reserved for future use


AVT Universal API - Camera Control module: S_SIS_DATA::m_Reserved2a

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reserved2a

reserved for future use


AVT Universal API - Camera Control module: S_SIS_DATA::m_Reservec1

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_Reservec1[2]

reserved for future use


AVT Universal API - Camera Control module: S_SIS_DATA::m_TriggerCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_TriggerCounter

from camera received triggers


AVT Universal API - Camera Control module: S_SIS_DATA::m_SequenceIndex

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_SequenceIndex

position in the sequence


AVT Universal API - Camera Control module: S_SIS_DATA::m_ColorCoding

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT8_TYPE S_SIS_DATA::m_ColorCoding

IIDC color coding for the transport format.


AVT Universal API - Camera Control module: S_SIS_DATA::m_FrameCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_FrameCounter

frame count since last reset


AVT Universal API - Camera Control module: S_SIS_DATA::m_Shutter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_Shutter

camera shutter for the image


AVT Universal API - Camera Control module: S_SIS_DATA::m_CycleCounter

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_CycleCounter

bus cycle count


AVT Universal API - Camera Control module: S_SIS_DATA::m_UserValue

S_SIS_DATA
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_Reservec1
m_Reserved0
m_Reserved2a
m_Reserved2b
m_SequenceIndex
m_SerialNumber
m_Shutter
m_SISEnable
m_TriggerCounter
m_UserValue
UINT32_TYPE S_SIS_DATA::m_UserValue

user defined value


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOITop

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOITop

inq top coordinate of the cameras AOI


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_ColorCoding

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_ColorCoding

inq IIDC color coding


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_InputState

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_InputState

inq input pin states


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIWidth

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIWidth

inq width of the AOI


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOILeft

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOILeft

inq left coordinate of the cameras AOI


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIHeight

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_AOIHeight

inq height of the AOI


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_OutputState

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_OutputState

inq output pin states


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_TriggerCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_TriggerCounter

inq triggers received by the camera


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved0

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2a

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SequenceIndex

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SequenceIndex

inq position in sequence


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2b

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Valid

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Valid

Data in Enable is valid.


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Shutter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Shutter

inq camera shutter for the image


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_CycleCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_CycleCounter

inq cycle counter


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Gain

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_Gain

inq camera gain for the image


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SerialNumber

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_SerialNumber

inq serial number of the camera


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_UserValue

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_UserValue

inq user defined value


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_FrameCounter

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid
UINT32_TYPE S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::m_FrameCounter

inq frame count since last reset


AVT Universal API - Camera Control module: S_SIS_ENABLE::S_SIS_ENABLE_FIELDS::Reserved2

S_SIS_ENABLE::S_SIS_ENABLE_FIELDS
m_AOIHeight
m_AOILeft
m_AOITop
m_AOIWidth
m_ColorCoding
m_CycleCounter
m_FrameCounter
m_Gain
m_InputState
m_OutputState
m_SequenceIndex
m_SerialNumber
m_Shutter
m_TriggerCounter
m_UserValue
m_Valid


AVT Universal API - Camera Control module: S_SUPPORT_STATE::Processor

S_SUPPORT_STATE
OperatingSystem
Processor
bool S_SUPPORT_STATE::Processor

technology supported by the processor


AVT Universal API - Camera Control module: S_SUPPORT_STATE::OperatingSystem

S_SUPPORT_STATE
OperatingSystem
Processor
bool S_SUPPORT_STATE::OperatingSystem

technology supported by the OS


AVT Universal API - Camera Control module: S_TECHNO_INFO::AMD3DNow

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::AMD3DNow

AMD 3DNow.


AVT Universal API - Camera Control module: S_TECHNO_INFO::IntelSSE2

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE2

INTEL Streaming SIMD Extension 2.


AVT Universal API - Camera Control module: S_TECHNO_INFO::IntelSSE

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE

INTEL Streaming SIMD Extension.


AVT Universal API - Camera Control module: S_TECHNO_INFO::IntelSSE3

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSE3

INTEL Streaming SIMD Extension 3.


AVT Universal API - Camera Control module: S_TECHNO_INFO::IntelSSSE3

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelSSSE3

INTEL Supplemental Streaming SIMD Extension 3.


AVT Universal API - Camera Control module: S_TECHNO_INFO::IntelMMX

S_TECHNO_INFO
AMD3DNow
IntelMMX
IntelSSE
IntelSSE2
IntelSSE3
IntelSSSE3
S_SUPPORT_STATE S_TECHNO_INFO::IntelMMX

INTEL first gen MultiMedia eXtension.


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT::m_Reserved

S_UNI_CALLBACK_ARGUMENT
m_CamId
m_Parameter
m_Reserved
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT
UINT32_TYPE S_UNI_CALLBACK_ARGUMENT::m_Reserved

reserved


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT::S_UNI_CALLBACK_ARGUMENT

S_UNI_CALLBACK_ARGUMENT
m_CamId
m_Parameter
m_Reserved
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT::S_UNI_CALLBACK_ARGUMENT | ( | VOID_POINTER | Prm,
 |  | UINT32_TYPE | CamId = 0xFFffFFff |
 | ) |  |  | [inline]

constructor with init if c++.

Parameters:
[in] | Prm | user defined parameter which is passed every time the callback is called
[in] | CamId | Canera ID for which the notification is registered default: UNI_ALL_CAMERAS


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT::S_UNI_CALLBACK_ARGUMENT

S_UNI_CALLBACK_ARGUMENT
m_CamId
m_Parameter
m_Reserved
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT::S_UNI_CALLBACK_ARGUMENT ( ) [inline]

default constructor if c++.


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT::m_Parameter

S_UNI_CALLBACK_ARGUMENT
m_CamId
m_Parameter
m_Reserved
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT
VOID_POINTER S_UNI_CALLBACK_ARGUMENT::m_Parameter

User defined parameter will be returned as-is.


AVT Universal API - Camera Control module: S_UNI_CALLBACK_ARGUMENT::m_CamId

S_UNI_CALLBACK_ARGUMENT
m_CamId
m_Parameter
m_Reserved
S_UNI_CALLBACK_ARGUMENT
S_UNI_CALLBACK_ARGUMENT
UINT32_TYPE S_UNI_CALLBACK_ARGUMENT::m_CamId

Will be filled with the sending camera id when called.


AVT Universal API - Camera Control module: S_UNI_IMAGE::pImageY

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT8_TYPE* S_UNI_IMAGE::pImageY

Pointer to intensity plane.


AVT Universal API - Camera Control module: S_UNI_IMAGE::pImageRed

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT8_TYPE* S_UNI_IMAGE::pImageRed

Pointer to red plane.


AVT Universal API - Camera Control module: S_UNI_IMAGE::ImageAsMultiPlanes

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
struct { ... } ::S_ImageAsMultiPlanes S_UNI_IMAGE::ImageAsMultiPlanes

RGBY planes image.


AVT Universal API - Camera Control module: S_UNI_IMAGE::SISData

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
S_SIS_DATA S_UNI_IMAGE::SISData

secure image signature for the current image


AVT Universal API - Camera Control module: S_UNI_IMAGE::sImageData

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat


AVT Universal API - Camera Control module: S_UNI_IMAGE::uImageformat

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT32_TYPE S_UNI_IMAGE::uImageformat

significator of the image format - for valid values see E_UNI_IMAGE_FORMAT


AVT Universal API - Camera Control module: S_UNI_IMAGE::pImageAsSinglePlane

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT8_TYPE* S_UNI_IMAGE::pImageAsSinglePlane

Bitmap.


AVT Universal API - Camera Control module: S_UNI_IMAGE::pImageBlue

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT8_TYPE* S_UNI_IMAGE::pImageBlue

Pointer to blue plane.


AVT Universal API - Camera Control module: S_UNI_IMAGE::SISEnabled

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
bool S_UNI_IMAGE::SISEnabled

meta info about SISData, if true SISData holds the secure image signature


AVT Universal API - Camera Control module: S_UNI_IMAGE::pImageGreen

S_UNI_IMAGE
ImageAsMultiPlanes
pImageAsSinglePlane
pImageBlue
pImageGreen
pImageRed
pImageY
SISData
SISEnabled
uImageformat
UINT8_TYPE* S_UNI_IMAGE::pImageGreen

Pointer to green plane.


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::S_UNI_NOTIFICATION

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::m_NotificationWindowsMessage

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage
S_UNI_WINDOWS_MESSAGE S_UNI_NOTIFICATION::m_NotificationWindowsMessage

structure defining the windows message used if m_NotificationType == E_UNI_NOTIFICATION_MESSAGE - see S_UNI_WINDOWS_MESSAGE


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::m_CamId

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage
UINT32_TYPE S_UNI_NOTIFICATION::m_CamId

camera to register the notification for */


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::m_NotificationType

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage
UINT32_TYPE S_UNI_NOTIFICATION::m_NotificationType

id of the notification type - see E_UNI_NOTIFICATION_TYPE


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::m_NotificationEvent

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage
S_UNI_NOTIFICATION_EVENT S_UNI_NOTIFICATION::m_NotificationEvent

structure defining the event used if m_NotificationType == E_UNI_NOTIFICATION_EVENT - see S_UNI_NOTIFICATION_EVENT


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_CALLBACK::S_UNI_NOTIFICATION_CALLBACK

S_UNI_NOTIFICATION_CALLBACK
m_Arg
m_Callback
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK::S_UNI_NOTIFICATION_CALLBACK | ( | UNI_NOTIFICATION_CALLBACK_FUNCTION | callback,
 |  | S_UNI_CALLBACK_ARGUMENT | arg |
 | ) |  |  | [inline]

constructor with init.

Parameters:
[in] | callback | callback function for the notification
[in] | arg | callback argument


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_CALLBACK::m_Arg

S_UNI_NOTIFICATION_CALLBACK
m_Arg
m_Callback
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK
S_UNI_CALLBACK_ARGUMENT S_UNI_NOTIFICATION_CALLBACK::m_Arg

Function argument which is passed with the callback function.


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_CALLBACK::m_Callback

S_UNI_NOTIFICATION_CALLBACK
m_Arg
m_Callback
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK
UNI_NOTIFICATION_CALLBACK_FUNCTION S_UNI_NOTIFICATION_CALLBACK::m_Callback

Callbackfunction which will be called as notification.


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_CALLBACK::S_UNI_NOTIFICATION_CALLBACK

S_UNI_NOTIFICATION_CALLBACK
m_Arg
m_Callback
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK
S_UNI_NOTIFICATION_CALLBACK::S_UNI_NOTIFICATION_CALLBACK ( ) [inline]

default constructor if c++.


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT::m_CamId

S_UNI_NOTIFICATION_EVENT
m_CamId
m_Event
m_Reserved
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT
UINT32_TYPE S_UNI_NOTIFICATION_EVENT::m_CamId

non-syncronized serial number from camera which triggered the last event


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT::S_UNI_NOTIFICATION_EVENT

S_UNI_NOTIFICATION_EVENT
m_CamId
m_Event
m_Reserved
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT::S_UNI_NOTIFICATION_EVENT | ( | HANDLE * | Event,
 |  | UINT32_TYPE | CamId = 0xFFffFFff |
 | ) |  |  | [inline]

constructor with variable init if c++.

Parameters:
[in] | Event | windows event HANDLE
[in] | CamId | Camera ID for which this notification is triggered


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT::S_UNI_NOTIFICATION_EVENT

S_UNI_NOTIFICATION_EVENT
m_CamId
m_Event
m_Reserved
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT::S_UNI_NOTIFICATION_EVENT ( ) [inline]

default constructor if c++


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT::m_Reserved

S_UNI_NOTIFICATION_EVENT
m_CamId
m_Event
m_Reserved
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT
UINT32_TYPE S_UNI_NOTIFICATION_EVENT::m_Reserved

reserved for internal use


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION_EVENT::m_Event

S_UNI_NOTIFICATION_EVENT
m_CamId
m_Event
m_Reserved
S_UNI_NOTIFICATION_EVENT
S_UNI_NOTIFICATION_EVENT
HANDLE S_UNI_NOTIFICATION_EVENT::m_Event

the initialized Event to use for notification


AVT Universal API - Camera Control module: S_UNI_NOTIFICATION::m_NotificationCallback

S_UNI_NOTIFICATION
m_CamId
m_NotificationCallback
m_NotificationEvent
m_NotificationType
m_NotificationWindowsMessage
S_UNI_NOTIFICATION_CALLBACK S_UNI_NOTIFICATION::m_NotificationCallback

callback used if m_NotificationType == E_UNI_NOTIFICATION_CALLBACK - see S_UNI_NOTIFICATION_CALLBACK


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::m_lParam

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
LPARAM S_UNI_WINDOWS_MESSAGE::m_lParam

ID of sending camera.


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::m_wParam

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
WPARAM S_UNI_WINDOWS_MESSAGE::m_wParam

Reserved.


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::m_Msg

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
UINT S_UNI_WINDOWS_MESSAGE::m_Msg

Message id.


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::m_hWnd

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
HWND S_UNI_WINDOWS_MESSAGE::m_hWnd

Handle to the window to post the message.


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::S_UNI_WINDOWS_MESSAGE

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE::S_UNI_WINDOWS_MESSAGE ( ) [inline]

default Ctor if c++


AVT Universal API - Camera Control module: S_UNI_WINDOWS_MESSAGE::S_UNI_WINDOWS_MESSAGE

S_UNI_WINDOWS_MESSAGE
m_hWnd
m_lParam
m_Msg
m_wParam
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE
S_UNI_WINDOWS_MESSAGE::S_UNI_WINDOWS_MESSAGE | ( | HWND | hWnd,
 |  | UINT | Msg = 0,
 |  | WPARAM | wParam = 0,
 |  | LPARAM | lParam = 0 |
 | ) |  |  | [inline]

Ctor with args.

Parameters:
[in] | hWnd | Handle to window
[in] | Msg | Message to be send to window when triggered
[in] | wParam | Reserved
[in] | lParam | Camera id


AVT Universal API - Camera Control module: S_YUV411::Y2

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y2

the intensity of the third pixel


AVT Universal API - Camera Control module: S_YUV411::Y0

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y0

the intensity of the first pixel


AVT Universal API - Camera Control module: S_YUV411::Y1

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y1

the intensity of the second pixel


AVT Universal API - Camera Control module: S_YUV411::Y3

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::Y3

the intensity of the fourth pixel


AVT Universal API - Camera Control module: S_YUV411::V

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::V

the V part for all four pixels


AVT Universal API - Camera Control module: S_YUV411::U

S_YUV411
U
V
Y0
Y1
Y2
Y3
UINT8_TYPE S_YUV411::U

the U part for all four pixels


AVT Universal API - Camera Control module: S_YUV422::V

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::V

the V part for both pixels


AVT Universal API - Camera Control module: S_YUV422::Y1

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::Y1

the intensity of the second pixel


AVT Universal API - Camera Control module: S_YUV422::Y0

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::Y0

the intensity of the first pixel


AVT Universal API - Camera Control module: S_YUV422::U

S_YUV422
U
V
Y0
Y1
UINT8_TYPE S_YUV422::U

the U part for both pixels


AVT Universal API - Camera Control module: S_YUV444::U

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::U

U.


AVT Universal API - Camera Control module: S_YUV444::V

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::V

V.


AVT Universal API - Camera Control module: S_YUV444::Y

S_YUV444
U
V
Y
UINT8_TYPE S_YUV444::Y

Luma.


AVT Universal API - Camera Control module: S_IIDC_VideoInfoMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_IIDC_VIDEOINFO_MODE S_IIDC_VideoInfoMode

IIDC video modes.


AVT Universal API - Camera Control module: UNI_RESULT_UNKNOWN_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_UNKNOWN_ERROR 0x88000001

unclassified error


AVT Universal API - Camera Control module: E_UniFlipMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_FLIP_MODE E_UniFlipMode

Enumeration for the direction for flipping images.


AVT Universal API - Camera Control module: UNI_MAX_INPUT_PINS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_MAX_INPUT_PINS 4

Maximal number of input Pins.


AVT Universal API - Camera Control module: E_UNI_LICENSE_TYPE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_LICENSE_TYPE

License modes of Firegrab.

Enumerator:
E_LT_NOLICENSE | No license.
E_LT_CARDGUID | Firewire card.
E_LT_HARDDISK | Hard disk.
E_LT_ETHERNET | Ethernet adapter.
E_LT_VENDOR | Vendor global.
E_LT_DATELIMITED | Expires with date.
E_LT_DEVICE | Device specific.
E_T_FRAMELIMITED | Limited by frames.


AVT Universal API - Camera Control module: UNI_RESULT_AVT_CAMERA_NOT_FOUND

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_AVT_CAMERA_NOT_FOUND 0x88000011

AVT camera not found.


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_10

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_10 0x8800000B

parameter 10 is invalid


AVT Universal API - Camera Control module: E_UniFeatureState

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_FEATURE_STATE E_UniFeatureState

Enumeration for feature states.


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_5

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_5 0x88000006

parameter 5 is invalid


AVT Universal API - Camera Control module: UNI_RESULT_CAMERA_NOT_FOUND

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_CAMERA_NOT_FOUND 0x88000010

camera not found


AVT Universal API - Camera Control module: E_UniSioBaudRate

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIO_BAUDRATE E_UniSioBaudRate

Enumeration for I/O speed (for configuration of serial I/O communication).


AVT Universal API - Camera Control module: E_UNI_SIO_MODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIO_MODE

Enumeration for I/O speed (for configuration of serial I/O communication).

Enumerator:
E_SIOMODE_DISABLED | no serial transfer
E_SIOMODE_RECEIVE | only allow reception of serial input
E_SIOMODE_TRANSMIT | only allow transmission of serial output
E_SIOMODE_RECEIVETRANSMIT | allow both directions of the serial transfer


AVT Universal API - Camera Control module: E_UNI_SETTING_SELECT_MODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: E_OUTPUTPIN_MODES

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_OUTPUTPIN_MODES

Output Pin Modes.

Enumerator:
E_OPINMODE_OFF | pin disabled
E_OPINMODE_PINSTATE | output pin state determined by pin state member, don't combine with inverted polarity
E_OPINMODE_INTENA | signaling while integrating image
E_OPINMODE_FRAMEVALID | signaling after integration, when frame is ready
E_OPINMODE_BUSY | signaling while
E_OPINMODE_FOLLOW_IN | while exposure, sensor read out and data transmission


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_8

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_8 0x88000009

parameter 8 is invalid


AVT Universal API - Camera Control module: S_UniImage

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_UNI_IMAGE S_UniImage

Structure for image data access supporting different formats.

Using this structure, it is possible to request any of the supported image formats with the same function, e.g. UCC_GrabImage(). An instance of this structure has to be created and initialized by the user before function call. For initialization uImageformat has to be set to the desired image format. Memory space used for image data has to be provided by the user. According to the selected format, one or more memory segments are used. Therefore, one or more of S_UniImage's data pointers are needed to point to sufficiently sized memory segments. Image formats other than E_IF_RGB_PLANES and E_IF_RGBY_PLANES generally use pImageAsSinglePlane.
Example:

        UINT8_TYPE * pImgBytes=NULL;
        if( !m_Img.IsNull() )
            pImgBytes = (BYTE *)m_Img.GetBits();

        UINT32_TYPE bColor=0;
        S_UNI_IMAGE MyImageStruct;

        MyImageStruct.uImageformat = E_IF_MONO8;
        MyImageStruct.sImageData.pImageAsSinglePlane = pImgBytes;

        UNI_RETURN_TYPE hr = UNI_GrabImage( m_CamId, &MyImageStruct , &bColor, INFINITE );


AVT Universal API - Camera Control module: E_UniSioParity

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIO_PARITY E_UniSioParity

Enumeration for I/O parity (for configuration of serial I/O communication).


AVT Universal API - Camera Control module: E_UNI_SIO_STOPBITS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIO_STOPBITS

Enumeration for I/O stop bits (for configuration of serial I/O communication).

Enumerator:
E_SIOSTOPBITS_1 | 1 stop bit
E_SIOSTOPBITS_1_5 | 1.5 stop bits
E_SIOSTOPBITS_2 | 2 stop bits


AVT Universal API - Camera Control module: E_UNI_COLOR_CODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_COLOR_CODE

Enumeration for IIDC format 7 color codes / transfer formats.

Enumerator:
E_CC_MONO8 | no special byte order, one byte per pixel
E_CC_YUV411 | byte order is UYYVYYUYYVYY,
E_CC_YUV422 | byte order is UYVYUYVY,
E_CC_YUV444 | byte order is UYVUYV,
E_CC_RGB8 | byte order is RGBRGB,
E_CC_MONO16 | byte order is high_byte,low_byte
E_CC_RGB16 | byte order is Rh,Rl,Gh,Gl,Bh,Bl,
E_CC_SMONO16 | byte order is high_byte,low_byte
E_CC_SRGB16 | byte order is Rh,Rl,Gh,Gl,Bh,Bl,
E_CC_RAW8 | byte order is RGGB, GBRG, GRBG or BGGR
E_CC_RAW16 | same as RAW8, but each value: high_byte,low_byte
E_CC_MONOR | ->E_CC_MONO8
E_CC_MONOG | ->E_CC_MONO8
E_CC_MONOB | ->E_CC_MONO8
E_CC_MONO12 | two pixels in three bytes, see S_12BIT_2PACKED
E_CC_RGB12 | 12 bit RGB unused
E_CC_SMONO12 | see S_12BIT2PACKED
E_CC_SRGB12 | 12 SRGB unused
E_CC_RAW12 | two pixels in three bytes, see S_12BIT_2PACKED


AVT Universal API - Camera Control module: UNI_MAX_SIO_TX_DATA

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: UNI_RESULT_OUT_OF_MEMORY

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_OUT_OF_MEMORY 0x8800001A

out of memory


AVT Universal API - Camera Control module: UNI_RESULT_INVALID_FEATURECAPABILITY

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_INVALID_FEATURECAPABILITY 0x88000014

invalid operation for the selected feature


AVT Universal API - Camera Control module: UNI_RESULT_GRAB_NOT_INITIALIZED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_GRAB_NOT_INITIALIZED 0x88000016

the camera was not initialized before grabbing


AVT Universal API - Camera Control module: UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE 0x8800001B

operation not allowed in this mode


AVT Universal API - Camera Control module: E_UNI_FLIP_MODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_FLIP_MODE

Enumeration for the direction for flipping images.

Enumerator:
E_FLIP_MODE_HORIZONTAL | flip in horizontal direction
E_FLIP_MODE_LEFT_RIGHT | same as E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_VERTICAL | flip in vertical direction
E_FLIP_MODE_TOP_DOWN | same as E_FLIP_MODE_VERTICAL
E_FLIP_MODE_BOTH | flip in both directions


AVT Universal API - Camera Control module: UNI_RESULT_INSUFFICIENT_RESOURCES

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_INSUFFICIENT_RESOURCES 0x88000019

insufficient FireWire resources


AVT Universal API - Camera Control module: E_UniCameraInfo

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_CAMERA_INFO E_UniCameraInfo

Enumeration for retrieval of camera information.


AVT Universal API - Camera Control module: S_OK

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: UNI_RESULT_COMMAND_ABORTED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_COMMAND_ABORTED 0x8800001E

the current command was aborted


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_11

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_11 0x8800000C

parameter 11 is invalid


AVT Universal API - Camera Control module: E_UniColorCode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_COLOR_CODE E_UniColorCode

Enumeration for IIDC format 7 color codes / transfer formats.


AVT Universal API - Camera Control module: UNI_ALL_CAMERAS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_ALL_CAMERAS 0xFFffFFff

special camera id to address all connected cameras


AVT Universal API - Camera Control module: E_UniSioMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIO_MODE E_UniSioMode

Enumeration for I/O speed (for configuration of serial I/O communication).


AVT Universal API - Camera Control module: UNI_RESULT_MORE_DATA

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_MORE_DATA ERROR_MORE_DATA

timeout period expired


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_1

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_1 0x88000002

parameter 1 is invalid


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_9

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_9 0x8800000A

parameter 9 is invalid


AVT Universal API - Camera Control module: E_UniRopMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_ROPMODE E_UniRopMode

Enumeration for raster operation (used by re sampling methods).


AVT Universal API - Camera Control module: E_UNI_RESOLUTION_PRESETS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_RESOLUTION_PRESETS

Enumeration for resolution presets.

Enumerator:
E_PRESET_QVGA | 320 x 240 asp,rat 4:3
E_PRESET_VGA | 640 x 480
E_PRESET_PAL | 768 x 576
E_PRESET_SVGA | 800 x 600
E_PRESET_XGA | 1024 x 768
E_PRESET_XVGA | 1280 x 960
E_PRESET_SXGAP | 1400 x 1050
E_PRESET_UXGA | 1600 x 1200
E_PRESET_QXGA | 2048 x 1536
E_PRESET_SXGA | 1280 x 1024 asp rat 5:4
E_PRESET_QSXGA | 2580 x 2048
E_PRESET_WVGA | 854 x 480 asp rat 16:9
E_PRESET_HD720 | 1280 x 720 HDTV
E_PRESET_HD1080 | 1920 x 1080
E_PRESET_DC2K | 2048 x 1080 Digital Cinema // Line Binning 16/9
E_PRESET_DC4K | 4096 x 2160


AVT Universal API - Camera Control module: UNI_RESULT_INVALID_SETTINGS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_INVALID_SETTINGS 0x88000018

invalid camera settings selected


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_6

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_6 0x88000007

parameter 6 is invalid


AVT Universal API - Camera Control module: UNI_RESULT_NOTIFICATION_NO_TYPE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_NOTIFICATION_NO_TYPE 0x8800001F

Notification is missing the E_UNI_NOTIFICATION_TYPE parameter


AVT Universal API - Camera Control module: E_OutputPinModes

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_OUTPUTPIN_MODES E_OutputPinModes

Output Pin Modes.


AVT Universal API - Camera Control module: UNI_RESULT_FEATURE_NOT_IMPLEMENTED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_FEATURE_NOT_IMPLEMENTED 0x88000012

feature support is not implemented (yet?)


AVT Universal API - Camera Control module: E_UNI_SIO_PARITY

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIO_PARITY

Enumeration for I/O parity (for configuration of serial I/O communication).

Enumerator:
E_SIOPARITY_NONE | no parity info
E_SIOPARITY_ODD | odd parity
E_SIOPARITY_EVEN | even parity


AVT Universal API - Camera Control module: E_UNI_IMAGE_FORMAT

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_IMAGE_FORMAT

Enumeration for target image formats.

Enumerator:
E_IF_MONO8 | One bitmap with one byte per pixel.
E_IF_BGR | One bitmap with three bytes per pixel.
E_IF_ABGR | One bitmap with four bytes per pixel.
E_IF_RGB_PLANES | Three separate color plane bitmaps.
E_IF_RGBY_PLANES | Three separate color plane bitmaps plus intensity plane bitmap.
E_IF_NATIVE | One bitmap with diverse formats (mostly native transfer formats like YUV422 od RAW16). Provide enough memory!


AVT Universal API - Camera Control module: S_BGR24

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: E_INPUTPIN_MODES

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_INPUTPIN_MODES

Input Pin Modes.

Enumerator:
E_IPINMODE_OFF | pin disabled
E_IPINMODE_TRIGGER | pin signaled by trigger


AVT Universal API - Camera Control module: E_UNI_CAMERA_INFO

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_CAMERA_INFO

Enumeration for retrieval of camera information.

Enumerator:
E_CAMINFO_MODEL | model info
E_CAMINFO_VENDOR | vendor info
E_CAMINFO_IIDCVERSION | IIDC version info.
E_CAMINFO_SN | serial number
E_CAMINFO_ORDERID | order ID
E_CAMINFO_MCVERSION | Micro controller version info.
E_CAMINFO_FPGAVERSION | FPGA version info.
E_CAMINFO_CUSTOMERKEY | customer key info
E_CAMINFO_MAXWIDTH | maximum width of the camera
E_CAMINFO_MAXHEIGHT | maximum height of the camera
E_CAMINFO_MAXDEPTH | maximum bit depth of the camera
E_CAMINFO_COLORCAMERA | Is this a color camera?
E_CAMINFO_BAYERPATTERN | Bayer pattern of this sensor (see E_UNI_BAYER_PATTERN).
E_CAMINFO_INTERLACED | Is this an interlaced camera?
E_CAMINFO_SISTYPE | type of SIS supported by the camera


AVT Universal API - Camera Control module: UNI_UNDEFINED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_UNDEFINED 0xFFFFFFFF

represents an undefined input parameter


AVT Universal API - Camera Control module: UNI_RESULT_FIREGRAB_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_FIREGRAB_ERROR 0x8A000000

Mask for a FireGrab error.


AVT Universal API - Camera Control module: UNI_RESULT_FEATURE_NOT_SUPPORTED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_FEATURE_NOT_SUPPORTED 0x88000013

feature not supported by camera


AVT Universal API - Camera Control module: UNI_RESULT_API_NOT_INITIALIZED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_API_NOT_INITIALIZED 0x88000015

the API was not initialized - UCC_Init() has to be called first


AVT Universal API - Camera Control module: E_UniFreeModeInfo

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_FREE_MODE_INFO E_UniFreeModeInfo

Enumeration for Format 7 Mode information used by UCC_GetFreeModeInfo.


AVT Universal API - Camera Control module: E_UNI_LOGGING

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_LOGGING

Enumeration for controlling logging.

Enumerator:
E_LOG_FATAL | Log only fatal events.
E_LOG_ERROR | Log fatal events and errors.
E_LOG_WARNING | Log fatal events, errors and warnings.
E_LOG_INFO | Log fatal events, errors, warnings and info messages.
E_LOG_DEBUG | Log everything.
E_LOG_LEVELMASK | Mask for testing log levels.


AVT Universal API - Camera Control module: S_TechInfo

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_TECHNO_INFO S_TechInfo

states of the support for different multimedia technologies


AVT Universal API - Camera Control module: E_UNI_FEATURE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_FEATURE

Enumeration for uni features

Enumerator:
E_FEAT_NONE | default value
E_FEAT_BRIGHTNESS | image brightness feature - see E_FEAT_BRIGHTNESS
E_FEAT_AUTOEXPOSURE | auto exposure feature - see E_FEAT_AUTOEXPOSURE
E_FEAT_SHARPNESS | sharpness feature - see E_FEAT_SHARPNESS
E_FEAT_WHITEBALANCE_UB | white balance (ub) feature - see E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR | white balance (vr) feature - see E_FEAT_WHITEBALANCE_VR
E_FEAT_HUE | color hue feature - see E_FEAT_HUE
E_FEAT_SATURATION | color saturation feature - see E_FEAT_SATURATION
E_FEAT_GAMMA | gamma correction feature - see E_FEAT_GAMMA
E_FEAT_SHUTTER | camera shutter feature - see E_FEAT_SHUTTER
E_FEAT_GAIN | signal gain feature - see E_FEAT_GAIN
E_FEAT_TRIGGERDELAY | trigger delay feature - see E_FEAT_TRIGGERDELAY
E_FEAT_TIMEBASE | shutter timebase feature - see E_FEAT_TIMEBASE
E_FEAT_EXPOSUREOFFSET | exposure offset feature - see E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER | extended shutter feature - see E_FEAT_EXTENDEDSHUTTER
E_FEAT_LUT | lookup table (LUT) feature - see E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL | lookup table detail information: bits per value - see E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE | lookup table detail information: maximum table size - see E_FEAT_LUT_MAXSIZE
E_FEAT_SHADING | shading correction feature - see E_FEAT_SHADING
E_FEAT_FRAMECOUNTER | frame counter feature - see E_FEAT_FRAMECOUNTER
E_FEAT_COLORCORRECTION | color correction feature - see E_FEAT_COLORCORRECTION
E_FEAT_SOFTRESET | soft reset feature - see E_FEAT_SOFTRESET
E_FEAT_XMIRRORIMAGE | horizontal mirror feature - see E_FEAT_XMIRRORIMAGE
E_FEAT_TRIGGERDELAYADV | trigger delay feature - see E_FEAT_TRIGGERDELAYADV
E_FEAT_DSNUCORRECTION | dark signal non-uniformity correction feature - see E_FEAT_DSNUCORRECTION
E_FEAT_BLEMISHCORRECTION | blemish pixel correction feature - see E_FEAT_BLEMISHCORRECTION
E_FEAT_DELAYEDINTEGRATIONENABLE | delayed 'integration enable' feature - see E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_AUTOSHUTTER_LOW | auto shutter minimum feature - see E_FEAT_AUTOSHUTTER_LOW
E_FEAT_AUTOSHUTTER_HIGH | auto shutter maximum feature - see E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOGAIN_LOW | auto gain minimum feature - see E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOGAIN_HIGH | auto gain maximum feature - see E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOFUNCTIONAOI_XUNITS | auto function AOI detail information: x units - see E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS | auto function AOI detail information: y units - see E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOFUNCTIONAOI_LEFT | auto function AOI left offset - see E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP | auto function AOI top offset - see E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH | auto function AOI width - see E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_HEIGHT | auto function AOI height - see E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_HIGHSNR | high SNR mode control - see E_FEAT_HIGHSNR
E_FEAT_USERPROFILE | user profile feature - see E_FEAT_USERPROFILE
E_FEAT_HDR_KNEEPOINTCOUNT | HDR mode parameter: number of active knee points - see E_FEAT_HDR_KNEEPOINTCOUNT.
E_FEAT_HDR_KNEEPOINT1 | HDR mode setting for first knee point - see E_FEAT_HDR_KNEEPOINT1.
E_FEAT_HDR_KNEEPOINT2 | HDR mode setting for second knee point - see E_FEAT_HDR_KNEEPOINT2.
E_FEAT_HDR_KNEEPOINT3 | HDR mode setting for third knee point - see E_FEAT_HDR_KNEEPOINT3.
E_FEAT_WHITEBALANCE_GR | advanced white balance for complementary sensors - GR[CY] setting - see E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG | advanced white balance for complementary sensors - MG[YE] setting - see E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_CY | advanced white balance for complementary sensors - CY[MG] setting - see E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_YE | advanced white balance for complementary sensors - YE[GR] setting - see E_FEAT_WHITEBALANCE_YE
E_FEAT_REDUCEDSMEAR | reduced smear mode control - see E_FEAT_REDUCEDSMEAR
E_FEAT_PARAMUPDATETIMING | parameter update timing mode control - see E_FEAT_PARAMUPDATETIMING
E_FEAT_SIS | secure image signature feature this feature is present if E_FEAT_SIS_MARLIN or E_FEAT_SIS_PIKE is present - see E_FEAT_SIS
E_FEAT_SIS_MARLIN | this feature is used to distinguish between Marlin and Pike SIS Implementations see E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE | this feature is used to distinguish between Marlin and Pike SIS Implementations see E_FEAT_SIS_PIKE
E_FEAT_CAMERABUSY | this feature is used to query if the camera in busy state see E_FEAT_CAMERABUSY
E_FEAT_LOGGING | Parameter to control logging. See E_FEAT_LOGGING.
E_FEAT_LIST_ALL_CAMERAS | Controls if UCC_GetCameras and UCC_GetCamerasEx list cameras which are busy E_FEAT_LIST_ALL_CAMERAS.
E_FEAT_STARTIMMEDIATELY | starting parameter for GrabStart() if (default)TRUE the ISO stream will start immediately E_FEAT_STARTIMMEDIATELY
E_FEAT_PHYSPEED | The physical transmission speed for a camera. See E_FEAT_PHYSPEED.
E_FEAT_FRAMEBUFFERCOUNT | The number of frame buffers to be used by the driver - See E_FEAT_FRAMEBUFFERCOUNT.
E_FEAT_USEIRMFORBW | A flag to signal if the driver-internal isochronous resource manager should manage the bandwidth - See E_FEAT_USEIRMFORBW.
E_FEAT_FRAMEMEMORYSIZE | The size of one complete image in bytes. Read-only. See E_FEAT_FRAMEMEMORYSIZE.
E_FEAT_IRMFREEBW | The size of the free bandwidth that is reported by the enabled isochronous resource manager - See E_FEAT_IRMFREEBW.
E_FEAT_USEIRMFORCHN | A flag to signal if the driver-internal isochronous resource manager should manage the isochronous channel. See E_FEAT_USEIRMFORCHN.
E_FEAT_CAMACCEPTDELAY | The time-out length (in milliseconds) for the time the driver waits for a reaction to an asynchronous command - See E_FEAT_CAMACCEPTDELAY.
E_FEAT_ISOCHANNEL | A flag to signal if the driver should provide an isochronous resource manager. Enabled by default. See E_FEAT_ISOCHANNEL.
E_FEAT_CYCLETIME | The current cycle time on the bus Read-only. See E_FEAT_CYCLETIME.
E_FEAT_BURSTCOUNT | number of images to grab in bus trigger modeE_FEAT_BURSTCOUNT
E_FEAT_DO_BUSTRIGGER | broadcast ISO enable message E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER | broadcast ISO enable message on all selected cards E_FEAT_DO_MULTIBUSTRIGGER


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_2

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_2 0x88000003

parameter 2 is invalid


AVT Universal API - Camera Control module: E_UNI_BAYER_PATTERN

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_BAYER_PATTERN

Enumeration for the Bayer pattern.

Enumerator:
E_BP_AUTO | Set pattern to automatic mode (may not be used in conversion methods!!!).
E_BP_RGGB | RGGB pattern, red pixel comes first.
E_BP_GBRG | RGGB pattern, green pixel of blue row comes first.
E_BP_GRBG | RGGB pattern, green pixel of red row comes first.
E_BP_BGGR | RGGB pattern, blue pixel comes first.
E_BP_CYGM | CYGM pattern, cyan pixel comes first in the first row, green in the second row (of the sensor).
E_BP_GMCY | CYGM pattern, green pixel comes first in the first row, cyan in the second row (of the sensor).
E_BP_CYMG | CYGM pattern, cyan pixel comes first in the first row, magenta in the second row (of the sensor).
E_BP_MGCY | CYGM pattern, magenta pixel comes first in the first row, cyan in the second row (of the sensor).


AVT Universal API - Camera Control module: S_SISData

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_SIS_DATA S_SISData

SIS data structure.


AVT Universal API - Camera Control module: E_UNI_SIMPLE_IMAGE_FORMAT

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIMPLE_IMAGE_FORMAT

Simple image type enum.

Enumeration for simple image types with one image plane consisting of consecutive pixel (starting at the top of the image).

Enumerator:
E_SIF_MONO8_REC601 | the Y value is defined by the Rec.601
E_SIF_BGR24 | windows 24 bit BGR
E_SIF_BGRA32 | windows 32 bit BGRA
E_SIF_MONO8_REC709 | the Y value is the Y from the CIE - XYZ color space defined in Rec 709
E_SIF_UYVY | IIDC YUV422 full color space.


AVT Universal API - Camera Control module: S_IIDC_VideoInfoFormat

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_IIDC_VIDEOINFO_FORMAT S_IIDC_VideoInfoFormat

IIDC video formats.


AVT Universal API - Camera Control module: UNI_RESULT_CAMERA_TIMEOUT

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_CAMERA_TIMEOUT 0x8800001C

timeout period expired


AVT Universal API - Camera Control module: E_UniLicenseType

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_LICENSE_TYPE E_UniLicenseType

License modes of Firegrab.


AVT Universal API - Camera Control module: E_Uni1394Speed

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_1394_SPEED E_Uni1394Speed

Enumeration for 1394 speed (needed for feature E_FEAT_PHYSPEED).


AVT Universal API - Camera Control module: E_UniFeature

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_FEATURE E_UniFeature

Enumeration for uni features


AVT Universal API - Camera Control module: E_UniSISType

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIS_TYPE E_UniSISType

enum for the secure image signatures


AVT Universal API - Camera Control module: E_UNI_FEATURE_STATE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_FEATURE_STATE

Enumeration for feature states.

Enumerator:
E_FEATSTATE_OFF read:feature state is off;
write: disable feature
E_FEATSTATE_ON read:feature is enabled;
write: enable feature
E_FEATSTATE_ONEPUSH read:feature is temporarily in "OnePush" state;
write: Do "OnePush" action for this feature
E_FEATSTATE_AUTO read:feature is in "Auto" state until set to "Off" again;
write: enable automatic adjustment mode for this feature
E_FEATSTATE_BUSY | read:feature is in "Busy" state;
E_FEATSTATE_SHOWIMAGE read:feature is in "ShowImage" state;
write: enable "ShowImage" state for this feature
E_FEATSTATE_LOADDATA read:feature is temporarily in "LoadData" state;
write: enable "LoadData" state for this feature
E_FEATSTATE_SAVEDATA read:feature is temporarily in "SaveData" state;
write: enable "SaveData" state for this feature
E_FEATSTATE_CLEARDATA read:feature is temporarily in "ClearData" state;
write: enable "ClearData" state for this feature
E_FEATSTATE_ERROR | read:feature state could not be set
E_FEATSTATE_UNDEFINED | read:feature state is undefined


AVT Universal API - Camera Control module: UNI_RESULT_CAMERA_BUSY

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_CAMERA_BUSY 0x88000017

the camera is busy


AVT Universal API - Camera Control module: E_UniFrameRate

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_FRAME_RATE E_UniFrameRate

Enumeration for frame rates.


AVT Universal API - Camera Control module: E_UNI_SIS_TYPE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIS_TYPE

enum for the secure image signatures

Enumerator:
E_SIS_NOT_PRESENT | camera supports no SIS
E_SIS_MARLIN | Marlin Cycle,Frame,Trigger count.
E_SIS_PIKE | Pike 3.0 and Stingray SIS.


AVT Universal API - Camera Control module: S_SISEnable

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef union S_SIS_ENABLE S_SISEnable

information about state of the fields of the S_SIS_DATA struct


AVT Universal API - Camera Control module: E_UniBayerPattern

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_BAYER_PATTERN E_UniBayerPattern

Enumeration for the Bayer pattern.


AVT Universal API - Camera Control module: S_IIDCVideoInfoFps

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_IIDC_VIDEOINFO_FPS S_IIDCVideoInfoFps

Frame rates for IIDC video modes.


AVT Universal API - Camera Control module: E_UNI_SIO_BAUDRATE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_SIO_BAUDRATE

Enumeration for I/O speed (for configuration of serial I/O communication).

Enumerator:
E_SIOBAUDRATE_300 | 300 Baud
E_SIOBAUDRATE_600 | 600 Baud
E_SIOBAUDRATE_1200 | 1200 Baud
E_SIOBAUDRATE_2400 | 2400 Baud
E_SIOBAUDRATE_4800 | 4800 Baud
E_SIOBAUDRATE_9600 | 9600 Baud
E_SIOBAUDRATE_19200 | 19200 Baud
E_SIOBAUDRATE_38400 | 38400 Baud
E_SIOBAUDRATE_57600 | 57600 Baud
E_SIOBAUDRATE_115200 | 115200 Baud
E_SIOBAUDRATE_230400 | 230400 Baud


AVT Universal API - Camera Control module: E_UNI_FRAME_RATE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_FRAME_RATE

Enumeration for frame rates.

Enumerator:
E_FR_1_875 | 1.875 FPS
E_FR_3_75 | 3.75 FPS
E_FR_7_5 | 7.5 FPS
E_FR_15 | 15 FPS
E_FR_30 | 30 FPS
E_FR_60 | 60 FPS
E_FR_120 | 120 FPS
E_FR_240 | 240 FPS


AVT Universal API - Camera Control module: S_SupportState

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef struct S_SUPPORT_STATE S_SupportState

states of the multi media technology support for operating system and processor.


AVT Universal API - Camera Control module: E_UniSettingsSelectMode

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: UNI_MAX_OUTPUT_PINS

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_MAX_OUTPUT_PINS 4

Maximal number of output pins.


AVT Universal API - Camera Control module: E_UniSioStopbits

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIO_STOPBITS E_UniSioStopbits

Enumeration for I/O stop bits (for configuration of serial I/O communication).


AVT Universal API - Camera Control module: UNI_RESULT_API_ALREADY_INITIALIZED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_API_ALREADY_INITIALIZED 0x8800001D

second call to UCC_Init; the API was already initialized


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_7

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_7 0x88000008

parameter 7 is invalid


AVT Universal API - Camera Control module: S_BGRA32

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: E_InputPinModes

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_INPUTPIN_MODES E_InputPinModes

Input Pin Modes.


AVT Universal API - Camera Control module: E_UNI_1394_SPEED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_1394_SPEED

Enumeration for 1394 speed (needed for feature E_FEAT_PHYSPEED).

Enumerator:
E_SPEED_AUTO | automatic speed detection by the driver
E_SPEED100 | S100 (100 MBit/s).
E_SPEED200 | S200 (200 MBit/s).
E_SPEED400 | S400 (400 MBit/s).
E_SPEED800 | S800 (800 MBit/s).
E_SPEED_LAST | last value for this enumeration


AVT Universal API - Camera Control module: E_UNI_FREE_MODE_INFO

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_FREE_MODE_INFO

Enumeration for Format 7 Mode information used by UCC_GetFreeModeInfo.

Enumerator:
E_FREE_MODE_WIDTH | max image width in pixel
E_FREE_MODE_HEIGHT | max image height in pixel
E_FREE_MODE_PIXELCOUNT | number of pixels of the image
E_FREE_MODE_BYTE_PER_FRAME | bytes per frame
E_FREE_MODE_UNIT_SIZE_H | current size in pixel horizontal
E_FREE_MODE_UNIT_SIZE_V | current size in pixel vertical
E_FREE_MODE_UNIT_POS_H | step units horizontal
E_FREE_MODE_UNIT_POS_V | step units vertical


AVT Universal API - Camera Control module: MAKE_FGRAB_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: UNI_RESULT_API_ERROR

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_API_ERROR 0x88000000

mask for API error


AVT Universal API - Camera Control module: E_UniSimpleImageFormat

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_SIMPLE_IMAGE_FORMAT E_UniSimpleImageFormat

Simple image type enum.

Enumeration for simple image types with one image plane consisting of consecutive pixel (starting at the top of the image).


AVT Universal API - Camera Control module: E_UNI_ROPMODE

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
enum E_UNI_ROPMODE

Enumeration for raster operation (used by re sampling methods).

Enumerator:
E_ROP_SRCCPY | nearest neighbor raster operation method
E_ROP_LININTERPOL | interpolating raster operation method


AVT Universal API - Camera Control module: PS_12BIT_2PACKED

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_3

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_3 0x88000004

parameter 3 is invalid


AVT Universal API - Camera Control module: E_UniLogging

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_LOGGING E_UniLogging

Enumeration for controlling logging.


AVT Universal API - Camera Control module: E_UniResolutionPresets

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_RESOLUTION_PRESETS E_UniResolutionPresets

Enumeration for resolution presets.


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_12

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_12 0x8800000D

parameter 12 is invalid


AVT Universal API - Camera Control module: UNI_RESULT_PARAMETER_INVALID_4

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
#define UNI_RESULT_PARAMETER_INVALID_4 0x88000005

parameter 4 is invalid


AVT Universal API - Camera Control module: E_UniImageFormat

uni_defines.h
E_BP_AUTO
E_BP_BGGR
E_BP_CYGM
E_BP_CYMG
E_BP_GBRG
E_BP_GMCY
E_BP_GRBG
E_BP_MGCY
E_BP_RGGB
E_CAMINFO_BAYERPATTERN
E_CAMINFO_COLORCAMERA
E_CAMINFO_CUSTOMERKEY
E_CAMINFO_FPGAVERSION
E_CAMINFO_IIDCVERSION
E_CAMINFO_INTERLACED
E_CAMINFO_MAXDEPTH
E_CAMINFO_MAXHEIGHT
E_CAMINFO_MAXWIDTH
E_CAMINFO_MCVERSION
E_CAMINFO_MODEL
E_CAMINFO_ORDERID
E_CAMINFO_SISTYPE
E_CAMINFO_SN
E_CAMINFO_VENDOR
E_CC_MONO12
E_CC_MONO16
E_CC_MONO8
E_CC_MONOB
E_CC_MONOG
E_CC_MONOR
E_CC_RAW12
E_CC_RAW16
E_CC_RAW8
E_CC_RGB12
E_CC_RGB16
E_CC_RGB8
E_CC_SMONO12
E_CC_SMONO16
E_CC_SRGB12
E_CC_SRGB16
E_CC_YUV411
E_CC_YUV422
E_CC_YUV444
E_FEAT_AUTOEXPOSURE
E_FEAT_AUTOFUNCTIONAOI_HEIGHT
E_FEAT_AUTOFUNCTIONAOI_LEFT
E_FEAT_AUTOFUNCTIONAOI_TOP
E_FEAT_AUTOFUNCTIONAOI_WIDTH
E_FEAT_AUTOFUNCTIONAOI_XUNITS
E_FEAT_AUTOFUNCTIONAOI_YUNITS
E_FEAT_AUTOGAIN_HIGH
E_FEAT_AUTOGAIN_LOW
E_FEAT_AUTOSHUTTER_HIGH
E_FEAT_AUTOSHUTTER_LOW
E_FEAT_BLEMISHCORRECTION
E_FEAT_BRIGHTNESS
E_FEAT_BURSTCOUNT
E_FEAT_CAMACCEPTDELAY
E_FEAT_CAMERABUSY
E_FEAT_COLORCORRECTION
E_FEAT_CYCLETIME
E_FEAT_DELAYEDINTEGRATIONENABLE
E_FEAT_DO_BUSTRIGGER
E_FEAT_DO_MULTIBUSTRIGGER
E_FEAT_DSNUCORRECTION
E_FEAT_EXPOSUREOFFSET
E_FEAT_EXTENDEDSHUTTER
E_FEAT_FRAMEBUFFERCOUNT
E_FEAT_FRAMECOUNTER
E_FEAT_FRAMEMEMORYSIZE
E_FEAT_GAIN
E_FEAT_GAMMA
E_FEAT_HDR_KNEEPOINT1
E_FEAT_HDR_KNEEPOINT2
E_FEAT_HDR_KNEEPOINT3
E_FEAT_HDR_KNEEPOINTCOUNT
E_FEAT_HIGHSNR
E_FEAT_HUE
E_FEAT_IRMFREEBW
E_FEAT_ISOCHANNEL
E_FEAT_LIST_ALL_CAMERAS
E_FEAT_LOGGING
E_FEAT_LUT
E_FEAT_LUT_BITSPERVAL
E_FEAT_LUT_MAXSIZE
E_FEAT_NONE
E_FEAT_PARAMUPDATETIMING
E_FEAT_PHYSPEED
E_FEAT_REDUCEDSMEAR
E_FEAT_SATURATION
E_FEAT_SHADING
E_FEAT_SHARPNESS
E_FEAT_SHUTTER
E_FEAT_SIS
E_FEAT_SIS_MARLIN
E_FEAT_SIS_PIKE
E_FEAT_SOFTRESET
E_FEAT_STARTIMMEDIATELY
E_FEAT_TIMEBASE
E_FEAT_TRIGGERDELAY
E_FEAT_TRIGGERDELAYADV
E_FEAT_USEIRMFORBW
E_FEAT_USEIRMFORCHN
E_FEAT_USERPROFILE
E_FEAT_WHITEBALANCE_CY
E_FEAT_WHITEBALANCE_GR
E_FEAT_WHITEBALANCE_MG
E_FEAT_WHITEBALANCE_UB
E_FEAT_WHITEBALANCE_VR
E_FEAT_WHITEBALANCE_YE
E_FEAT_XMIRRORIMAGE
E_FEATSTATE_AUTO
E_FEATSTATE_BUSY
E_FEATSTATE_CLEARDATA
E_FEATSTATE_ERROR
E_FEATSTATE_LOADDATA
E_FEATSTATE_OFF
E_FEATSTATE_ON
E_FEATSTATE_ONEPUSH
E_FEATSTATE_SAVEDATA
E_FEATSTATE_SHOWIMAGE
E_FEATSTATE_UNDEFINED
E_FLIP_MODE_BOTH
E_FLIP_MODE_HORIZONTAL
E_FLIP_MODE_LEFT_RIGHT
E_FLIP_MODE_TOP_DOWN
E_FLIP_MODE_VERTICAL
E_FR_120
E_FR_15
E_FR_1_875
E_FR_240
E_FR_30
E_FR_3_75
E_FR_60
E_FR_7_5
E_FREE_MODE_BYTE_PER_FRAME
E_FREE_MODE_HEIGHT
E_FREE_MODE_PIXELCOUNT
E_FREE_MODE_UNIT_POS_H
E_FREE_MODE_UNIT_POS_V
E_FREE_MODE_UNIT_SIZE_H
E_FREE_MODE_UNIT_SIZE_V
E_FREE_MODE_WIDTH
E_IF_ABGR
E_IF_BGR
E_IF_MONO8
E_IF_NATIVE
E_IF_RGB_PLANES
E_IF_RGBY_PLANES
E_INPUTPIN_MODES
E_InputPinModes
E_IPINMODE_OFF
E_IPINMODE_TRIGGER
E_LOG_DEBUG
E_LOG_ERROR
E_LOG_FATAL
E_LOG_INFO
E_LOG_LEVELMASK
E_LOG_WARNING
E_LT_CARDGUID
E_LT_DATELIMITED
E_LT_DEVICE
E_LT_ETHERNET
E_LT_HARDDISK
E_LT_NOLICENSE
E_LT_VENDOR
E_OPINMODE_BUSY
E_OPINMODE_FOLLOW_IN
E_OPINMODE_FRAMEVALID
E_OPINMODE_INTENA
E_OPINMODE_OFF
E_OPINMODE_PINSTATE
E_OUTPUTPIN_MODES
E_OutputPinModes
E_PRESET_DC2K
E_PRESET_DC4K
E_PRESET_HD1080
E_PRESET_HD720
E_PRESET_PAL
E_PRESET_QSXGA
E_PRESET_QVGA
E_PRESET_QXGA
E_PRESET_SVGA
E_PRESET_SXGA
E_PRESET_SXGAP
E_PRESET_UXGA
E_PRESET_VGA
E_PRESET_WVGA
E_PRESET_XGA
E_PRESET_XVGA
E_ROP_LININTERPOL
E_ROP_SRCCPY
E_SIF_BGR24
E_SIF_BGRA32
E_SIF_MONO8_REC601
E_SIF_MONO8_REC709
E_SIF_UYVY
E_SIOBAUDRATE_115200
E_SIOBAUDRATE_1200
E_SIOBAUDRATE_19200
E_SIOBAUDRATE_230400
E_SIOBAUDRATE_2400
E_SIOBAUDRATE_300
E_SIOBAUDRATE_38400
E_SIOBAUDRATE_4800
E_SIOBAUDRATE_57600
E_SIOBAUDRATE_600
E_SIOBAUDRATE_9600
E_SIOMODE_DISABLED
E_SIOMODE_RECEIVE
E_SIOMODE_RECEIVETRANSMIT
E_SIOMODE_TRANSMIT
E_SIOPARITY_EVEN
E_SIOPARITY_NONE
E_SIOPARITY_ODD
E_SIOSTOPBITS_1
E_SIOSTOPBITS_1_5
E_SIOSTOPBITS_2
E_SIS_MARLIN
E_SIS_NOT_PRESENT
E_SIS_PIKE
E_SPEED100
E_SPEED200
E_SPEED400
E_SPEED800
E_SPEED_AUTO
E_SPEED_LAST
E_T_FRAMELIMITED
E_Uni1394Speed
E_UNI_1394_SPEED
E_UNI_BAYER_PATTERN
E_UNI_CAMERA_INFO
E_UNI_COLOR_CODE
E_UNI_FEATURE
E_UNI_FEATURE_STATE
E_UNI_FLIP_MODE
E_UNI_FRAME_RATE
E_UNI_FREE_MODE_INFO
E_UNI_IMAGE_FORMAT
E_UNI_LICENSE_TYPE
E_UNI_LOGGING
E_UNI_RESOLUTION_PRESETS
E_UNI_ROPMODE
E_UNI_SIMPLE_IMAGE_FORMAT
E_UNI_SIO_BAUDRATE
E_UNI_SIO_MODE
E_UNI_SIO_PARITY
E_UNI_SIO_STOPBITS
E_UNI_SIS_TYPE
E_UniBayerPattern
E_UniCameraInfo
E_UniColorCode
E_UniFeature
E_UniFeatureState
E_UniFlipMode
E_UniFrameRate
E_UniFreeModeInfo
E_UniImageFormat
E_UniLicenseType
E_UniLogging
E_UniResolutionPresets
E_UniRopMode
E_UniSimpleImageFormat
E_UniSioBaudRate
E_UniSioMode
E_UniSioParity
E_UniSioStopbits
E_UniSISType
S_IIDC_VideoInfoFormat
S_IIDC_VideoInfoMode
S_IIDCVideoInfoFps
S_SISData
S_SISEnable
S_SupportState
S_TechInfo
S_UniImage
UNI_ALL_CAMERAS
UNI_MAX_INPUT_PINS
UNI_MAX_OUTPUT_PINS
UNI_RESULT_API_ALREADY_INITIALIZED
UNI_RESULT_API_ERROR
UNI_RESULT_API_NOT_INITIALIZED
UNI_RESULT_AVT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_BUSY
UNI_RESULT_CAMERA_NOT_FOUND
UNI_RESULT_CAMERA_TIMEOUT
UNI_RESULT_COMMAND_ABORTED
UNI_RESULT_FEATURE_NOT_IMPLEMENTED
UNI_RESULT_FEATURE_NOT_SUPPORTED
UNI_RESULT_FIREGRAB_ERROR
UNI_RESULT_GRAB_NOT_INITIALIZED
UNI_RESULT_INSUFFICIENT_RESOURCES
UNI_RESULT_INVALID_FEATURECAPABILITY
UNI_RESULT_INVALID_SETTINGS
UNI_RESULT_MORE_DATA
UNI_RESULT_NOT_ALLOWED_IN_THIS_MODE
UNI_RESULT_NOTIFICATION_NO_TYPE
UNI_RESULT_OUT_OF_MEMORY
UNI_RESULT_PARAMETER_INVALID_1
UNI_RESULT_PARAMETER_INVALID_10
UNI_RESULT_PARAMETER_INVALID_11
UNI_RESULT_PARAMETER_INVALID_12
UNI_RESULT_PARAMETER_INVALID_2
UNI_RESULT_PARAMETER_INVALID_3
UNI_RESULT_PARAMETER_INVALID_4
UNI_RESULT_PARAMETER_INVALID_5
UNI_RESULT_PARAMETER_INVALID_6
UNI_RESULT_PARAMETER_INVALID_7
UNI_RESULT_PARAMETER_INVALID_8
UNI_RESULT_PARAMETER_INVALID_9
UNI_RESULT_UNKNOWN_ERROR
UNI_UNDEFINED
typedef enum E_UNI_IMAGE_FORMAT E_UniImageFormat

Enumeration for target image formats.


AVT Universal API - Camera Control module: E_UNI_NOTIFICATION_EVENTS

uni_notification.h
E_UNI_NOTIFICATION_CALLBACK
E_UNI_NOTIFICATION_ERROR_BUS
E_UNI_NOTIFICATION_ERROR_DMA
E_UNI_NOTIFICATION_ERROR_FRAME
E_UNI_NOTIFICATION_ERROR_MISC
E_UNI_NOTIFICATION_EVENT
E_UNI_NOTIFICATION_EVENTS
E_UNI_NOTIFICATION_FRAME_DROPPED
E_UNI_NOTIFICATION_FRAME_READY
E_UNI_NOTIFICATION_FRAME_START
E_UNI_NOTIFICATION_MESSAGE
E_UNI_NOTIFICATION_NO_TYPE
E_UNI_NOTIFICATION_NODELIST_CHANGED
E_UNI_NOTIFICATION_TYPE
UNI_NOTIFICATION_HANDLE
VOID_TYPE
enum E_UNI_NOTIFICATION_EVENTS

Events you can register a notification for.

Enumerator:
E_UNI_NOTIFICATION_NODELIST_CHANGED | triggered when the internal bus node list has changed
E_UNI_NOTIFICATION_ERROR_BUS | triggered when there was an error on the bus
E_UNI_NOTIFICATION_FRAME_READY | triggered at the end of a frame transfer
E_UNI_NOTIFICATION_FRAME_START | triggered at the beginning of a frame transfer
E_UNI_NOTIFICATION_FRAME_DROPPED | triggered when a frame was dropped
E_UNI_NOTIFICATION_ERROR_FRAME | triggered when the driver reports a corrupted frame (for future use)
E_UNI_NOTIFICATION_ERROR_DMA | triggered when the DMA was halted (for future use)
E_UNI_NOTIFICATION_ERROR_MISC | triggered when an unknown event occurred


AVT Universal API - Camera Control module: E_UNI_NOTIFICATION_TYPE

uni_notification.h
E_UNI_NOTIFICATION_CALLBACK
E_UNI_NOTIFICATION_ERROR_BUS
E_UNI_NOTIFICATION_ERROR_DMA
E_UNI_NOTIFICATION_ERROR_FRAME
E_UNI_NOTIFICATION_ERROR_MISC
E_UNI_NOTIFICATION_EVENT
E_UNI_NOTIFICATION_EVENTS
E_UNI_NOTIFICATION_FRAME_DROPPED
E_UNI_NOTIFICATION_FRAME_READY
E_UNI_NOTIFICATION_FRAME_START
E_UNI_NOTIFICATION_MESSAGE
E_UNI_NOTIFICATION_NO_TYPE
E_UNI_NOTIFICATION_NODELIST_CHANGED
E_UNI_NOTIFICATION_TYPE
UNI_NOTIFICATION_HANDLE
VOID_TYPE
enum E_UNI_NOTIFICATION_TYPE

Enumeration to id the notification type.

Enumerator:
E_UNI_NOTIFICATION_CALLBACK | the notification will use a user defined callback
E_UNI_NOTIFICATION_EVENT | the notification will use a user defined event
E_UNI_NOTIFICATION_MESSAGE | the notification will use a windows message (needs windows.h)
E_UNI_NOTIFICATION_NO_TYPE | undefined type


AVT Universal API - Camera Control module: VOID_TYPE

uni_notification.h
E_UNI_NOTIFICATION_CALLBACK
E_UNI_NOTIFICATION_ERROR_BUS
E_UNI_NOTIFICATION_ERROR_DMA
E_UNI_NOTIFICATION_ERROR_FRAME
E_UNI_NOTIFICATION_ERROR_MISC
E_UNI_NOTIFICATION_EVENT
E_UNI_NOTIFICATION_EVENTS
E_UNI_NOTIFICATION_FRAME_DROPPED
E_UNI_NOTIFICATION_FRAME_READY
E_UNI_NOTIFICATION_FRAME_START
E_UNI_NOTIFICATION_MESSAGE
E_UNI_NOTIFICATION_NO_TYPE
E_UNI_NOTIFICATION_NODELIST_CHANGED
E_UNI_NOTIFICATION_TYPE
UNI_NOTIFICATION_HANDLE
VOID_TYPE
typedef VOID_TYPE ( __cdecl * UNI_NOTIFICATION_CALLBACK_FUNCTION )

Declaration of callback type.


AVT Universal API - Camera Control module: UNI_NOTIFICATION_HANDLE

uni_notification.h
E_UNI_NOTIFICATION_CALLBACK
E_UNI_NOTIFICATION_ERROR_BUS
E_UNI_NOTIFICATION_ERROR_DMA
E_UNI_NOTIFICATION_ERROR_FRAME
E_UNI_NOTIFICATION_ERROR_MISC
E_UNI_NOTIFICATION_EVENT
E_UNI_NOTIFICATION_EVENTS
E_UNI_NOTIFICATION_FRAME_DROPPED
E_UNI_NOTIFICATION_FRAME_READY
E_UNI_NOTIFICATION_FRAME_START
E_UNI_NOTIFICATION_MESSAGE
E_UNI_NOTIFICATION_NO_TYPE
E_UNI_NOTIFICATION_NODELIST_CHANGED
E_UNI_NOTIFICATION_TYPE
UNI_NOTIFICATION_HANDLE
VOID_TYPE
typedef UINT32_TYPE UNI_NOTIFICATION_HANDLE

Declaration of the notification handle.


AVT Universal API - Camera Control module: NOTIFICATION_CALLING_CONVENTION

uni_notification.h
E_UNI_NOTIFICATION_CALLBACK
E_UNI_NOTIFICATION_ERROR_BUS
E_UNI_NOTIFICATION_ERROR_DMA
E_UNI_NOTIFICATION_ERROR_FRAME
E_UNI_NOTIFICATION_ERROR_MISC
E_UNI_NOTIFICATION_EVENT
E_UNI_NOTIFICATION_EVENTS
E_UNI_NOTIFICATION_FRAME_DROPPED
E_UNI_NOTIFICATION_FRAME_READY
E_UNI_NOTIFICATION_FRAME_START
E_UNI_NOTIFICATION_MESSAGE
E_UNI_NOTIFICATION_NO_TYPE
E_UNI_NOTIFICATION_NODELIST_CHANGED
E_UNI_NOTIFICATION_TYPE
UNI_NOTIFICATION_HANDLE
VOID_TYPE


AVT Universal API - Camera Control module: VOID_POINTER

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef VOID_TYPE* VOID_POINTER

pointer to void tyype


AVT Universal API - Camera Control module: UNICODE_CHAR

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef char UNICODE_CHAR

char type dependent on the UNICODE define multi byte or single byte


AVT Universal API - Camera Control module: INT32_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int32_t INT32_IN_TYPE

32 bit signed integer type for input


AVT Universal API - Camera Control module: INT8_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef signed char INT8_IN_TYPE

8 bit signed integer type for input


AVT Universal API - Camera Control module: UINT64_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint64_t UINT64_IN_TYPE

64 bit unsigned integer type for input


AVT Universal API - Camera Control module: INT64_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int64_t INT64_IN_TYPE

64 bit signed integer type for input


AVT Universal API - Camera Control module: UINT8_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned char UINT8_TYPE

8 bit unsigned integer


AVT Universal API - Camera Control module: WCHAR_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef WCHAR_TYPE* WCHAR_OUT_TYPE

valid pointer to a wchar_t, will return results from a function


AVT Universal API - Camera Control module: INT8_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT8_IN_TYPE* INT8_OUT_TYPE

8 bit signed integer type for output


AVT Universal API - Camera Control module: UINT32_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint32_t UINT32_IN_TYPE

32 bit unsigned integer type for input


AVT Universal API - Camera Control module: DOUBLE_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef double DOUBLE_IN_TYPE

8 byte floating point type for input


AVT Universal API - Camera Control module: COLORCODE_ENUMERATION

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void* COLORCODE_ENUMERATION

Type for an enumeration of color codes.


AVT Universal API - Camera Control module: WCHAR_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef wchar_t WCHAR_IN_TYPE

string with wide char


AVT Universal API - Camera Control module: INT16_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT16_IN_TYPE* INT16_INOUT_TYPE

16 bit signed integer type for input and output


AVT Universal API - Camera Control module: INT32_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int32_t INT32_TYPE

32 bit signed integer


AVT Universal API - Camera Control module: POINTER_SIZE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef size_t POINTER_SIZE

size of a pointer system dependent


AVT Universal API - Camera Control module: BOOL_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef BOOL_IN_TYPE* BOOL_INOUT_TYPE

"bool" type for input and output


AVT Universal API - Camera Control module: INT8_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT8_IN_TYPE* INT8_INOUT_TYPE

8 bit signed integer type for input and output


AVT Universal API - Camera Control module: int32_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int int32_t

32 bit signed integer on non-Microsoft systems


AVT Universal API - Camera Control module: UINT8_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned char UINT8_IN_TYPE

8 bit unsigned integer type for input


AVT Universal API - Camera Control module: CHAR_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UNICODE_CHAR CHAR_TYPE

string type will change with UNICODE builds from char to wchar_t


AVT Universal API - Camera Control module: HRESULT

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef long HRESULT

Definition just in case HRESULT is not defined (and winnt.h should not be included).


AVT Universal API - Camera Control module: ACHAR_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef ACHAR_TYPE* ACHAR_OUT_TYPE

8bit ASCII string returning a result from a function


AVT Universal API - Camera Control module: DOUBLE_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef double DOUBLE_TYPE

8 byte floating point


AVT Universal API - Camera Control module: INT16_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int16_t INT16_TYPE

16 bit signed integer


AVT Universal API - Camera Control module: INT16_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT16_IN_TYPE* INT16_OUT_TYPE

16 bit signed integer type for output


AVT Universal API - Camera Control module: uint16_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned short uint16_t

16 bit unsigned integer on non-Microsoft systems


AVT Universal API - Camera Control module: uint32_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned int uint32_t

32 bit unsigned integer on non-Microsoft systems


AVT Universal API - Camera Control module: ID_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE ID_TYPE

Type for identifying a camera.


AVT Universal API - Camera Control module: COLOR_CORRECTION_HANDLE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void* COLOR_CORRECTION_HANDLE

A handle for a color correction object to be used during debayering.


AVT Universal API - Camera Control module: UINT16_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT16_IN_TYPE* UINT16_OUT_TYPE

16 bit unsigned integer type for output


AVT Universal API - Camera Control module: UINT16_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint16_t UINT16_IN_TYPE

16 bit unsigned integer type for input


AVT Universal API - Camera Control module: int64_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef long long int64_t

64 bit signed integer on non-Microsoft systems


AVT Universal API - Camera Control module: INT64_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT64_IN_TYPE* INT64_INOUT_TYPE

64 bit signed integer type for input and output


AVT Universal API - Camera Control module: BOOL_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef BOOL_IN_TYPE* BOOL_OUT_TYPE

"bool" type for output


AVT Universal API - Camera Control module: UINT64_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT64_IN_TYPE* UINT64_INOUT_TYPE

64 bit unsigned integer type for input and output


AVT Universal API - Camera Control module: CHAR_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Camera Control module: INT32_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT32_IN_TYPE* INT32_OUT_TYPE

32 bit signed integer type for output


AVT Universal API - Camera Control module: wchar_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned short wchar_t

if not defined wchar_t define it


AVT Universal API - Camera Control module: UINT16_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint16_t UINT16_TYPE

16 bit unsigned integer


AVT Universal API - Camera Control module: FLOAT_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef FLOAT_IN_TYPE* FLOAT_INOUT_TYPE

4 byte floating point type for input and output


AVT Universal API - Camera Control module: PRESETS_ENUMERATION

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void* PRESETS_ENUMERATION

Type for an enumeration of presets.


AVT Universal API - Camera Control module: UINT64_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT64_IN_TYPE* UINT64_OUT_TYPE

64 bit unsigned integer type for output


AVT Universal API - Camera Control module: INT64_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT64_IN_TYPE* INT64_OUT_TYPE

64 bit signed integer type for output


AVT Universal API - Camera Control module: UINT8_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT8_IN_TYPE* UINT8_INOUT_TYPE

8 bit unsigned integer type for input and output


AVT Universal API - Camera Control module: UINT64_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint64_t UINT64_TYPE

64 bit unsigned integer


AVT Universal API - Camera Control module: UINT32_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE* UINT32_OUT_TYPE

32 bit unsigned integer type for output


AVT Universal API - Camera Control module: DOUBLE_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef DOUBLE_IN_TYPE* DOUBLE_OUT_TYPE

8 byte floating point type for output


AVT Universal API - Camera Control module: UINT16_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT16_IN_TYPE* UINT16_INOUT_TYPE

16 bit unsigned integer type for input and output


AVT Universal API - Camera Control module: int16_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef short int16_t

16 bit signed integer on non-Microsoft systems


AVT Universal API - Camera Control module: CHAR_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef CHAR_TYPE* CHAR_INOUT_TYPE

a valid pointer to a mutable char/wchar_t as, will take values into a function and return the result


AVT Universal API - Camera Control module: uint64_t

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef unsigned long long uint64_t

64 bit unsigned integer on non-Microsoft systems


AVT Universal API - Camera Control module: ACHAR_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Camera Control module: ACHAR_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef ACHAR_TYPE* ACHAR_INOUT_TYPE

8bit ASCII char string taking values int a function and returning a result


AVT Universal API - Camera Control module: INT8_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef signed char INT8_TYPE

8 bit signed integer


AVT Universal API - Camera Control module: WCHAR_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t


AVT Universal API - Camera Control module: UINT32_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE* UINT32_INOUT_TYPE

32 bit unsigned integer type for input and output


AVT Universal API - Camera Control module: ACHAR_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef char ACHAR_IN_TYPE

string of 8bit ASCII chars


AVT Universal API - Camera Control module: INT16_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int16_t INT16_IN_TYPE

16 bit signed integer type for input


AVT Universal API - Camera Control module: UINT32_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef uint32_t UINT32_TYPE

32 bit unsigned integer


AVT Universal API - Camera Control module: FLOAT_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef float FLOAT_IN_TYPE

4 byte floating point type for input


AVT Universal API - Camera Control module: BOOL_IN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT32_IN_TYPE BOOL_IN_TYPE

BOOL type for input.


AVT Universal API - Camera Control module: DOUBLE_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef DOUBLE_IN_TYPE* DOUBLE_INOUT_TYPE

8 byte floating point type for input and output


AVT Universal API - Camera Control module: CHAR_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef CHAR_TYPE* CHAR_OUT_TYPE

a valid pointer to a char/wchar_t, will return results from a function


AVT Universal API - Camera Control module: VOID_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef void VOID_TYPE

void type


AVT Universal API - Camera Control module: UNI_RETURN_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef HRESULT UNI_RETURN_TYPE

Return value for all the methods of the API.


AVT Universal API - Camera Control module: WCHAR_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef WCHAR_TYPE* WCHAR_INOUT_TYPE

valid pointer to a mutable wchar_t, will take values into a function and return the ressult.


AVT Universal API - Camera Control module: INT64_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef int64_t INT64_TYPE

64 bit signed integer


AVT Universal API - Camera Control module: UINT8_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT8_IN_TYPE* UINT8_OUT_TYPE

8 bit unsigned integer type for output


AVT Universal API - Camera Control module: FLOAT_OUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef FLOAT_IN_TYPE* FLOAT_OUT_TYPE

4 byte floating point type for output


AVT Universal API - Camera Control module: __1394GUID

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef UINT64_TYPE __1394GUID

The definition of a 1394 GUID


AVT Universal API - Camera Control module: FLOAT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef float FLOAT_TYPE

4 byte floating point


AVT Universal API - Camera Control module: INT32_INOUT_TYPE

uni_types.h
__1394GUID
ACHAR_IN_TYPE
ACHAR_INOUT_TYPE
ACHAR_OUT_TYPE
BOOL_IN_TYPE
BOOL_INOUT_TYPE
BOOL_OUT_TYPE
CHAR_INOUT_TYPE
CHAR_OUT_TYPE
CHAR_TYPE
COLOR_CORRECTION_HANDLE
COLORCODE_ENUMERATION
DOUBLE_IN_TYPE
DOUBLE_INOUT_TYPE
DOUBLE_OUT_TYPE
DOUBLE_TYPE
FLOAT_IN_TYPE
FLOAT_INOUT_TYPE
FLOAT_OUT_TYPE
FLOAT_TYPE
HRESULT
ID_TYPE
INT16_IN_TYPE
INT16_INOUT_TYPE
INT16_OUT_TYPE
int16_t
INT16_TYPE
INT32_IN_TYPE
INT32_INOUT_TYPE
INT32_OUT_TYPE
int32_t
INT32_TYPE
INT64_IN_TYPE
INT64_INOUT_TYPE
INT64_OUT_TYPE
int64_t
INT64_TYPE
INT8_IN_TYPE
INT8_INOUT_TYPE
INT8_OUT_TYPE
INT8_TYPE
POINTER_SIZE
PRESETS_ENUMERATION
UINT16_IN_TYPE
UINT16_INOUT_TYPE
UINT16_OUT_TYPE
uint16_t
UINT16_TYPE
UINT32_IN_TYPE
UINT32_INOUT_TYPE
UINT32_OUT_TYPE
uint32_t
UINT32_TYPE
UINT64_IN_TYPE
UINT64_INOUT_TYPE
UINT64_OUT_TYPE
uint64_t
UINT64_TYPE
UINT8_IN_TYPE
UINT8_INOUT_TYPE
UINT8_OUT_TYPE
UINT8_TYPE
UNI_RETURN_TYPE
UNICODE_CHAR
VOID_POINTER
VOID_TYPE
WCHAR_IN_TYPE
WCHAR_INOUT_TYPE
WCHAR_OUT_TYPE
wchar_t
typedef INT32_IN_TYPE* INT32_INOUT_TYPE

32 bit signed integer type for input and output


AVT Universal API - Camera Control module: S_SIS_ENABLE::m_Data

S_SIS_ENABLE
m_Data
m_Enable
UINT32_TYPE S_SIS_ENABLE::m_Data

Enable as UINT32.


AVT Universal API - Camera Control module: S_SIS_ENABLE::m_Enable

S_SIS_ENABLE
m_Data
m_Enable
struct S_SIS_ENABLE::S_SIS_ENABLE_FIELDS S_SIS_ENABLE::m_Enable

states of the sis data

inq for supported sis data